Autor Tópico: DroidCam: Audio não funciona de jeito nenhum  (Lida 803 vezes)

Offline eaxgrande

  • Usuário Ubuntu
  • *
  • Mensagens: 514
  • "Todo homem, por natureza, quer saber"
    • Ver perfil
DroidCam: Audio não funciona de jeito nenhum
« Online: 24 de Novembro de 2020, 13:17 »
Prezados Amigos do Fórum

Estou precisando de ajuda para fazer funcionar o audio do DroidCam no Ubuntu Mate 16.04.
Sei que deveria ser uma coisa fácil de se fazer, mas por algum motivo, o vídeo da câmera do smartphone é capturado normalmente, enquanto o som não sai de jeito nenhum!
Como não sei o que está acontecendo, comecei a tentar de tudo aqui:
- instalar e desinstalar pacotes do alsa,
- instalar e desinstalar pacotes do pulseaudio,
- mexer em /etc/pulse/default.pa, acrescentando isso aqui: load-module module-alsa-source device = hw: Loopback, 1,0 no arquivo,
- desinstalar e instalar com/sem o arquivo install-sound
- desinstalar e instalar com/sem o arquivo install-dkms,
- desinstalar e instalar com/sem os arquivos libjpeg-turbo libavutil-dev libswscale-dev libasound2-dev libspeex-dev libusbmuxd-dev libplist-dev
E antes de tudo, já tinha rodado o comando sudo apt install linux-headers-`uname -r` gcc make
A cada instalação, testei no cheese, no guvcview e no vlc incontáveis vezes.
Também tentei opções diferentes na configuração de microfone do DroidCam do aparelho: Voltar/Microfone da câmera - Desative para usar o microfone padrão, com uma caixa de seleção
Também experimentei trocar de aparelho, e o resultado é o mesmo!
O estranho é que quando inicio o Droidcam, o smartphone mostra uma mensagem de audio habilitado!
Também fiz um teste no google meet com a ajuda de meu filho. Mesmo com a mensagem de áudio funcionando, o som não é captado. Mas na tela do PC, o meet mostra o status de audio funcionando!
Pesquisei pela internet afora e vi que o DroidCam é bem antigo, e costuma ser usado normalmente em outros SO. Não achei nada que pudesse me ajudar a solucionar o problema.
E mesmo aqui no fórum, em uma busca rápida, não achei nada relacionado a um problema grave de audio do Droidcam...
Minha nossa, por que uma coisa que deveria ser absolutamente simples ficou tão complexa?
Isso acabou se transformando numa das coisas mais difíceis que já tentei resolver no Ubuntu! Como pode?!, rs, rs, rs...

Desde já, agradeço imensamente por qualquer ajuda

Abraços!

Ubuntu-Mate 16.04 Xenial
Lubuntu-LXQt 20.04 Focal

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 113
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #1 Online: 24 de Novembro de 2020, 15:43 »
Talvez seja um problema de software. Tem o "ubuntu-restricted-extras" instalado°
Flavio ML

Offline eaxgrande

  • Usuário Ubuntu
  • *
  • Mensagens: 514
  • "Todo homem, por natureza, quer saber"
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #2 Online: 24 de Novembro de 2020, 19:07 »
Verifiquei no synaptic.
Sim, está instalado.
Ubuntu-Mate 16.04 Xenial
Lubuntu-LXQt 20.04 Focal

Offline eaxgrande

  • Usuário Ubuntu
  • *
  • Mensagens: 514
  • "Todo homem, por natureza, quer saber"
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #3 Online: 25 de Novembro de 2020, 14:54 »
Prezados amigos do fórum

Como ainda não consegui descobrir o que está acontecendo, e preciso urgentemente resolver esse problema pra fazer provas online por esses dias, não tive outra escolha a não ser comprar uma webcam: WebCam Argom Tech CAM20 HD 720P ARG-WC-9120BK. Essa câmera tem microfone embutido e tanto o sinal de vídeo como o de audio passam pelo plug USB.

No entanto, o problema também se manifestou nela! Ou seja, o Cheese e o Guvcview captam a imagem, mas nada de som!

Vejam:
Citar
root@labfab2:~# lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 012: ID 1224:2a25 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 010: ID 10c4:8105 Silicon Labs
Bus 004 Device 006: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 010: ID 10c4:8105 Silicon Labs → Mouse
Bus 004 Device 006: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory → Teclado
Bus 002 Device 012: ID 1224:2a25 → deve ser ela, mas não aparece nada...

Com o sinal da cãmera sendo captado pelo Guvcview, mas ainda sem som:
Citar
root@labfab2:~#  dmesg | grep -i "Camera"
[   18.870434] uvcvideo 2-1:1.0: Entity type for entity Camera 1 was not initialized!
[   18.870686] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-1/2-1:1.0/input/input11
[  903.455920] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[  903.456170] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input12
[ 1314.782817] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 1314.783075] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input20
[ 1335.568033] uvcvideo 2-5:1.0: Entity type for entity Camera 1 was not initialized!
[ 1335.568629] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-5/2-5:1.0/input/input21
[ 1357.499006] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 1357.499613] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input22
[ 1420.313549] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 1420.314126] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input23
[ 1442.719913] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 1442.722009] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input24
[ 2177.208396] usb 2-5: Product: USB2.0 Camera
[ 2177.217495] uvcvideo: Found UVC 1.00 device USB2.0 Camera (1e4e:0110)
[ 2177.223655] uvcvideo 2-5:1.0: Entity type for entity Camera 1 was not initialized!
[ 2177.224061] input: USB2.0 Camera: USB2.0 Camera as /devices/pci0000:00/0000:00:13.2/usb2/2-5/2-5:1.0/input/input25
[ 2220.902968] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 2220.903573] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input26
[ 3398.089998] uvcvideo 2-4:1.0: Entity type for entity Camera 1 was not initialized!
[ 3398.090435] input: USB PHY 2.0: USB CAMERA as /devices/pci0000:00/0000:00:13.2/usb2/2-4/2-4:1.0/input/input28

Caramba, não sei o que está acontecendo. Será falta de algum codec? Mas qual(is)? Alguém sabe me dizer uma lista de prováveis?
Será falta de driver proprietário de webcam?! Mas existe isso?!  Não deveria ser simplesmente plugar e sair usando!?

Como é que todos os usuários de Linux no mundo se viraram pra trabalhar home office durante a pandemia?

Não faz sentido... Deve ter algum jeito...

Agradeço imensamente por qualquer informação que me ajude a entender o que estou deixando escapar.

Ainda que seja bronca, rs, rs, rs.

Não é possível, deve ser alguma coisa muito, muito complexa, de tão trivial, kkkkkk

Abraços!



Ubuntu-Mate 16.04 Xenial
Lubuntu-LXQt 20.04 Focal

Offline eaxgrande

  • Usuário Ubuntu
  • *
  • Mensagens: 514
  • "Todo homem, por natureza, quer saber"
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #4 Online: 26 de Novembro de 2020, 06:50 »
Resolvi formatar o PC e atualizar para o Ubuntu Mate 20.04, e percebi que nesse, a câmera foi reconhecida:
Citar
instalador@ubuntu:~$ lsusb
Bus 001 Device 004: ID 1224:2a25 Jieli Technology USB PHY 2.0
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 003: ID 1bcf:0007 Sunplus Innovation Technology Inc. Optical Mouse
Bus 002 Device 002: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

E por um instante, mesmo o Droidcam acabou funcionando. (Quase pulei, rs, rs) Mas depois parou novamente.
Foi alguma coisa que eu fiz aqui...
Testei outro aplicativo chamado Irium Webcam, que corta o som da saída de audio quando o microfone do Celular é ativado pelo aplicativo no PC, pelo visto, um problema relacionado ao plugin jack.

Mexi no arquivo /etc/pulse/default.pa, acrescentando e tirando linhas de tutoriais que fui achando, mas até agora nada...

Resumindo: estou percebendo que meu problema na verdade parece estar relacionado à configuração incorreta de audio, pois caso contrário, o Droidcam não teria funcionado (ainda que apenas uma vez)

É vergonhoso ter que reconhecer - me desculpem a ignorância - mas é que até o momento não faço ideia do que exatamente é pulseaudio, alxamixer, qual a relação entre eles, por que precisa mexer no arquivo /etc/pulse/default.pa para que alguns dispositivos sejam reconhecidos e passem a aparecer no controle de volume, enfim...

E olha que já uso ubuntu faz bastante tempo... Mas é que nunca precisei mexer em audio do sistema até agora...

Alguém sabe me dizer como fazer a configuração correta de um microfone USB de webcam? Precisa mesmo editar o arquivo default.pa ou é mais simples que isso? E quanto ao microfone do celular, como ele deveria aparecer no controle de volume? Tem como personalizar isso?

Agradeço qualquer informação


Ubuntu-Mate 16.04 Xenial
Lubuntu-LXQt 20.04 Focal

Offline agente100gelo

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.365
  • @Ceará
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #5 Online: 26 de Novembro de 2020, 08:26 »
Pode parecer bobagem minha, mas você já verificou os volumes de entrada e o dispositivo selecionado de entrada de áudio?

Passei vários dias achando que meu fone tinha falhado num lado até que fui ver os volumes e tava todo virado pra esquerda.

Tenho uma webcam com áudio interno que foi automático. Também tenho um microfone semi-profissional USB que também foi de boa.
Advogado e analista de sistema cearense.
Twitter: @glaydson

Offline eaxgrande

  • Usuário Ubuntu
  • *
  • Mensagens: 514
  • "Todo homem, por natureza, quer saber"
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #6 Online: 01 de Dezembro de 2020, 14:32 »
Tentei de tudo aqui, mas o PC não reconheceu o microfone embutido da câmera.
Por fim, comprei um microfone separado, que conectei na saida traseira do PC. Esse, foi reconhecido imediatamente.
Ou seja, meu problema foi resolvido de outra forma, mas até hoje não fiquei sabendo por que diabos o Ubuntu não reconheceu o o microfone da câmera, via usb.
Me parece que o mesmo problema interno que fazia com que o som do smartphone via Droidcam não fosse reconhecido também era o responsável por fazer com que o microfone embutido da câmera também não fosse.
Sendo assim, agradeço pelas tentativas de ajuda, caros flavioml e agente100gelo.
Vou mudar o enfoque e tentar entender melhor como funciona o pulseaudio e o alsamixer.

Abraços!
Ubuntu-Mate 16.04 Xenial
Lubuntu-LXQt 20.04 Focal

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 610
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #7 Online: 01 de Dezembro de 2020, 19:02 »
Olá @eaxgrande,

Quem é vivo sempre aparece!

Deixa eu dar meus R$ 0,05 cents, eu quando tenho qualquer problema de áudio jamais esqueço de olhar o "alsamixer" nele quase sempre há o desfecho para o quiproquó

T+
A vida, é feito andar de bicicleta, se parar, você cai! (Gabriel Contino)
Blog do Paulo Corrêa Creto

Offline eaxgrande

  • Usuário Ubuntu
  • *
  • Mensagens: 514
  • "Todo homem, por natureza, quer saber"
    • Ver perfil
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #8 Online: 02 de Dezembro de 2020, 05:05 »
Fala aí, creto! Beleza? Quanto tempo, rs, rs, rs

Então... eu andei fuçando no alsamixer também... É verdade que em alguns casos relacionados ao microfone, bastou mexer nele pra funcionar.

Agora estou querendo mesmo é arrumar pra cabeça.

Queria entender como é que o menu do alsamixer é feito. Como se faz para que nele apareça um dispositivo que você nuca usou no PC?

Andei fuçando em um negócio chamado "set-default-source" relacionado a um módulo que estava listado em /etc/pulse/defaults.pa e isso aconteceu no controle de volume do ubuntu...

O caso é que nem sei que diabos é um módulo, kkkkkkkk!!!

Tanto que mudei o foco e abri um tópico novo: https://ubuntuforum-br.org/index.php?topic=124741.0

Bom falar com você, creto.

Abraços!

Ubuntu-Mate 16.04 Xenial
Lubuntu-LXQt 20.04 Focal

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 610
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:DroidCam: Audio não funciona de jeito nenhum
« Resposta #9 Online: 05 de Dezembro de 2020, 10:22 »
Já somos figurinhas velhas aqui meu amigo e tendo saúde, estamos ai pronto a tentar auxiliar
;)

T+
A vida, é feito andar de bicicleta, se parar, você cai! (Gabriel Contino)
Blog do Paulo Corrêa Creto