Autor Tópico: Wi-fi está logada, mas não conecta.  (Lida 1468 vezes)

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Wi-fi está logada, mas não conecta.
« Online: 13 de Maio de 2020, 14:19 »
Olá Pessoal.

Estou com um problema a algum tempo, mas só agora resolvi buscar ajuda pq cansei de esperar e ficar no "mecânico".
Ocorre que o meu computador está logado no wi-fi e as vezes ele conecta direto e as vezes não. Mesmo logado ele fica sem sinal. Eu fico conectando insistentemente, manualmente e as vezes até desisto pq ele não conecta de jeito algum. Fiz alguns prints pra ver se alguém consegue me ajudar.

https://drive.google.com/file/d/1FsQ92-DS1QW4zosmpSh7pP8V9KQw9RU0/view?usp=sharing,%20
https://drive.google.com/file/d/1Zbb0g5Bnc-35FgxSyrVWWMBNzC0IO5Fm/view?usp=sharing,%20
https://drive.google.com/file/d/1gxQ2eEnM-DFzZRX2Ju-oCsoffvIFtpZx/view?usp=sharing

O detalhe é que todos os aparelhos de casa, celular, tv smart, outro notebook com windows, todos são conectados na rede wi-fi, então o problema não é o sinal.

Pesquisei na internet o comando sudo service network-manager restart mas a única diferença é que o sinal na barra fica como conectado, mas internamente ele não está.

Alguém pode me ajuda?
« Última modificação: 13 de Maio de 2020, 14:51 por RosaneNany »

Offline flavioml

  • Usuário Ubuntu
  • *
  • Mensagens: 111
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #1 Online: 13 de Maio de 2020, 17:00 »
Informe qual é o seu adpatador wifi.
Flavio ML

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #2 Online: 13 de Maio de 2020, 17:37 »
Flávio, uso apenas o notebook e o modem da internet a cabo (Cabo Telecom).

Offline CelticWarrior

  • Usuário Ubuntu
  • *
  • Mensagens: 132
    • Ver perfil
    • CHANGAN Auto
Re:Wi-fi está logada, mas não conecta.
« Resposta #3 Online: 13 de Maio de 2020, 18:21 »
Esse modem mais bem deve ser um router com WiFi...

A sua pergunta afinal é porque o "computador está logado no wi-fi e as vezes ele conecta direto e as vezes não". Então o seu computador se conecta com algo por WiFi, certo? Ora bem, uma vez que diz que tudo o resto funciona, esse "algo" ao qual se conecta está funcionando e por isso é irrelevante.

O que importa saber é qual o dispositivo WiFi no seu computador porque o problema está aí ou, pelo menos, o início do diagnóstico começa sempre por aí, entendeu?

Por favor diga-nos qual é. Se não sabe basta correr no Terminal 'lspci' e/ou 'lsusb', este último aplica-se apenas a dispositivos externos USB.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.437
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wi-fi está logada, mas não conecta.
« Resposta #4 Online: 13 de Maio de 2020, 19:47 »
Olá @RosaneNanny,

Seus prints estão inacessíveis. Você precisa liberar para que qualquer um com o link possa vê-los, ou confirmar que o link foi postado corretamente.

Como os outros colegas já disseram, precisamos de informação de sua máquina pra poder te ajudar. Ajuda também saber qual a versão exata do Ubuntu você está usando.

Os comandos abaixo vão dar a informação que precisamos. Por favor, execute-os em uma janela de comandos e cole o resultado aqui. Evite usar prints, pois além de haver o risco do problema se repetir, tira a informação de texto que usamos pra pesquisar o problema.

sudo lshw -C network
iwconfig
ifconfig -a
route -n
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #5 Online: 13 de Maio de 2020, 21:00 »
Se não sabe basta correr no Terminal 'lspci' e/ou 'lsusb', este último aplica-se apenas a dispositivos externos USB.

Obrigada pelos esclarecimentos e realmente sou leiga, então alguns termos não sei de fato, mas sua orientação ajudou assim como a o outro colegal. Grata.

Não uso nenhum dispositivo externo para conexão.O resultado no terminal foi:

rosanesilva@rss:~$ lspci
00:00.0 Host bridge: Intel Corporation Core Processor DRAM Controller (rev 02)
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
00:16.0 Communication controller: Intel Corporation 5 Series/3400 Series Chipset HECI Controller (rev 06)
00:1a.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1b.0 Audio device: Intel Corporation 5 Series/3400 Series Chipset High Definition Audio (rev 05)
00:1c.0 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 1 (rev 05)
00:1c.1 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 2 (rev 05)
00:1c.2 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 3 (rev 05)
00:1c.4 PCI bridge: Intel Corporation 5 Series/3400 Series Chipset PCI Express Root Port 5 (rev 05)
00:1d.0 USB controller: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller (rev 05)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev a5)
00:1f.0 ISA bridge: Intel Corporation HM55 Chipset LPC Interface Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 5 Series/3400 Series Chipset 4 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 5 Series/3400 Series Chipset SMBus Controller (rev 05)
00:1f.6 Signal processing controller: Intel Corporation 5 Series/3400 Series Chipset Thermal Subsystem (rev 05)
05:00.0 Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 02)
ff:00.0 Host bridge: Intel Corporation Core Processor QuickPath Architecture Generic Non-core Registers (rev 02)
ff:00.1 Host bridge: Intel Corporation Core Processor QuickPath Architecture System Address Decoder (rev 02)
ff:02.0 Host bridge: Intel Corporation Core Processor QPI Link 0 (rev 02)
ff:02.1 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor QPI Physical 0 (rev 02)
ff:02.2 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)
ff:02.3 Host bridge: Intel Corporation 1st Generation Core i3/5/7 Processor Reserved (rev 02)

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #6 Online: 13 de Maio de 2020, 21:17 »
zekkerj muito obrigada pelas palavras. Fiz como orientado e vou postar aqui.

sudo lshw -C network
iwconfig
ifconfig -a
route -n



rosanesilva@rss:~$ sudo lshw -C network
[sudo] senha para rosanesilva:
  *-network                 
       descrição: Interface sem fio
       produto: AR9285 Wireless Network Adapter (PCI-Express)
       fabricante: Qualcomm Atheros
       ID físico: 0
       informações do barramento: pci@0000:05:00.0
       nome lógico: wlp5s0
       versão: 01
       serial: c4:46:19:26:8b:95
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=ath9k driverversion=5.3.0-51-generic firmware=N/A ip=192.168.1.6 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       recursos: irq:17 memória:d6400000-d640ffff
  *-network
       descrição: Ethernet interface
       produto: RTL810xE PCI Express Fast Ethernet controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:06:00.0
       nome lógico: enp6s0
       versão: 02
       serial: 00:23:5a:65:cd:76
       capacidade: 100Mbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8169 latency=0 link=no multicast=yes port=MII
       recursos: irq:18 porta de E/S:2000(tamanho=256) memória:d2410000-d2410fff memória:d2400000-d240ffff memória:d5400000-d541ffff
rosanesilva@rss:~$ iwconfig
wlp5s0    IEEE 802.11  ESSID:"Berenet" 
          Mode:Managed  Frequency:2.447 GHz  Access Point: E2:37:17:BA:B3:F8   
          Bit Rate=1 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=63/70  Signal level=-47 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:26   Missed beacon:0

lo        no wireless extensions.

enp6s0    no wireless extensions.

rosanesilva@rss:~$ ifconfig -a 
enp6s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 00:23:5a:65:cd:76  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback Local)
        RX packets 19978  bytes 1556188 (1.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 19978  bytes 1556188 (1.5 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.6  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::f6cc:f25f:9817:a8d2  prefixlen 64  scopeid 0x20<link>
        inet6 fd00::d97f:ce00:a205:e9d8  prefixlen 64  scopeid 0x0<global>
        inet6 fd00::80f7:6238:c8e3:5df7  prefixlen 64  scopeid 0x0<global>
        ether c4:46:19:26:8b:95  txqueuelen 1000  (Ethernet)
        RX packets 22840  bytes 15691511 (15.6 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 13674  bytes 2011280 (2.0 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
rosanesilva@rss:~$ route -n
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    600    0        0 wlp5s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp5s0
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp5s0



Pronto! acho que é isso. Mais uma vez gratidão. :)
« Última modificação: 13 de Maio de 2020, 21:18 por RosaneNany »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.437
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wi-fi está logada, mas não conecta.
« Resposta #7 Online: 15 de Maio de 2020, 14:14 »
OK. Seu adaptador Wi-Fi é um "AR9285 Wireless Network Adapter (PCI-Express)".

Pela saída dos comandos, sua Wi-Fi está conectada e tem sinal bom (63/70). Talvez seu problema seja de DNS, ou com o IPv6.

Execute mais estes comandos, pf., pra gente avaliar.

ping -4 -c 4 8.8.8.8
ping -4 -c 4 www.google.com
ping -6 -c 4 2800:3f0:4004:809::2004
ping -6 -c 4 www.google.com

Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #8 Online: 15 de Maio de 2020, 14:29 »
Execute mais estes comandos, pf., pra gente avaliar.
ping -4 -c 4 8.8.8.8
ping -4 -c 4 www.google.com
ping -6 -c 4 2800:3f0:4004:809::2004
ping -6 -c 4 www.google.com


Olá. Executei e o resulta está aqui embaixo.

rosanesilva@rss:~$ ping -4 -c 4 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=41.0 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=43.2 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=56 time=40.8 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=56 time=40.7 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 40.785/41.478/43.206/1.034 ms
rosanesilva@rss:~$ ping -4 -c 4 www.google.com
PING www.google.com (172.217.172.196) 56(84) bytes of data.
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=1 ttl=56 time=40.5 ms
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=2 ttl=56 time=42.3 ms
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=3 ttl=56 time=40.5 ms
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=4 ttl=56 time=40.9 ms

--- www.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3003ms
rtt min/avg/max/mdev = 40.518/41.090/42.369/0.770 ms
rosanesilva@rss:~$ ping -6 -c 4 2800:3f0:4004:809::2004
PING 2800:3f0:4004:809::2004(2800:3f0:4004:809::2004) 56 data bytes

--- 2800:3f0:4004:809::2004 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3070ms

rosanesilva@rss:~$ ping -4 -c 4 www.google.com
PING www.google.com (172.217.172.196) 56(84) bytes of data.
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=1 ttl=56 time=40.7 ms
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=2 ttl=56 time=40.1 ms
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=3 ttl=56 time=40.9 ms
64 bytes from gru14s14-in-f4.1e100.net (172.217.172.196): icmp_seq=4 ttl=56 time=40.6 ms

--- www.google.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 40.143/40.633/40.938/0.298 ms
rosanesilva@rss:~$

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.437
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wi-fi está logada, mas não conecta.
« Resposta #9 Online: 15 de Maio de 2020, 15:25 »
Como eu imaginei... você não tem uma conexão IPv6 funcional, o que está "embananando" seu Ubuntu.

Alguns passos...

1. Execute o comando abaixo.

echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf

2. Reinicie seu Ubuntu. (Isso vai desabilitar o IPv6 globalmente).

3. Abra o Firefox, abra o endereço "about:config". Prometa que será cuidadosa.

4. Procure pelo controle "network.DNS.disableIPv6" e ative-o.

5. Reinicie o Firefox e teste sua conexão.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #10 Online: 16 de Maio de 2020, 10:49 »
Como eu imaginei... você não tem uma conexão IPv6 funcional, o que está "embananando" seu Ubuntu.

Alguns passos...

1. Execute o comando abaixo.

echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf

2. Reinicie seu Ubuntu. (Isso vai desabilitar o IPv6 globalmente).

3. Abra o Firefox, abra o endereço "about:config". Prometa que será cuidadosa.

4. Procure pelo controle "network.DNS.disableIPv6" e ative-o.

5. Reinicie o Firefox e teste sua conexão.

Olá Zekkerj. Fiz todo o procedimento. O network.dns.disableIPv6 ficou no teu, mas nada aconteceu.
Tentei conectar manualmente por uns 10 minutos, porém não deu certo. Estou sem o acesso ao Wi-Fi.

Há alguma outra coisa a ser feita?

Eu acabei executando novamente os comandos anteriores que você solicitou pra ver se a resposta era a mesma, mas parece que não foi a mesma...

Nas duas vezes que digitei o comando abaixo a resposta foi essa.

rosanesilva@rss:~$ ping -4 -c 4 www.google.com
PING www.google.com: Nome ou serviço desconhecido.

Fiz os quatro comandos na sequência

rosanesilva@rss:~$ ping -4 -c 4 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=41.9 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=127 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=56 time=70.9 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=56 time=40.7 ms

--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 40.799/70.357/127.743/35.259 ms

rosanesilva@rss:~$ ping -6 -c 4 2800:3f0:4004:809::2004
PING 2800:3f0:4004:809::2004(2800:3f0:4004:809::2004) 56 data bytes

--- 2800:3f0:4004:809::2004 ping statistics ---
4 packets transmitted, 0 received, 100% packet loss, time 3063ms

Offline Anderson_Coelho

  • Usuário Ubuntu
  • *
  • Mensagens: 603
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #11 Online: 16 de Maio de 2020, 11:01 »
Posso estar falando bobeira, mas acho que para carregar as alterações feitas no sysctl.conf precisa executar um sudo sysctl -p

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.437
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re:Wi-fi está logada, mas não conecta.
« Resposta #12 Online: 17 de Maio de 2020, 18:31 »
Posso estar falando bobeira, mas acho que para carregar as alterações feitas no sysctl.conf precisa executar um sudo sysctl -p
Não é bobeira. Apenas não precisa, reiniciar dá no mesmo.
Mas... vc reiniciou o Ubuntu, @Rosane? Pq a mensagem que vc deveria receber no "ping -6" seria "Network unreachable" ou coisa parecida, então seu IPv6 continua ativo.
Será que o comando pra mudar a configuração falhou???
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 701
    • Ver perfil
    • fabmak://website
Re:Wi-fi está logada, mas não conecta.
« Resposta #13 Online: 18 de Maio de 2020, 10:17 »
Agora, me parece um problema de DNS.

RosaneNany, poste o resultado aqui dos comandos:

cat /etc/resolv.conf

sudo systemd-resolve --status (Role até em baixo)

         DNS Servers: 8.8.8.8                   
                      1.1.1.1                       
                      2804:14c:bb10:672:189:5:128:115
                      2804:14c:bb10:672:189:5:128:107


Depois edite e salve o arquivo com sudo nano /etc/resolv.conf e deixe assim: (Control + O para salvar e Control + X para sair
nameserver 8.8.8.8
nameserver 1.1.1.1

E tente realizar os testes de ping novamente.
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline RosaneNany

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re:Wi-fi está logada, mas não conecta.
« Resposta #14 Online: 18 de Maio de 2020, 23:06 »
Não é bobeira. Apenas não precisa, reiniciar dá no mesmo.
Mas... vc reiniciou o Ubuntu, @Rosane? Pq a mensagem que vc deveria receber no "ping -6" seria "Network unreachable" ou coisa parecida, então seu IPv6 continua ativo.
Será que o comando pra mudar a configuração falhou???

zekkerj, copiei e colei os comandos, então creio realmente ter feito como me pediu.

Mas, depois que eu fiz o comando que o Anderson_Coelho sugeriu, parece que está mais 'fácil' conectar. As vezes quando ligo ele não está disponível, depois abro as configurações do wi-fi/configurações da minha rede e clico em aplicar, ele tenta conectar e não demora muito conecta.

Como precisarei estar mais conectada na semana, vou verificar como ele se comporta e volto a dar um feedback aqui.

Desde já, gratidão ; )