Autor Tópico: [RESOLVIDO] Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.  (Lida 1994 vezes)

Offline Daniela Martins

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
[RESOLVIDO] Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Online: 05 de Maio de 2020, 14:30 »
Sempre usei o programa GRIFFITH porque ele é disparadamente o melhor detodos.
Eu já experimentei um monte.
Desde o ubuntu 16 tenho tido problemas para instalá-lo mas sempre consigo no fim, fazendo um monte de comandos e downloads separados. Catando informações inclusive aqui, mas consigo.
Só que esta semana, passei grande parte do tempo tentando instalar, procurando informações de como instalar e não acho nada.

Preciso instalar o GRIFFITH no ubuntu 20.04LTS.
Alguém me ajude, por favor!
« Última modificação: 09 de Maio de 2020, 11:23 por Daniela Martins »

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 557
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Preciso instalar o GRIFFITH no ubuntu 20.04LTS. Alguém me ajude, por favor!
« Resposta #1 Online: 05 de Maio de 2020, 23:20 »
Olá Daniela,

Em primeira dica é peço que não me leve a mal, edite o titúlo do de seu tópico para que ele não seja trancado por algum admin ou moderador, retirando a palavra "ajuda".

Como estou no smart mas vamos logo ao ponto se você está em uma dessas versões do ubuntu 16.04 ou 14.04 bastaria você abrir a central de programas e procurar por Griffith.

Ou abrir um terminal e:
Código: [Selecionar]
sudo apt update ; sudo apt install griffith
Porém se está usando uma versão mais recente acho que será difícil olhe >>> este link aqui <<< por hora é em que posso lhe auxiliar.

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto

Offline zoroastro

  • Usuário Ubuntu
  • *
  • Mensagens: 615
  • Membro de Honra
    • Ver perfil
Re:Preciso instalar o GRIFFITH no ubuntu 20.04LTS.
« Resposta #2 Online: 06 de Maio de 2020, 04:12 »
Pelo que entendi, há algum empecilho para fazer o software funcionar?

Eu até agradeço por saber que existe o Griffith. Vi aqui em
Código: [Selecionar]
$ apt-cache search griffithQue ele está disponível para instalação.

Eu não conheço o software, então eu não sei. O que há de trabalhoso para instalar ele além de aplicar o comando
Código: [Selecionar]
$ sudo apt-get install griffith  ?

A sua resposta pode nos ajudar a saber como ajudá-la.
« Última modificação: 07 de Maio de 2020, 02:28 por zoroastro »

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 557
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Preciso instalar o GRIFFITH no ubuntu 20.04LTS.
« Resposta #3 Online: 06 de Maio de 2020, 10:49 »
Olá zoroastro, Daniela, bom dia a todos,
...

Eu até agradeço por saber que existe o Griffith. Vi aqui em
Código: [Selecionar]
$ apt-cache seach griffithQue ele está disponível para instalação.

...

Mas zoroastro, me bateu uma curiosidade (agora que estou na frente do PC com o BigLinux 20.04, não encontro o griffith aqui:
Código: [Selecionar]
creto@creto:~$ apt-cache search griffith
libstatistics-distributions-perl - module for calculating some values of common statistical distributions
creto@creto:~$

Ou melhor pelo packages ubuntu search >>> olhe aqui <<< só se encontra o aplicativo para a versão 16.04 LTS xenial, e nossa amiga diz que
 
...

Preciso instalar o GRIFFITH no ubuntu 20.04LTS.
Alguém me xxx, por favor!


Então achei curioso, a não ser que se adicione uma linha do repo do xenial, mas ai teria a possibilidade de o app não funcionar.

Site oficial do Griffith https://repology.org/project/griffith/versions

T+
« Última modificação: 06 de Maio de 2020, 10:54 por creto »
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto

Offline Daniela Martins

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:Preciso instalar o GRIFFITH no ubuntu 20.04LTS. Alguém me ajude, por favor!
« Resposta #4 Online: 06 de Maio de 2020, 11:28 »
Olá Daniela,

Em primeira dica é peço que não me leve a mal, edite o titúlo do de seu tópico para que ele não seja trancado por algum admin ou moderador, retirando a palavra "ajuda".

Como estou no smart mas vamos logo ao ponto se você está em uma dessas versões do ubuntu 16.04 ou 14.04 bastaria você abrir a central de programas e procurar por Griffith.

Ou abrir um terminal e:
Código: [Selecionar]
sudo apt update ; sudo apt install griffith
Porém se está usando uma versão mais recente acho que será difícil olhe >>> este link aqui <<< por hora é em que posso lhe auxiliar.

T+



Olá, Creto.

Que legal você me responder. Há 4 anos atrás, quando instalei o ubuntu 16 e tive problemas para abrir o este mesmo programa, você foi quem solucionou. Que bom te reencontrar.


Vamos lá:

Desde o ubuntu 16 o Griffith não aparece mais na UBUNTU SOFTWARE. Pra instalar é uma confusão porque não sei muita coisa de computador.
quando dei os comandos que você sugeriu o update ele dá mas a instalação da:

daniela@daniela-System-Product-Name:~$ sudo apt install griffith
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote griffith


O link que você mandou eu achei ontem a noite só que não consegui entender nada.
Achei que eu ia clicar e fazer o download do griffith 16.04 mas entra numa página onde tudo que a gente clica não faz download. Honestamente, como devo usar aquele monte de links do site?
No ubuntu 16, a solução foi instalar o griffith do ubuntu 14, que veio com problemas mas instalou, aí foi quando você me ajudou e deu certo. Quando entrei neste site pkgs.org, tive esperança de conseguir mas não sei usar o site.

Offline Daniela Martins

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:Preciso instalar o GRIFFITH no ubuntu 20.04LTS.
« Resposta #5 Online: 06 de Maio de 2020, 11:36 »
Pelo que entendi, há algum empecilho para fazer o software funcionar?

Eu até agradeço por saber que existe o Griffith. Vi aqui em
Código: [Selecionar]
$ apt-cache seach griffithQue ele está disponível para instalação.

Eu não conheço o software, então eu não sei. O que há de trabalhoso para instalar ele além de aplicar o comando
Código: [Selecionar]
$ sudo apt-get install griffith  ?

A sua resposta pode nos ajudar a saber como ajudá-la.


Olá, Zoroastro.

Bem, o Griffith não está disponível para instalação no Ubuntu 20.04 LTS. Tenho certeza.
Ele deixou de estar desde o Ubuntu 16.04.
De todo modo, ao dar o comando que você sugeriu:

daniela@daniela-System-Product-Name:~$ sudo apt-cache seach griffith
E: Operação seach inválida


Resolvi mudar a palavra SEACH para SEARCH e deu isso:

daniela@daniela-System-Product-Name:~$ sudo apt-cache search griffith
libstatistics-distributions-perl - module for calculating some values of common statistical distributions





Offline Daniela Martins

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #6 Online: 06 de Maio de 2020, 11:43 »
Eu achei ontem a noite esse link que é de uma pessoa que não conseguiu instalar no ubuntu 18.
Será que serviria pra mim?

https://bugs.launchpad.net/griffith/+bug/1776064

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 557
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #7 Online: 06 de Maio de 2020, 21:34 »
Olá,

E primeiro, agora estou em um PC e vou tentar te mostrar o quão isso seria complicado, preste atenção no logs do meu terminal abaixo:

Eu achei ontem a noite esse link que é de uma pessoa que não conseguiu instalar no ubuntu 18.
Será que serviria pra mim?

https://bugs.launchpad.net/griffith/+bug/1776064

Baixando e tentando instalar o Griffith do ubuntu 16.04  https://packages.ubuntu.com/xenial/griffith no meu BigLinux 20.04 que é um derivado do ubuntu

Leia com atenção:
Código: [Selecionar]
creto@creto:~$ cd ~/Downloads/
creto@creto:~/Downloads$ ls
 AndSanttos
 anydesk_5.5.5-1_amd64.deb
 bodhibuilder_2.18.5_all
'bodhibuilder_2.18.5_all (1).deb'
 bodhibuilder_2.18.5_all.deb
 Bolo-Peppa-Pig-19.jpg
 BosqueTK.jpg
 BosqueTK_resized.jpg
 EmpacotamentoDebRPM.pdf
 griffith_0.13+20140313-1_all.deb
'Telegram Desktop'
creto@creto:~/Downloads$ sudo apt install ./griffith_0.13+20140313-1_all.deb
[sudo] senha para creto:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Note, a seleccionar 'griffith' em vez de './griffith_0.13+20140313-1_all.deb'
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 griffith : Depende: python-gtk2 (>= 2.8.6-1) mas não é instalável
            Depende: python-glade2 (>= 2.8.6-1) mas não é instalável
            Depende: python-imaging (>= 1.1.5-6) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.
creto@creto:~/Downloads$

Como pode ver não há as dependências de que ele necessita para ser instalado.

Compilar o arquivo em tar.xz vai dar no mesmo problema então olhe bem no final dessa página os aplicativos similares ao Griffith:

Procure no final de https://packages.ubuntu.com/xenial/griffith

Lá você vai encontrar links sobre esses apps:

Citar
Similar packages:
libtickit-widget-floatbox-perl
libxml-sax-machines-perl
mysql-utilities
qapt-utils
ruby-mixlib-shellout
daemontools
fotoxx
swac-get
tellico
fotoxx-common
ldm-themes

Espero ter sido útil de alguma forma.

Pode dar uma olhada neste tópico que fala sobre mais ou menos o que você quer (eu particularmente não conheço o Griffith)

https://ubuntuforum-br.org/index.php?topic=28625.0

T+
« Última modificação: 06 de Maio de 2020, 21:40 por creto »
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto

Offline Daniela Martins

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #8 Online: 06 de Maio de 2020, 22:43 »
Eu consegui instlar ele pelo playonlinux, o .exe.
só que não restaura minha database e nem busca nada na internet.

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 724
    • Ver perfil
    • fabmak://website
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #9 Online: 06 de Maio de 2020, 22:51 »
Se não existe nos repositórios, o único jeito é compilar a partir do fontes.

Consulte o projeto.
https://gitlab.com/Strit/griffith
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline zoroastro

  • Usuário Ubuntu
  • *
  • Mensagens: 615
  • Membro de Honra
    • Ver perfil
Re:Preciso instalar o GRIFFITH no ubuntu 20.04LTS.
« Resposta #10 Online: 07 de Maio de 2020, 02:35 »
daniela@daniela-System-Product-Name:~$ sudo apt-cache seach griffith
E: Operação seach inválida


Resolvi mudar a palavra SEACH para SEARCH e deu isso:

daniela@daniela-System-Product-Name:~$ sudo apt-cache search griffith
libstatistics-distributions-perl - module for calculating some values of common statistical distributions


Eu ERREI quando faltou o R no SEARCH.

Essa informação é importante para saber que o pacote não está no seu repositório.

Geralmente eu quando quero instalar um software que eu sei que tem nos repositórios de outra distro derivada do Debian ou do próprio Debian, eu faço uns testes para ver se consigo antes de partir para a instalação por fontes e compilação.

Funciona assim:
1) Adicionar o repositório de alguma distro que contém o software
Backup do sources.list:
Código: [Selecionar]
# cp  /etc/apt/sources.list  /etc/apt/sources.list_bkp
E adicionar o repositório de outra versão debian-based ou Debian ou versão anterior do Ubuntu:
Código: [Selecionar]
# pluma  /etc/apt/sources.list
Coloquei o Pluma mas eu não sei qual Editor de Texto você usa. E depois fechar o arquivo, salvando.

2) Passar o comando
Código: [Selecionar]
# apt-get update
3) Verificar pendências ao tentar instalar o software
Código: [Selecionar]
# apt-get install griffith
Se não houver dependências conflitantes, e não apresentar dificuldades para seguir em frente, eu tento e assumo os riscos. Às vezes funciona muto bem. Quando não funciona, ou quando mexeu com um pacote conflitante, a questão é reverter. Se não mexeu com pacote conflitante e o software simplesmente não executar, basta remover.

Quais versões de Ubuntu tem o griffith? Eu instalei ele aqui em um derivado do Ubuntu 14.04 LTS, que é o que estou usando. São poucos pacotes:
Código: [Selecionar]
The following extra packages will be installed:
  python-sqlalchemy
Suggested packages:
  griffith-extra-artwork python-sqlite ipython python-sqlalchemy-doc
  python-kinterbasdb python-pymssql
Recommended packages:
  python-gtkspell python-psycopg2 python-mysqldb python-sqlalchemy-ext
The following NEW packages will be installed:
  griffith python-sqlalchemy


Instalei o Griffith aqui no meu Distro Astro e mesmo depois de instalar os pacotes sugeridos, ele não deu certo:
Código: [Selecionar]
$ griffith
Traceback (most recent call last):
  File "/usr/bin/griffith", line 86, in <module>
    import add
  File "/usr/share/griffith/lib/add.py", line 31, in <module>
    import quick_filter
  File "/usr/share/griffith/lib/quick_filter.py", line 25, in <module>
    import db
  File "/usr/share/griffith/lib/db/__init__.py", line 30, in <module>
    from _objects import *
  File "/usr/share/griffith/lib/db/_objects.py", line 33, in <module>
    import validators
  File "/usr/share/griffith/lib/db/validators.py", line 26, in <module>
    from sqlalchemy.orm.interfaces import AttributeExtension, InstrumentationManager
ImportError: cannot import name InstrumentationManager

Como eu não conheço o software e nunca o usei, então não conheço a situação. Vou ter que estudar para saber o que está ocorrendo. Vai ser útil para ver filmes.

*** Hora de formatar para uma versão mais recente. Já é tempo.***
« Última modificação: 07 de Maio de 2020, 03:11 por zoroastro »

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 557
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #11 Online: 07 de Maio de 2020, 12:31 »
Olá a todos,

Vamos ao processo mais demorado, e como disse o FaBMak mais acima, compilar o griffith do Git

1º - Instalar o git no ubuntu
Código: [Selecionar]
sudo apt update ; sudo apt install git
2º - Preparar o GIT
Código: [Selecionar]
git config --global user.name "Paulo Creto"
Código: [Selecionar]
git config --global user.email "exemplo@seuemail.com.br"
Trocar nome pelo seu e email também

3º - Clonar o griffith do repositório
Código: [Selecionar]
git clone https://gitlab.com/Strit/griffith.git
4º - Compilar o bicho
Código: [Selecionar]
cd ~/griffith
Código: [Selecionar]
sudo make install

Clique na imagem para ampliar

Porém o griffith não abre, então o que suponho ele não irá funcionar no ubuntu 20.04 nem a bala
Código: [Selecionar]
creto@creto:~$ griffith
/usr/bin/griffith:27: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
  import imp
2020-05-07T12:30:48: E: Griffith(griffith:77): Error: missing modules:
2020-05-07T12:30:48: E: Griffith(griffith:79): sqlalchemy
2020-05-07T12:30:48: E: Griffith(griffith:81):  :: required version: 0.5rc3
2020-05-07T12:30:48: E: Griffith(griffith:84):

creto@creto:~$

A solução dada pelo FaBMak

Código: [Selecionar]
sudo apt update ; sudo apt install python3-sqlalchemy python3-pypillowfight python3-reportlabÉ só copiar daqui e colar no seu terminal todos os comandos postados nesta mensagem


Clique para ampliar o Griffith funcionando

Espero ter sido útil de alguma forma

T+
« Última modificação: 08 de Maio de 2020, 10:10 por creto »
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto

Offline FaBMak

  • Administrador
  • Usuário Ubuntu
  • *****
  • Mensagens: 724
    • Ver perfil
    • fabmak://website
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #12 Online: 07 de Maio de 2020, 14:47 »
Tem que ler a documentação, pacotes sempre tem dependências, podem tentar instalar:
python3-sqlalchemy
python3-pypillowfight
python3-reportlab
"Não creias impossível o que apenas improvável parece". (Shakespeare)
fabmak://website | http://twitter.com/fabmak

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 557
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #13 Online: 08 de Maio de 2020, 10:00 »
Obrigado pela dica Professor FaBMak,

Tem que ler a documentação, pacotes sempre tem dependências, podem tentar instalar:
python3-sqlalchemy
python3-pypillowfight
python3-reportlab

Realmente tem:
Código: [Selecionar]
creto@creto:~$ apt-cache policy python3-sqlalchemy python3-pypillowfight python3-reportlab
python3-sqlalchemy:
  Instalado: (nenhum)
  Candidato: 1.3.12+ds1-1ubuntu2
  Tabela de versão:
     1.3.12+ds1-1ubuntu2 500
        500 http://ubuntu.lua.im/ubuntu focal/main amd64 Packages
        500 http://ubuntu.lua.im/ubuntu focal/main i386 Packages
python3-pypillowfight:
  Instalado: (nenhum)
  Candidato: 0.3.0-3build1
  Tabela de versão:
     0.3.0-3build1 500
        500 http://ubuntu.lua.im/ubuntu focal/universe amd64 Packages
python3-reportlab:
  Instalado: 3.5.34-1ubuntu1
  Candidato: 3.5.34-1ubuntu1
  Tabela de versão:
 *** 3.5.34-1ubuntu1 500
        500 http://ubuntu.lua.im/ubuntu focal/main amd64 Packages
        500 http://ubuntu.lua.im/ubuntu focal/main i386 Packages
        100 /var/lib/dpkg/status
     3.5.13-1+deb10u1 100
        100 http://cloudfront.debian.net/debian-security buster/updates/main amd64 Packages
creto@creto:~$

Vamos ver...

T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto

Offline creto

  • Usuário BigLinux
  • Usuário Ubuntu
  • *
  • Mensagens: 557
  • Vivemos esperando dias melhores
    • Ver perfil
    • Blog do Creto
Re:Preciso instalar o GRIFFITH no ubuntu 20.04 LTS.
« Resposta #14 Online: 08 de Maio de 2020, 10:16 »
A solução de instalação

Acessar a mensagem acima em https://ubuntuforum-pt.org/index.php?topic=124391.msg679568#msg679568

E proceder da mesma forma que está na mensagem

Obs: Como o pacote foi compilado não consegui fazer um .DEB com o dpkg-repack

Mas espero termos sido úteis de alguma forma Daniela, agora terá o Griffith


T+
Perguntas-me qual foi o meu progresso? Comecei a ser amigo de mim mesmo. (Lúcio Aneu Séneca)
Blog do Paulo Corrêa Creto