Autor Tópico: Adaptador wireless não funciona  (Lida 515 vezes)

Offline lucacete

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Adaptador wireless não funciona
« Online: 21 de Maio de 2019, 14:51 »
Eu utilizo o windows 10.
Atualmente estou com um computador(desktop) e fica longe do roteador, não sendo possível conectar via cabo, comprei um adaptador wireless e tal. Funciona normalmente no windows 10 porém em nenhuma distro linux ele não funciona, testei no kubuntu, nem apareceu nenhum wifi, linux mint xfce e ubuntu mate, apareceram porém não conecta.
Tenho um cd que veio junto mas não possuo leitor de cd/dvd. Aqui diz ser suportar múltiplos sistemas operacionais, não tem nenhuma especificação de modelo, nome nem nada do adaptador wireless, mas procurei pela internet e parece ser esse: https://www.amazon.com.br/Mini-adaptador-150Mbs-Wireless-802-11/dp/B077FXGGQM?tag=goog0ef-20&smid=A1WJIIN3ITG4RR&ascsubtag=go_1676964938_67796570520_325220716474_pla-662842274384_c_

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.262
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Adaptador wireless não funciona
« Resposta #1 Online: 21 de Maio de 2019, 16:02 »
Execute os comandos abaixo no (K)ubuntu com o adaptador conectado, em uma janela de comandos, e cole o resultado aqui.

sudo lshw -C network
iwconfig
ifconfig -a
route -n
nmcli dev wifi list
rfkill list wifi
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline lucacete

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Adaptador wireless não funciona
« Resposta #2 Online: 21 de Maio de 2019, 18:36 »
Então, eu instalei o ubuntu 19.04 e me conectei através do celular via usb, acontece de aparecer o wifi, coloco a senha mas não conecta, só pede pra colocar a senha de novo..
Enviarei os resultados dos comandos utilizando o Ubuntu, sem problemas?
Obs: fiz os comandos já conectado via usb/celular, devo fazê-los desconectado?

Citar
*-network                 
       descrição: Ethernet interface
       produto: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:03:00.0
       nome lógico: enp3s0
       versão: 15
       serial: b8:97:5a:fb:27:9c
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=r8169 duplex=half firmware=rtl8168h-2_0.0.2 02/26/15 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       recursos: irq:27 porta de E/S:f000(tamanho=256) memória:fe704000-fe704fff memória:fe700000-fe703fff
  *-network:0
       descrição: Ethernet interface
       ID físico: 1
       nome lógico: enp1s0f0u6u2
       serial: 7a:e9:69:1a:6b:4c
       capacidades: ethernet physical
       configuração: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.97 link=yes multicast=yes
  *-network:1
       descrição: Interface sem fio
       ID físico: 2
       informações do barramento: usb@1:6.4
       nome lógico: wlx7cdd90f754d1
       serial: 7c:dd:90:f7:54:d1
       capacidades: ethernet physical wireless
       configuração: broadcast=yes driver=rt2800usb driverversion=5.0.0-13-generic firmware=0.36 link=no multicast=yes wireless=IEEE 802.11

Citar
lo        no wireless extensions.

enp1s0f0u6u2  no wireless extensions.

wlx7cdd90f754d1  IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:on
         
enp3s0    no wireless extensions.

Citar
enp1s0f0u6u2: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.42.97  netmask 255.255.255.0  broadcast 192.168.42.255
        inet6 fe80::b0e7:1e73:a383:5436  prefixlen 64  scopeid 0x20<link>
        ether 7a:e9:69:1a:6b:4c  txqueuelen 1000  (Ethernet)
        RX packets 64674  bytes 87833405 (87.8 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 40829  bytes 5249161 (5.2 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

enp3s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:97:5a:fb:27:9c  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Loopback Local)
        RX packets 5351  bytes 422982 (422.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 5351  bytes 422982 (422.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx7cdd90f754d1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 7c:dd:90:f7:54:d1  txqueuelen 1000  (Ethernet)
        RX packets 12  bytes 1356 (1.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Citar
Tabela de Roteamento IP do Kernel
Destino         Roteador        MáscaraGen.    Opções Métrica Ref   Uso Iface
0.0.0.0         192.168.42.129  0.0.0.0         UG    100    0        0 enp1s0f0u6u2
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp1s0f0u6u2
192.168.42.0    0.0.0.0         255.255.255.0   U     100    0        0 enp1s0f0u6u2

Citar
IN-USE  SSID         MODE   CHAN  RATE        SIGNAL  BARS  SECURITY 
        Wi-Fi        Infra  11    135 Mbit/s  85      ▂▄▆█  WPA1 WPA2
        NIUFIBRA 97  Infra  1     130 Mbit/s  69      ▂▄▆_  WPA1 WPA2
        FERREIRA     Infra  2     270 Mbit/s  65      ▂▄▆_  WPA1 WPA2

Citar
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.262
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Adaptador wireless não funciona
« Resposta #3 Online: 31 de Maio de 2019, 08:49 »
Eu preciso que você execute os comandos usando o ambiente que você pretende usar, depois. Ou seja, com a mesma versão do Ubuntu que você pretende usar, e com o mesmo adaptador wireless que você pretende usar.

Agora, se você só quer resolver um problema passageiro, e consegue conectar com uma determinada versão, e/ou usando o celular, em vez do adaptador, pq perder tempo consertando algo que vc não vai usar?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D