Autor Tópico: Erro driver nvidia  (Lida 365 vezes)

Offline danspell

  • Usuário Ubuntu
  • *
  • Mensagens: 5
    • Ver perfil
Erro driver nvidia
« Online: 19 de Fevereiro de 2019, 21:43 »
Boa noite pessoal.

Recentemente instalei o ubuntu 18 em meu computador e correu tudo bem. Após isso instalei o steam e counter strike e comecei a fazer testes para jogar, porem ficou muito lento, ai fiz os procedimentos para instalar os drivers proprietários e etc. Testei o 340 e tudo, apos isso testei o 390 e assim por diante, ate achar o melhor. Porem em certo momento ele nao me permitia mais escolher o driver proprietario e ficou travado no opensource. Fiz algumas dicas que encontrei na internet, mas nada resolveu. Tente iniciar de modo avançado e usar a recuperação de pacotes mas também não resolveu. Segue abaixo os erros que obtive ao fazer a ultima tentativa de solução:

Daniel@daniel-System-Product-Name:~$ sudo apt-get install nvidia-340
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você pode querer executar 'apt --fix-broken install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
 libnvidia-cfg1-390 : Conflita: libnvidia-cfg1-any
 libnvidia-decode-390 : Conflita: libnvidia-decode
 libnvidia-decode-390:i386 : Conflita: libnvidia-decode
 libnvidia-encode-390 : Conflita: libnvidia-encode
 libnvidia-encode-390:i386 : Conflita: libnvidia-encode
 libnvidia-fbc1-390 : Conflita: libnvidia-fbc1
 libnvidia-fbc1-390:i386 : Conflita: libnvidia-fbc1
 libnvidia-ifr1-390 : Depende: libnvidia-gl-390 mas não será instalado
                      Conflita: libnvidia-ifr1
 libnvidia-ifr1-390:i386 : Depende: libnvidia-gl-390:i386 mas não será instalado
                           Conflita: libnvidia-ifr1
 nvidia-340 : Conflita: libnvidia-cfg1-any
              Conflita: libnvidia-decode
              Conflita: libnvidia-decode:i386
              Conflita: libnvidia-encode
              Conflita: libnvidia-encode:i386
              Conflita: libnvidia-fbc1
              Conflita: libnvidia-fbc1:i386
              Conflita: libnvidia-ifr1
              Conflita: libnvidia-ifr1:i386
              Conflita: nvidia-dkms-kernel
              Conflita: nvidia-dkms-kernel:i386
              Conflita: nvidia-persistenced
              Conflita: xorg-driver-binary
              Recomenda: libcuda1-340 mas não será instalado
              Recomenda: nvidia-opencl-icd-340 mas não será instalado
 nvidia-compute-utils-390 : Conflita: nvidia-persistenced
 nvidia-dkms-390 : Conflita: nvidia-dkms-kernel
E: Dependências desencontradas. Tente 'apt --fix-broken install' sem nenhum pacote (ou especifique uma solução).
daniel@daniel-System-Product-Name:~$ sudo apt --fix-broken install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  dkms lib32gcc1 libc6-i386 libnvidia-cfg1-390 libnvidia-common-390
  libnvidia-common-415 libnvidia-compute-390:i386 libnvidia-decode-390
  libnvidia-decode-390:i386 libnvidia-encode-390 libnvidia-encode-390:i386
  libnvidia-fbc1-390 libnvidia-fbc1-390:i386 libnvidia-gl-390
  libnvidia-gl-390:i386 libnvidia-ifr1-390 libnvidia-ifr1-390:i386
  libwayland-client0:i386 libwayland-server0:i386 nvidia-compute-utils-390
  nvidia-dkms-390 nvidia-kernel-common-390 nvidia-kernel-source-390
  nvidia-prime nvidia-settings nvidia-utils-390 pkg-config
  screen-resolution-extra xserver-xorg-video-nvidia-390
Utilize 'sudo apt autoremove' para os remover.
The following additional packages will be installed:
  libnvidia-gl-390 libnvidia-gl-390:i386
Os NOVOS pacotes a seguir serão instalados:
  libnvidia-gl-390 libnvidia-gl-390:i386
0 pacotes atualizados, 2 pacotes novos instalados, 0 a serem removidos e 7 não atualizados.
2 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/29,2 MB de arquivos.
Depois desta operação, 147 MB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
(Lendo banco de dados ... 175606 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libnvidia-gl-390_390.87-0ubuntu0~gpu18.04.2_i386.deb ...
desvio de /usr/lib/i386-linux-gnu/libGL.so.1 para /usr/lib/i386-linux-gnu/libGL.so.1.distrib por nvidia-340
dpkg-divert: erro: incompatibilidade em pacote
  na remoção de 'desvio de /usr/lib/i386-linux-gnu/libGL.so.1 por libnvidia-gl-390'
  encontrado 'desvio de /usr/lib/i386-linux-gnu/libGL.so.1 para /usr/lib/i386-linux-gnu/libGL.so.1.distrib por nvidia-340'
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libnvidia-gl-390_390.87-0ubuntu0~gpu18.04.2_i386.deb (--unpack):
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
A preparar para desempacotar .../libnvidia-gl-390_390.87-0ubuntu0~gpu18.04.2_amd64.deb ...
desvio de /usr/lib/x86_64-linux-gnu/libGL.so.1 para /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib por nvidia-340
dpkg-divert: erro: incompatibilidade em pacote
  na remoção de 'desvio de /usr/lib/x86_64-linux-gnu/libGL.so.1 por libnvidia-gl-390'
  encontrado 'desvio de /usr/lib/x86_64-linux-gnu/libGL.so.1 para /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib por nvidia-340'
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libnvidia-gl-390_390.87-0ubuntu0~gpu18.04.2_amd64.deb (--unpack):
 new libnvidia-gl-390:amd64 package pre-installation script subprocess returned error exit status 2
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libnvidia-gl-390_390.87-0ubuntu0~gpu18.04.2_i386.deb
 /var/cache/apt/archives/libnvidia-gl-390_390.87-0ubuntu0~gpu18.04.2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Meu PC é:
amd fx6300
6gb ram ddr3
gtx 750 ti 2gb
placa mae asus m5