Autor Tópico: Como eu faço downgrade de libs?  (Lida 662 vezes)

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Como eu faço downgrade de libs?
« Online: 25 de Janeiro de 2019, 03:52 »
Olá, eu sou novo em ubuntu, eu tive um problema ao executar um arquivo, que aparece este erro:
Código: [Selecionar]
error while loading shared libraries: libboost_regex.so.1.46.1: cannot open shared object file: No such file or directorymas eu já tenho a libboost 1.54 instalada, e eu não consigo desinstalar ela, eu baixei essa: https://sourceforge.net/projects/boost/files/boost/1.46.1/ mas não consigo instalar ela por conta da outra libboost, o que eu faço?
ps: meu ubuntu é 14.04
« Última modificação: 25 de Janeiro de 2019, 03:57 por viniciusbig »

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Como eu faço downgrade de libs?
« Resposta #1 Online: 25 de Janeiro de 2019, 12:54 »
Qual seria a aplicação que você está tentando executar?

Apesar de o Ubuntu 14.04 ser uma versão LTS (Long Time Support), seria recomendável você atualizá-la para a versão 18.04, que também é LTS e também executar aplicativos mais recentes, pois este que você está tentando usar faz uso da biblioteca desatualizada, e fazer o downgrade da mesma não é recomendável, pois pode quebrar outras partes do sistema que fazem uso da mesma.

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Como eu faço downgrade de libs?
« Resposta #2 Online: 25 de Janeiro de 2019, 15:32 »
no caso eu consigo utilizar somente o terminal e tal, é o putty, ai eu não posso atualizar, tenho que manter na 14.04 e tal

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Como eu faço downgrade de libs?
« Resposta #3 Online: 25 de Janeiro de 2019, 16:18 »
no caso eu consigo utilizar somente o terminal e tal, é o putty, ai eu não posso atualizar, tenho que manter na 14.04 e tal

Se você consegue usar o terminal, não precisa do putty. Pode se conectar a outro servidor usando o comando ssh.

Consulte o manual com um "man ssh" para aprender como usá-lo.

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Como eu faço downgrade de libs?
« Resposta #4 Online: 25 de Janeiro de 2019, 21:34 »
eu só tenho acesso ao putty no caso, eu paguei um serviço de vps sabe?

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Como eu faço downgrade de libs?
« Resposta #5 Online: 25 de Janeiro de 2019, 22:40 »
eu só tenho acesso ao putty no caso, eu paguei um serviço de vps sabe?

Putty é um software comumente utilizado para acessar máquinas Linux que possuam o serviço ssh. Geralmente usuários Windows usam mais ele para acessar servidores Linux, através do serviço ssh, o Putty possui a aparência como na imagem abaixo:



Usuários Linux para acessar servidores Linux com serviço ssh ativado na maioria das vezes o fazem apenas via terminal, com o próprio comando ssh, como por exemplo:


ssh usuario@192.168.0.1 -p 12345

Onde:
vermelho: comando principal
azul: usuário existente na máquina que será acessada
verde: ip da máquina que será acessada
marrom: parâmetros de porta, no exemplo, seria a porta 12345. Porém se a máquina a ser acessada estiver com o serviço ssh configurado para ser acessado pela porta padrão (22), não é necessário este parâmetro.

Portanto novamente: você não precisa do Putty em sua máquina Linux para acessar a outra máquina Linux que no caso é o VPS, isso pode ser feito via terminal.
« Última modificação: 25 de Janeiro de 2019, 22:43 por Felix »

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Como eu faço downgrade de libs?
« Resposta #6 Online: 26 de Janeiro de 2019, 12:35 »
mas tipo, eu uso windows ifhdopfsaudfodiadpufs, eu n tô usando linux, eu uso o putty pra acessar tlgd?

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Como eu faço downgrade de libs?
« Resposta #7 Online: 26 de Janeiro de 2019, 16:12 »
mas tipo, eu uso windows ifhdopfsaudfodiadpufs, eu n tô usando linux, eu uso o putty pra acessar tlgd?

Então explique melhor qual é o seu problema. Afinal, qual é o aplicativo que você está tentando utilizar que apresenta a mensagem de erro da primeira mensagem deste tópico?

Da forma como você relatou, deu a entender que o erro apresenta-se ao você tentar executar o Putty no Ubuntu.

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Como eu faço downgrade de libs?
« Resposta #8 Online: 26 de Janeiro de 2019, 19:10 »
tipo, eu só tenho acesso ao putty, mas eu utilizo windows, eu não consigo abrir um programa compilado pq dá um erro de libs sabe? mas eu não consigo colocar a tal lib

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Como eu faço downgrade de libs?
« Resposta #9 Online: 26 de Janeiro de 2019, 19:20 »
tipo, eu só tenho acesso ao putty, mas eu utilizo windows, eu não consigo abrir um programa compilado pq dá um erro de libs sabe? mas eu não consigo colocar a tal lib

Tá difícil, mas vamos tentar novamente:

1) Você não tem acesso ao Putty. Putty é um programa instalado em sua máquina Windows, que você utiliza para acessar uma máquina Linux que está executando um serviço SSH.

2) Novamente: Qual o programa da máquina Linux que está apresentando este erro?. Se você não responder isso não há muito como lhe ajudar.

Offline viniciusbig

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re:Como eu faço downgrade de libs?
« Resposta #10 Online: 26 de Janeiro de 2019, 19:28 »
é esse aqui, o programa q é o que serve pra iniciar o servidor no caso

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.060
    • Ver perfil
    • Alexsandro Felix
Re:Como eu faço downgrade de libs?
« Resposta #11 Online: 26 de Janeiro de 2019, 20:08 »
Como eu disse: se desde o início você tivesse dito qual o programa estava tentando executar, a solução teria sido mais rápida:

The Forgotten Server é um servidor open-source de MMORPG, um fork do projeto OpenTibia. Acessei a página do projeto e descobri que em Outubro de 2014, ainda na versão 1.0 foi removida a dependência da libboost, isto pode ser visto no changelog do projeto.

Portanto, novamente como já sugerido, a atualização de seu servidor Ubuntu para a versão 18.04 é altamente recomendável, e além disso, também atualize seu The Forgotten Server, pois atualmente ele está na versão 1.3. Pois um servidor desatualizado é um risco de segurança que realmente você não quer ter.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.245
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Como eu faço downgrade de libs?
« Resposta #12 Online: 28 de Janeiro de 2019, 19:32 »
Além do que o @Felix sugeriu, você pode também baixar o código-fonte do seu servidor de jogo, e compilá-lo pra sua máquina. Assim você garante que não vai ter problemas com bibliotecas.

Normalmente problemas como esse que você descreveu acontecem quando se tenta instalar um programa à força, simplesmente copiando os executáveis pré-compilados, sem o auxílio do gerenciador de pacotes (ou passando por cima dele).
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D