Autor Tópico: Ubuntu Sem Conexão - Problema Driver Asrock H310m  (Lida 452 vezes)

Offline mateusguida

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Ubuntu Sem Conexão - Problema Driver Asrock H310m
« Online: 11 de Dezembro de 2018, 11:32 »
Bom dia!

Estou com um problema no Ubuntu. Montei uma máquina nova, com a placa mãe da Asrock H310M-G/M.2. Instalei o Dual Boot, tudo certo no Windows 10. Mas no Ubuntu não funciona a rede (cabeada) e aparece que não há nenhum dispositivo de rede instalado. No site do suporte da placa mãe, eles não possuem drive algum para Ubuntu... Não sei então como funciona, como ver se realmente o driver do dispositivo de rede da placa mãe não está devidamente instalado, ou se somente desativado.

Agradeço a ajuda desde já!
« Última modificação: 13 de Dezembro de 2018, 17:27 por mateusguida »

Offline mateusguida

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re:Ubuntu Sem Conexão - Problema Driver Asrock H310m
« Resposta #1 Online: 13 de Dezembro de 2018, 17:26 »
Consegui resolver através de outro fórum, então divido aqui a solução pro meu caso.


Rode esse comando:

Código: [Selecionar]
lspci | grep Ethernet
Resultado:
Código: [Selecionar]
root@mateus-desktop:~# lspci | grep Ethernet
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (7) I219-V (rev 10)



Faça download desse arquivo: https://downloadcenter.intel.com/download/15817/Intel-Network-Adapter-Driver-for-PCI-E-Gigabit-Netwo...

Vá até a pasta de Downloads, clique com o botão direito em Extrair Aqui.

Abra o terminal e use esses comandos:
Código: [Selecionar]
cd Downloads
cd e1000e-3.4.2.1/src/
sudo rmmod e1000e
sudo make install
sudo modprobe e1000e
sudo dpkg-reconfigure linux-image-$(uname -r)

Reinicie o computador.

https://unix.stackexchange.com/questions/294753/intel-ethernet-connection-i219-v-not-working-under-linux-on-an-asuspro-b-laptop/295052#295052

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.236
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Ubuntu Sem Conexão - Problema Driver Asrock H310m
« Resposta #2 Online: 14 de Dezembro de 2018, 09:19 »
Normalmente não é preciso instalar o driver proprietário pra essa placa.

Só o comando “modprobe e1000e” já teria sido suficiente pra resolver.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D