Autor Tópico: Num Lock no Ubuntu Mate 18.04  (Lida 1543 vezes)

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Num Lock no Ubuntu Mate 18.04
« Online: 13 de Abril de 2018, 11:33 »
Saiba como instalar o numlock na inicialização do sistema.

Abra o terminal e instale o numlock com o comando:
sudo apt-get install numlockx

Configurar:  Ainda no terminal, esse comando abrira um arquivo.
sudo pluma /usr/share/lightdm/lightdm.conf.d/50-slick-greeter.conf

Adicione a seguinte linha no final do arquivo e o salve:
greeter-setup-script=/usr/bin/numlockx on

Quando inicializar seu sistema novamente o Nunlock estará ativo ao iniciar seu Ubuntu Mate.

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #1 Online: 15 de Abril de 2018, 10:11 »
no 18.04 isto não funcionou.
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #2 Online: 15 de Abril de 2018, 11:27 »
Fiz exatamente como esta descrito e no meu Ubuntu Mate 18.04 funcionou de primeira.

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #3 Online: 16 de Abril de 2018, 08:22 »
no ubuntu gnome 18.04 não funcionou.
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline Nelson Quintanilha

  • Usuário Ubuntu
  • *
  • Mensagens: 520
  • "O mundo não deve ter fronteiras, mas horizontes."
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #4 Online: 16 de Abril de 2018, 19:27 »
No Ubuntu Gnome

Abra o terminal e instale o numlock com o comando:
sudo apt-get install numlockx

Configurar:  Ainda no terminal, esse comando abrira um arquivo.
sudo gedit /usr/share/lightdm/lightdm.conf.d/50-ubuntu.conf

Adicione a seguinte linha no final do arquivo e o salve:
greeter-setup-script=/usr/bin/numlockx on

Quando inicializar seu sistema novamente o Nunlock estará ativo ao iniciar seu Ubuntu Gnome.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.612
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #5 Online: 17 de Abril de 2018, 16:03 »
no ubuntu gnome 18.04 não funcionou.

Mas o Nelson postou a dica para: Ubuntu Mate 18.04!!!   ::) ::) ::)
Ubuntu  Mate 17.10 64bits

Offline jrkamil

  • Usuário Ubuntu
  • *
  • Mensagens: 412
  • Cabo Frio - RJ - Brasil
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #6 Online: 18 de Abril de 2018, 09:08 »
no ubuntu 18.04 gnome isto aqui funcionou:    gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true
ECS A890GXM-A , Athlon II X3 440, 8 Gb DDR3, nvidia GF 8400GS,  ubuntu  18.04  gnome, ssd 120G, hd 500 g

Offline devesa

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
Re:Num Lock no Ubuntu Mate 18.04
« Resposta #7 Online: 14 de Setembro de 2018, 17:51 »
# Os seguintes passos deu certo pra mim (pode ser que a segunda linha não seja necessária):

Código: [Selecionar]
sudo apt-get install numlockx
gsettings set org.gnome.settings-daemon.peripherals.keyboard remember-numlock-state true
# Reiniciei mas o num lock continuou off, então...
Código: [Selecionar]
sudo -i
su gdm -s /bin/bash
gsettings set org.gnome.settings-daemon.peripherals.keyboard numlock-state 'on'
exit
exit
# Pronto, Num lock ligado na tela de login!