Autor Tópico: [RESOLVIDO] Ubuntu 16.04 demora muito pra ligar  (Lida 988 vezes)

Offline felippeta

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
[RESOLVIDO] Ubuntu 16.04 demora muito pra ligar
« Online: 28 de MAR?O de 2018, 11:40 »
Bom dia pessoal.

Tenho um notebook Acer Aspire 5 com as seguintes configurações:

Processador: Intel i5-7200U
Placa de Vídeo: NVIDIA GeForce 940 MX
Memória RAM: 8GB DDR4
HD: 1TB

Esse note veio com o windows 10 intalado e atualmente está com a versão mais atual, entretanto resolvi fazer um dual boot nele pra utilizar o UBUNTU 16.04, porém ele está muito lento para iniciar (demorando cerca de 1 min).

Já havia feito um dual boot em um outro computador, entretando ele não usava UEFI e sim BIOS. Assim, a tela de dual boot ficou com muito mais opções do que quando fiz no outro computador.
Também confesso que não fiz a partição SWAP (pela quantidade de memória existente) e não se é isso que está prejudicando esse desempenho ao ligar (Tentei criar uma partição SWAP, mas o GParted havia dito que eu poderia perder dados ai não conclui).

Segue a imagem da tela de Boot.
https://ibb.co/jk8jun

Obrigado a todos.
« Última modificação: 31 de MAR?O de 2018, 11:11 por felippeta »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.137
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #1 Online: 28 de MAR?O de 2018, 15:01 »
Não sei se 1 min de boot é "demorar muito". Mas, como você configurou a rede desse aparelho?


Enviado do meu smartphone
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.613
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #2 Online: 28 de MAR?O de 2018, 16:32 »
Tem partição criptografada?

O HD é mecânico ou SSD?
Ubuntu  Mate 17.10 64bits

Offline felippeta

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #3 Online: 28 de MAR?O de 2018, 23:01 »
O hd é mecânico. Não tenho partição criptografada.
A configuração da rede eu confesso que foi o default fornecido pelo ubuntu, na instalação nem mexi nisso.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.613
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #4 Online: 29 de MAR?O de 2018, 08:53 »
Então vamos achar o culpado!

No terminal:

sudo systemd-analyze

E

sudo system-analyze blame

Copie e cole aqui os resultados pra gente ver.
Ubuntu  Mate 17.10 64bits

Offline felippeta

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #5 Online: 29 de MAR?O de 2018, 11:01 »
sudo systemd-analyze

Startup finished in 4.656s (kernel) + 48.978s (userspace) = 53.634s

----------------------------------------------------------------------------------------------------------
sudo systemd-analyze blame

         58.059s apt-daily.service
         30.088s dev-sda6.device
         24.860s systemd-udevd.service
          7.295s NetworkManager-wait-online.service
          6.741s snapd.service
          6.049s fwupd.service
          4.431s NetworkManager.service
          2.882s keyboard-setup.service
          2.257s accounts-daemon.service
          2.016s ModemManager.service
          1.971s systemd-fsck@dev-disk-by\x2duuid-3C98\x2d3DCF.service
          1.806s systemd-tmpfiles-setup-dev.service
          1.507s dev-hugepages.mount
          1.391s grub-common.service
          1.361s apparmor.service
          1.212s plymouth-read-write.service
          1.109s systemd-journald.service
          1.057s udisks2.service
           974ms sys-kernel-debug.mount
           974ms dev-mqueue.mount
           974ms systemd-modules-load.service
           912ms networking.service
           878ms avahi-daemon.service
           871ms irqbalance.service
           858ms apport.service
           711ms polkitd.service
           631ms ufw.service
           589ms systemd-tmpfiles-clean.service
           565ms kmod-static-nodes.service
           557ms systemd-sysctl.service
           532ms rsyslog.service
           490ms upower.service
           474ms console-setup.service
           468ms plymouth-start.service
           442ms systemd-rfkill.service
           387ms wpa_supplicant.service
           376ms systemd-logind.service
           367ms speech-dispatcher.service
           365ms ondemand.service
           360ms systemd-tmpfiles-setup.service
           357ms alsa-restore.service
           347ms pppd-dns.service
           343ms systemd-user-sessions.service
           330ms gpu-manager.service
           263ms systemd-fsck@dev-disk-by\x2duuid-73f7afe0\x2d2c86\x2d430e\x2d8d
           235ms boot.mount
           232ms lightdm.service
           220ms boot-efi.mount
           141ms systemd-update-utmp.service
           138ms systemd-journal-flush.service
           122ms systemd-remount-fs.service
           106ms setvtrgb.service
            83ms systemd-udev-trigger.service
            48ms snap-core-4206.mount
            40ms systemd-timesyncd.service
            36ms bluetooth.service
            33ms snap-spotify-6.mount
            28ms colord.service
            25ms snap-core-4110.mount
            23ms snapd.socket
            18ms user@1000.service
             5ms ureadahead-stop.service
             4ms dns-clean.service
             4ms systemd-update-utmp-runlevel.service
             3ms resolvconf.service
             2ms dev-loop1.device
             2ms rtkit-daemon.service
             2ms dev-loop2.device
             2ms sys-fs-fuse-connections.mount
             2ms systemd-random-seed.service
             1ms sys-kernel-config.mount
             1ms rc-local.service
             1ms plymouth-quit-wait.service
             1ms dev-loop0.device
             1ms systemd-backlight@backlight:intel_backlight.service


Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.613
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #6 Online: 30 de MAR?O de 2018, 07:38 »
Tá aí o culpado: 58.059s no apt-daily.service

Ele está verificando por atualizações do sistema na hora do boot!

Tem várias formas de desligar isso.

Vamos por partes. De forma gráfica vamos tentar esse tutorial primeiro:

http://www.edivaldobrito.com.br/como-desativar-as-atualizacoes-automaticas-no-ubuntu/

Veja se resolve reiniciando o sistema. Se não resolver, vamos desligar o serviço dele no systemd, no terminal:


sudo systemctl stop apt-daily.service


sudo systemctl disable apt-daily.service


e depois

sudo systemctl kill --kill-who=all apt-daily.service

Reinicie o sistema e veja se funciona.

No aguardo!
Ubuntu  Mate 17.10 64bits

Offline felippeta

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #7 Online: 30 de MAR?O de 2018, 11:18 »
Cara, muito obrigado pela ajuda. De certa forma o tempo de inicialização está bem mais baixo, até depois de colocar a senha. Ainda não está tão rápido quanto eu esperaria (cerca de 10s), mas não sei se isso é possível. Mas, pelo menos deu uma melhorada considerável.

Muito obrigado.
Abraço.

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.613
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #8 Online: 30 de MAR?O de 2018, 11:49 »
Então coloca um resolvido no tópico por favor!

Não sei se você etá comparando o tempo de boot dele com Windows 8 ou 10. Eles não desligam o sistema por padrão, ele suspende o sistema.

Pra deixar mais rápido o boot dele só desligando serviços, mexer na montagem do sistema de arquivos, trocar kernel e outras coisas para otimizar o sistema.
Ubuntu  Mate 17.10 64bits

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.137
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Ubuntu 16.04 demora muito pra ligar
« Resposta #9 Online: 30 de MAR?O de 2018, 23:19 »
Estranho o sistema parar pra checar por atualizações, poderia perfeitamente seguir a inicialização, até mesmo pq se for uma conexão wireless ela só vai estar disponível depois do login do usuário.


Enviado do meu smartphone
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D