Autor Tópico: Problemas com dependências (16.10 x64 sem ambiente gráfico)  (Lida 436 vezes)

Offline Murgoth

  • Usuário Ubuntu
  • *
  • Mensagens: 29
    • Ver perfil
Problemas com dependências (16.10 x64 sem ambiente gráfico)
« Online: 27 de Janeiro de 2018, 14:16 »
Utilizando o comando sudo
 apt-get -f install apenas exclui o pacote que precisa das dependências ao invés de solucionar os problemas.

root@ns1:/tmp# apt install build-essential
Reading package lists... Done
Building dependency tree
Reading state information... Done
build-essential is already the newest version (12.1ubuntu2).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: g++ (>= 4:5.2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@ns1:/tmp#

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.136
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re:Problemas com dependências (16.10 x64 sem ambiente gráfico)
« Resposta #1 Online: 30 de Janeiro de 2018, 08:01 »
O 16.10 não está mais em período de suporte, até onde eu sei.

Isso pode estar prejudicando a localização dos pacotes necessários.

Sugiro que você se programe para atualizar sua máquina para a versão corrente (17.10), ou faça downgrade pra versão 16.04.

Confirme também se vc não está com algum repositório fora do padrão que esteja criando conflito.


Enviado do meu smartphone
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D