Autor Tópico: Teclado muito sensível  (Lida 2870 vezes)

Offline Rafael Favero

  • Usuário Ubuntu
  • *
  • Mensagens: 170
  • Wake up and straight ahead
    • Ver perfil
Teclado muito sensível
« Online: 08 de Junho de 2017, 13:05 »
Olá. Comprei um teclado da C3 Tech, ele funciona  bem, o único problema é que ele é muito sensível no Linux, por vezes dou um clique e escreve umas 3 letras. Já tentei mexer nas configurações de teclado, deixei em atraso de repetição 1000 e velocidade de repetição em 3, até cheguei a desativar para ver se melhorava, mas mesmo assim as teclas se repetem por demais.

Já cheguei a mexer nas configurações, não diretamente na opção teclado, mas nas configurações e edição das configurações, mudando  o número de atraso além de 1000,  mesmo assim ocorre de escrever várias letras seguidas. Como devo proceder sendo que no windows o teclado funciona bem?

Atualmente a repetição está como desativada, mesmo assim algumas letras, não especificas, se repetem.

Ubuntu 16.04.2
« Última modificação: 09 de Junho de 2017, 20:59 por Rafael Favero »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #1 Online: 08 de Junho de 2017, 19:32 »
[...] sendo que no windows o teclado funciona bem?

No sistema operacional comercial evidentemente sempre funciona, pois o fabricante faz o hardware tendo ele em vista e por essa razão já fornece os drivers apropriados, pois que se não fosse vender para usuários de Windows iria vender para quem?

Se você é um fabricante de hardware para PC e faz um dispositivo qualquer, o que você teria em vista ao projetar e fabricar sabendo que o sistema operacional W detém 85% do market share, a maçã tem aí uns 10% e o pinguim tem uns 2%. Pra quem você apontaria suas baterias?

A resposta é um pouco óbvia, daí que não se trata de uma comparação válida, exceto para constatar que não está quebrado ou com defeito.

Mas vamos ao que interessa:

1) Qual distribuição/versão/sabor está usando?

Código: [Selecionar]
lsb_release -rd
2) qual o kernel em uso?

Código: [Selecionar]
uname -a
3) Com a função de repetição ligada, posta aí o resultado para:

Código: [Selecionar]
xinput
Código: [Selecionar]
xset -q
« Última modificação: 08 de Junho de 2017, 19:41 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Rafael Favero

  • Usuário Ubuntu
  • *
  • Mensagens: 170
  • Wake up and straight ahead
    • Ver perfil
Re:Teclado muito sensível
« Resposta #2 Online: 08 de Junho de 2017, 20:30 »
Código: [Selecionar]
lsb_release -rdDescription:   Ubuntu 16.04.1 LTS
Release:   16.04

Código: [Selecionar]
uname -aLinux rafael-desktop 4.4.0-79-generic #100-Ubuntu SMP Wed May 17 19:58:14 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Código: [Selecionar]
xinput Virtual core pointer                       id=2   [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                 id=4   [slave  pointer  (2)]
⎜   ↳ LXD Gaming Mouse                           id=9   [slave  pointer  (2)]
⎜   ↳ USB USB Keyboard                           id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                      id=3   [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                id=5   [slave  keyboard (3)]
    ↳ Power Button                               id=6   [slave  keyboard (3)]
    ↳ Power Button                               id=7   [slave  keyboard (3)]
    ↳ LXD Gaming Mouse                           id=8   [slave  keyboard (3)]
    ↳ USB USB Keyboard                           id=10   [slave  keyboard (3)]

Código: [Selecionar]
xset -qKeyboard Control:
  auto repeat:  off    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  989    repeat rate:  3
  auto repeating keys:  00ffffffdffffbbf
                        fa9fffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,built-ins
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled
« Última modificação: 08 de Junho de 2017, 22:08 por Rafael Favero »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #3 Online: 09 de Junho de 2017, 15:35 »
Qual desktop está usando, é o Ubuntu padrão (=Unity) ou é algum outro "sabor"? Qual?

Já experimentou deixar ligado o autorepeat e aumentar o delay lá pra cima, um número bem alto?

xset

Para ligar/desligar o autorepeat:

xset -r ou xset r off  --> desliga

xset  r ou xset r on   --> liga

Para alterar o delay:

xset r rate quant.delay quant.autorepeat


exemplo:

xset r rate 5000 3

O primeiro número é o delay em milisegundos e segundo é a taxa de repetição, igualmente em milisegundos.


gsettings

Se não resultar como acima, então experimente também:

gsettings set org.gnome.desktop.peripherals.keyboard delay 1000

gsettings set org.gnome.desktop.peripherals.keyboard repeat-interval 200

Talvez a alteração se perca ao reiniciar a sessão/sistema, questão de ver, mas aí, se o caso,verificamos como tornar permanente.


kbdrate

Caso também não tenha resultado da forma acima, então veja também se produz algum efeito usar o kbdrate (que me parece esteja obsoleto, ao menos para o Ubuntu padrão, mas depende do que esteja usando como desktop ou como distro Linux).

A sintaxe é a seguinte:

sudo kbdrate -r rate -d delay

exemplo:

sudo kbdrate -r 4.0 -d 1000

o rate é dado em caracteres por segundos (cps), o delay em caracteres por milisegundos (ms).

Porém os valores são fixos em uma tabela, isto é, não podem ser qualquer um.

Para valores de sistemas baseados em Intel os valores de rate podem ser:

2.0, 2.1, 2.3, 2.5, 2.7, 3.0, 3.3, 3.7, 4.0, 4.3, 4.6, 5.0, 5.5, 6.0,
6.7,  7.5,  8.0,  8.6,  9.2, 10.0, 10.9, 12.0, 13.3, 15.0, 16.0,
17.1, 18.5, 20.0, 21.8, 24.0, 26.7, 30.0.

o delay em degraus de 250ms, limitado a 1000ms

250, 500, 750, 1000

Caso produza efeito é possível alterar o arquivo /etc/kbd/config com os valores adequados.

« Última modificação: 09 de Junho de 2017, 20:02 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #4 Online: 09 de Junho de 2017, 15:37 »
Se nada disso funcionou, então experimente um outro kernel, especialmente teste com o último 4.8 disponível (porque a partir da 16.04.2 dá para migrar automaticamente pelo stack) e ainda o 4.10 disponível na versão 17.04.

Um teste com algum outro "sabor" do Ubuntu também não é má ideia.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #5 Online: 09 de Junho de 2017, 15:37 »
Se nem mesmo assim ainda deu certo, o suporte da C3Tech diz que os teclados deles são compatíveis com Linux, então talvez seja o caso de entrar em contato para ver se eles possuem alguma informação adicional.


"Os teclados da C3 Tech são compatíveis com Linux?
Eles são compatíveis com qualquer distribuição Linux, com exceção das teclas de função específicas do Office, que deverão ser configuradas pelo próprio usuário nos aplicativos de escritório conforme o Linux adotado."


http://www.c3technology.com.br/2013/suporte_drive_faq.php?d=all

Contato:

http://www.c3technology.com.br/2013/contato.php

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #6 Online: 09 de Junho de 2017, 18:09 »
Me recordo de ter visto esses dias aqui que você comprou um novo notebook.
Esse teclado da C3Tech está conectado nesse novo notebook?
Se sim, qual é a resposta do teclado próprio do notebook, isto é, independente do usb-wireless da C3Tech?
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Rafael Favero

  • Usuário Ubuntu
  • *
  • Mensagens: 170
  • Wake up and straight ahead
    • Ver perfil
Re:Teclado muito sensível
« Resposta #7 Online: 09 de Junho de 2017, 19:07 »
Estou utilizando o ambiente xfce.

Sim, já testei com o delay em 1000 e ativado, mesmo assim apresentava repetições.

O comando para desativar a repetição funcionou, ainda há alguns poucos casos de repetição, mas agora aparentemente está funcionando bem, em grande parte do tempo, vejo que depende também de como digito, no meu outro teclado era um pouco diferente, as teclas nesse são mais elevadas portanto tenho de clicar mais e quando não clico o suficiente há repetição, mas ainda, mesmo clicando "forte" ocorre um ou outro pequeno caso.

Estou utilizando no pc mesmo, havia esquecido de mencionar esse fato, o pc voltou depois de eu ter iniciado aquele tópico e como o custo de reparo não foi alto resolvi manter o pc na ativa. O problema do teclado é nele, no notebook não cheguei a instalar o Ubuntu, não tive momento oportuno para isso.

No notebook, apenas com o Windows havia funcionado, não cheguei a testa-lo lá com o Linux.

Não sei se estava falhando ou o que, mas com o comando noto que a digitação melhorou muito, agora consigo digitar tranquilamente, talvez tenha havido alguma falha no modo gráfico para não ter desativado como agora, apesar de visualmente estar como desativado, ainda há um ou outro mínimo caso, mas nada que atrapalhe, só pegar o jeito de digitar que melhora.

Com o comando
Código: [Selecionar]
xset -r ou xset r off aparentemente desativou como deveria e está funcionando bem.

Foi resolvido em parte.*

Muito obrigado pela ajuda druidaobelix!  :D

*Ainda ocorre alguns pequenos casos, mas não quero dar-lhe trabalho devido a um pequeno incomodo, com o tempo pego jeito de digitar e conseguirei evitar as ocasionais repetições.

Edit: arrumei um problema e surgiu-me outro, retirei a informação de resolvido do título.

« Última modificação: 09 de Junho de 2017, 21:01 por Rafael Favero »

Offline Rafael Favero

  • Usuário Ubuntu
  • *
  • Mensagens: 170
  • Wake up and straight ahead
    • Ver perfil
Re:Teclado muito sensível (RESOLVIDO)
« Resposta #8 Online: 09 de Junho de 2017, 20:59 »
Druidao, apenas complementando, não posso deixar ativado a repetição pois escreve umas 3 letras por vez, portanto deixo essa opção desativada, mas ocorre de por exemplo eu clicar no shift, ficar uns 3 segundos e o clique cair fora, no teclado antigo eu conseguia deixar ativado quantos segundos eu quisesse, mas agora eu preciso dessa função e não sei como proceder, há como criar uma exceção para essa tecla para que ela fique exercendo sua função de acordo com o tempo clicado?

Apenas posso usar o teclado com a repetição desativada, foi solucionado, em parte, mas deu para quebrar um galho.
« Última modificação: 09 de Junho de 2017, 21:02 por Rafael Favero »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #9 Online: 09 de Junho de 2017, 22:14 »
[...] há como criar uma exceção para essa tecla para que ela fique exercendo sua função de acordo com o tempo clicado?

Por incrível que pareça, dá para fazer por tecla também.   :)

Tem que usar no xset a opção r seguida do código da tecla (keycode), que é um número entre o 0 (zero) e 255, isso vai habilitar ou desabilitar aquela tecla especíica.

Não sei dizer, assim de antemão, se aplicável a essa tecla especificamente.
Aos códigos abaixo de 8 tipicamente não é aplicável.

A sintaxe é algo assim:

xset -r keycode

exemplo:

xset -r 10

Vai desabilitar o autorepeat para o 1 no *meu* teclado externo, que é um Microsoft Wireless Keyboard 3000 (o seu pode ser diferente)

No seu caso seria o inverso, desabilitado em geral e somente habilitado para essa tecla específica.

xset r keycode

Precisa, nesse específico teclado, determinar qual é o keycode dessa tecla que você quer.

Pode usar o xev para identificar a keycode específica.

Como usar o xev, dê uma olhada nesse tópico, post #12, lá fala do mouse, mas é a mesma coisa.


http://ubuntuforum-br.org/index.php/topic,120740.msg663057.html#msg663057

« Última modificação: 09 de Junho de 2017, 22:20 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Teclado muito sensível
« Resposta #10 Online: 09 de Junho de 2017, 22:22 »
Ah, sim, ia esquecendo, o jeitão fácil de saber se está tudo ligado ou desligado é fazendo:

Código: [Selecionar]
xset -q | grep auto
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Rafael Favero

  • Usuário Ubuntu
  • *
  • Mensagens: 170
  • Wake up and straight ahead
    • Ver perfil
Re:Teclado muito sensível
« Resposta #11 Online: 10 de Junho de 2017, 00:07 »
Resultado:
Código: [Selecionar]
xxset q
Keyboard Control:
  auto repeat: off    key click percent:  0    LED mask:  00000002
  XKB indicators:
    00: Caps Lock:   off    01: Num Lock:    on     02: Scroll Lock: off
    03: Compose:     off    04: Kana:        off    05: Sleep:       off
    06: Suspend:     off    07: Mute:        off    08: Misc:        off
    09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
    12: Group 2:     off    13: Mouse Keys:  off
  auto repeat delay:  111    repeat rate:  3
  auto repeating keys:  00ffffffdffffbbf
                        fa9fffefffedffff
                        9fffffffffffffff
                        fff7ffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0x0    WhitePixel:  0xffffff
Font Path:
  /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,built-ins
DPMS (Energy Star):
  Standby: 7200    Suspend: 7200    Off: 14400
  DPMS is Disabled

Código: [Selecionar]
xset -q | grep auto
 auto repeat:  off    key click percent:  0    LED mask:  00000002
 auto repeat delay:  105    repeat rate:  13
 auto repeating keys:  00ffffffdffffbbf

Eu havia conseguido realizar, aparentemente o lshift funciona apenas na versão online do jogo, bem, funciona em parte, as vezes ocorre falhas.

Continuarei fazendo ajustes, a propósito utilizei os seguintes comandos, para maiores informações.
Código: [Selecionar]
xset r on lshift
Código: [Selecionar]
xset r on 50
Novamente obrigado pelo auxílio druidao.

-------------------------------------------------------------------------------------------
Após muitos meses com esse problema e mesmo enviando email para o suporte apesar de não haver respostas, resolvi dar um update no kernel, troquei-o pela versão mais recente, a 4.15.3 e o teclado, por enquanto está funcionando adequadamente sem repetições inadequadas.  :)

Edit, repete um pouco e quando deveria repetir não faz com tal precisão, não foi resolvido em si, mas está menos pior que antes.
« Última modificação: 12 de Fevereiro de 2018, 23:20 por Rafael Favero »

Offline Rafael Favero

  • Usuário Ubuntu
  • *
  • Mensagens: 170
  • Wake up and straight ahead
    • Ver perfil
Re:Teclado muito sensível
« Resposta #12 Online: 02 de MAR?O de 2018, 23:50 »
Reanimando o tópico.

Ainda não encontrei solução definitiva.

As de acima apenas retardam por breves momentos, elas funcionam por breves segundos e depois o teclado volta a repetir de forma exagerada.
 
Estou usando o Kernel 4.15.5, mas parece que só piora.

O suporte da C3T3CH parece que está de enfeite, já mandei emails para a Ouvidoria desde Outubro de 2017 e não obtive resposta, mesmo indicando esse  tópico para auxiliá-los.

Até testei  live usb com o Lubuntu e o resultado foi quase o mesmo, repetia exageradamente como agora. (Tenho arrumado as palavras, mas a maioria sai com alguma letra repetida.)

Prratticamentte ttodos os ddias tenho de repetir comandos afim de ajustar o delay do teclado, sempre um quebra galho apenas.

Testarei vários kernel(éis) para ver se há algum resultado melhor.

Enfim, sse alguém ttiver allguma soluçãõ permaanentte peço qque informe. DDeiixaareii esse úulttuimmo ttrecho sem coreçção parra mostrrar  como é escreverr com essee teclado.