Autor Tópico: Looping no Boot do Ubuntu ao Instalar driver Nvidia 304  (Lida 5276 vezes)

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Online: 21 de Novembro de 2016, 12:27 »
Pessoal.

Já faz algumas versões do Ubuntu que não consigo utilizar os driver da Nvidia 304.
O meu note HP DV6750BR possui placa de vídeo Geforce 7150M / nForce 630M.
No momento estou utilizando o driver xserver-xorg-video-nouveau (open source), mas quando instalo o nvidia 304 (304.132) não consigo fazer login.
Inicia o ubuntu, e ao digitar a senha do usuário o sistema volta para a tela de login, e só volta a funcionar quando vou para o ambiente tty1 (crtl+alt+F1) e desinstalo o nvídia (sudo apt-get purge nvidia*).
Já procurei a solução em tudo que é lugar, mas até agora sem sucesso.
« Última modificação: 21 de Novembro de 2016, 12:47 por Sapiranga »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #1 Online: 21 de Novembro de 2016, 14:23 »
Sempre supondo que o sistema esteja devidamente atualizado

Código: [Selecionar]
sudo apt update
Código: [Selecionar]
sudo apt upgrade
os comandos acima devem terminar sem erros

Isso posto:

1) qual versão/ambiente do Ubuntu?

Código: [Selecionar]
lsb_release -rd
2) kernel?

Código: [Selecionar]
uname -srvm
3) situação atual do subsistema gráfico?

Código: [Selecionar]
lspci | grep -i vga
Código: [Selecionar]
sudo lshw -c display
Código: [Selecionar]
xrandr | grep -i current
4) drivers oferecidos por padrão pelo sistema?

Código: [Selecionar]
ubuntu-drivers list
Código: [Selecionar]
apt-cache search "NVIDIA binary driver"
« Última modificação: 21 de Novembro de 2016, 14:31 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #2 Online: 21 de Novembro de 2016, 14:26 »
O site do fabricante confirme que o driver dessa gpu (=placa gráfica) é esse mesmo:


Linux x64 (AMD64/EM64T) Display Driver
 
Versão:    304.132
Data de Lançamento:    2016.9.26
Sistema Operacional:    Linux 64-bit
Linguagem:    Português (Brazil)
Tamanho:    66.21 MB

GeForce Go 7 Series (Notebooks):

GeForce Go 7950 GTX, GeForce Go 7900 GS, GeForce Go 7800 GTX, GeForce Go 7800, GeForce Go 7700, GeForce Go 7600, GeForce Go 7400, GeForce Go 7300, GeForce Go 7200, GeForce 7150M / nForce 630M, GeForce 7000M / nForce 610M

http://www.nvidia.com.br/download/driverResults.aspx/108181/br

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #3 Online: 21 de Novembro de 2016, 14:29 »
Note que a ordem "natural" de proveniência de drivers é sempre:

1) instalar dos repositórios da própria distribuição se lá estiver disponível;
2) instalar a partir de uma ppa homologada no launchpad, caso não esteja disponível  ou não funcione a partir dos repositórios oficiais da distribuição;
3) instalar a partir do binário direto do fabricante na inexistência/impossibilidade de 1 e 2 anteriores.

Se já não fez, vamos explorar organizadamente todas essas possibilidades.

Talvez seja necessário fazer uma certa manobra para instalar e não resultar em tela preta, mas vamos ver.

« Última modificação: 21 de Novembro de 2016, 14:34 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #4 Online: 21 de Novembro de 2016, 18:18 »
Estou no trabalho, a noite posto as saídas dos comandos.


Enviado do meu iPhone usando Tapatalk

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #5 Online: 21 de Novembro de 2016, 23:16 »
Sempre supondo que o sistema esteja devidamente atualizado

Código: [Selecionar]
sudo apt update
Código: [Selecionar]
sudo apt upgrade
os comandos acima devem terminar sem erros

Isso posto:

1) qual versão/ambiente do Ubuntu?

Código: [Selecionar]
lsb_release -rd
2) kernel?

Código: [Selecionar]
uname -srvm
3) situação atual do subsistema gráfico?

Código: [Selecionar]
lspci | grep -i vga
Código: [Selecionar]
sudo lshw -c display
Código: [Selecionar]
xrandr | grep -i current
4) drivers oferecidos por padrão pelo sistema?

Código: [Selecionar]
ubuntu-drivers list
Código: [Selecionar]
apt-cache search "NVIDIA binary driver"


Vamos aos retornos.....

sudo apt update:
Código: [Selecionar]
Atingido:1 http://br.archive.ubuntu.com/ubuntu xenial InRelease               
Obter:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [94,5 kB] 
Obter:3 http://br.archive.ubuntu.com/ubuntu xenial-updates InRelease [95,7 kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu xenial-backports InRelease [92,2 kB]
Obter:5 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [163 kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [426 kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [420 kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [164 kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [337 kB]
Obter:10 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [159 kB]
Obter:11 http://br.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [204 kB]
Obter:12 http://br.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [362 kB]
Obter:13 http://br.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [359 kB]
Obter:14 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [68,0 kB]
Obter:15 http://br.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [131 kB]
Obter:16 http://br.archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages [4.396 B]
Obter:17 http://br.archive.ubuntu.com/ubuntu xenial-backports/main i386 Packages [4.400 B]
Obter:18 http://br.archive.ubuntu.com/ubuntu xenial-backports/main Translation-en [3.104 B]
Obter:19 http://br.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [195 B]
Obter:20 http://br.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages [2.412 B]
Obter:21 http://br.archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages [2.412 B]
Obter:22 http://br.archive.ubuntu.com/ubuntu xenial-backports/universe Translation-en [1.216 B]
Obter:23 http://br.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [200 B]
Obter:24 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [79,8 kB]
Obter:25 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [57,9 kB]
Obter:26 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [59,4 kB]
Obter:27 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [57,1 kB]
Obter:28 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [33,5 kB]
Obter:29 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [7.406 B]
Obter:30 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [16,4 kB]
Baixados 3.406 kB em 8s (381 kB/s)                                             
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
14 packages can be upgraded. Run 'apt list --upgradable' to see them.

Sudo apt upgrade:
Código: [Selecionar]
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Calculando atualização... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  lib32gcc1 libc6-i386 libcuda1-304 xserver-xorg-legacy
Utilize 'sudo apt autoremove' para os remover.
Os pacotes a seguir serão atualizados:
  imagemagick imagemagick-6.q16 imagemagick-common libmagickcore-6.q16-2
  libmagickcore-6.q16-2-extra libmagickwand-6.q16-2 libpulse-mainloop-glib0
  libpulse0 libpulsedsp pulseaudio pulseaudio-module-bluetooth
  pulseaudio-module-x11 pulseaudio-utils tar
14 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 3.774 kB de arquivos.
Depois desta operação, 22,5 kB adicionais de espaço em disco serão usados.
Você quer continuar? [S/n] s
Obter:1 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 tar amd64 1.28-2.1ubuntu0.1 [209 kB]
Obter:2 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libmagickwand-6.q16-2 amd64 8:6.8.9.9-7ubuntu5.2 [288 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libmagickcore-6.q16-2 amd64 8:6.8.9.9-7ubuntu5.2 [1.575 kB]
Obter:4 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 imagemagick-common all 8:6.8.9.9-7ubuntu5.2 [41,9 kB]
Obter:5 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 imagemagick amd64 8:6.8.9.9-7ubuntu5.2 [44,8 kB]
Obter:6 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 imagemagick-6.q16 amd64 8:6.8.9.9-7ubuntu5.2 [387 kB]
Obter:7 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libmagickcore-6.q16-2-extra amd64 8:6.8.9.9-7ubuntu5.2 [59,5 kB]
Obter:8 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libpulsedsp amd64 1:8.0-0ubuntu3.1 [21,1 kB]
Obter:9 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 pulseaudio-utils amd64 1:8.0-0ubuntu3.1 [51,0 kB]
Obter:10 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 pulseaudio-module-bluetooth amd64 1:8.0-0ubuntu3.1 [56,5 kB]
Obter:11 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 pulseaudio-module-x11 amd64 1:8.0-0ubuntu3.1 [16,0 kB]
Obter:12 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 pulseaudio amd64 1:8.0-0ubuntu3.1 [765 kB]
Obter:13 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libpulse-mainloop-glib0 amd64 1:8.0-0ubuntu3.1 [11,5 kB]
Obter:14 http://br.archive.ubuntu.com/ubuntu xenial-updates/main amd64 libpulse0 amd64 1:8.0-0ubuntu3.1 [248 kB]
Baixados 3.774 kB em 9s (389 kB/s)                                             
(Lendo banco de dados ... 210444 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../tar_1.28-2.1ubuntu0.1_amd64.deb ...
A descompactar tar (1.28-2.1ubuntu0.1) sobre (1.28-2.1) ...
A processar 'triggers' para man-db (2.7.5-1) ...
A processar 'triggers' para mime-support (3.59ubuntu1) ...
Configurando tar (1.28-2.1ubuntu0.1) ...
(Lendo banco de dados ... 210444 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libmagickwand-6.q16-2_8%3a6.8.9.9-7ubuntu5.2_amd64.deb ...
A descompactar libmagickwand-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.2) sobre (8:6.8.9.9-7ubuntu5.1) ...
A preparar para desempacotar .../libmagickcore-6.q16-2_8%3a6.8.9.9-7ubuntu5.2_amd64.deb ...
A descompactar libmagickcore-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.2) sobre (8:6.8.9.9-7ubuntu5.1) ...
A preparar para desempacotar .../imagemagick-common_8%3a6.8.9.9-7ubuntu5.2_all.deb ...
A descompactar imagemagick-common (8:6.8.9.9-7ubuntu5.2) sobre (8:6.8.9.9-7ubuntu5.1) ...
A preparar para desempacotar .../imagemagick_8%3a6.8.9.9-7ubuntu5.2_amd64.deb ...
A descompactar imagemagick (8:6.8.9.9-7ubuntu5.2) sobre (8:6.8.9.9-7ubuntu5.1) ...
A preparar para desempacotar .../imagemagick-6.q16_8%3a6.8.9.9-7ubuntu5.2_amd64.deb ...
A descompactar imagemagick-6.q16 (8:6.8.9.9-7ubuntu5.2) sobre (8:6.8.9.9-7ubuntu5.1) ...
A preparar para desempacotar .../libmagickcore-6.q16-2-extra_8%3a6.8.9.9-7ubuntu5.2_amd64.deb ...
A descompactar libmagickcore-6.q16-2-extra:amd64 (8:6.8.9.9-7ubuntu5.2) sobre (8:6.8.9.9-7ubuntu5.1) ...
A preparar para desempacotar .../libpulsedsp_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar libpulsedsp:amd64 (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A preparar para desempacotar .../pulseaudio-utils_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar pulseaudio-utils (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A preparar para desempacotar .../pulseaudio-module-bluetooth_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar pulseaudio-module-bluetooth (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A preparar para desempacotar .../pulseaudio-module-x11_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar pulseaudio-module-x11 (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A preparar para desempacotar .../pulseaudio_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar pulseaudio (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A preparar para desempacotar .../libpulse-mainloop-glib0_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar libpulse-mainloop-glib0:amd64 (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A preparar para desempacotar .../libpulse0_1%3a8.0-0ubuntu3.1_amd64.deb ...
A descompactar libpulse0:amd64 (1:8.0-0ubuntu3.1) sobre (1:8.0-0ubuntu3) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu4) ...
A processar 'triggers' para mime-support (3.59ubuntu1) ...
A processar 'triggers' para man-db (2.7.5-1) ...
A processar 'triggers' para bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
A processar 'triggers' para gnome-menus (3.13.3-6ubuntu3.1) ...
A processar 'triggers' para desktop-file-utils (0.22-1ubuntu5) ...
A processar 'triggers' para menu (2.1.47ubuntu1) ...
A processar 'triggers' para hicolor-icon-theme (0.15-0ubuntu1) ...
A processar 'triggers' para dbus (1.10.6-1ubuntu3.1) ...
Configurando imagemagick-common (8:6.8.9.9-7ubuntu5.2) ...
Configurando libmagickcore-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.2) ...
Configurando libmagickwand-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.2) ...
Configurando imagemagick-6.q16 (8:6.8.9.9-7ubuntu5.2) ...
Configurando imagemagick (8:6.8.9.9-7ubuntu5.2) ...
Configurando libmagickcore-6.q16-2-extra:amd64 (8:6.8.9.9-7ubuntu5.2) ...
Configurando libpulse0:amd64 (1:8.0-0ubuntu3.1) ...
Configurando libpulsedsp:amd64 (1:8.0-0ubuntu3.1) ...
Configurando pulseaudio-utils (1:8.0-0ubuntu3.1) ...
Configurando pulseaudio (1:8.0-0ubuntu3.1) ...
Configurando pulseaudio-module-bluetooth (1:8.0-0ubuntu3.1) ...
Configurando pulseaudio-module-x11 (1:8.0-0ubuntu3.1) ...
Configurando libpulse-mainloop-glib0:amd64 (1:8.0-0ubuntu3.1) ...
A processar 'triggers' para libc-bin (2.23-0ubuntu4) ...
A processar 'triggers' para menu (2.1.47ubuntu1) ...


1) qual versão/ambiente do Ubuntu?

Código: [Selecionar]
lsb_release -rd
Código: [Selecionar]
Description: Ubuntu 16.04.1 LTS
Release: 16.04

2) kernel?

Código: [Selecionar]
uname -srvm
Código: [Selecionar]
Linux 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64

3) situação atual do subsistema gráfico?

Código: [Selecionar]
lspci | grep -i vga
Código: [Selecionar]
00:12.0 VGA compatible controller: NVIDIA Corporation C67 [GeForce 7150M / nForce 630M] (rev a2)

Código: [Selecionar]
sudo lshw -c display
Código: [Selecionar]
  *-display               
       descrição: VGA compatible controller
       produto: C67 [GeForce 7150M / nForce 630M]
       fabricante: NVIDIA Corporation
       ID físico: 12
       informações do barramento: pci@0000:00:12.0
       versão: a2
       largura: 64 bits
       clock: 66MHz
       capacidades: pm msi vga_controller bus_master cap_list rom
       configuração: driver=nouveau latency=0
       recursos: irq:16 memória:f5000000-f5ffffff memória:d0000000-dfffffff memória:f4000000-f4ffffff memória:80000000-8001ffff

Código: [Selecionar]
xrandr | grep -i current
Código: [Selecionar]
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 4096 x 4096

4) drivers oferecidos por padrão pelo sistema?

Código: [Selecionar]
ubuntu-drivers list
Código: [Selecionar]
bcmwl-kernel-source
amd64-microcode
nvidia-304

Código: [Selecionar]
apt-cache search "NVIDIA binary driver"
Código: [Selecionar]
nvidia-340 - NVIDIA binary driver - version 340.98
nvidia-367 - NVIDIA binary driver - version 367.57


Uma dúvida, existe alguma diferença entre sudo apt update e sudo apt-get update?
« Última modificação: 21 de Novembro de 2016, 23:21 por Sapiranga »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #6 Online: 21 de Novembro de 2016, 23:36 »
Citar
Uma dúvida, existe alguma diferença entre sudo apt update e sudo apt-get update?


Nesse caso específico que você menciona são idênticos.

O apt sozinho é mais recente que o tradicional apt-get, foi modificado, dizem os autores, para se tornar mais intuitivo ao usuário.
Em muitas situações fazem a mesma coisa, como no exemplo que você mencionou o efeito é exatamente o mesmo, porém o apt-get tem uma amplitude um pouco maior, isto é, apresenta algumas opções que o apt sozinho não tem.

Consulte esse tópico:

apt install ou apt-get install e onde são armazenadas os arquivos baixados

http://ubuntuforum-br.org/index.php/topic,120298.msg660554.html#msg660554

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #7 Online: 21 de Novembro de 2016, 23:41 »
Mas creio que antes de mais nada parece interessante modificar o sistema para autologin antes de qualquer alteração para vermos o que acontece.

Graficamente dessa forma:

Citar
-->Configurações do sistema/Contas de usuários/Opções de início de sessão

Modifique a chave para "Início automático de sessão"

Ou se preferir editar diretamente o arquivo:

Código: [Selecionar]
sudo gedit /etc/lightdm/lightdm.conf
Na linha abaixo, onde está username substitua pelo nome concreto do seu usuário.

autologin-user=username

Ou seja, o sistema subirá direto sem parar na tela de logon.

Reinicie o sistema e confirme se está de fato funcionando o autologin

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #8 Online: 21 de Novembro de 2016, 23:55 »
Tendo alterado para autologin, agora faça o bloqueio do driver nouveau.

Código: [Selecionar]
sudo gedit /etc/modprobe.d/blacklist-nouveau.conf
Esse arquivo não existe, então irá abrir apenas uma página em branco.

Então coloque nesse arquivo:

blacklist nouveau

Salvar e sair


Agora, **antes** de reiniciar, experimente instalar o driver da nvidia 304 usando o recurso "Drives Adicionais" pela tela padrão do sistema, acessível em:

Citar
-->Configurações do sistema/Programas e atualizações/Drivers Adicionais

ou mais diretamente:

Código: [Selecionar]
sudo software-properties-gtk
Evidentemente após a alteração para o driver 304 padrão, reinicie o sistema.

O que acontece?

=================

Nota:
Qualquer dificuldade posterior em relação ao bloqueio do nouveau é ir pelo Recovey Mode (Mode de Recuperação) ou ainda por um live-iso (pendrive ou cdrom), ou talvez até suba o sistema no modo gráfico usando um driver genérico VESA, e novamente editar o arquivo ora criado, colocando um # (tralha) na frente da linha que irá inutilizá-lo e retornar à situação anterior.
Estou supondo que você sabe fazer isso, se tem dificuldade ou não sabe, avise que posso tentar detalhar.

« Última modificação: 21 de Novembro de 2016, 23:59 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #9 Online: 22 de Novembro de 2016, 00:15 »
Mas creio que antes de mais nada parece interessante modificar o sistema para autologin antes de qualquer alteração para vermos o que acontece.

Graficamente dessa forma:

Citar
-->Configurações do sistema/Contas de usuários/Opções de início de sessão

Modifique a chave para "Início automático de sessão"

Ou se preferir editar diretamente o arquivo:

Código: [Selecionar]
sudo gedit /etc/lightdm/lightdm.conf
Na linha abaixo, onde está username substitua pelo nome concreto do seu usuário.

autologin-user=username

Ou seja, o sistema subirá direto sem parar na tela de logon.

Reinicie o sistema e confirme se está de fato funcionando o autologin

Configurei para login automatico e testei.... funcionou com os driver genérico de vídeo.
Então instalei os drivers nvidia304, fiz o reboot.
O ubuntu iniciou ficou um tempo na tela preta e voltou pra tela de login.... tentei logar novamente mas retornou para a tela de login.

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #10 Online: 22 de Novembro de 2016, 00:28 »
Tendo alterado para autologin, agora faça o bloqueio do driver nouveau.

Código: [Selecionar]
sudo gedit /etc/modprobe.d/blacklist-nouveau.conf
Esse arquivo não existe, então irá abrir apenas uma página em branco.

Então coloque nesse arquivo:

blacklist nouveau

Salvar e sair


Agora, **antes** de reiniciar, experimente instalar o driver da nvidia 304 usando o recurso "Drives Adicionais" pela tela padrão do sistema, acessível em:

Citar
-->Configurações do sistema/Programas e atualizações/Drivers Adicionais

ou mais diretamente:

Código: [Selecionar]
sudo software-properties-gtk
Evidentemente após a alteração para o driver 304 padrão, reinicie o sistema.

O que acontece?

=================

Nota:
Qualquer dificuldade posterior em relação ao bloqueio do nouveau é ir pelo Recovey Mode (Mode de Recuperação) ou ainda por um live-iso (pendrive ou cdrom), ou talvez até suba o sistema no modo gráfico usando um driver genérico VESA, e novamente editar o arquivo ora criado, colocando um # (tralha) na frente da linha que irá inutilizá-lo e retornar à situação anterior.
Estou supondo que você sabe fazer isso, se tem dificuldade ou não sabe, avise que posso tentar detalhar.
Realizei o bloqueio, reinstalei o driver nvidia. O Ubuntu iniciou, ficou um tempo na tela preta e depois caiu na tela de login.


Enviado do meu iPhone usando Tapatalk

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #11 Online: 22 de Novembro de 2016, 00:52 »
Ainda deixando em autologin, configurado bloqueado o nouveau e instalado o 304, adicione o parâmetro nomodest na linha de boot.

Se o sistema tem a tela inicial do grub, lá onde se escolhe qual sistema subir ou qual kernel subir, pode adicionar provisoriamente ali mesmo.

É só acionar a tecla e (vogal e) e na linha do boot acrescentar nomodeset, onde quase sempre a linha tem as expressões quiet e splash

Algo assim (só um exemplo):

BOOT_IMAGE=/boot/vmlinuz-4.4.0-47-generic root=UUID=7a0f44d0-f6b9-4660-bee6-b83634b2af41 ro quiet splash nomodeset

Essa mudança é provisória, se perde no próximo reboot.

Outra forma de fazer a mesma coisa, porém de forma gravada real, é ir no arquivo:

Código: [Selecionar]
sudo gedit /etc/default/grub
então editar a linha:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Salvar e sair

atualize o grub

Código: [Selecionar]
sudo update-grub
reinicie o sistema e vamos ver o que acontece.





www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #12 Online: 22 de Novembro de 2016, 07:53 »
Ainda deixando em autologin, configurado bloqueado o nouveau e instalado o 304, adicione o parâmetro nomodest na linha de boot.

Se o sistema tem a tela inicial do grub, lá onde se escolhe qual sistema subir ou qual kernel subir, pode adicionar provisoriamente ali mesmo.

É só acionar a tecla e (vogal e) e na linha do boot acrescentar nomodeset, onde quase sempre a linha tem as expressões quiet e splash

Algo assim (só um exemplo):

BOOT_IMAGE=/boot/vmlinuz-4.4.0-47-generic root=UUID=7a0f44d0-f6b9-4660-bee6-b83634b2af41 ro quiet splash nomodeset

Essa mudança é provisória, se perde no próximo reboot.

Outra forma de fazer a mesma coisa, porém de forma gravada real, é ir no arquivo:

Código: [Selecionar]
sudo gedit /etc/default/grub
então editar a linha:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Salvar e sair

atualize o grub

Código: [Selecionar]
sudo update-grub
reinicie o sistema e vamos ver o que acontece.

Fiz a alteração direto no Grub, mas seguiu o problema. Não faz o login automático e cai na tela de login.


Enviado do meu iPhone usando Tapatalk

Offline Sapiranga

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #13 Online: 22 de Novembro de 2016, 08:18 »
Também tenho instalado a distro Elementary OS.
Instalei o driver a Nvidia 304, então não carrega a tela de login. Fica alternando entre tela preta e tela preta com backlight ligado.


Enviado do meu iPhone usando Tapatalk

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.555
    • Ver perfil
Re:Looping no Boot do Ubuntu ao Instalar driver Nvidia 304
« Resposta #14 Online: 22 de Novembro de 2016, 21:35 »
Também tenho instalado a distro Elementary OS.
Instalei o driver a Nvidia 304, então não carrega a tela de login. Fica alternando entre tela preta e tela preta com backlight ligado.

Como já mencionado no início, se não funcionou a partir dos "Drivers Adicionais" oferecidos por padrão pelo sistema, então o pŕoximo passo é ir para a ppa Graphics Drivers.

Antes de mais nada precisa eliminar qualquer vestígio que possa existir de instalações anteriores de qualquer driver nvidia (inclusive dessas tentativas que fizemos pouco antes, conforme posts anteriores), principalmente qualquer ppa relativa a drivers gpu que tenha sido instalada anteriormente.

Especialmente, se tiver antes usado a Xorg-edgers PPA ou a Michael Marley’s Nvidia PPA, precisa antes remover (talvez não seja o seu caso específico, se você nunca fez isso).

Se necessário removar alguma ppa instale o ppa-purge:

Código: [Selecionar]
sudo apt-get install ppa-purge
Depois, para removar:

Código: [Selecionar]
sudo ppa-purge nome_da_ppa
Se quiser obter o comando direto de remoção da ppa pode fazer:

Código: [Selecionar]
find /etc/apt/sources.list.d -type f -name "*.list" -print0 | \
    while read -d $'\0' file; do awk -F/ '/deb / && /ppa\.launchpad\.net/ {print "sudo ppa-purge ppa:"$4"/"$5}' "$file"; done

Vai resultar numa saída pronta para executar.

(Não tente digitar o código acima, raramente dá certo, copie com o mouse e cole no terminal evitando, assim, erros de retranscrição)

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.