Autor Tópico: Não consigo ligar/usar minha Placa de Vídeo Híbrida  (Lida 2012 vezes)

Offline -InuYasha-

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Não consigo ligar/usar minha Placa de Vídeo Híbrida
« Online: 01 de Agosto de 2015, 02:57 »
Olá, boa noite!

Meu nome é Thiago, possuo um Notebook Dell Inspirion 15R Special Edition, com as seguintes configurações:

Intel Core i5 3210m com clock de 2.5ghz a 3.1ghz, com Placa de Vídeo HD 4000 (integrada);
Placa de Vídeo Dedidcada AMD HD 7730M;
6GB de Memória RAM DDR 1.333;
HD 750GB 7200RPM;
Sistema Operacional Ubuntu 15.04 64 Bits com Kernel 3.19 e todas as atualizações feitas.

Meu problema:

O Ubuntu reconhece a existência das duas placas de vídeos, porém eu só consigo utilizar a placa de vídeo integrada da Intel (HD 4000).
Já tentei de tudo pra "ligar" e usar a placa dedicada (AMD HD 7730M), porém não consigo.
Obs.: Estou querendo usar os drivers opensources mesmo, pois me servem melhor para o uso geral no Desktop e pelo que tenho pesquisado eles já têm um bom desempenho para os jogos que jogo (atualmente Dota 2 da Valve).

Aí vão alguns comandos pelo terminal que podem ajudar:

LSPCI:
thiago@Thiago-Note:~$ lspci
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Chelsea LP [Radeon HD 7730M]
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 07)
08:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)

GLXINFO | GREP OPENGL
thiago@Thiago-Note:~$ glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile
OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.7.0-devel (git-7830e46 2015-07-31 vivid-oibaf-ppa)
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.7.0-devel (git-7830e46 2015-07-31 vivid-oibaf-ppa)
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 10.7.0-devel (git-7830e46 2015-07-31 vivid-oibaf-ppa)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

CAT
thiago@Thiago-Note:~$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Pwr:0000:01:00.0

Eu não me importo de desligar a placa intel, pela questão de autonomia da bateria, até porque utilizo o notebook tal qual um desktop, praticamente não tiro da tomada.
Qualquer ajuda é bem vinda, desde já agradeço.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Não consigo ligar/usar minha Placa de Vídeo Híbrida
« Resposta #1 Online: 01 de Agosto de 2015, 03:50 »
Na verdade não sei realmente qual o estado da arte nesse assunto de gpu híbrida, ainda mais Radeon, entretanto, se ainda é como era anteriormente, um bom começo pode ser por aqui:

VGAswitcheroo

http://ubuntuforum-br.org/index.php/topic,84528.0.html

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.