Autor Tópico: Touchpad travando Dell Vostro 5470  (Lida 77486 vezes)

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #75 Online: 14 de Dezembro de 2014, 14:26 »
Faça o seguinte:

Entre no diretório modprobe.d

Código: [Selecionar]
cd /etc/modprobe.d
Crie um arquivo com o nome psmouse.conf

Código: [Selecionar]
sudo touch psmouse.conf
Acrescente esse conteúdo ao arquivo criado:

Código: [Selecionar]
echo "options psmouse proto=imps" | sudo tee /etc/modprobe.d/psmouse.conf >/dev/null
Confirme o conteúdo do arquivo psmouse.conf fazendo:

Código: [Selecionar]
cat /etc/modprobe.d/psmouse.conf
Deve resultar:

options psmouse proto=imps

Recarregue o módulo psmouse fazendo (ou reinicie o sistema):

Código: [Selecionar]
sudo modprobe -r psmouse && sudo modprobe psmouse
Confirme a alteração efetuada fazendo novamente:

Código: [Selecionar]
cat /sys/module/psmouse/parameters/proto
Agora deve resultar:

ImPS/2

Acelere a velocidade do mouse indo em "Configurações do sistema/Mouse&Touchpad

Mouse
Velocidade do ponteiro ==> inicialmente coloque no máximo e veja se é possível ir usando assim e testando.
Se ficar exageradamente rápido e realmente inusável, reduza um pouco, porém deixando o mais acelerado que puder e for usável.

É necessário que fique acelerado para ver se isso evita o travamento ocasional.
« Última modificação: 14 de Dezembro de 2014, 14:29 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #76 Online: 14 de Dezembro de 2014, 14:38 »
Conforme conversamos no post #51:

"Talvez seja o caso, então, de modificar diretamente no arquivo de configuração ao invés de usar o synclient como set, embora, em tese, devessem proporcionar o mesmo efeito."

Vamos, então, alterar o arquivo synaptics.conf para tornar o parâmetro TouchpadOff permanente.

Entretanto, isso não deve ser feito diretamente onde ele originalmente existe, aliás, como expressamente alertado no post # 61 que você fez, lá constando:

# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.

Como no Ubuntu (e Kubuntu) também não existe um diretório xorg.conf.d no local indicado, será necessário criá-lo.

Assim, inicialmente crie um diretório de nome xorg.conf.d dentro de /etc/X11/

Note que o X de X11 é em caixa alta, isto é, letra maiúscula!

Código: [Selecionar]
cd /etc/X11

sudo mkdir xorg.conf.d

Faça um ls (letra ele mais letra esse) para 'ver' se foi criado corretamente a pasta xorg.conf.d que neste momento ainda está vazia.

Vá agora para (o X novamente em caixa alta):


Código: [Selecionar]
cd /usr/share/X11/xorg.conf.d/

Faça um ls e veja que há alguns arquivos numerados dentro dessa pasta. Interessa-nos especificamente o arquivo 50-synaptics.conf

Faça uma cópia de segurança desse arquivo, fazendo:

Código: [Selecionar]
sudo cp 50-synaptics.conf 50-synaptics.conf-original

Copie agora o arquivo 50-synaptics.conf para dentro daquele diretório xorg.conf.d anteriormente criado em /etc/X11

Código: [Selecionar]
sudo cp 50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf

Vá novamente para dentro da pasta xorg.conf.d em /etc/X11

Código: [Selecionar]
cd /etc/X11/xorg.conf.d

Abra o arquivo 50-synaptics.conf que para lá foi copiado:

Código: [Selecionar]
sudo gedit /etc/X11/xorg.conf.d/50-synaptics.conf

Acrescente ao primeiro bloco 'Section' a linha abaixo, imediatamente após a linha MatchIsTouchpad "on" lá já existente:

Código: [Selecionar]
Option "TouchpadOff" "0"

Deve ficar dessa forma:

Código: [Selecionar]
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
Option "TouchpadOff" "0"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection

Salvar e sair.

Verifique e confirme a alteração feita fazendo:

Código: [Selecionar]
cat /etc/X11/xorg.conf.d/50-synaptics.conf | grep TouchpadOff

Deve obter como saída:

Código: [Selecionar]
Option "TouchpadOff" "0"

Reinicie a sessão.

Verifique o estado atual da alteração fazendo:

Código: [Selecionar]
synclient | grep TouchpadOff

Novamente deve obter como saída:

Código: [Selecionar]
TouchpadOff             = 0

Caso não esteja dessa forma, reinicie o sistema (e não apenas a sessão), talvez mais de uma vez, aqui demorou um pouco para o sistema entender a alteração, tive que usar um pouco o touchpad e reiniciar para só depois aparecer corretamente a alteração feita.

Use o touchpad do computador com essa alteração feita para verificar se houve efeito sobre o travamento.



Fiz esse todo esse procedimento agora a pouco.

Logo depois desse procedimento:

Código: [Selecionar]
synclient | grep TouchpadOff

Novamente deve obter como saída:

Código: [Selecionar]
TouchpadOff             = 0

Ficou dessa forma:

Código: [Selecionar]
TouchpadOff             = 2
« Última modificação: 14 de Dezembro de 2014, 14:50 por bakhtinjf »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #77 Online: 14 de Dezembro de 2014, 14:59 »
Êpa, não entendi muito bem!
Então não tinha feito ainda o procedimento do post #67 ?

Se for isso, então é um por vez, primeiro o #67 e vá testando, caso volte a travar, então aí sim faça o procedimento do post de hoje #75.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #78 Online: 14 de Dezembro de 2014, 15:04 »
Se o procedimento do post #67 foi feito corretamente deve estar aparecendo:

TouchpadOff             = 0

Como eu havia dito, parece que ele demora um pouco para entender a alteração feita, então reinicie o sistema (talvez mais de uma vez), use um pouco o Touchpad e só depois de alguma tempo faça uma nova verificação.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #79 Online: 14 de Dezembro de 2014, 15:37 »
Se o procedimento do post #67 foi feito corretamente deve estar aparecendo:

TouchpadOff             = 0

Como eu havia dito, parece que ele demora um pouco para entender a alteração feita, então reinicie o sistema (talvez mais de uma vez), use um pouco o Touchpad e só depois de alguma tempo faça uma nova verificação.

oK...vou esperar o procedimento do post 67 concluir.

e logo depois lhe digo o que ocorreu.

mas por enquanto não surgiu efeito. conforme vc pode conferir na post.

vou aguardar mais um pouco. porque todo o procedimento foi feito de forma correta.
« Última modificação: 14 de Dezembro de 2014, 15:42 por bakhtinjf »

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #80 Online: 14 de Dezembro de 2014, 15:49 »
Não sei se isso tem haver, mas...quando eu instalei o Kubuntu e o Xubuntu ele não criou a partição swap, tive que criar a partição manualmente quando o SO estava instalado. Eu tentei criar a partição swap no modo manual, informando o tamanho desejado.

Ele criou somente a partição, sem nenhum tipo.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #81 Online: 14 de Dezembro de 2014, 17:03 »
Citar
ele não criou a partição swap

Não vejo nenhuma relação entre uma coisa e outra, é indiferente, isso não tem nada a ver com o touchpad.

Se precisar de uma swap apenas crie uma, é apenas uma partição com um formato especial, nada além, aliás, mesmo tendo uma swap e ainda com o sistema em funcionamento é possível ativá-la ou desativá-la a qualquer tempo.

Não há relação disso com o mau funcionamento do touchpad.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #82 Online: 14 de Dezembro de 2014, 18:30 »
Código: [Selecionar]
# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        Option "TouchpadOff" "0"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on
# non-synaptics clickpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
#       To disable the bottom edge area so the buttons only work as buttons,
#       not for movement, set the AreaBottomEdge
#       Option "AreaBottomEdge" "82%"
EndSection

# This option disables software buttons on Apple touchpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Disable clickpad buttons on Apple touchpads"
        MatchProduct "Apple|bcm5974"
        MatchDriver "synaptics"
        Option "SoftButtonAreas" "0 0 0 0 0 0 0 0"
EndSection

Parece que esta tudo ok, ne?

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #83 Online: 14 de Dezembro de 2014, 19:01 »
Citar
Parece que esta tudo ok, ne?

Não, não está OK, está faltando exatamente fazer a alteração proposta!

O restante é tudo igual, é apenas acrescentar uma linha na posição mencionada no post respectivo # 67.
« Última modificação: 14 de Dezembro de 2014, 19:03 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #84 Online: 14 de Dezembro de 2014, 22:10 »
Olá, druidaobelix

Toda vez que o computador é iniciado aparece

TouchpadOff             = 2

Depois de um tempo de uso muda para o:

TouchpadOff             = 0

Depois que muda para o TouchpadOff             = 0, o computador fica muito estranho...não reinicia automaticamente, o atalho para abrir o terminal não funciona =S

Complicado =(
« Última modificação: 14 de Dezembro de 2014, 22:13 por bakhtinjf »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #85 Online: 14 de Dezembro de 2014, 22:27 »
Citar
Depois de um tempo de uso muda para o:
TouchpadOff             = 0

Então quer dizer que altera, o que é bom, então é usar e usar e ver se ainda trava ou não.

Citar
o computador fica muito estranho...não reinicia automaticamente,

Explique melhor isso aí acima, normalmente o computador não reinicia mesmo automaticamente, é necessário que se ordene (executando um comando ou clicando em um ícone correspondente) para que ele reinicie.

Citar
o atalho para abrir o terminal não funciona

Que atalho?
Não sei qual é o atalho para o terminal no Kubuntu.
Tenho a impressão que a última vez que usei um live do Kubuntu eu próprio configurei o atalho para o terminal para deixá-lo igual ao padrão do Ubuntu, tenho uma vaga lembrança que isso não vem configurado por padrão. É assim ou não?

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #86 Online: 14 de Dezembro de 2014, 22:31 »
Citar
Depois de um tempo de uso muda para o:
TouchpadOff             = 0

Então quer dizer que altera, o que é bom, então é usar e usar e ver se ainda trava ou não.

Citar
o computador fica muito estranho...não reinicia automaticamente,

Explique melhor isso aí acima, normalmente o computador não reinicia mesmo automaticamente, é necessário que se ordene (executando um comando ou clicando em um ícone correspondente) para que ele reinicie.

Citar
o atalho para abrir o terminal não funciona

Que atalho?
Não sei qual é o atalho para o terminal no Kubuntu.
Tenho a impressão que a última vez que usei um live do Kubuntu eu próprio configurei o atalho para o terminal para deixá-lo igual ao padrão do Ubuntu, tenho uma vaga lembrança que isso não vem configurado por padrão. É assim ou não?



Quando eu clico no botão reiniciar o computador não reinicia e o botão CRTL + T não funciona para abrir o Terminal. (esse comando eu configurei manualmente)

Agora por exemplo, não alterou para o TouchpadOff             = 0, já reiniciei o computador duas vezes e não alterou. Permanece no TouchpadOff             = 2.

Quando eu digito o comando:

Código: [Selecionar]
sudo kate /etc/X11/xorg.conf.d/50-synaptics.conf

Para verificar como esta o arquivo aparece diversos erros, é natural isso?
« Última modificação: 14 de Dezembro de 2014, 22:37 por bakhtinjf »

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #87 Online: 15 de Dezembro de 2014, 00:46 »
Citar
Quando eu digito o comando:
sudo kate /etc/X11/xorg.conf.d/50-synaptics.conf
Para verificar como esta o arquivo [...]

Para ver o arquivo não é necessário usar o kate, que é um editor de texto, use apenas:

Código: [Selecionar]
cat /etc/X11/xorg.conf.d/50-synaptics.conf | grep TouchpadOff

Deve resultar:

Option "TouchpadOff" "0"

Mas isso não é necessário ficar verificando, pois uma vez alterado e confirmada a alteração no arquivo de configuração, está alterado e não irá mudar sozinho.

O que indica o *estado*  em que está operando é:

Código: [Selecionar]
synclient | grep TouchpadOff
Deve resultar:

TouchpadOff             = 0

Ou seja, isso indica se o parâmetro do arquivo de configuração está de fato sendo usado pelo sistema.


De qualquer forma parece que você já confirmou que o *estado* foi para 0 (zero), demora um pouco mas vai, então é insistir em usar para testar o efeito sobre o travamento, que é o objeto central da questão.

Consertar o modo de desligar e ainda a tecla de atalho para o Terminal podemos fazer se o travamento de fato parar, caso contrário, isto é, se o travamento continuar, então é só reverter a mudança e por consequência tudo volta a ser como antes, porém, se o travamento realmente parar, aí então procuramos solução para os problemas novos.
« Última modificação: 15 de Dezembro de 2014, 00:48 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline weillerronfini

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Mouse travando
« Resposta #88 Online: 30 de Dezembro de 2014, 11:27 »
Olá usuário do Ubuntu, tudo bem? Eu estou com um problema que eu comprei um mouse novo, e o mesmo trava depois de um tempo de uso. Fui ao Windows, e ele funcionou perfeitamente. Fiquei usando-o direto durante sete(7) horas e nada de travar. No Ubuntu, trava depois de uns trinta(30) minutos. Eu acho que o problema deve estar no arquivo "xserver-xorg-input-mouse". A versão do meu é 1:1.9.1-1 que está dando este problema. O meu é um computador normal, diferente do relatado por vocês aqui nos tópicos, o "Dell". A minha placa-mãe, é uma Asrock, modelo "G41m-vs3" mas isto eu acho que não tenha nada a ver, já que o problema acontece com a parte de software. Vou tentar reportar este bug e informar que está acontecendo em diversos dispositivos que movimentem o ícone.

Offline bakhtinjf

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Touchpad travando Dell Vostro 5470
« Resposta #89 Online: 11 de Janeiro de 2015, 21:43 »
Problema, acontecendo com frequencia...=//

Estava de ferias e não estava usando o computador...

Mas agora voltou...