Autor Tópico: [Resolvido] Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set  (Lida 9377 vezes)

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Olá prezados,

Estou tentando instalar um Lubuntu 13.10 num computador com uma placa VIA..
Pesquisei sobre essa placa VIA, e vi os procedimentos para ela funcionar. Fiz o seguinte:
- Entrei em modo "xforcevesa" para poder instalar sem entrar no modo live
- Instalei e depois para tentar fazer "dar video", fiz os seguintes procedimentos, que vi no tópico http://ubuntuforum-br.org/index.php?topic=111599.15 :

"1º Ao ligar o computador, pressiona ambas as teclas <shift> para acessar o menu do GRUB (o gerenciador de boot).
2º Selecionar a opção “opções avançadas”
3º Selecionar a opção “Modo de recuperação”
4º Selecionar a opção “habilitar rede”
5º Selecionar a opção “sim”
6º Selecionar a opção “Desistir e ir para terminal em modo root”
7º Após entrar no terminal, digitar os seguintes comandos:

sudo add-apt-repository ppa:bigboss77/ppa -y;
sudo apt-get update;
sudo apt-get install xserver-xorg-video-openchrome

8º Reiniciar o PC. "

Mas continua sem entrar o video, ficando numa tela preta, e aparece uma mensagem quando carrega escrito algo como: "Longhout Enable not set" talvez a frase não esteja perfeita, porque foi rápido e não sei se copiei certo. Imaginei uma possibilidade de ter que desligar o modo "xforcevesa" mas acho que não é isso.

Se puderem ajudar, desde já agradeço, um ótimo dia! Valeu!
« Última modificação: 06 de Agosto de 2014, 19:58 por FilipeWVS »

Offline galactus

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.683
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #1 Online: 09 de Julho de 2014, 17:04 »
Tentou as dicas deste tópico?
http://ubuntuforum-br.org/index.php?topic=104389.0

Começa com as dicas que você postou, mas tem mais coisas para tentar, desinstalou o xorg antes de instalar o driver openchrome?

Boa sorte.
BigLinux no Notebook  / Várias Distros Virtualizadas no PC.

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #2 Online: 09 de Julho de 2014, 18:23 »
Recomendo que você instale a versão 14.04, que já corrigiu este problema.

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #3 Online: 09 de Julho de 2014, 19:37 »
Olá, prezados, obrigado pela ajuda,

Galactus,
Tentei desinstalar o xorg com os procedimentos abaixo mas não sei se fiz certo, ainda to aprendendo a mexer na linha de comando:

sudo apt-get remove --purge xserver-xorg (não funcionou)

Então tentei:
sudo dpkg-reconfigure xserver-xorg

Fiz certo?

Rogrigo.miguel
O 14.04 já corrigiu esse problema mesmo?
Estranho, porque o primeiro Lubuntu que tentei instalar foi o 14.04 e deu o mesmo problema.

- Será que foi o nomodeset que coloquei no início para poder instalar, que teria que ser desabilitado agora?
- E o que seria esse "Longhout Enable not set"?

« Última modificação: 09 de Julho de 2014, 19:47 por FilipeWVS »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #4 Online: 09 de Julho de 2014, 20:05 »
Sim, foi corrigido.

Tente o boot normal, sem nomodeset.

Poste aqui o resultado deste comando:

Código: [Selecionar]
lspci | grep -i vga

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #5 Online: 09 de Julho de 2014, 22:43 »
Entrei com
sudo nano /etc/default/grub
e alterei a linha
grub_cmdline_linux_default="quiet splash nomodoset" para grub_cmdline_linux_default="quiet splash"

Mas não funcionou.. continua parando na tela preta.
« Última modificação: 09 de Julho de 2014, 23:40 por FilipeWVS »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #6 Online: 10 de Julho de 2014, 09:42 »
...
- E o que seria esse "Longhout Enable not set"?

Tem a ver com isso: http://lxr.free-electrons.com/source/drivers/cpufreq/longhaul.c

E o resultado deste comando:

Código: [Selecionar]
lspci | grep -i vga
? ? ?

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #7 Online: 10 de Julho de 2014, 11:45 »
Bom dia,

Complexos aqueles algoritmos sobre o longhaul...

Caro Rodrigo.miguel segue o conteúdo do comando lspci | grep -i vga

01:00.0 VGA compatible controler: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev01)

Desde já, obrigado pela atenção. : )

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #8 Online: 10 de Julho de 2014, 17:14 »
Você tem exatamente a mesma placa de vídeo integrada que eu. Neste momento estou usando o Xubuntu 14.04 sem os problemas apresentados pelas versões anteriores (note que sou o autor deste tópico: http://ubuntuforum-br.org/index.php/topic,104389.0.html ).

Essa mensagem que aparece na tela pode ter ou não relação com o problema.

Tente utilizar um LiveCd/USB do 14.04. Tente carregar o sistema normalmente. Não use nenhum parâmetro, pois não deveria ser necessário. Se o LiveCD carregar, então está tudo OK. Senão, tente os outros parâmetros (noacpi, noapic, nolapic, etc).

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #9 Online: 10 de Julho de 2014, 18:55 »
Puxa, legal, espero também conseguir essa proeza. rsrs

Vc conseguiu o Xubuntu 14.04 nessa placa, sem dar nenhum erro e sem ter que configurar nada?

Tentei fazer o que você falou...
Utilizei um CD LiveCd/USB do Ubuntu 14.04, quando carrega no início, aparece aquela mensagem de erro "Longhout Enable not set".....
Mas, mesmo assim, vai para aquela tela de escolher o idioma e entre experimentar ou instalar... Então, escolho o idioma e clico no modo "para experimentar o Ubuntu", e quando vai carregar o sistema aparece a mensagem:

"The system is runing in low-graphics mode.
You screen graphics card, and input device settings could not be detected currently. You will need configure these yourself."

Ai manda escolher entre gráficos reduzidos, ou reconfigurar e outra opção.. mas não funcionou nenhuma.

Mesmo no modo experimentar, tentei também, pelo terminal, o comando:
sudo add-apt-repository ppa:bigboss77/ppa

Mas continuou sem entrar no modo gráfico.
« Última modificação: 10 de Julho de 2014, 19:28 por FilipeWVS »

Offline rodrigo.miguel

  • Usuário Ubuntu
  • *
  • Mensagens: 720
    • Ver perfil
    • LinuxUserVlog
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #10 Online: 11 de Julho de 2014, 01:03 »
Aqui funcionou sem configurar nada.

Você não deve instalar esse PPA no 14.04.

Infelizmente não sei a causa nem a solução para o seu problema.

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #11 Online: 11 de Julho de 2014, 09:46 »
OK! Mas, mesmo assim, obrigado pela ajuda miguel, valeu! : )

Se alguém tiver outra ideia, é bem vinda.

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #12 Online: 11 de Julho de 2014, 15:23 »
Consegui anotar a msgm toda:

longaul: option enable not set. Aborting

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #13 Online: 11 de Julho de 2014, 16:41 »
Ola

Desculpe minha ignorância, mas:

Longaul controla a freqüência do processador e nada mas nada mesmo tem a ver com sua placa de video.

Voce tem dois problemas aí. Um deles é ajustar o cpufreq e outro ajustar sua placa de video.

Um problema não interfere no outro, ok?

[]'s

Offline FilipeWVS

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
Re: Sem dar Video numa Placa VIA e dando Msgm Longhout Enable not set
« Resposta #14 Online: 11 de Julho de 2014, 17:09 »
Obrigado por esclarecer melhor prezado Tota, entendi. Seria bom uma distro Linux que resolvesse esses dois problemas de uma vez.
Abraços
« Última modificação: 12 de Julho de 2014, 01:06 por FilipeWVS »