Autor Tópico: Problema com linux ubuntu 10.04-editado.  (Lida 15634 vezes)

Offline tinoco silva

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Problema com linux ubuntu 10.04-editado.
« Online: 08 de Novembro de 2013, 23:17 »
ola pessoal estou com um problema com o ubuntu 10.04 conseguir instalar fiz duas partições uma 1gb em swap e outra de 30gb como ext4/ só que quando arranca o ubuntu aparece isto já tentei recuperar de novo a grub do ubuntu e nada fica igual será que alguém me pode ajudar como resolvo este embrulho obrigado e adeus.

 Gave up waiting for root device. Common problems:
 - Boot args (cat /proc/cmdline)
 - Check rootdelay= (did the system wait long enough?)
 - Check root= (did the system wait for the right device?)
 - Missing modules (cat /proc/modules; ls /dev)
 ALERT! /dev/disk/by-uuid/920903aa-762f-40d2-8126-87f4b0e6f975 does not exist. Dropping to a shell!

 BusyBox v1.19.3 (Ubuntu 1:1.10.3-7ubuntu1.1) bult-in shell (ash)
 Enter 'help' for a lost of built-in commands.
 (initramfs)
já consegui arrancar com o ubuntu mas o problema é que quando o ubuntu é encerrado quando volto a ligar tenho que escrever sempre estas palavras no (initramfs) para voltar a arrancar:
blkid
blkid dev --rereadpt /dev /sda1
blkid
exit
se alguém me poder ajudar agradecia adeus.
 ??? ???
« Última modificação: 09 de Novembro de 2013, 08:40 por Ioca100 »

Offline santos

  • Usuário Ubuntu
  • *
  • Mensagens: 157
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #1 Online: 09 de Novembro de 2013, 11:14 »
Ola.

Tinoco, creio que mais de 512 MB de Swap eh desperdicio.  Quando instalou vc escolheu a inicializacao para MBR?  Estando ainda neste ponto, eu tentaria uma nova instalacao.

Offline tinoco silva

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #2 Online: 09 de Novembro de 2013, 20:51 »
olá colega será que me podes informar  como eu faço uma nova instalação porque o disco rígido não tinha nada lá dentro por isso quando foi formatado foi com as partições do ubuntu, mas eu também tentei instalar sem fazer partições e foi igual acabou por ficar dois ubunutus dentro do disco rigido e aconteceu o mesmo problema a tela preta com essas palavras.
o disco rígido foi comprado usado numa casa de informática provavelmente apagaram o sistema operativo que lá tinha.
o que pensas que devo fazer se me poderes ajudar agradecia adeus.   

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.332
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #3 Online: 11 de Novembro de 2013, 10:31 »
Pra começar, não tente instalar o Ubuntu 10.04; tente o 12.04.

Depois, verifique se seu hardware atende os requisitos mínimos do sistema.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.050
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #4 Online: 11 de Novembro de 2013, 12:34 »

já consegui arrancar com o ubuntu mas o problema é que quando o ubuntu é encerrado quando volto a ligar tenho que escrever sempre estas palavras no (initramfs) para voltar a arrancar:
blkid
blkid dev --rereadpt /dev /sda1
blkid
exit
se alguém me poder ajudar agradecia adeus.
 ??? ???

Inicie novamente deste modo e colha alguns dados adicionais para melhor analise do seu problema.
Poste a saida destes comandos:
Código: [Selecionar]
sudo blkid
Código: [Selecionar]
cat /etc/fstab
Código: [Selecionar]
cat /boot/grub/grub.cfg
Código: [Selecionar]
sudo fdisk -l
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline tinoco silva

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #5 Online: 11 de Novembro de 2013, 16:07 »
olá colega apareceu isto será que dá para resolver porque eu já não consigo fazer mais nada ou então vou ter que o deixar como está se me podres ajudar agradecia adeus e obrigado pela vossa ajuda.

tinoco@tinoco-desktop:~$ sudo blkid
[sudo] password for tinoco:
/dev/sda1: UUID="50a6fc50-a55a-4ba0-83a7-c1152cb23c7c" TYPE="ext4"
/dev/sda5: UUID="67b9c34f-06ad-46aa-ba85-ea40325ca8e8" TYPE="swap"
tinoco@tinoco-desktop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=50a6fc50-a55a-4ba0-83a7-c1152cb23c7c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=67b9c34f-06ad-46aa-ba85-ea40325ca8e8 none            swap    sw              0       0
tinoco@tinoco-desktop:~$ cat /boot/grub/grub.cfg
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"
if [ ${prev_saved_entry} ]; then
  set saved_entry=${prev_saved_entry}
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z ${boot_once} ]; then
    saved_entry=${chosen}
    save_env saved_entry
  fi
}

function recordfail {
  set recordfail=1
  if [ -n ${have_grubenv} ]; then if [ -z ${boot_once} ]; then save_env recordfail; fi; fi
}
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 50a6fc50-a55a-4ba0-83a7-c1152cb23c7c
if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 50a6fc50-a55a-4ba0-83a7-c1152cb23c7c
set locale_dir=($root)/boot/grub/locale
set lang=pt
insmod gettext
if [ ${recordfail} = 1 ]; then
  set timeout=-1
else
  set timeout=10
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/light-gray
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Ubuntu, com Linux 2.6.32-38-generic' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 50a6fc50-a55a-4ba0-83a7-c1152cb23c7c
   linux   /boot/vmlinuz-2.6.32-38-generic root=UUID=50a6fc50-a55a-4ba0-83a7-c1152cb23c7c ro   quiet splash
   initrd   /boot/initrd.img-2.6.32-38-generic
}
menuentry 'Ubuntu, com Linux 2.6.32-38-generic (modo de recuperação)' --class ubuntu --class gnu-linux --class gnu --class os {
   recordfail
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 50a6fc50-a55a-4ba0-83a7-c1152cb23c7c
   echo   'A carregar Linux 2.6.32-38-generic ...'
   linux   /boot/vmlinuz-2.6.32-38-generic root=UUID=50a6fc50-a55a-4ba0-83a7-c1152cb23c7c ro single
   echo   'A carregar ramdisk inicial ...'
   initrd   /boot/initrd.img-2.6.32-38-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 50a6fc50-a55a-4ba0-83a7-c1152cb23c7c
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   insmod ext2
   set root='(hd0,1)'
   search --no-floppy --fs-uuid --set 50a6fc50-a55a-4ba0-83a7-c1152cb23c7c
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
if [ ${timeout} != -1 ]; then
  if keystatus; then
    if keystatus --shift; then
      set timeout=-1
    else
      set timeout=0
    fi
  else
    if sleep --interruptible 3 ; then
      set timeout=0
    fi
  fi
fi
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###
tinoco@tinoco-desktop:~$ sudo fdisk -l

Disco /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificador do disco: 0x000b4c8f

Dispositivo Boot Início Fim Blocos Id Sistema
/dev/sda1   *           1        3648    29295616   83  Linux
/dev/sda2            3648        3721      584705    5  Estendida
/dev/sda5            3648        3721      584704   82  Linux swap / Solaris
tinoco@tinoco-desktop:~$

Eliseu Carvalho

  • Visitante
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #6 Online: 11 de Novembro de 2013, 16:31 »
A não ser que você trabalhe com servidores, não há mais por que instalar o Ubuntu 10.04. O suporte pra desktop já acabou. Se quiser algo leve, tenta o Lubuntu 13.10, ele é a versão do Ubuntu que usa o ambiente gráfico LXDE (e acho que LXDE-QT num futuro próximo).

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.050
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #7 Online: 11 de Novembro de 2013, 17:09 »
olá colega apareceu isto será que dá para resolver porque eu já não consigo fazer mais nada ou então vou ter que o deixar como está se me podres ajudar agradecia adeus e obrigado pela vossa ajuda.


Após carregar novamente o sistema use o comando abaixo no terminal e reinicie:

Código: [Selecionar]
sudo grub-install /dev/sda
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline Felix

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 3.064
    • Ver perfil
    • Alexsandro Felix
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #8 Online: 11 de Novembro de 2013, 17:30 »
Ola.

Tinoco, creio que mais de 512 MB de Swap eh desperdicio.  Quando instalou vc escolheu a inicializacao para MBR?  Estando ainda neste ponto, eu tentaria uma nova instalacao.

Eu também pensava isso sobre a questão do tamanho da swap. Até ter um notebook com apenas 1 Gb de memória com placa de video compartilhando da mesma ainda por cima, ou seja, me sobravam 800Mb aproximadamente, o que era consumido praticamente só pelo navegador dependendo de quantas abas eu mantivesse aberto.

Hoje confesso, com o mesmo notebook deixei com 8 Gb aproximadamente de swap e trabalho normalmente com todas minhas aplicações (sim, a velocidade de acesso é extremamente menor, mas funciona)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.332
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #9 Online: 11 de Novembro de 2013, 18:41 »
O tamanho do swap é totalmente irrelevante pro problema dele...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline tinoco silva

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #10 Online: 11 de Novembro de 2013, 20:27 »
  colocai este comando como me foi sugerido deu isto reiniciei a maquina e nada aparece o que já relatei em principio. 
sudo grub-install /dev/sdaI
nstallation finished. No error reported.

eu pretendia o ubuntu 10.04 para esse mesmo fim servidor mas confesso que está impossível dar a volta a isto se me poderem continuar a ajudar agradecia obrigado a todos pelas vossas dicas adeus e obrigado 

Eliseu Carvalho

  • Visitante
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #11 Online: 11 de Novembro de 2013, 20:45 »
sudo grub-install /dev/sdaI

Aqui está o erro. Era pra por só isso:

sudo grub-install /dev/sda

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.332
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #12 Online: 11 de Novembro de 2013, 21:18 »
  colocai este comando como me foi sugerido deu isto reiniciei a maquina e nada aparece o que já relatei em principio. 
sudo grub-install /dev/sdaI
nstallation finished. No error reported.

eu pretendia o ubuntu 10.04 para esse mesmo fim servidor mas confesso que está impossível dar a volta a isto se me poderem continuar a ajudar agradecia obrigado a todos pelas vossas dicas adeus e obrigado 

Volto a dizer... primeiro, consiga uma mídia de instalação do Ubuntu 12.04. Há uma chance de que seu sistema não esteja bootando pq a controladora não foi reconhecida; e esse é o tipo de problema pelo qual vc pode passar usando uma distribuição antiga. Se o problema for esse, muito provavelmente será resolvido instalando o 12.04.

Durante a instalação, escolha a opção pra remover as partições anteriores, deixe o sistema se instalar como achar melhor.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.050
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #13 Online: 11 de Novembro de 2013, 21:30 »
Carrege novamente seu sistema e use o comando abaixo:

Código: [Selecionar]
sudo update-initramfs -c -k $(uname -r)
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline tinoco silva

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problema com linux ubuntu 10.04-editado.
« Resposta #14 Online: 11 de Novembro de 2013, 21:42 »
update-initramfs: Generating /boot/initrd.img-2.6.32-38-generic
tinoco@tinoco-desktop:~$
deu isto e agora