Autor Tópico: Driver de rede com fio não funciona  (Lida 3807 vezes)

Offline accampos_

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Driver de rede com fio não funciona
« Online: 05 de Novembro de 2013, 10:19 »
Olá Pessoal!
A rede com fio  do meu notebook Lenovo G470 não está funcionando. Estou com a versão 13.10 do sistema, e na 12.10, funcionava perfeitamente.
Acho que é o driver que não está funcionando, pois as luzes da porta de rede acendem normalmente. Como faço para solucionar isso?  Obrigado

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver de rede com fio não funciona
« Resposta #1 Online: 05 de Novembro de 2013, 15:21 »
Execute os comandos abaixo e cole o resultado aqui.

sudo lshw -C network
ifconfig -a
nm-tool
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline accampos_

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Driver de rede com fio não funciona
« Resposta #2 Online: 05 de Novembro de 2013, 15:48 »
arthur@arthur-Lenovo-G470:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 00:23:5a:7a:85:e2 
          BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:513 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:513 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:41011 (41.0 KB) TX bytes:41011 (41.0 KB)

wlan0     Link encap:Ethernet  Endereço de HW 74:de:2b:c0:60:63 
          BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

arthur@arthur-Lenovo-G470:~$ nm-tool

NetworkManager Tool

State: asleep

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath9k
  State:             unmanaged
  Default:           no
  HW Address:        74:DE:2B:C0:60:63

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             unmanaged
  Default:           no
  HW Address:        00:23:5A:7A:85:E2

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver de rede com fio não funciona
« Resposta #3 Online: 05 de Novembro de 2013, 16:23 »
Preciso de todos os comandos pra poder te ajudar.

Outra coisa, qual é a sua conexão internet?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver de rede com fio não funciona
« Resposta #4 Online: 05 de Novembro de 2013, 16:24 »
Mais um comando que vou precisar:

cat /etc/network/interfaces
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline accampos_

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Driver de rede com fio não funciona
« Resposta #5 Online: 06 de Novembro de 2013, 15:07 »
nenhum código funciona, eu vou tentar rezolver de outra forma. Obragado.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver de rede com fio não funciona
« Resposta #6 Online: 06 de Novembro de 2013, 15:09 »
Apenas copie os comandos que eu passei e cole o resultado aqui, pra gente analisar o que está acontecendo. Nada do que eu passei até agora vai resolver o seu problema, estamos apenas tentando entender o que o está causando.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline accampos_

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Driver de rede com fio não funciona
« Resposta #7 Online: 06 de Novembro de 2013, 15:13 »
ok, colocarei os resultados aqui mais tarde.

Offline accampos_

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Driver de rede com fio não funciona
« Resposta #8 Online: 06 de Novembro de 2013, 20:30 »
arthur@arthur-Lenovo-G470:~$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver de rede com fio não funciona
« Resposta #9 Online: 06 de Novembro de 2013, 21:48 »
OK.

Que tipo de conexão internet você usa?
« Última modificação: 06 de Novembro de 2013, 21:50 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline accampos_

  • Usuário Ubuntu
  • *
  • Mensagens: 16
    • Ver perfil
Re: Driver de rede com fio não funciona
« Resposta #10 Online: 06 de Novembro de 2013, 21:59 »
Oi Velox, aqui em casa, o cabo é ligado a um modem DSL.
Tem a internet cabeada da escola também que é ligada a um switch. E não funciona em nenhuma das duas, as luzes da porta acendem, mas não conecta e não aparece nada no ubuntu.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Driver de rede com fio não funciona
« Resposta #11 Online: 06 de Novembro de 2013, 22:14 »
Seu modem de casa está roteado, certo? Se estiver, execute os comandos abaixo e cole o resultado aqui.

echo -e "\nauto eth0\niface eth0 inet dhcp\n" | sudo tee -a /etc/network/interfaces
sudo ifdown eth0
sudo ifup eth0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D