Autor Tópico: (Resolvido) Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04  (Lida 6599 vezes)

Offline vitorf

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
(Resolvido) Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Online: 21 de Julho de 2013, 18:58 »
Olá, amigos!

O meu notebook está com um estranho problema; não consigo acessar a internet com nenhum aplicativo se não o Google Chrome.

No começo eu desconfiava de que o problema era o driver da placa wifi (uso apenas conexão wifi) mais tentei navegar com a placa ethernet e também não consegui acessar.

Já atualizei o driver da placa de rede wifi, kernel do Ubuntu para 3.10.1 e o problema não foi resolvido.

A proposito, o modelo da placa wifi é RTL8188CE. E na janela de informações da conexão exibe um driver diferente para o da placa, o que aparece lá é "rtl8192ce".

Andei pesquisando em outros fóruns sobre como resolver esse problema e vi que muita gente também estava com o mesmo.

Algumas das soluções postadas eram criar rtl8192.conf em etc/mprobe.d com o conteúdo "options rtl8192ce ips=0 fwlps=0 debug=2" mas não aparenta solucionar o problema. Outras sugeriam atualizar o driver da placa e o fiz mas também não consegui resolver.

Alguém pode me ajudar? Tô em apuros tendo como opção apenas o Google Chrome.
« Última modificação: 24 de Julho de 2013, 07:28 por vitorf »

Offline jkmsjq

  • Usuário Ubuntu
  • *
  • Mensagens: 3.343
  • Ubuntu Member
    • Ver perfil
LinuxUser: 548942 / Dando um tópico como resolvido
"A verdade só é agressiva a quem vive de mentiras". Autor desconhecido.
Twitter: @jeisonkertesz

Offline vitorf

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #2 Online: 22 de Julho de 2013, 11:26 »
Oi, jkmsjq

Li e re-li e os tópicos e segui os passos de alguns mais nenhum resultado positivo :/

O estranho mesmo é o fato de ele só acessar com o Google Chrome então podemos desconfiar de que é problema nas configurações de rede, né?
Até quando tento fazer downloads pelo terminal não dá certo...

Executei os comandos:

sudo lshw -C network
ifconfig -a
iwconfig
nm-tool
rfkill list wifi
uname -a

Você pode analisar o resultado?

Offline Renan Rischiotto

  • Usuário Ubuntu
  • *
  • Mensagens: 2.888
    • Ver perfil
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #3 Online: 22 de Julho de 2013, 14:20 »
Onde está o resultado?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #4 Online: 22 de Julho de 2013, 18:45 »
Oi, jkmsjq

Li e re-li e os tópicos e segui os passos de alguns mais nenhum resultado positivo :/

O estranho mesmo é o fato de ele só acessar com o Google Chrome então podemos desconfiar de que é problema nas configurações de rede, né?
Se funciona com um navegador, então não é problema na camada de rede --- tem que ser problema na camada de aplicativos.

Acho que seria o caso de mudar o enfoque, e tentar descobrir exatamente o que não funciona nos outros navegadores. Qual a mensagem de erro que você recebe? Página não encontrada, timeout, etc.

Citar
Até quando tento fazer downloads pelo terminal não dá certo...
Novamente, precisamos de detalhes sobre o que você tentou fazer e o que aconteceu quando você tentou.

Citar
Executei os comandos:

sudo lshw -C network
ifconfig -a
iwconfig
nm-tool
rfkill list wifi
uname -a

Você pode analisar o resultado?
Só quando você postar esse resultado, apesar de que eu acho muito pouco provável que vá influir alguma coisa.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline vitorf

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #5 Online: 22 de Julho de 2013, 23:23 »
Reinstalei o Ubuntu hoje pra ver se resultaria em algo (bobagem, né? rsrsrs) e não mudou nada.

Aqui o resultado dos comandos:

Código: [Selecionar]
vitor@vitor-C14RV01:~$ sudo lshw -C network
[sudo] password for vitor:
  *-network               
       descrição: Ethernet interface
       produto: JMC250 PCI Express Gigabit Ethernet Controller
       fabricante: JMicron Technology Corp.
       ID físico: 0.5
       informações do barramento: pci@0000:03:00.5
       nome lógico: eth0
       versão: 03
       serial: 80:ee:73:45:93:85
       tamanho: 10Mbit/s
       capacidade: 1Gbit/s
       largura: 32 bits
       clock: 33MHz
       capacidades: pm pciexpress msix msi bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuração: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       recursos: irq:42 memória:fe000000-fe003fff porta de E/S:e100(tamanho=128) porta de E/S:e000(tamanho=256)
  *-network
       descrição: Interface sem fio
       produto: RTL8188CE 802.11b/g/n WiFi Adapter
       fabricante: Realtek Semiconductor Co., Ltd.
       ID físico: 0
       informações do barramento: pci@0000:06:00.0
       nome lógico: wlan0
       versão: 01
       serial: 5c:c9:d3:13:53:58
       largura: 64 bits
       clock: 33MHz
       capacidades: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuração: broadcast=yes driver=rtl8192ce driverversion=3.8.0-26-generic firmware=N/A ip=192.168.0.101 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       recursos: irq:17 porta de E/S:d000(tamanho=256) memória:fea00000-fea03fff
vitor@vitor-C14RV01:~$ ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW 80:ee:73:45:93:85 
          UP BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
          IRQ:42

lo        Link encap:Loopback Local 
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:65536  Métrica:1
          pacotes RX:3222 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:3222 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:301557 (301.5 KB) TX bytes:301557 (301.5 KB)

wlan0     Link encap:Ethernet  Endereço de HW 5c:c9:d3:13:53:58 
          inet end.: 192.168.0.101  Bcast:192.168.0.255  Masc:255.255.255.0
          endereço inet6: fe80::5ec9:d3ff:fe13:5358/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Métrica:1
          pacotes RX:45232 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:40942 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:45885128 (45.8 MB) TX bytes:6262282 (6.2 MB)

vitor@vitor-C14RV01:~$ iwconfig
wlan0     IEEE 802.11bgn  ESSID:"Uai_Fai" 
          Mode:Managed  Frequency:2.427 GHz  Access Point: C8:3A:35:08:5B:88   
          Bit Rate=18 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:7   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

vitor@vitor-C14RV01:~$ nm-tool

NetworkManager Tool

State: connected (global)

- Device: wlan0  [Uai_Fai] -----------------------------------------------------
  Type:              802.11 WiFi
  Driver:            rtl8192ce
  State:             connected
  Default:           yes
  HW Address:        5C:C9:D3:13:53:58

  Capabilities:
    Speed:           18 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    *Uai_Fai:        Infra, C8:3A:35:08:5B:88, Freq 2427 MHz, Rate 54 Mb/s, Strength 72 WPA2
    SLJRNET:         Infra, 00:15:6D:69:3B:9E, Freq 2412 MHz, Rate 11 Mb/s, Strength 87 WPA WPA2

  IPv4 Settings:
    Address:         192.168.0.101
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1


- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            jme
  State:             unavailable
  Default:           no
  HW Address:        80:EE:73:45:93:85

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


vitor@vitor-C14RV01:~$ rfkill list wifi
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
vitor@vitor-C14RV01:~$ uname -a
Linux vitor-C14RV01 3.8.0-26-generic #38-Ubuntu SMP Mon Jun 17 21:46:08 UTC 2013 i686 athlon i686 GNU/Linux
vitor@vitor-C14RV01:~$


Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #6 Online: 23 de Julho de 2013, 01:04 »
É, não tem nada que pareça estar "fora do lugar".

Quer dar uma tentativa no Ubuntu 12.04 LTS?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline vitorf

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #7 Online: 23 de Julho de 2013, 01:46 »
zekkerj, testei o 12.04 por LiveCD mas algo pior aconteceu: a rede wifi não foi reconhecida.

Offline vitorf

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #8 Online: 23 de Julho de 2013, 01:55 »
Citar
Novamente, precisamos de detalhes sobre o que você tentou fazer e o que aconteceu quando você tentou.
Bom, sobre o terminal tentei baixar um script via wget mas o download não foi concluído, então baixei pelo Google Chrome e consegui.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.584
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #9 Online: 23 de Julho de 2013, 12:28 »
Cadê os detalhes? Não dá pra trabalhar com um "não deu certo". Precisamos de saídas dos comandos, telas, dados pra trabalhar.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline vitorf

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Conexão WiFi problemas - RTL8188CE - Ubuntu 13.04
« Resposta #10 Online: 23 de Julho de 2013, 13:29 »
zekkerj, aparentemente consegui resolver o problema desativando o serviço "dnsmasq" do network-manager.

Li em um blog que este serviço começa a cair constantemente e por isso não consigo acessar. (link da postagem: http://www.dominiodesconhecido.com.br/ti/2012/06/11/dnsmasq-algo-util-que-pode-virar-um-problema/)

Depois que desativei ele o problema da conexão desapareceu (até agora nenhuma queda), mas o acesso a internet no Firefox ficou um pouco lento... tipo, quando digito o endereço de um site demora uns 5 segundos até que ele comece a baixar os arquivos do site.

Bom, aqui vai o procedimento para desativar o dnsmasq:

No terminal, edite o arquivo /etc/NetworkManager/NetworkManager.conf

Para editar, digite o comando:
sudo gedit /etc/NetworkManager/NetworkManager.conf

No arquivo NetworkManager.conf adicione # antes de dns e salve, deve ficar assim:
#dns=dnsmasq

Depois, no terminal, digite o seguinte:
sudo rm -f /etc/resolv.conf
sudo ln -s /run/resolvconf/interface/NetworkManager /etc/resolv.conf


Para finalizar, reinicie o NetworkManager com:
sudo service network-manager restart

zekkerj, me desculpe por não ter enviado as saídas dos comandos. Eu não os salvei.
« Última modificação: 23 de Julho de 2013, 13:32 por vitorf »