Autor Tópico: Vídeo Piscando - AMD Radeon HD 6400M  (Lida 2542 vezes)

Offline AcidPlague

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Vídeo Piscando - AMD Radeon HD 6400M
« Online: 13 de Junho de 2013, 21:36 »
Olá,

É minha primeira vez aqui então tenham paciência.

Meu pc é um note Dell inspiron  com ubuntu 12.04 64 bits instalado e uma placa de vídeo AMD Radeon HD 6400M Series, kernel 3.5.0-34-generic. No site do ibunto até fala que o modelo do meu note é certificado (http://www.ubuntu.com/certification/hardware/201012-6932/).

Tentei a instalação do driver indo em: Driver Adicionais, mas ao instalar o driver proprietário este não aparece como ativo, mas ao fazer as atualizações pós instalação este é marcado como ativo, mas não em uso e minha tela fica piscando.

Procurei na net e achei o seguinte tutorial: http://ubuntued.info/instale-os-drivers-proprietarios-da-nvidia-e-ati-amd, mas depois de reiniciar, nem vídeo eu tinha.

Continuei minha peregrinação e acabei parando nesse tutorial: http://www.noobslab.com/2013/04/install-ati-amd-catalyst-drivers-in.html, mas ele nem encontra minha placa.

Ai foi no site da ati e encontrei essa comunidade: http://wiki.cchtml.com/index.php/Main_Page, segui o tutorial para instalação manual, o driver instalou, consigo abri o amdccc (AMD Catalyst Control Center), quando vou em Driver Adicionais ele é apresentado como ativado, entretanto meu monitor continua piscando.

Fiz todo tipo de combinação para os erros apresentados na wiki acima, mas meu vídeo continua piscando.

OBS: Instalei o Linux mint 13 64 bitse tive o mesmo problema, mas tive a impressão de que quando instalei o ked este problema não ocorreu, mas não posso afirmar pq não utilizei muito esse distro (não me adaptei bem ao KDE, fiquei muito perdido)

Ao executar lspci:
marcos@marcos-DS:~$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M Series]
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
09:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
0b:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

Ao executar  lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M Series]

Podem me ajudar?

Eliseu Carvalho

  • Visitante
Re: Vídeo Piscando - AMD Radeon HD 6400M
« Resposta #1 Online: 13 de Junho de 2013, 21:39 »
O grande problema aí é ter duas placas de vídeo, Intel e AMD. Isso se chama gráficos híbridos.
Você tem duas alternativas: desabilitar uma dessas placas de vídeo no BIOS (EFI) ou ler o tutorial sobre o VGASwitcheroo aqui:

http://ubuntuforum-br.org/index.php/topic,84528.0.html

Offline AcidPlague

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Vídeo Piscando - AMD Radeon HD 6400M
« Resposta #2 Online: 14 de Junho de 2013, 12:17 »
 :-\

Muito obrigado!
Vou seguir os procedimentos e ver se melhora alguma coisa, é uma pena não funcionar tão bem como no Windows.
Irei usar mais uma vez o kubuntu (por mais tempo) e ver se a impressão de que esse problema não ocorre lá é real.
Mas confesso que fiquei desanimado.

Abraço cara!!!

Eliseu Carvalho

  • Visitante
Re: Vídeo Piscando - AMD Radeon HD 6400M
« Resposta #3 Online: 14 de Junho de 2013, 12:26 »
Se essa máquina fosse minha eu certamente desabilitaria uma dessas placas de vídeo, de preferência a AMD, que exige driver proprietário. Deixaria apenas a Intel habilitada, já que funciona direto. Experimenta aí.

Offline AcidPlague

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Vídeo Piscando - AMD Radeon HD 6400M
« Resposta #4 Online: 14 de Junho de 2013, 16:24 »
Olá

Desativei a placa ATI pelo switcheiroo e tudo parece ter melhorado (temperatura, vídeo aparentemente parou de piscar), aparentemente o problema foi resolvido.
Como o uso do Linux será para o início da carreia de programador, logo não utilizarei tanto vídeo.
É ruim o fato da coisa toda não rolar fácil como no Windows, mas creio que seja uma questão de tempo.

Abraço e muito obrigado!!!
« Última modificação: 14 de Junho de 2013, 16:26 por AcidPlague »

Offline AcidPlague

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Vídeo Piscando - AMD Radeon HD 6400M
« Resposta #5 Online: 14 de Junho de 2013, 18:56 »
Nada... mesmo desabilitando a placa ATI, o vídeo continuou piscando.