Autor Tópico: [Resolvido] Touchpad Dell não funciona no Kubuntu 12.04...  (Lida 5299 vezes)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.729
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
[Resolvido] Touchpad Dell não funciona no Kubuntu 12.04...
« Online: 07 de Outubro de 2012, 23:48 »
E aí galera?

Atualizei meu note Latitude E5500 do Kubuntu 10.04 para o 12.04 este fim de semana, porém agora não consigo fazer algumas coisas que antes rolavam de boa, como clicar com os dois botões ao mesmo tempo para emular o botão do meio, e rolar a tela com o canto do touchpad.

Nas propriedades do sistema, o touchpad parace como "não encontrado". Acho que tem a ver com o hardware, mas não consigo fazê-lo ser reconhecido...

Fiz algumas buscas sobre isso na internet, mas não tive bons resultados. Alguém já passou por isso?
« Última modificação: 12 de Outubro de 2012, 21:10 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.729
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Touchpad Dell não funciona no Kubuntu 12.04...
« Resposta #1 Online: 09 de Outubro de 2012, 11:30 »
Plutoniun Marijuana.

Tive algum progresso hoje; descobri que o problema é antigo com os dispositivos ALPS, que é o caso do touchpad do meu note.

Citar
$ xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Mouse                                id=11   [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Video Bus                                 id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ HID 413c:8157                             id=9    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=13   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]

Fuçando aqui e ali, acabei encontrando uma forma de ler as propriedades que o sistema assume pra ele, com o comando

xinput list-props "AlpsPS/2 ALPS GlidePoint"

Código: [Selecionar]
$ xinput list-props "AlpsPS/2 ALPS GlidePoint"
Device 'AlpsPS/2 ALPS GlidePoint':
        Device Enabled (152):   1
        Coordinate Transformation Matrix (154): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        Device Accel Profile (276):     0
        Device Accel Constant Deceleration (277):       1.000000
        Device Accel Adaptive Deceleration (278):       1.000000
        Device Accel Velocity Scaling (279):    10.000000
        Device Product ID (272):        2, 8
        Device Node (273):      "/dev/input/event13"
        Evdev Axis Inversion (280):     0, 0
        Evdev Axis Calibration (281):   <no items>
        Evdev Axes Swap (282):  0
        Axis Labels (283):      "Abs X" (301), "Abs Y" (302), "Abs Pressure" (303)
        Button Labels (284):    "Button Left" (155), "Button 1" (298), "Button Right" (157), "Button Wheel Up" (158), "Button Wheel Down" (159), "Button Horiz Wheel Left" (160), "Button Horiz Wheel Right" (161), "Button 3" (300)
        Evdev Middle Button Emulation (285):    1
        Evdev Middle Button Timeout (286):      50
        Evdev Third Button Emulation (287):     0
        Evdev Third Button Emulation Timeout (288):     1000
        Evdev Third Button Emulation Button (289):      3
        Evdev Third Button Emulation Threshold (290):   20
        Evdev Wheel Emulation (291):    1
        Evdev Wheel Emulation Axes (292):       0, 0, 4, 5
        Evdev Wheel Emulation Inertia (293):    10
        Evdev Wheel Emulation Timeout (294):    200
        Evdev Wheel Emulation Button (295):     4
        Evdev Drag Lock Buttons (296):  0

Também consegui fazer o botão do meio voltar a funcionar, com o comando

xinput set-prop "AlpsPS/2 ALPS GlidePoint" "Evdev Middle Button Emulation" 1

Mas o scroll continua não funcionando, ainda falta alguma coisa.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Touchpad Dell não funciona no Kubuntu 12.04...
« Resposta #2 Online: 09 de Outubro de 2012, 14:44 »
Quando eu usava alps touchpad, contornava o scroll com
Código: [Selecionar]
sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

Não sei se rola no 12.04

[]'s

Creto

  • Visitante
Re: Touchpad Dell não funciona no Kubuntu 12.04...
« Resposta #3 Online: 09 de Outubro de 2012, 18:46 »
Oá zekkerj,

Um cliente aqui tem um notebook que se não me engano é quase ou senão o mesmo que com umas mexidinhas no kubuntu e com esse pacote aqui http://biglinux.c3sl.ufpr.br/packages/precise/main/big-ktouch-ptbr_1.0.0-0biglinux1_all.deb conseguiu ficar otimo o touch a distro é o próprio kubuntu, porém modificado dessa forma aqui para poder instalar o pacote sem faltas de dependências.

Sei que não é muito mas quem sabe funcione.

T+

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.729
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Touchpad Dell não funciona no Kubuntu 12.04...
« Resposta #4 Online: 12 de Outubro de 2012, 21:09 »
Resolvido... depois de muito fuçar pela internet, caí numa página do "AskUbuntu" onde o autor foi indicado a usar o programa "synclient" pra configurar o touchpad. Daí eu fui procurar esse programa e vi que ele não estava instalado.

Quando eu mandei procurá-lo ("apt-cache search synclient"), o sistema me recomendou o pacote "xserver-xorg-input-synaptics", que não estava instalado. Instalei, rebootei e... voilà!!! Touchpad funcionando.

De bônus, o programa synaptiks passou a funcionar, e agora eu tenho um controle mais fino do que tinha antes sobre as funções do touchpad, como a rolagem horizontal (não funcionava antes) e o "tap" (batidas leves no touchpad pra simular o botão esquerdo).

Obrigado pela ajuda de todos!
« Última modificação: 13 de Outubro de 2012, 11:01 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline asghan

  • Usuário Ubuntu
  • *
  • Mensagens: 1.219
    • Ver perfil
Re: [Resolvido] Touchpad Dell não funciona no Kubuntu 12.04...
« Resposta #5 Online: 13 de Outubro de 2012, 09:54 »
Interessante, tenho um note Dell e o touch funciona normal no Ubuntu ( Unity )
   Ubuntu 12.04 - Unity 64bits

Offline notade3

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: [Resolvido] Touchpad Dell não funciona no Kubuntu 12.04...
« Resposta #6 Online: 26 de Novembro de 2012, 21:22 »
Eu estou tendo uma problema parecido com o meu note dell
porem como sou leigo  nao entendi o procedimento (voce digitou aqueles comandos no terminal?)
vc poderia me explicar passo a passo o procedimento para o ubuntu reconher o touchpad.
o meu touchpad funciona entretanto nao consigo configura-lo pois o ubuntu diz que nao ha touchpad instalado.

desde ja
valeu