Autor Tópico: Erro ao usar o apt-get  (Lida 12245 vezes)

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Erro ao usar o apt-get
« Online: 08 de Dezembro de 2011, 23:37 »
Olá a todos, estive utilizando o Kubuntu por esses dias e encontrei um problema ao executar esse comando:
Citar
sudo apt-get -f install
Pois aparece a seguinte mensagem:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  libgck-1-0 libgcr-3-1 libnotify4 libcap2-bin
  libp11-kit0 libcroco3 librsvg2-2 python-twisted-bin
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 237 não atualizados.
1 pacotes não totalmente instalados ou removidos.
Depois desta operação, 0 B adicionais de espaço em disco serão usados.
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Recurso temporariamente indisponível
Configurando man-db (2.6.0.2-2) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Recurso temporariamente indisponível
dpkg: erro processando man-db (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 man-db
E: Sub-process /usr/bin/dpkg returned an error code (1)

Como posso resolver isso?
Obrigado a todos ;D


« Última modificação: 09 de Dezembro de 2011, 21:03 por jorge505 »

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #1 Online: 09 de Dezembro de 2011, 00:03 »
tente rodar o comando

sudo dpkg --configure -a

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Re: Erro ao usar o apt-get
« Resposta #2 Online: 09 de Dezembro de 2011, 00:06 »
Andry, apareceu isso:
Configurando man-db (2.6.0.2-2) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Recurso temporariamente indisponível
dpkg: erro processando man-db (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 man-db


Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #3 Online: 09 de Dezembro de 2011, 00:08 »
Tenta isso

sudo fuser -v /var/cache/debconf/config.dat


Isso um bug no debconf (aqui não aconteceu, hehe) https://bugs.launchpad.net/ubuntu/+source/debconf/+bug/349469

depois tente (é tudo um comando só)

sudo rm /var/lib/apt/lists/* ; sudo rm /var/lib/apt/lists/partial/* ; sudo apt-get clean ; sudo apt-get -f install ; sudo apt-get update
« Última modificação: 09 de Dezembro de 2011, 00:19 por Andry »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #4 Online: 09 de Dezembro de 2011, 00:13 »
Configurando man-db (2.6.0.2-2) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Recurso temporariamente indisponível

Ola

voce não pode ter o synaptic ou a central de programas abertos enquanto usa o terminal com apt-get

[]'s

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Re: Erro ao usar o apt-get
« Resposta #5 Online: 09 de Dezembro de 2011, 00:17 »
Andry, ainda não resolveu, as útilmas mensagem que apareceram foram:
W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/oneiric/InRelease  

W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/oneiric-updates/InRelease  

W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/oneiric-backports/InRelease  

W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/oneiric/Release.gpg  Desabilitado para conectar com br.archive.ubuntu.com:http:

W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/oneiric-updates/Release.gpg  Desabilitado para conectar com br.archive.ubuntu.com:http:

W: Falhou ao buscar http://br.archive.ubuntu.com/ubuntu/dists/oneiric-backports/Release.gpg  Desabilitado para conectar com br.archive.ubuntu.com:http:

W: Alguns arquivos index falharam ao ser baixados. Eles foram ignorados, ou cópias antigas são usadas ao invés.

E depois execuei o
Citar
sudo apt-get -f install
e o erro persiste  ???

Tota, estou usando o Kubuntu, no caso o Muon estava aberto, então o fechei e o erro ainda persiste  :-\

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #6 Online: 09 de Dezembro de 2011, 00:18 »
Tenta isso
sudo fuser -v /var/cache/debconf/config.dat


Isso um bug no debconf (aqui não aconteceu, hehe) https://bugs.launchpad.net/ubuntu/+source/debconf/+bug/349469

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Re: Erro ao usar o apt-get
« Resposta #7 Online: 09 de Dezembro de 2011, 00:22 »
Recebi essa mensagem:
                    USUÁRIO     PID ACESSO COMANDO
/var/cache/debconf/config.dat:
                     root       2764 F.... frontend

Então tentei novamente executar o comando sudo apt-get -f install e nada de diferente, mesmo erro de sempre  :'(

Andry, tentei executar esses comandos que vi nesse site: http://eldermf.wordpress.com/2010/09/03/problemas-com-bloqueios-de-processos/
Citar
$ sudo rm -f /var/lib/dpkg/lock

$ sudo rm -drf /var/lib/dpkg/updates/

$ sudo aptitude -f clean

E agora ao tentar executar o sudo apt-get -f install tenho dois erros:
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Recurso temporariamente indisponível
dpkg: erro: não foi possível vasculhar diretório de atualizações '/var/lib/dpkg/updates/': Arquivo ou diretório não encontrado
E: Sub-process /usr/bin/dpkg returned an error code (2)

« Última modificação: 09 de Dezembro de 2011, 00:27 por jorge505 »

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #8 Online: 09 de Dezembro de 2011, 00:24 »
Primeiro
sudo kill 2764

depois

sudo apt-get install -f

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Re: Erro ao usar o apt-get
« Resposta #9 Online: 09 de Dezembro de 2011, 00:30 »
Andry, mutio obrigadooo, esse seu último comando deu certo  ::)
resolvi assim o problema do diretório:
Citar
sudo mkdir /var/lib/dpkg/updates
E então executei:
Citar
sudo kill 2764
sudo apt-get install -f
E agora parece estar tudo certo ;D

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #10 Online: 09 de Dezembro de 2011, 00:32 »
não esquece de editar o primeiro tópico e colocar o icone resolvido
 ;D ;D ;D

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Re: Erro ao usar o apt-get
« Resposta #11 Online: 09 de Dezembro de 2011, 00:42 »
Mas Andry, por que o Muon parece ter ficado "louco"? Aparece que tenho instala um monte de programas que sei que jamais instalei e inclusive quando procuro por eles aqui no PC não os encontro, inclusive o GIMP sumiu de lá  :o

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #12 Online: 09 de Dezembro de 2011, 00:51 »
alguns programas são instalador por ser dependência de outro,
mas parece estralho esse problema,

tente abrir o gimp pelo terminal


abra o terminal e digite gimp

tente remover o que não usar e as dependecias você pode remover pelo terminal digitando

sudo apt-get autoremove --purge

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: Erro ao usar o apt-get
« Resposta #13 Online: 09 de Dezembro de 2011, 00:52 »
dependendo do problema que "parece acontecer" feche o muon e abra novamente.

Offline jorge505

  • Usuário Ubuntu
  • *
  • Mensagens: 430
  • Ubuntu 12.10
    • Ver perfil
    • Tutoriais GIMP
Re: Erro ao usar o apt-get
« Resposta #14 Online: 09 de Dezembro de 2011, 00:57 »
Tentei abrir o GIMP pelo terminal mas aparece o seguinte:
O programa 'gimp' não está instalado no momento.  Você pode instalá-lo digitando:
sudo apt-get install gimp

Então executei este comando:
Citar
sudo apt-get install gimp
E apareceu isto:
Lendo informação de estado... Pronto
O pacote gimp não está disponível, mas é referenciado por outro pacote.
Isto pode significar que o pacote está faltando, ficou obsoleto ou
está disponível somente a partir de outra fonte

E: O pacote 'gimp' não tem candidato para instalação

Em relação ao Muon, nada  :-\