Autor Tópico: Firefox 3.6.2 não abre no ubuntu  (Lida 5699 vezes)

Offline mrrogens

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Firefox 3.6.2 não abre no ubuntu
« Online: 06 de Abril de 2010, 22:03 »
Caros,

resolvi atualizar o firefox no meu ubuntu e andei pesquisando para tal.

conheci as diferenças entre as versões nativas do ubuntu e o'original' do mozilla.

atualizei então pelo ubuntuzilla para a versão 3.6.2 e depois para o 3.6.3.

desde que procedi essa atualização o aplicativo vem passando por problemas para iniciar. as vezes inicia. na maioria das vezes nao. migrei momentaneamente para o crome

inciando pelo terminal aparece a seguinte mensagem:

(firefox-bin:2305) : GLib-WARNING **: g_set_prgname () called multiple times

gostaria de saber se já existe alguma forma de resolver esse problema...

saudações livres

Offline alexandre.mbm

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
    • Chat direto com meu GTalk
Re: Firefox 3.6.2 não abre no ubuntu
« Resposta #1 Online: 08 de Abril de 2010, 00:13 »
O problema tem a ver com algumas extensões do Firefox e com a versão dos pacotes libglib2.0-0 e libglib2.0-data no Ubuntu Karmic Koala 9.10; pelo menos esse é o sistema que uso e foi nele que experimentei o problema. Aqui é Firefox 3.6.3, atualizado hoje.

Citar
Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

O pacote libglib2.0-data é uma dependência de libglib2.0-0, então basta de preocupar com a instalação deste segundo.

Acontece que algumas extensões não funcionam nessa versão do Firefox se os pacotes libglib2.0-0 e libglib2.0-data versão 2.22.3-0ubuntu1 (do repositório karmic-updates) estiverem instalados. A maioria dessas extensões somente funcionam se estiver "forçada" a versão 2.22.2-0ubuntu1 (do repositório karmic). Mas algumas outras extensões, nem assim funcionam, e o pior, nessas condições o comando firefox não tem qualquer saída ou ação visível para o usuário.

A "solução paliativa" que preferi foi: manter atualizados o dois pacotes supracitados, e usar um mínimo de extensões. Para testar as extensões, vou habilitando elas ao poucos, testando se o Firefox abre, via Terminal, com o comando firefox. Quando dá errado, inicio o Firefox com a opção --safe-mode e desabilito a extensão que provocou a falha.

Código: [Selecionar]
firefox --safe-mode
Para forçar a versão de pacotes eu recomendo usar o "Gerenciador de pacotes Synaptic". Ele pode ser acessado através dos menus "Sistema > Administração". Com o Synaptic aberto, selecione o pacote desejado, faça "(menu) Pacote > (item) Forçar Versão..." e, no diálogo que abre, escolha a versão desejada. Confirme as alterações antes de fechar o Synaptic, usando o botão "Aplicar".

Cuidado! Os pacotes com a versão "forçada" serão sempre propostos para atualização, pelo "Gerenciador de Atualizações". Eu não sei como mudar isso. Parece-me que a "solução definitiva" para o problema vem na versão 2.22.4 dos pacotes da libglib...

Edição de sexta-feira, 9 de abril de 2010, às 13:08h:

Estou desconfiando que o problema é somente com extensões, com algumas extensões. Pois ontem, por exemplo, eu quiz re-ativar a extensão "Read It Later" e pude observar algo muito interessante: quando eu ativei a tal extensão o Firefox deixou de abrir, e então fui para os testes no Terminal, explicados acima, constatando que com os pacotes 2.22.4 a mensagem GLib-WARNING **: g_set_prgname () called multiple times "sempre sai", o Firefox funcionando ou não. Logo, é razoável trabalhar com a hipótese de que não é a glib que está bichando o Firefox junto com a extensão. "Pode ser apenas a extensão!"

Edição de sexta-feira, 9 de abril de 2010, às 14:21h:

Somente agora eu me lembrei do Google para uma pesquisa do tipo "firefox 3.6 and extensions. Mas foi em vão. Achei dicas interessantes (em inglês), mas elas não servem para resolver o problema em questão. Vejamos as melhores:


Também, fiz o teste de iniciar o Firefox com arquivos limpos em .mozilla, testando instalar a extensão "Read It Later". Não passou!

Código: [Selecionar]
alexandre$ mv .mozilla .mozilla-backup-extensions
[b]Nesse ponto iniciei o Firefox normalmente e instalei a extensão "Read It Later". Reinicie o Firefox, e fechei.[/b]
alexandre$ firefox
(firefox-bin:3995): GLib-WARNING **: g_set_prgname() called multiple times
alexandre$ rm -rf .mozilla
alexandre$ mv .mozilla-backup-extensions .mozilla

O último comando acima volta o sistema ao que era.
« Última modificação: 14 de Abril de 2010, 00:54 por alexandre.mbm@gmail.com »

Offline vitolla

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Firefox 3.6.2 não abre no ubuntu
« Resposta #2 Online: 08 de Abril de 2010, 02:16 »

fica a dika

Offline alexandre.mbm

  • Usuário Ubuntu
  • *
  • Mensagens: 43
    • Ver perfil
    • Chat direto com meu GTalk
Re: Firefox 3.6.2 não abre no ubuntu
« Resposta #3 Online: 14 de Abril de 2010, 03:24 »
Parece que eu resolvi o problema!

Existe uma grande probabilidade do problema estar sanado. Vejamos.

Eu estava lendo no fórum que alguém sugeriu um teste drástico para diante desses problemas que temos enfretado com o Firefox. A proposta: desinstalar o Firefox completamente (a "remoção completa" oferecida pela Synaptic), excluindo os arquivos de configurações. Inclusive excluir também, manualmente, a pasta .mozilla, a qual guarda as configurações do usuário.

Eu segui essa dica, mas antes fiz backup, tanto da pasta .mozilla, como dos Favoritos. Também exportei a lista de extensões que gosto, mesmo elas estando desabilitadas. Para isso eu usei a extensão "Extension List Dumper", que funcionou pelo menos em -safe-mode.

Na minha pasta de backup eu guardei todos os tipos de arquivos de backup possíveis:

Citar
bookmarks-2010-04-14.json - backup dos Favoritos em formato JSON
bookmarks.html - exportação dos Favoritos em HTML
extensions-bbcode.txt - dump da lista de extensões em BBCODE, que é linguagem de marcação usada neste fórum
extensions.html - dump da lista de extensões em HTML
extensions-pv.csv - dump da lista de extensões em CSV separado por ponto e vírgula
extensions.txt - dump da lista de extensões em texto simples
extensions-v.csv - dump da lista de extensões em CSV separado por vírgula

Mas eu fiz esse processo, e tive a idéia de testar com uma das extensões que não estavam funcionando, a Colorzilla, mas pude constatar que nada adiantou reinstalar tudo. Por uns instantes eu "coloquei a mão na cabeça"; pensei: como pode, um software que todo o mundo usa e elogia, na sua versão mais recente não estar funcionando com uma instalação limpa?! Só podia ter algo errado! Um detalhe...

Então eu pensei novamente: "uma instalação limpa..". Veio o estalo: vou procurar os instaladores fornecidos pela Mozilla, no site oficial do Firefox. Então eu me deparei com "Firefox da Mozilla vs. Firefox 'nativo'", e lá eu pude tomar conhecimento do Ubuntuzila, apesar de que o nome me lembrava algo... parecia até que eu já tinha usado esse tal Ubuntuzila em um passado um pouco distante.

Então agora eu cogitei a a idéia de usá-lo, com o comando "ubuntuzilla.py -a install -p firefox". Mas, para minha surpresa, descobri no sistema de pacotes um pacote que provia a mesmo build feito pelo Ubuntuzilla: firefox-mozilla-build. Pior: já estava instalado!

Agora sim, parece que foi uma iluminação. Eu conclui que deveria procurar os Firefox...

Código: [Selecionar]
alexandre$ whereis firefox
firefox: /usr/bin/firefox /usr/bin/firefox.ubuntu /etc/firefox /usr/lib/firefox /usr/local/firefox /usr/share/firefox

Na saída do whereis acima: firefox e firefox.ubuntu. Mas quem é quem? Eu executo sempre firefox e dar errado!

Código: [Selecionar]
alexandre$ ls -la /usr/bin/firefox*
lrwxrwxrwx 1 root root 20 2010-04-05 15:13 /usr/bin/firefox -> /opt/firefox/firefox
lrwxrwxrwx 1 root root 31 2010-04-14 01:55 /usr/bin/firefox.ubuntu -> ../lib/firefox-3.6.3/firefox.sh

O ls acima ajuda muito com esta questão. Pois investigando as propriedades dos pacotes firefox e firefox-mozilla-build (Ubuntuzilla), a lista dos arquivos que os pacotes instalam, os caminhos, eu pude concluir que a versão instalada em /opt/firefox é a versão empacotada pelo Projeto Ubuntuzila. Ou seja: o comando firefox estava executando um Firefox empacotado pelo Ubuntuzilla, a partir dos fontes originais da Mozilla Foundation; e o comando firefox.ubuntu, que testei em seguida, com sucesso, executaria o Firefox empacotado pela Canonical, que provavelmente tem uma integração melhor com o resto do sistema Ubuntu. O código fonte do Firefox é alterado pela Canonical.

Para confirmar, eu apaguei as configurações de usuário mais uma vez e testei o firefox.ubuntu:

Código: [Selecionar]
alexandre$ rm -rf .mozilla
alexandre$ firefox.ubuntu

(firefox-bin:7125): GLib-WARNING **: g_set_prgname() called multiple times

(firefox-bin:7125): GLib-WARNING **: g_set_prgname() called multiple times

(firefox-bin:7125): GLib-WARNING **: g_set_prgname() called multiple times

Então eu desinstalei o pacote firefox-mozilla-build, usando o Synaptic. Ele já se encarregou de ajeitar os links:

Código: [Selecionar]
alexandre$ ls -la /usr/bin/firefox*
lrwxrwxrwx 1 root root 31 2010-04-14 01:55 /usr/bin/firefox -> ../lib/firefox-3.6.3/firefox.sh

Agora o comando firefox reamente executado o Firefox empacotado pela Canonical, que é o build está OK para o Ubuntu e as extensões!

Usando ele, quando eu iniciei o Firefox pela primeira vez ele mostrou uma três linhas WARNING. Então eu instalei a extensão Colozilla e o Firefox foi reiniciado, imprimindo mais duas linhas WARNING.

Código: [Selecionar]
alexandre$ firefox

(firefox-bin:7406): GLib-WARNING **: g_set_prgname() called multiple times

(firefox-bin:7406): GLib-WARNING **: g_set_prgname() called multiple times

(firefox-bin:7406): GLib-WARNING **: g_set_prgname() called multiple times

(firefox-bin:7406): GLib-WARNING **: g_set_prgname() called multiple times

(firefox-bin:7406): GLib-WARNING **: g_set_prgname() called multiple times

Então eu fechei o Firefox e o abri novamente, para testar:

Código: [Selecionar]
alexandre$ firefox

(firefox-bin:7484): GLib-WARNING **: g_set_prgname() called multiple times

Mais uma vez fechei o Firefox e o abri novamente, para testar:

Código: [Selecionar]
alexandre$ firefox

(firefox-bin:7516): GLib-WARNING **: g_set_prgname() called multiple times

Conclusão: problema resolvido!

Edição de 14 de abril de 2010, às 05:14 h

Os pacotes para o Firefox da Canonical são estes:

  • firefox
  • firefox-branding
  • firefox-gnome-support
« Última modificação: 14 de Abril de 2010, 17:22 por alexandre.mbm@gmail.com »

Offline solrafa

  • Usuário Ubuntu
  • *
  • Mensagens: 26
    • Ver perfil
Re: Firefox 3.6.2 não abre no ubuntu
« Resposta #4 Online: 20 de Junho de 2010, 11:15 »
Valeu pela ajuda!

Depois de instalar os complementos de tradução (google tradutor e IM translator)

o Firefox parou de funcionar.

Segui seu tutorial só na parte de remover o firefox-build

E tudo ficou ok!