Autor Tópico: Tutorial para HSP56 MR driver Smartlink  (Lida 953588 vezes)

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1110 Online: 22 de Julho de 2009, 12:45 »
olá alrcon!
quero dizer q baixei seu pacote para instalação deste modem para meu linux 9.04 e segui todos os procedimentos. só q ao tentar instalar o pacote "slmodem" dentro desta pasta com o comando "make" acontece isto:
rockmarcus@rockmarcus-desktop:~/slmodem-2.9.11-20090222$ make
make -C modem all
make[1]: Entrando no diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make[1]: *** Sem regra para processar o alvo `all'.  Pare.
make[1]: Saindo do diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make: ** [modem] Erro 2
rockmarcus@rockmarcus-desktop:~/slmodem-2.9.11-20090222$ sudo make install
[sudo] password for rockmarcus:
make -C modem all
make[1]: Entrando no diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make[1]: *** Sem regra para processar o alvo `all'.  Pare.
make[1]: Saindo do diretório `/home/rockmarcus/slmodem-2.9.11-20090222/modem'
make: ** [modem] Erro 2
rockmarcus@rockmarcus-desktop:~/slmodem-2.9.11-20090222$
obtive também esta resposta ao tentar outro procedimento:
rockmarcus@rockmarcus-desktop:~$ sudo ps -aux | grep slmodemd
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
1000      3877  0.0  0.1   3352   812 pts/0    S+   22:05   0:00 grep slmodemd
espero q vc possa me ajudar.
desde já obrigado.

Não me pareceu que você realmente usou o meu pacote modem-arquivos-v30.tar.gz para tentar ativar o seu modem e sim tentou fazer a ativação do modem manualmente baixando o driver smartlink slmodem-2.9.11-20090222.tar.gz, portanto se explique melhor.

Instalando o pacote modem-arquivos-v30.tar.gz que vc baixa deste link aqui:

http://ubuntuforum-br.org/index.php/topic,4204.msg287645.html#msg287645

bastaria seguir a risca o que é falado no link acima (principalmente na parte do alerta) e nos arquivos Leia-me e guia_instalação.pdf (presentes no pacote modem-arquivos-v30.tar.gz), sendo necessário somente mais isso aqui:

abrir um terminal (menu Aplicativos > Acessórios > Terminal) e digitar esses dois comandos:

sudo chmod a+x /usr/sbin/pppd

sudo gpasswd -a rockmarcus dip


depois reinicia o PC para que as alterações dos comandos acima tenham efeito.

Seu erro na tentativa manual muito provavelmente é por que não tem instalado aí uns pacotes .deb necessários a compilação do driver, tais como:

- make
- gcc
- build-essential
- linux-headers-2.6.28-11-generic
- libasound2-dev

Também, antes de instalar o driver smartlink, é necessário instalar o driver ungrab-winmodem. Isso se vc está tentando fazer de forma manual, caso use o meu pacote ele já faz tudo isso.

O meu pacote é feito paar usar no Ubuntu 9.04 versão 32bits e não 64bits ok.

Se o que deseja é fazer tudo de maneira manual, então veja tópicos como esse aqui:

http://ubuntuforum-br.org/index.php/topic,49609.msg288360.html#msg288360
« Última modificação: 22 de Julho de 2009, 12:51 por alarcon »

Offline Júlio

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1111 Online: 23 de Julho de 2009, 03:49 »
Estou com o Linux Mint 7 (Kernel 2.6.28-11-generic) que é baseado no Ubuntu 9.04. Não consegui instalar o pacote 9.04, retornou a mensagem "Sinto muito mas seu softmodem não suporta o driver da Smartlink :'(...", porém consegui instalar o pacote da versão anterior do Ubuntu (8), mas quando eu mando conectar aparece "Conectando" e para nisso... ja segui algumas dicas do tutorial em PDF:


sudo gnome-ppp&

sudo /etc/init.d/sl-modem-daemon restart

sudo route add default ppp0


mas nenhuma funcionou. To meio perdido, não sei mais o que fazer, alguém tem alguma dica? Meu modem é o SM56 da Motorola.
« Última modificação: 23 de Julho de 2009, 03:55 por Júlio »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1112 Online: 23 de Julho de 2009, 09:45 »
Estou com o Linux Mint 7 (Kernel 2.6.28-11-generic) que é baseado no Ubuntu 9.04. Não consegui instalar o pacote 9.04, retornou a mensagem "Sinto muito mas seu softmodem não suporta o driver da Smartlink :'(...", porém consegui instalar o pacote da versão anterior do Ubuntu (8), mas quando eu mando conectar aparece "Conectando" e para nisso... ja segui algumas dicas do tutorial em PDF:


sudo gnome-ppp&

sudo /etc/init.d/sl-modem-daemon restart

sudo route add default ppp0


mas nenhuma funcionou. To meio perdido, não sei mais o que fazer, alguém tem alguma dica? Meu modem é o SM56 da Motorola.

Isso do "Sinto muito mas seu softmodem não suporta o driver da Smartlink Chorar..." ocorre pelo meu script instalador ou é uma informação do Mint?

pergunto isso por que nesta última versão do meu pacote, eu coloquei algo para evitar de quem usar outros tipos de modem, por exemplo um Conexant, não ficassem tentando instalar a toa o meu pacote, percebi que muitos vinham fazendo isso, mas se vc diz que o seu modem é um motorola sm56, não era para acontecer isso pois a ID dele está lá, portnto, me forneça o resultado dos comandos:

lspci

e

lspci -n

Para eu checar qual é realmente o seu modem e a ID dele.

Offline _ZERO_CALL_

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1113 Online: 23 de Julho de 2009, 15:58 »
Salve galera, o topico eh bem extenso e não consegui ler tudo mais consegui pegar bastante coisa... Sou iniciante em Linux e gostaria de uma ajuda aih...

Tenho um ADM 64 e instalei esse o Ubuntu 9.04 (Acredito que seja automatico neh?! O SO 32 ou 64 eh instalado de acordo com meu processador). Meu modem é um SmartLink e junto com ele veio um driver (CD) que diz ser para o Debian (logo imaginei que naum teria problemas para instalar).

Bom, como eu vi que tinha que instalar o Gnome-ppp eu optei por instalar o modem-arquivos-v22.tar.gz. Toda instalação foi sussa, soh no final de deu uma mensagem pra setar o modem como default pois a placa de rede estava ativa.
Aih eu fui tentar usar o Gnome-ppp, ele abre mais quando eu clico em conectar ele faz como se estive discando mais naum disca nada... fica ali eternamente até eu cancelar...   :'(

Bom, será isso por causa do naum suporte à 64bits?
Se precisarem de mais alguma informação me deem um toke que eu executo a noite e posto aki, estou no trampo agora...

Desde jah obrigado.
§§§ _ZERO_CALL_ §§§

"O inteligente conserta, o sábio previne!".

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1114 Online: 23 de Julho de 2009, 17:01 »
Salve galera, o topico eh bem extenso e não consegui ler tudo mais consegui pegar bastante coisa... Sou iniciante em Linux e gostaria de uma ajuda aih...

Tenho um ADM 64 e instalei esse o Ubuntu 9.04 (Acredito que seja automatico neh?! O SO 32 ou 64 eh instalado de acordo com meu processador). Meu modem é um SmartLink e junto com ele veio um driver (CD) que diz ser para o Debian (logo imaginei que naum teria problemas para instalar).

Bom, como eu vi que tinha que instalar o Gnome-ppp eu optei por instalar o modem-arquivos-v22.tar.gz. Toda instalação foi sussa, soh no final de deu uma mensagem pra setar o modem como default pois a placa de rede estava ativa.
Aih eu fui tentar usar o Gnome-ppp, ele abre mais quando eu clico em conectar ele faz como se estive discando mais naum disca nada... fica ali eternamente até eu cancelar...   :'(

Bom, será isso por causa do naum suporte à 64bits?
Se precisarem de mais alguma informação me deem um toke que eu executo a noite e posto aki, estou no trampo agora...

Desde jah obrigado.

Primeira coisa, meus pacotes (modem-arquivos-v?.tar.gz) só funcionam para a versão 32bits do Ubuntu, portanto para saber se sua versão do Ubuntu é 32bits ou não, abra um terminal (menu Aplicativos > Acessórios > Terminal) e digite:

uname -m

se der como resposta isso:

i686

então sua versão é 32bits, caso contrário será 64bits.


Segunda observação, para cada versão do Ubuntu 32bits, há um determinado pacote que faço especificamente para ele e vc pode obter o link adequado deste link aqui:

http://ubuntuforum-br.org/index.php/topic,4204.0.html

portanto o que vc usou (modem-arquivos-v22.tar.gz) não é adequando para a versão do Ubuntu que vc afirma usar (Ubuntu 9.04). Para ele o correto seria o modem-arquivos-v30.tar.gz que vc encontra o link no link anterior.

Terceira e última observação é a de que vc tem de ter certeza que seu modem é um do tipo que seja suportado pelo driver Smartlink. O nome não é uma informação muito confiável por que nem sempre condiz com a verdade. O melhor método seria pela ID do modem que vc pode saber, de uma forma simples, pelos comandos (no terminal):

lspci

e

lspci -n

portanto cole aqui o resultado dos comandos acima.


PS: Você tem que baixar ou uma versão 32bits do Ubuntu ou uma versão 64bits, não existe isso de baixar um Ubuntu e ele identificar se vai ser 32bits ou 64bits a instalação, ok. Agora vc pode sim usar uma versão 32bits num computador 64bits, a recíproca é que não é verdadeira.
« Última modificação: 23 de Julho de 2009, 17:06 por alarcon »

Offline _ZERO_CALL_

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1115 Online: 23 de Julho de 2009, 17:37 »
Salve galera, o topico eh bem extenso e não consegui ler tudo mais consegui pegar bastante coisa... Sou iniciante em Linux e gostaria de uma ajuda aih...

Tenho um ADM 64 e instalei esse o Ubuntu 9.04 (Acredito que seja automatico neh?! O SO 32 ou 64 eh instalado de acordo com meu processador). Meu modem é um SmartLink e junto com ele veio um driver (CD) que diz ser para o Debian (logo imaginei que naum teria problemas para instalar).

Bom, como eu vi que tinha que instalar o Gnome-ppp eu optei por instalar o modem-arquivos-v22.tar.gz. Toda instalação foi sussa, soh no final de deu uma mensagem pra setar o modem como default pois a placa de rede estava ativa.
Aih eu fui tentar usar o Gnome-ppp, ele abre mais quando eu clico em conectar ele faz como se estive discando mais naum disca nada... fica ali eternamente até eu cancelar...   :'(

Bom, será isso por causa do naum suporte à 64bits?
Se precisarem de mais alguma informação me deem um toke que eu executo a noite e posto aki, estou no trampo agora...

Desde jah obrigado.

Primeira coisa, meus pacotes (modem-arquivos-v?.tar.gz) só funcionam para a versão 32bits do Ubuntu, portanto para saber se sua versão do Ubuntu é 32bits ou não, abra um terminal (menu Aplicativos > Acessórios > Terminal) e digite:

uname -m

se der como resposta isso:

i686

então sua versão é 32bits, caso contrário será 64bits.


Segunda observação, para cada versão do Ubuntu 32bits, há um determinado pacote que faço especificamente para ele e vc pode obter o link adequado deste link aqui:

http://ubuntuforum-br.org/index.php/topic,4204.0.html

portanto o que vc usou (modem-arquivos-v22.tar.gz) não é adequando para a versão do Ubuntu que vc afirma usar (Ubuntu 9.04). Para ele o correto seria o modem-arquivos-v30.tar.gz que vc encontra o link no link anterior.

Terceira e última observação é a de que vc tem de ter certeza que seu modem é um do tipo que seja suportado pelo driver Smartlink. O nome não é uma informação muito confiável por que nem sempre condiz com a verdade. O melhor método seria pela ID do modem que vc pode saber, de uma forma simples, pelos comandos (no terminal):

lspci

e

lspci -n

portanto cole aqui o resultado dos comandos acima.


PS: Você tem que baixar ou uma versão 32bits do Ubuntu ou uma versão 64bits, não existe isso de baixar um Ubuntu e ele identificar se vai ser 32bits ou 64bits a instalação, ok. Agora vc pode sim usar uma versão 32bits num computador 64bits, a recíproca é que não é verdadeira.



OK Alarcon, realmente eu viajei feio... baixei o pacote errado...

A instalação do meu Ubuntu foi feita através de um Live CD que me foi enviado direto dos USA, por isso naum sei se eh 32 ou 64bits, tenho certeza que é 9.04 pois está escrito na capa do CD...rsrs... mais como esse esclarecimento seu agora, acredito que seja 32bits... vou conferir ao chegar em casa e posto pra vcs aki assim como o resultado do lspci e lspci -n.

Eu já baixei a versão correta que vc me passou (modem-arquivos-v30.tar.gz) e vou tentar instalar também, assim que conferir os passos acima...mais fikei com uma duvida. Preciso desinstalar o modem-arquivos-v22.tar.gz antes de instalar a nova versão???? Como eu faço isso???

Desde já obrigado.
§§§ _ZERO_CALL_ §§§

"O inteligente conserta, o sábio previne!".

Offline Júlio

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1116 Online: 23 de Julho de 2009, 19:04 »
Estou com o Linux Mint 7 (Kernel 2.6.28-11-generic) que é baseado no Ubuntu 9.04. Não consegui instalar o pacote 9.04, retornou a mensagem "Sinto muito mas seu softmodem não suporta o driver da Smartlink :'(...", porém consegui instalar o pacote da versão anterior do Ubuntu (8), mas quando eu mando conectar aparece "Conectando" e para nisso... ja segui algumas dicas do tutorial em PDF:


sudo gnome-ppp&

sudo /etc/init.d/sl-modem-daemon restart

sudo route add default ppp0


mas nenhuma funcionou. To meio perdido, não sei mais o que fazer, alguém tem alguma dica? Meu modem é o SM56 da Motorola.

Isso do "Sinto muito mas seu softmodem não suporta o driver da Smartlink Chorar..." ocorre pelo meu script instalador ou é uma informação do Mint?

pergunto isso por que nesta última versão do meu pacote, eu coloquei algo para evitar de quem usar outros tipos de modem, por exemplo um Conexant, não ficassem tentando instalar a toa o meu pacote, percebi que muitos vinham fazendo isso, mas se vc diz que o seu modem é um motorola sm56, não era para acontecer isso pois a ID dele está lá, portnto, me forneça o resultado dos comandos:

lspci

e

lspci -n

Para eu checar qual é realmente o seu modem e a ID dele.

Alarcom, eis os resultados dos comandos solicitados:

lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. CN896/VN896/P4M900 I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Security Device
00:00.7 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:02.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80)
00:03.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)
05:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
06:04.0 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller
06:04.1 SD Host controller: ENE Technology Inc ENE PCI SmartMedia / xD Card Reader Controller
06:04.3 FLASH memory: ENE Technology Inc ENE PCI Secure Digital / MMC Card Reader Controller



lspci -n
00:00.0 0600: 1106:0364
00:00.1 0600: 1106:1364
00:00.2 0600: 1106:2364
00:00.3 0600: 1106:3364
00:00.4 0600: 1106:4364
00:00.5 0800: 1106:5364
00:00.6 0600: 1106:6364
00:00.7 0600: 1106:7364
00:01.0 0604: 1106:b198
00:02.0 0604: 1106:a364 (rev 80)
00:03.0 0604: 1106:c364 (rev 80)
00:0f.0 0101: 1106:0591 (rev 80)
00:0f.1 0101: 1106:0571 (rev 07)
00:10.0 0c03: 1106:3038 (rev a0)
00:10.1 0c03: 1106:3038 (rev a0)
00:10.2 0c03: 1106:3038 (rev a0)
00:10.3 0c03: 1106:3038 (rev a0)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3337
00:11.7 0600: 1106:287e
00:12.0 0200: 1106:3065 (rev 7c)
00:13.0 0604: 1106:337b
00:13.1 0604: 1106:337a
01:00.0 0300: 1106:3371 (rev 01)
05:01.0 0403: 1106:3288 (rev 10)
06:04.0 0501: 1524:0730
06:04.1 0805: 1524:0750
06:04.3 0501: 1524:0751

Offline _ZERO_CALL_

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1117 Online: 24 de Julho de 2009, 00:22 »
Boa noite Alarcon, depois de ler o que vc escreveu eu procurei saber melhor e meu ubuntu é 32bits mesmo (ufaaaa...rs)

Eu instalei o pacote correto e fikei feliz com o primeiro resultado, o modem pelo menos discou... porém não fechou a conexão, então eu peguei o log do erro e salvei.... depois disso eu reiniciei o meu micro e quando fui tentar conectar de novo aconteceu um problema, recebi a mensagem de modem naum encontrado...
Abaixou vou postar o log de conexão de quando o modem discou e o resultado dos comandos lspci e lspci -n. Veja se vc pode me ajudar em mais alguma coisa...


--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT31289315
--> Waiting for carrier.
ATM1L1DT31289315
CONNECT 28800
--> Carrier detected.  Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
UQKT2 23.3
Login:
--> Timed out while dialing.  Trying again.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Thu Jul 23 23:25:45 2009



root@tomezinho-desktop:/# uname -m
i686



root@tomezinho-desktop:/# lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Modem: Smart Link Ltd. SmartPCI2800 V.92 PCI Soft DFT (rev 02)
02:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)



root@tomezinho-desktop:/# lspci -n
00:00.0 0500: 10de:03ea (rev a1)
00:01.0 0601: 10de:03e0 (rev a2)
00:01.1 0c05: 10de:03eb (rev a2)
00:01.2 0500: 10de:03f5 (rev a2)
00:02.0 0c03: 10de:03f1 (rev a2)
00:02.1 0c03: 10de:03f2 (rev a2)
00:04.0 0604: 10de:03f3 (rev a1)
00:05.0 0403: 10de:03f0 (rev a2)
00:06.0 0101: 10de:03ec (rev a2)
00:07.0 0680: 10de:03ef (rev a2)
00:08.0 0101: 10de:03f6 (rev a2)
00:09.0 0604: 10de:03e8 (rev a2)
00:0b.0 0604: 10de:03e9 (rev a2)
00:0c.0 0604: 10de:03e9 (rev a2)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
01:06.0 0703: 2000:2800 (rev 02)
02:00.0 0300: 10de:0392 (rev a1)

« Última modificação: 24 de Julho de 2009, 09:27 por _ZERO_CALL_ »
§§§ _ZERO_CALL_ §§§

"O inteligente conserta, o sábio previne!".

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1118 Online: 24 de Julho de 2009, 09:38 »
Boa noite Alarcon, depois de ler seu email eu procurei saber melhor e meu ubuntu é 32bits mesmo (ufaaaa...rs)

Eu instalei o pacote correto e fikei feliz com o primeiro resultado, o modem pelo menos discou... porém não fechou a conexão, então eu peguei o log do erro e salvei.... depois disso eu reiniciei o meu micro e quando fui tentar conectar de novo aconteceu um problema, recebi a mensagem de modem naum encontrado...
Abaixou vou postar o log de conexão de quando o modem discou e o resultado dos comandos lspci e lspci -n. Veja se vc pode me ajudar em mais alguma coisa...


--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT31289315
--> Waiting for carrier.
ATM1L1DT31289315
CONNECT 28800
--> Carrier detected.  Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
UQKT2 23.3
Login:
--> Timed out while dialing.  Trying again.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Thu Jul 23 23:25:45 2009



root@tomezinho-desktop:/# uname -m
i686



root@tomezinho-desktop:/# lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Modem: Smart Link Ltd. SmartPCI2800 V.92 PCI Soft DFT (rev 02)
02:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)



root@tomezinho-desktop:/# lspci -n
00:00.0 0500: 10de:03ea (rev a1)
00:01.0 0601: 10de:03e0 (rev a2)
00:01.1 0c05: 10de:03eb (rev a2)
00:01.2 0500: 10de:03f5 (rev a2)
00:02.0 0c03: 10de:03f1 (rev a2)
00:02.1 0c03: 10de:03f2 (rev a2)
00:04.0 0604: 10de:03f3 (rev a1)
00:05.0 0403: 10de:03f0 (rev a2)
00:06.0 0101: 10de:03ec (rev a2)
00:07.0 0680: 10de:03ef (rev a2)
00:08.0 0101: 10de:03f6 (rev a2)
00:09.0 0604: 10de:03e8 (rev a2)
00:0b.0 0604: 10de:03e9 (rev a2)
00:0c.0 0604: 10de:03e9 (rev a2)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
01:06.0 0703: 2000:2800 (rev 02)
02:00.0 0300: 10de:0392 (rev a1)




abrir um terminal (menu Aplicativos > Acessórios > Terminal) e digitar esses dois comandos:

sudo chmod a+x /usr/sbin/pppd

sudo gpasswd -a seu_usuário dip


onde o que destaquei em vermelho, mude para exatamente o nome que vc digita para entrar no ubuntu, ou seja, seu nome de login.

Olha só percebo que vc sempre está logado como root, não é preciso isso, pois quando for preciso estar como root, nos comandos que eu passo, eu coloco a palavra sudo na frente, então ele vai pedir uma senha e rodar como root, mas se vc preferir continuar como root (comando sudo su), então todos os comandos que eu passar aqui que tiverem a palavra sudo na frente, vc retira, caso já esteja no terminal como root ok.

Ainda no terminal faça isso aqui:

sudo gedit /etc/init.d/ativar-modem

e no arquivo vazio que abrir coloque exatamente este conteúdo aqui:

Citar
#!/bin/sh

dispositivo=`ls /dev | grep slamr0`

if [ "${dispositivo}" = "slamr0" ]; then

/etc/init.d/sl-modem-daemon stop
modprobe -r ungrab-winmodem
modprobe -r slamr
sleep 2
modprobe ungrab-winmodem
modprobe slamr
/etc/init.d/sl-modem-daemon restart

else

/etc/init.d/sl-modem-daemon stop
modprobe -r ungrab-winmodem
modprobe -r slamr
mknod -m 600 /dev/slamr0 c 242 0
sleep 2
modprobe ungrab-winmodem
modprobe slamr
/etc/init.d/sl-modem-daemon restart

fi

não esqueça de nenhuma linha, se pudesse copiar e colar seria melhor.

e depois ainda no terminal mais isso aqui:

sudo chmod +x /etc/init.d/ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc2.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc3.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc4.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc5.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc6.d/S98ativar-modem



Ainda no terminal digite:

sudo gedit /etc/default/sl-modem-daemon

no arquivo que abrir troque a linha:

SLMODEMD_DEVICE=auto

por:

SLMODEMD_DEVICE=slamr0

troque a linha:

SLMODEMD_COUNTRY=USA

ou a linha:

SLMODEMD_COUNTRY=PORTUGAL

por:

SLMODEMD_COUNTRY=BRAZIL

e por fim troque a linha:

OPTS=""

por

OPTS="--perm=0666"

salve e saia do arquivo.


E reinicie o seu PC de maneira completa e só depois tente usar o discador no menu Aplicativos > Internet > GNOME PPP.

PS: alguns modems precisam que a opção verificar portadora na aba Opções das configurações do discador gnome-ppp fique desmarcada e ela está marcada pela instalação do meu pacote, então tente das duas formas a conexão, ou seja, com a opção verificar portadora marcada e caso não funcione com a opção desmarcada, ok.
« Última modificação: 24 de Julho de 2009, 09:39 por alarcon »

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1119 Online: 24 de Julho de 2009, 09:49 »

Alarcom, eis os resultados dos comandos solicitados:

lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. CN896/VN896/P4M900 I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Security Device
00:00.7 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:02.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80)
00:03.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)
05:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
06:04.0 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller
06:04.1 SD Host controller: ENE Technology Inc ENE PCI SmartMedia / xD Card Reader Controller
06:04.3 FLASH memory: ENE Technology Inc ENE PCI Secure Digital / MMC Card Reader Controller



lspci -n
00:00.0 0600: 1106:0364
00:00.1 0600: 1106:1364
00:00.2 0600: 1106:2364
00:00.3 0600: 1106:3364
00:00.4 0600: 1106:4364
00:00.5 0800: 1106:5364
00:00.6 0600: 1106:6364
00:00.7 0600: 1106:7364
00:01.0 0604: 1106:b198
00:02.0 0604: 1106:a364 (rev 80)
00:03.0 0604: 1106:c364 (rev 80)
00:0f.0 0101: 1106:0591 (rev 80)
00:0f.1 0101: 1106:0571 (rev 07)
00:10.0 0c03: 1106:3038 (rev a0)
00:10.1 0c03: 1106:3038 (rev a0)
00:10.2 0c03: 1106:3038 (rev a0)
00:10.3 0c03: 1106:3038 (rev a0)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3337
00:11.7 0600: 1106:287e
00:12.0 0200: 1106:3065 (rev 7c)
00:13.0 0604: 1106:337b
00:13.1 0604: 1106:337a
01:00.0 0300: 1106:3371 (rev 01)
05:01.0 0403: 1106:3288 (rev 10)
06:04.0 0501: 1524:0730
06:04.1 0805: 1524:0750
06:04.3 0501: 1524:0751

Como já estava suspeitando, seu modem não é um motorola sm56 e por isso deu aquela mensagem. O que vc tem aí é uma placa de som especial que faz o papel de modem, veja:

modem HDA (na verdade audio):
05:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
ID 1106:3288

Como no meu script instalador não tem esta ID ele cancela a instalação.

Você vai ter de baixar e usar o script scanModem para ver o que ele indica como possível driver para ativar seu modem no linux e isso se existir algo.

Baixe o script daqui:

http://linmodems.technion.ac.il/packages/scanModem.gz

depois de baixado o arquivo compactado scanModem.gz leve-o ao ubuntu, coloque na sua pasta de usuário, clique nele com o botão direito do mouse e escolha a opção extrair aqui, depois abra um terminal (menu Aplicativos > Acessórios > Terminal) e digite:

chmod +x scanModem*

para dar permissão de execução e depois digite:

./scanModem*

para executá-lo, aguarde o processo terminar, depois vá na sua pasta de usuário que lá deve ter uma pasta chamada Modem com vários aruivos de texto com informações sobre o seu modem. VEja o conteúdo do arquivo ModemData.txt que é o que deve orientar para alguma solução, indicar que driver pode dar suporte a esse modem.



Offline Júlio

  • Usuário Ubuntu
  • *
  • Mensagens: 9
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1120 Online: 24 de Julho de 2009, 14:39 »

Alarcom, eis os resultados dos comandos solicitados:

lspci
00:00.0 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. CN896/VN896/P4M900 I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Security Device
00:00.7 Host bridge: VIA Technologies, Inc. CN896/VN896/P4M900 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237/VX700 PCI Bridge
00:02.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80)
00:03.0 PCI bridge: VIA Technologies, Inc. CN896/VN896/P4M900 PCI to PCI Bridge Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] (rev 01)
05:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
06:04.0 FLASH memory: ENE Technology Inc ENE PCI Memory Stick Card Reader Controller
06:04.1 SD Host controller: ENE Technology Inc ENE PCI SmartMedia / xD Card Reader Controller
06:04.3 FLASH memory: ENE Technology Inc ENE PCI Secure Digital / MMC Card Reader Controller



lspci -n
00:00.0 0600: 1106:0364
00:00.1 0600: 1106:1364
00:00.2 0600: 1106:2364
00:00.3 0600: 1106:3364
00:00.4 0600: 1106:4364
00:00.5 0800: 1106:5364
00:00.6 0600: 1106:6364
00:00.7 0600: 1106:7364
00:01.0 0604: 1106:b198
00:02.0 0604: 1106:a364 (rev 80)
00:03.0 0604: 1106:c364 (rev 80)
00:0f.0 0101: 1106:0591 (rev 80)
00:0f.1 0101: 1106:0571 (rev 07)
00:10.0 0c03: 1106:3038 (rev a0)
00:10.1 0c03: 1106:3038 (rev a0)
00:10.2 0c03: 1106:3038 (rev a0)
00:10.3 0c03: 1106:3038 (rev a0)
00:10.4 0c03: 1106:3104 (rev 86)
00:11.0 0601: 1106:3337
00:11.7 0600: 1106:287e
00:12.0 0200: 1106:3065 (rev 7c)
00:13.0 0604: 1106:337b
00:13.1 0604: 1106:337a
01:00.0 0300: 1106:3371 (rev 01)
05:01.0 0403: 1106:3288 (rev 10)
06:04.0 0501: 1524:0730
06:04.1 0805: 1524:0750
06:04.3 0501: 1524:0751

Como já estava suspeitando, seu modem não é um motorola sm56 e por isso deu aquela mensagem. O que vc tem aí é uma placa de som especial que faz o papel de modem, veja:

modem HDA (na verdade audio):
05:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)
ID 1106:3288

Como no meu script instalador não tem esta ID ele cancela a instalação.

Você vai ter de baixar e usar o script scanModem para ver o que ele indica como possível driver para ativar seu modem no linux e isso se existir algo.

Baixe o script daqui:

http://linmodems.technion.ac.il/packages/scanModem.gz

depois de baixado o arquivo compactado scanModem.gz leve-o ao ubuntu, coloque na sua pasta de usuário, clique nele com o botão direito do mouse e escolha a opção extrair aqui, depois abra um terminal (menu Aplicativos > Acessórios > Terminal) e digite:

chmod +x scanModem*

para dar permissão de execução e depois digite:

./scanModem*

para executá-lo, aguarde o processo terminar, depois vá na sua pasta de usuário que lá deve ter uma pasta chamada Modem com vários aruivos de texto com informações sobre o seu modem. VEja o conteúdo do arquivo ModemData.txt que é o que deve orientar para alguma solução, indicar que driver pode dar suporte a esse modem.




Alarcon, fiz o recomendado, li o arquivo gerado porém não soube interpertálo...

 Only plain text email is forwarded by the  Discuss@Linmodems.org List Server,
 as HTML can contain viruses. Use as the email Subject Line:
           YourName, YourCountry Linux Mint 7 Gloria - Main Edition  kernel 2.6.28-11-generic
 With this Subject Line cogent experts will be alerted, and useful case names left in the Archive.
 YourCountry will enable Country specific guidance. Linux experts in YourCountry
 can be found through: http://www.linux.org/groups/index.html.
They will know your Country's modem code, which may be essential for dialup service.
Responses from Discuss@Linmodems.org are sometimes blocked by an Internet Provider mail filters.
 So in a day, also check the Archived responses at http://www.linmodems.org
--------------------------  System information ----------------------------
CPU=i686,  Linux Mint 7 Gloria - Main Edition
Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
 scanModem update of:  2009_07_17
The modem symbolic link is /dev/modem -> ttySL0
The dialer utility package WVDIAL does not appear to be installed on your System.
Please read Modem/DOCs/wvdial.txt

 There are no blacklisted modem drivers in /etc/modprobe*  files
 Potentially useful modem drivers now loaded are:
       slamr  snd_hda_intel       

slamrTest=
Attached USB devices are:
 ID 0402:5606 ALi Corp.
 ID 046d:c315 Logitech, Inc. Classic New Touch Keyboard
 ID 15d9:0a33 
 ID 05e3:0606 Genesys Logic, Inc. USB 2.0 Hub / D-Link DUB-H4 USB 2.0 Hub
 ID 0951:1603 Kingston Technology Data Traveler 1GB/2GB Pen Drive
If a cellphone is not detected, see http://ubuntuforums.org/archive/index.php/t-878554.html
A sample report is:  http://linmodems.technion.ac.il/bigarch/archive-nineth/msg00578.html

If a USB modem or cellphone is attached and was not detected, please
provide available information in your request to discuss@linmodems.org

For candidate card in slot 05:01.0, firmware information and bootup diagnostics are:
 PCI slot   PCI ID      SubsystemID   Name
 ----------   ---------   ---------   --------------
 05:01.0   1106:3288   1106:3288   Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC]

 Modem interrupt assignment and sharing:
 17:       3288          0   IO-APIC-fasteoi   mmc0, mmc1, HDA Intel
 --- Bootup diagnostics for card in PCI slot 05:01.0 ----
[    0.610537] pci 0000:05:01.0: reg 10 64bit mmio: [0xfa000000-0xfa003fff]
[    0.610580] pci 0000:05:01.0: PME# supported from D0 D3hot D3cold
[    0.610586] pci 0000:05:01.0: PME# disabled
[    9.854763] HDA Intel 0000:05:01.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    9.854869] HDA Intel 0000:05:01.0: setting latency timer to 64
[    9.854875] HDA Intel 0000:05:01.0: PCI: Disallowing DAC for device

 The PCI slot 05:01.0 of the modem card may be disabled early in
 a bootup process,  but then enabled later. If modem drivers load
 but the  modem is not responsive, read DOCs/Bootup.txt about possible fixes.
 Send dmesg.txt along with ModemData.txt to discuss@linmodems.org
 if help is needed.
 


===== Advanced Linux Sound Architecture (ALSA) diagnostics =====
The ALSA packages provide audio support and also drivers for some modems.
ALSA diagnostics are written during bootup to /proc/asound/ folders.

The ALSA verion is 1.0.18
The modem cards detected by "aplay -l"  are:
card 0: VT82xx [HDA VIA VT82xx], device 6: Si3054 Modem [Si3054 Modem]

The /proc/asound/pcm file reports:
-----------------------
00-00: VT1708 Analog : VT1708 Analog : playback 1 : capture 2
00-01: VT1708 Digital : VT1708 Digital : playback 1
00-06: Si3054 Modem : Si3054 Modem : playback 1 : capture 1

about /proc/asound/cards:
------------------------
 0 [VT82xx         ]: HDA-Intel - HDA VIA VT82xx
                      HDA VIA VT82xx at 0xfa000000 irq 17

 PCI slot 05:01.0 has a High Definition Audio Card
 The drivers are in the kernel modules tree at:
 /lib/modules/2.6.28-11-generic/kernel/sound/pci/hda/snd-hda-intel.ko
 The modem codec file for the HDA card is: /proc/asound/card0/codec#1
--------------------------------------------------------
Codec: Motorola Si3054
Address: 1
Vendor Id: 0x10573055
Subsystem Id: 0x10573055
Revision Id: 0x100700
Modem Function Group: 0x1

 The audio card hosts a softmodem chip:  0x10573055

The softmodem chip 0x10573055 is in principle supported by the COMM support of slmodemd
and the joint snd-hda-intel audio+modem driver, begun with ALSA version 1.0.13. 
For HDA cards with ALC883 chips, an upgrade to ALSA verions 1.0.15 way be necessary. Instructions for Upgrading snd-hda-intel and its dependent driver set are at:
http://linmodems.technion.ac.il/bigarch/archive-eighth/msg00838.html

If not a Conexant modem, the driver snd-hda-intel with its dependent drivers:
snd_hda_intel         435636  3
snd_pcm                82948  2 snd_hda_intel,snd_pcm_oss
snd                    62628  15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc         16904  2 snd_hda_intel,snd_pcm
----------
provide audio + modem support with the modem chip residing on the subsystem.
Any particular card can host any one of several soft modem chips.

=== Finished firmware and bootup diagnostics, next deducing cogent software. ===

Predictive  diagnostics for card in bus 05:01.0:
   Modem chipset  detected on
NAME="Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] "
CLASS=0403
PCIDEV=1106:3288
SUBSYS=1106:3288
IRQ=17
HDA=1106:3288
SOFT=1106:3288.HDA
HDAchipVendorID=1057
CHIP=0x10573055
IDENT=slmodemd
SLMODEMD_DEVICE=hw:0,6
Driver=snd-hda-intel

 For candidate modem in:  05:01.0
   0403 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC]
      Primary device ID:  1106:3288
    Subsystem PCI_id  1106:3288
    Softmodem codec or chipset from diagnostics: 0x10573055
                               from    Archives:
                        The HDA card softmodem chip is 0x10573055
     

Support type needed or chipset:   slmodemd supporting the snd-hda-intel audio+modem driver

 An ALSA (Advanced Linux Sound Architecture) modem driver:  snd-hda-intel
 provides Low Level support enabling contact with the modem hardware.
 For all BUT Conexant chip soft modems (using hsfmodem software)
 complementary High Level support is through a Smartlink utility:  slmodemd

 Download from http://linmodems.technion.ac.il/packages/smartlink/
 the package SLMODEMD.gcc4.3.tar.gz having a compiled slmodemd. Unpack under Linux with:
    $ tar zxf SLMODEMD.gcc4.3.tar.gz
 and read instructions therein. But briefly, the modem is setup with command:
     slmodemd -c YOUR_COUNTRY --alsa hw:0,6
 reporting dynamic creation of ports:
   /dev/ttySL0 --> /dev/pts/N   , with N some number
 Read DOCs/Smartlink.txt and Modem/DOCs/YourSystem.txt for follow through guidance.

Writing DOCs/Smartlink.txt
============ end Smartlink section =====================

 Completed candidate modem analyses.

 The base of the UDEV device file system is: /dev/.udev

 Versions adequately match for the compiler installed: 4.3.3
             and the compiler used in kernel assembly: 4.3.3

 The patch utility is needed and is needed for compiling ALSA drivers, and possibly others.

 
 Minimal compiling resources appear complete:
   make utility - /usr/bin/make
   Compiler version 4.3
   linuc_headers base folder /lib/modules/2.6.28-11-generic/build

 However some compilations and executable functions may need additional files,
 in the FileNames.h (so called kernel "h"eaders) collection installed in  /usr/include/ .
 For martian_modem, additional required packages are needed. The also required headers of package libc6 are commonly installed by default.
 Compiling hsfmodem drivers does require linux-libc-dev and libc6-dev packages, for kernels 2.6.24 and later versions.
 In not included on your install CD, search for them at http://packages.ubuntu.com
 or comparable Repository for other Linux distros.
 When compiling ALSA drivers, the utility "patch" will also be needed.



For Debian and some related distributions, a package kernel-kbuild-2.6-28 may be needed to support driver compiling.


If a driver compilation fails, with message including some lack of some FileName.h (stdio.h for example), then
Some additional kernel-header files need installation to /usr/include. The minimal additional packages are libc6-dev
and any of its dependents, under Ubuntu linux-libc-dev

If an alternate ethernet connection is available,
$  apt-get update
$  apt-get -s install linux-kernel-devel
will install needed packages.
For Debian/Ubuntu related distributions, run the following command to display the needed package list:

Otherwise packages have to be found through http://packages.ubuntu.com
Once downloaded and transferred into a Linux partition,
they can be installed alltogether with:
$ sudo dpkg -i *.deb

Checking settings of:   /etc/ppp/options
asyncmap 0
noauth
crtscts
lock
hide-password
modem
proxyarp
lcp-echo-interval 30
lcp-echo-failure 4
noipx

In case of a message like:
   Warning: Could not modify /etc/ppp/pap-secrets: Permission denied
see http://linmodems.technion.ac.il/bigarch/archive-sixth/msg04656.html

Read Modem/DOCs/YourSystem.txt concerning other COMM channels: eth0
Which can interfere with Browser naviagation.

 Don't worry about the following, it is for experts should trouble shooting be necessary.
==========================================================

# start/stop the daemon when the USB modem is connected
KERNEL=="slusb[0-9]*", GROUP="dialout", RUN+="/etc/init.d/sl-modem-daemon"
 Checking for modem support lines:
 --------------------------------------
     /device/modem symbolic link:   lrwxrwxrwx 1 root root 6 2009-07-24 13:17 /dev/modem -> ttySL0
slmodemd created symbolic link /dev/ttySL0: 
     Within /etc/udev/ files:
/etc/udev/rules.d/030_sl-modem-daemon.rules:# start/stop the daemon when the USB modem is connected
/etc/udev/rules.d/030_sl-modem-daemon.rules:KERNEL=="slusb[0-9]*", GROUP="dialout", RUN+="/etc/init.d/sl-modem-daemon"
/etc/udev/sl-modem-daemon.rules:# start/stop the daemon when the USB modem is connected
/etc/udev/sl-modem-daemon.rules:KERNEL=="slusb[0-9]*", GROUP="dialout", RUN+="/etc/init.d/sl-modem-daemon"
     Within /etc/modprobe.conf files:
/etc/modprobe.d/blacklist-modem.conf:# Uncomment these entries in order to blacklist unwanted modem drivers
/etc/modprobe.d/blacklist-modem.conf:# blacklist snd-atiixp-modem
/etc/modprobe.d/blacklist-modem.conf:# blacklist snd-via82xx-modem
/etc/modprobe.d/alsa-base.conf:options snd-atiixp-modem index=-2
/etc/modprobe.d/alsa-base.conf:options snd-via82xx-modem index=-2
/etc/modprobe.d/sl-modem-daemon.modutils:install slamr modprobe --ignore-install ungrab-winmodem ;  modprobe --ignore-install slamr; test -e /dev/slamr0 || (/bin/mknod -m 660 /dev/slamr0 c 242 0 2>/dev/null && chgrp dialout /dev/slamr0)
     Within any ancient /etc/devfs files:

     Within ancient kernel 2.4.n /etc/module.conf files:

--------- end modem support lines --------


Offline _ZERO_CALL_

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1121 Online: 24 de Julho de 2009, 16:30 »
Boa noite Alarcon, depois de ler seu email eu procurei saber melhor e meu ubuntu é 32bits mesmo (ufaaaa...rs)

Eu instalei o pacote correto e fikei feliz com o primeiro resultado, o modem pelo menos discou... porém não fechou a conexão, então eu peguei o log do erro e salvei.... depois disso eu reiniciei o meu micro e quando fui tentar conectar de novo aconteceu um problema, recebi a mensagem de modem naum encontrado...
Abaixou vou postar o log de conexão de quando o modem discou e o resultado dos comandos lspci e lspci -n. Veja se vc pode me ajudar em mais alguma coisa...


--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATM1L1DT31289315
--> Waiting for carrier.
ATM1L1DT31289315
CONNECT 28800
--> Carrier detected.  Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
UQKT2 23.3
Login:
--> Timed out while dialing.  Trying again.
--> Maximum Attempts Exceeded..Aborting!!
--> Disconnecting at Thu Jul 23 23:25:45 2009



root@tomezinho-desktop:/# uname -m
i686



root@tomezinho-desktop:/# lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Modem: Smart Link Ltd. SmartPCI2800 V.92 PCI Soft DFT (rev 02)
02:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GS] (rev a1)



root@tomezinho-desktop:/# lspci -n
00:00.0 0500: 10de:03ea (rev a1)
00:01.0 0601: 10de:03e0 (rev a2)
00:01.1 0c05: 10de:03eb (rev a2)
00:01.2 0500: 10de:03f5 (rev a2)
00:02.0 0c03: 10de:03f1 (rev a2)
00:02.1 0c03: 10de:03f2 (rev a2)
00:04.0 0604: 10de:03f3 (rev a1)
00:05.0 0403: 10de:03f0 (rev a2)
00:06.0 0101: 10de:03ec (rev a2)
00:07.0 0680: 10de:03ef (rev a2)
00:08.0 0101: 10de:03f6 (rev a2)
00:09.0 0604: 10de:03e8 (rev a2)
00:0b.0 0604: 10de:03e9 (rev a2)
00:0c.0 0604: 10de:03e9 (rev a2)
00:18.0 0600: 1022:1100
00:18.1 0600: 1022:1101
00:18.2 0600: 1022:1102
00:18.3 0600: 1022:1103
01:06.0 0703: 2000:2800 (rev 02)
02:00.0 0300: 10de:0392 (rev a1)




abrir um terminal (menu Aplicativos > Acessórios > Terminal) e digitar esses dois comandos:

sudo chmod a+x /usr/sbin/pppd

sudo gpasswd -a seu_usuário dip


onde o que destaquei em vermelho, mude para exatamente o nome que vc digita para entrar no ubuntu, ou seja, seu nome de login.

Olha só percebo que vc sempre está logado como root, não é preciso isso, pois quando for preciso estar como root, nos comandos que eu passo, eu coloco a palavra sudo na frente, então ele vai pedir uma senha e rodar como root, mas se vc preferir continuar como root (comando sudo su), então todos os comandos que eu passar aqui que tiverem a palavra sudo na frente, vc retira, caso já esteja no terminal como root ok.

Ainda no terminal faça isso aqui:

sudo gedit /etc/init.d/ativar-modem

e no arquivo vazio que abrir coloque exatamente este conteúdo aqui:

Citar
#!/bin/sh

dispositivo=`ls /dev | grep slamr0`

if [ "${dispositivo}" = "slamr0" ]; then

/etc/init.d/sl-modem-daemon stop
modprobe -r ungrab-winmodem
modprobe -r slamr
sleep 2
modprobe ungrab-winmodem
modprobe slamr
/etc/init.d/sl-modem-daemon restart

else

/etc/init.d/sl-modem-daemon stop
modprobe -r ungrab-winmodem
modprobe -r slamr
mknod -m 600 /dev/slamr0 c 242 0
sleep 2
modprobe ungrab-winmodem
modprobe slamr
/etc/init.d/sl-modem-daemon restart

fi

não esqueça de nenhuma linha, se pudesse copiar e colar seria melhor.

e depois ainda no terminal mais isso aqui:

sudo chmod +x /etc/init.d/ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc2.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc3.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc4.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc5.d/S98ativar-modem
sudo ln -sf /etc/init.d/ativar-modem /etc/rc6.d/S98ativar-modem



Ainda no terminal digite:

sudo gedit /etc/default/sl-modem-daemon

no arquivo que abrir troque a linha:

SLMODEMD_DEVICE=auto

por:

SLMODEMD_DEVICE=slamr0

troque a linha:

SLMODEMD_COUNTRY=USA

ou a linha:

SLMODEMD_COUNTRY=PORTUGAL

por:

SLMODEMD_COUNTRY=BRAZIL

e por fim troque a linha:

OPTS=""

por

OPTS="--perm=0666"

salve e saia do arquivo.


E reinicie o seu PC de maneira completa e só depois tente usar o discador no menu Aplicativos > Internet > GNOME PPP.

PS: alguns modems precisam que a opção verificar portadora na aba Opções das configurações do discador gnome-ppp fique desmarcada e ela está marcada pela instalação do meu pacote, então tente das duas formas a conexão, ou seja, com a opção verificar portadora marcada e caso não funcione com a opção desmarcada, ok.



Alarcon, eu fiz tudo que vc me pediu, na edição do arquivo /etc/default/sl-modem-daemon mudei pouca coisa, o pais já estava como BRAZIL e o OPTS já tinha o valor "--perm=0666".

Bom, após isso reiniciei o micro e tentei conectar... e novamente a mensagem de modem não encontrado  :'(... entrei no setup e verifiquei o modem, lá tem um /modem, /tfy0, /tfy1, /tfy2, /tfy3, etc (num tenho certeza se é esse nome mesmo, tfy, eh algo parecido...), testei todos eles e a mensagem continua, tirei a verificação de portadora e nada também... veja o log abaixo:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding


Bom, não sei se tem alguma coisa a ver, mais eu entrei no Gerenciador de pacotes Synaptic e logo ao abrir ele me deu uma mensagem que eu tinha 14 pacotes quebrados. Fui no Filtro e lá está o pacote sl-modem-daemon como quebrado... vou postar um print da tela pra vc ver...






E aih??? mais alguma dica????


Abraço
« Última modificação: 24 de Julho de 2009, 21:48 por _ZERO_CALL_ »
§§§ _ZERO_CALL_ §§§

"O inteligente conserta, o sábio previne!".

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1122 Online: 24 de Julho de 2009, 20:54 »
Júlio, me parece que vc tem que usar o driver smartlink da forma ALSA, então o que peço para que você faça é baixar o meu pacote modem-arquivos-v30.tar.gz deste link aqui:

http://ubuntuforum-br.org/index.php/topic,4204.msg287645.html#msg287645

levá-lo para o Ubuntu e colocar ele na sua pasta de usuário. Em seguida clique nele com o botão direito do mouse e escolha a opção extrair aqui. Será criada uma pasta chamada modem-arquivos-v30, entre nela e leia os arquivos Leia-me e guia_instalação.pdf para saber como usar o meu pacote.

No seu caso vc vai fazer algo diferente, pois o seu deve ser o modo ALSA, então no processo de instalação do meu pacote, quando aparecer uma janela com vários itens marcados, você deve desmarcar as seguintes opções:

- Ungrab-Winmodem (Driver ungrab-winmodem for modem)
- Slmodem-2.9.11-20090222  (Driver Smartlink for modem)
- Sl-Modem-Daemon (SmartLink software modem daemon)

que são opções relativas a compilação do driver smartlink que vc vai pular. O resto siga as janelas que vão aparecendo a vc e as intruções do arquivos já comentados.

Depois de tudo instalado baixe isso aqui:

http://linmodems.technion.ac.il/packages/smartlink/SLMODEMD_gcc4.3_alsa1.0.18.tar.gz

leve o aquivo SLMODEMD_gcc4.3_alsa1.0.18.tar.gz baixado para o Ubuntu colocando na sua pasta de usuário, depois clique nele com o botão direito do mousse e escolha a opção extrair aqui. Será criada uma pasta chamada SLMODEMD_gcc4.3_alsa1.0.18

Abra um terminal (menu Aplicativos > Acessórios > Terminal) e entre na pasta em questão:

cd SLMODEMD_gcc4.3_alsa1.0.18

pelo terminal e dentro desta pasta digite:

sudo ./setup

aguarde o processo terminar e aindo no terminal digite:

sudo chmod a+x /usr/sbin/pppd

sudo gpasswd -a seu_usuário dip


onde o que destaquei em vermelho, mude para exatamente o nome que vc digita para entrar no ubuntu, ou seja, seu nome de login.

Reinicie o PC.

Depois que voltar ao Ubuntu abra um terminal outra vez e digite exatamente isso aqui:

sudo /usr/sbin/slmodemd --perm=0666 -c BRAZIL --alsa hw:0,6 &

não feche o terminal, mas vá no menu Aplicativos > Internet > GNOME PPP e tente a conexão. O discador já deve estar corretamente configurado pela suas respostas as perguntas feitas pelo instalador do meu pacote.

Se vc tiver feito tudo de maneira correta e funcionar, ótimo, entretanto ainda será necessário criar um script para que seu modem fique ativo no boot, mas se vc tiver feito tudo de maneira correta e o modem não funcionar, então sinto muito mas não poderei ajudar mais, pois esses modems HDA são muito difíceis de fazer funcionar, principalmente com o driver smartlink, no Conexant é mais fácil porém ele dá suporte a poucos modems HDA.

alarcon

  • Visitante
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1123 Online: 24 de Julho de 2009, 20:59 »

Alarcon, eu fiz tudo que vc me pediu, na edição do arquivo /etc/default/sl-modem-daemon mudei pouca coisa, o pais já estava como BRAZIL e o OPTS já tinha o valor "--perm=0666".

Bom, após isso reiniciei o micro e tentei conectar... e novamente a mensagem de modem não encontrado  :'(... entrei no setup e verifiquei o modem, lá tem um /modem, /tfy0, /tfy1, /tfy2, /tfy3, etc (num tenho certeza se é esse nome mesmo, tfy, eh algo parecido...), testei todos eles e a mensagem continua, tirei a verificação de portadora e nada também... veja o log abaixo:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding


Bom, não sei se tem alguma coisa a ver, mais eu entrei no Gerenciador de pacotes Synaptic e logo ao abrir ele me deu uma mensagem que eu tinha 14 pacotes quebrados. Fui no Filtro e lá está o pacote sl-modem-daemon como quebrado... vou postar um print da tela pra vc ver...



E aih??? mais alguma dica????


Abraço


Olha só, os pacotes que faço não causam quebras no sistema, então veja aí o que vc possa ter feito de errado até durante a instalação do seu Ubuntu ok.

Como obteve sua cópia do Ubuntu?

foi pedindo o CD de instalação ou baixou a ISO da internet?

Se vc baixou a ISO, teve o cuidado de verificar o código md5sum da ISO para ver se conferia, indicando assim que a cópia não chegou corrompida?

Veja se vc entendeu bem todo o processo de instalação do meu pacote, se deixou o CD de instalação do driver optico antes da execução do script de instalação, pois alguns arquivos devem ser baixados dele e etc.

Se vc puder reinstale seu Ubuntu e tente o meu pacote modem-arquivos-v30.tar.gz outra vez.

Offline _ZERO_CALL_

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: Tutorial para HSP56 MR driver Smartlink
« Resposta #1124 Online: 24 de Julho de 2009, 21:59 »

Alarcon, eu fiz tudo que vc me pediu, na edição do arquivo /etc/default/sl-modem-daemon mudei pouca coisa, o pais já estava como BRAZIL e o OPTS já tinha o valor "--perm=0666".

Bom, após isso reiniciei o micro e tentei conectar... e novamente a mensagem de modem não encontrado  :'(... entrei no setup e verifiquei o modem, lá tem um /modem, /tfy0, /tfy1, /tfy2, /tfy3, etc (num tenho certeza se é esse nome mesmo, tfy, eh algo parecido...), testei todos eles e a mensagem continua, tirei a verificação de portadora e nada também... veja o log abaixo:

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0
--> Re-Sending: ATZ
--> Modem not responding


Bom, não sei se tem alguma coisa a ver, mais eu entrei no Gerenciador de pacotes Synaptic e logo ao abrir ele me deu uma mensagem que eu tinha 14 pacotes quebrados. Fui no Filtro e lá está o pacote sl-modem-daemon como quebrado... vou postar um print da tela pra vc ver...



E aih??? mais alguma dica????


Abraço


Olha só, os pacotes que faço não causam quebras no sistema, então veja aí o que vc possa ter feito de errado até durante a instalação do seu Ubuntu ok.

Como obteve sua cópia do Ubuntu?

foi pedindo o CD de instalação ou baixou a ISO da internet?

Se vc baixou a ISO, teve o cuidado de verificar o código md5sum da ISO para ver se conferia, indicando assim que a cópia não chegou corrompida?

Veja se vc entendeu bem todo o processo de instalação do meu pacote, se deixou o CD de instalação do driver optico antes da execução do script de instalação, pois alguns arquivos devem ser baixados dele e etc.

Se vc puder reinstale seu Ubuntu e tente o meu pacote modem-arquivos-v30.tar.gz outra vez.


Alarcon, eu instalei o Ubuntu através do CD original que eu solicitei pelo site... na hora da instalação não deu nenhum erro nem nada, até estranhei esses erros...

Na hora da instalação do seu pacote eu segui os passos a risca e não deu nenhum erro, nem mensagem nem nada...

Será que essa quebra num pode ter acontecido por eu ter instalado aquele pacote errado anteriormente e depois instalei o v30??? Lembra que o mané aqui instalou o v22 pensando ser o correto?? rs

Bom, duas perguntas:
1º) Não tem como "consertar" esse problema dos pacotes quebrados???

2º) Posso reinstalar o Ubuntu sim, mais será que naum vou ter problemas com o Dual Boot jah existente (Ubuntu + XP)???

Abraço e valew a ajuda, eu ainda chego lah...rs
§§§ _ZERO_CALL_ §§§

"O inteligente conserta, o sábio previne!".