Autor Tópico: Solucionando problemas com o Java  (Lida 32218 vezes)

Offline sylvester

  • Usuário Ubuntu
  • *
  • Mensagens: 545
    • Ver perfil
Solucionando problemas com o Java
« Online: 20 de Outubro de 2008, 11:32 »
Problemas com o Java

Não faça isto se usa a versão 64 bit
Segundo o que o Galactus me disse o pacote icedtea-gcjwebplugin está instalado por padrão e dá problemas no acesso no Site do Banco do Brasil. A solução é seguir esta dica dada pelo Alarcon:

- desinstalar o pacote: icedtea-gcjwebplugin

Código: [Selecionar]
sudo apt-get remove icedtea-gcjwebplugin
- instalar o java assim (se já não estiver instalado):

Código: [Selecionar]
sudo apt-get -y install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin

ou reinstalar

- e digitar o comando:

Código: [Selecionar]
sudo update-alternatives --config java

e escolher o java da sun recém instalado.
« Última modificação: 20 de Outubro de 2008, 11:36 por sylvester »

http://opensourceformac.blogspot.com/                                      http://easyubuntulinux.blogspot.com/

Offline catitao

  • Usuário Ubuntu
  • *
  • Mensagens: 113
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #1 Online: 13 de Novembro de 2008, 09:55 »
e para os usuários de 64bits?????
Vi$ta Business SP1 + Ubuntu 8.10 64Bits

Offline sylvester

  • Usuário Ubuntu
  • *
  • Mensagens: 545
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #2 Online: 13 de Novembro de 2008, 11:33 »
Utilizadores do 64 bit devem permanecer com o icedtea-gcjwebplugin visto que ainda não existe o plugin do java da sun para 64 bit.
Outra solução poderia ser usar o konqueror, ou instalar o firefox 32 bit dentro do sistema 64 bit.

http://opensourceformac.blogspot.com/                                      http://easyubuntulinux.blogspot.com/

Offline catitao

  • Usuário Ubuntu
  • *
  • Mensagens: 113
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #3 Online: 14 de Novembro de 2008, 20:18 »
Infelizmente! Mas esse plugin de java não funciona no bc. De qualquer forma obrigado pelo esclarecimento
Vi$ta Business SP1 + Ubuntu 8.10 64Bits

Offline paulocelso68

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #4 Online: 25 de Abril de 2009, 11:27 »
 8) Pegando a dica do Marcelo Kalib, basta isso:

$ sudo aptitude install sun-java6-jre sun-java6-plugin sun-java6-fonts

... e Pronto! Uso o Ubuntu 9.04 64 bits num notebook intel core2 duo 2.0 ghz, 4gb ram, chipset intel 965, wifi 4965 e video 965 e som hda Intel Alsa Mixer. Está tudo funcionando perfeitamente.

Offline juniorph

  • Usuário Ubuntu
  • *
  • Mensagens: 6
  • juniorphy
    • Ver perfil
    • Junior PH
Funcionou !!!
« Resposta #5 Online: 04 de Maio de 2009, 13:33 »
Eu havia tentado instalar o Java manualmente e não tinha conseguido,

mas com esse comando :

$ sudo aptitude install sun-java6-jre sun-java6-plugin sun-java6-fonts


funcionou legal para o Banco do Brasil.

Valeu !!!
Junior Ph
Virtual Info.

Offline catitao

  • Usuário Ubuntu
  • *
  • Mensagens: 113
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #6 Online: 05 de Maio de 2009, 21:51 »
atualmente quem tem placa de video ati, cuidado! o 9.04 não funciona nem com todas as gambiaras feitas atualmente pra usar o 8.10. Se quiser o java usa o 8.10 32 bits
Vi$ta Business SP1 + Ubuntu 8.10 64Bits

Offline lucasgf

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #7 Online: 06 de Maio de 2009, 10:35 »
Com o firefox 3.0.10 no ubuntu 9.04 aqui agora aparece a seguinte mensagem no site do Banco do Brasil:
"A máquina virtual não possui as permissões necessárias (E02)"

O estranho é tava funcionando normalmente...

Alguém ajuda?
Agora de ubuntu 9.10 no Latitude D531

Offline catitao

  • Usuário Ubuntu
  • *
  • Mensagens: 113
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #8 Online: 06 de Maio de 2009, 11:02 »
Com o firefox 3.0.10 no ubuntu 9.04 aqui agora aparece a seguinte mensagem no site do Banco do Brasil:
"A máquina virtual não possui as permissões necessárias (E02)"

O estranho é tava funcionando normalmente...

Alguém ajuda?

instala por aqui http://ericogr.wordpress.com/2009/02/05/instalando-javasun-ubuntu/ no lugar do jdk usa o JRE , pra usar o último java é só baixar do site da sun o www.java.com. Boa sorte.
Vi$ta Business SP1 + Ubuntu 8.10 64Bits

Offline lucasgf

  • Usuário Ubuntu
  • *
  • Mensagens: 35
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #9 Online: 06 de Maio de 2009, 12:07 »
Opa, valeu demais!

Funfou :)

Com o firefox 3.0.10 no ubuntu 9.04 aqui agora aparece a seguinte mensagem no site do Banco do Brasil:
"A máquina virtual não possui as permissões necessárias (E02)"

O estranho é tava funcionando normalmente...

Alguém ajuda?

instala por aqui http://ericogr.wordpress.com/2009/02/05/instalando-javasun-ubuntu/ no lugar do jdk usa o JRE , pra usar o último java é só baixar do site da sun o www.java.com. Boa sorte.
Agora de ubuntu 9.10 no Latitude D531

Offline catitao

  • Usuário Ubuntu
  • *
  • Mensagens: 113
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #10 Online: 06 de Maio de 2009, 22:54 »
Opa, valeu demais!

Funfou :)

Com o firefox 3.0.10 no ubuntu 9.04 aqui agora aparece a seguinte mensagem no site do Banco do Brasil:
"A máquina virtual não possui as permissões necessárias (E02)"

O estranho é tava funcionando normalmente...

Alguém ajuda?


ok disponha!

instala por aqui http://ericogr.wordpress.com/2009/02/05/instalando-javasun-ubuntu/ no lugar do jdk usa o JRE , pra usar o último java é só baixar do site da sun o www.java.com. Boa sorte.
Vi$ta Business SP1 + Ubuntu 8.10 64Bits

Offline simon

  • Usuário Ubuntu
  • *
  • Mensagens: 110
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #11 Online: 12 de Maio de 2009, 13:56 »
Utilizadores do 64 bit devem permanecer com o icedtea-gcjwebplugin visto que ainda não existe o plugin do java da sun para 64 bit.
Outra solução poderia ser usar o konqueror, ou instalar o firefox 32 bit dentro do sistema 64 bit.

Já existe a versão para 64 bit. Depois de baixado e instalado tem que criar um link para o arquivo libnpjp2.so na pasta
 ~/.mozilla/plugins/ :
Código: [Selecionar]
ln -s /diretorio_do_java/lib/amd64/libnpjp2.so ~/.mozilla/plugins/libnpjp2.so
Para verificar se foi instalado corretamente basta abrir o firefox e digitar about:plugins na barra de navegação.

Offline rruella

  • Usuário Ubuntu
  • *
  • Mensagens: 1.097
    • Ver perfil
Re: Solucionando problemas com o Java (resolvido)
« Resposta #12 Online: 15 de Maio de 2009, 14:21 »
Tentei e deu isso
robson@Robson:~$ sudo aptitude install sun-java6-jre sun-java6-plugin sun-java6-fonts
E: Não foi possível obter acesso exclusivo a /var/lib/dpkg/lock - open (11 Recurso indisponível temporariamente)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
A inicializar os estados dos pacotes... Pronto
E: Não foi possível obter acesso exclusivo a /var/lib/dpkg/lock - open (11 Recurso indisponível temporariamente)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
robson@Robson:~$
« Última modificação: 18 de Maio de 2009, 14:40 por rruella »
Dar como resolvido, ou como solucionado um tópico seu:

http://www.youtube.com/watch?v=cW8isbYhR_M

alarcon

  • Visitante
Re: Solucionando problemas com o Java
« Resposta #13 Online: 15 de Maio de 2009, 19:45 »
Tentei e deu isso
robson@Robson:~$ sudo aptitude install sun-java6-jre sun-java6-plugin sun-java6-fonts
E: Não foi possível obter acesso exclusivo a /var/lib/dpkg/lock - open (11 Recurso indisponível temporariamente)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
A inicializar os estados dos pacotes... Pronto
E: Não foi possível obter acesso exclusivo a /var/lib/dpkg/lock - open (11 Recurso indisponível temporariamente)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
robson@Robson:~$


Este erro (erro de lock) ocorre geralmente por que você já está usando um comando/aplicativo de instalação do Ubuntu e que usar novamente um comando/aplicativo de instalação no mesmo instante, por exemplo, está com o Synaptic aberto e quer usar o comando sudo apt-get install ou quer usar o Adicionar/Remover... e etc.

Veja:

Citar
Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Só use um comando/aplicativo de instalação por vez ok.
« Última modificação: 15 de Maio de 2009, 19:48 por alarcon »

Offline burns

  • Usuário Ubuntu
  • *
  • Mensagens: 14
    • Ver perfil
Re: Solucionando problemas com o Java
« Resposta #14 Online: 23 de Junho de 2009, 07:30 »
as paginas em java no ubuntu9.04+firefox 3.11 estão rodando meio lerdas, acredito que venha 1 pacote por padrão nesse ubuntu para java, se eu remover esse pacote como foi citado no inicio do post e adicionar os q estão nas dicas será q melhora?