Autor Tópico: Instalação "quase" perfeita do Pulse Audio/ possível solução para som no Flash  (Lida 14940 vezes)

Offline Nossile

  • Usuário Ubuntu
  • *
  • Mensagens: 807
  • Loading...
    • Ver perfil
Fiz uma instalação limpa do 8.04 e percebi que tinha o problema com o Flash sem som, então fiz uma busca no fórum em inglês e encontrei este tópico do usuário zman0900 que propõe uma solução para o uso do Pulse Audio:
http://ubuntuforums.org/showthread.php?t=776739

Isso é meio que uma "gambiarra" mas achei interessante postar aqui, então fiz uma tradução dos pontos mais importantes. Aqui funcionou muito bem, mas faça por sua própria conta e risco.  ;D

1) Instale os pacotes adicionais
Código: [Selecionar]
sudo apt-get install libao-pulse libasound2-plugins
2) Configurações
    --edite seu /etc/asound.conf dessa maneira:
     
Código: [Selecionar]
pcm.pulse {
    type pulse
}
ctl.pulse {
    type pulse
}
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}
    --edit seu /etc/libao.conf dessa maneira:
     
Código: [Selecionar]
default_driver=pulse    Crie os arquivos se não existirem.

    --Vá até Sistema>Preferencias>Som
    --Mude as quatro primeiras opções pra Servidor de Som PulseAudio
    --Escolha a opção com o nome de sua placa de som para o Mixer de Trilhas Padrão

3) Instale os pacotes Pulse adicionais
Código: [Selecionar]
sudo apt-get install libflashsupport padevchooser pulseaudio-module-hal pulseaudio-module-x11Permita a instalação das dependencias adicionais

Para garantir que você instale o pacote libSDL padrão, rode isso primeiro:
Código: [Selecionar]
sudo apt-get install libsdl1.2debian libsdl1.2debian-alsa
Agora adicione as estas linhas a /etc/apt/sources.list (Isso irá adicionar o repositório do usuário (fórum inglês) zman0900, tem apenas os pacotes necessários):
Código: [Selecionar]
## zman0900's PPA
deb http://ppa.launchpad.net/zman0900/ubuntu hardy main
deb-src http://ppa.launchpad.net/zman0900/ubuntu hardy main

Agora rode:
Código: [Selecionar]
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libsdl1.2debian-pulseaudio

Nota: Se libsdl1.2debian-pulseaudio não for instalado, faça o seguinte:
Código: [Selecionar]
sudo apt-get install libsdl1.2debian-all
e adicione isso a ~/.profile :
Código: [Selecionar]
# Make SDL audio work properly with Pulse
#export SDL_AUDIODRIVER=pulse



5) Configure o device chooser
Vá até Aplicações>Som & Video>PulseAudio Device Chooser
Isso irá carregar um plugin na área de notificação
Click com o botão direito, click em Preferences, marque Start applet on session login. 

6) REINICIE O COMPUTADOR!
Tudo deve estar configurado. Você deve agora ser capaz de reproduzir audio, tanto através de aplicações ALSA, ESD e Pulse ao mesmo tempo, e tudo vai aparecer no Chooser como um dispositivo separado.





« Última modificação: 08 de Maio de 2008, 01:47 por Nossile »
sudo aptitude remove terno-e-gravata && sudo aptitude install bermuda chinelo -y

Offline mestre_Kame

  • Usuário Ubuntu
  • *
  • Mensagens: 15
  • Mestre_Kame
    • Ver perfil
Parabéns cara! Valeo.
Estava com o mesmo problema, e consegui resovler com seu tutorial!!!
Obrigado!!!

Abços!
Mestre_Kame
::: Ubuntu User :::

Offline Master_Coyote

  • Usuário Ubuntu
  • *
  • Mensagens: 74
    • Ver perfil
eu estava com um problema parecido,como digo nesse tópico aki :

http://ubuntuforum-br.org/index.php/topic,36706

mas eu fiz tudo como indicado,e após reiniciar meu sistema,meu problema além de continuar,só consigo ouvir sons do lado esquerdo |:

e agora ?

Offline Madrigal

  • Usuário Ubuntu
  • *
  • Mensagens: 835
    • Ver perfil

Eu me dei mal.  >:(

Acabou ficando é tudo mudo!

Tentei desfazer tudo mas só funciona agora se coloco a caixa externa usb no meu notebook. O som do próprio notebook não funciona mais!
 Como consertar isso?

Offline Madrigal

  • Usuário Ubuntu
  • *
  • Mensagens: 835
    • Ver perfil
Um colega me indicou essa página: http://ubuntudicas.blogspot.com/2008/07/erro-no-flash-com-o-pulse-audio.html não testei ainda, vou ver depois se dá certo, aí posto aqui.

Offline miltoin

  • Usuário Ubuntu
  • *
  • Mensagens: 49
    • Ver perfil
    • catando...
Olá, Pessoas.

usei a dica do nossile e deu tudo certo. na verdade nem tudo. o som do flash e de um player de áudio rodam simultaneamente, porém o flash tá dando problema nos navegadores, digo navegadores porque instalei o epiphany, pensando que podia ser um problema com firefox, mas não adiantou. o que ocorre é que estou vendo um vídeo no youtube e tudo certo, mas geralmente quando termina um e coloco para rodar outro o navegador fecha quase instantaneamente.

isso começou a acontecer logo após eu fazer essa treta do pulse audio.

alguém tem uma idéia de como sanar isso?


abraço.


Offline entaotoloko

  • Usuário Ubuntu
  • *
  • Mensagens: 102
    • Ver perfil

e adicione isso a ~/.profile :
Código: [Selecionar]
# Make SDL audio work properly with Pulse
#export SDL_AUDIODRIVER=pulse


Travei aqui, onde devo ir pra adicionar isso?
Amazon PC
Optimum - Turion X2 1.60Ghz 4GB de RAM HD de 250GB

Offline Madrigal

  • Usuário Ubuntu
  • *
  • Mensagens: 835
    • Ver perfil
~/.profile
Travei aqui, onde devo ir pra adicionar isso?

Em Locais>Pasta Pessoal (~/ indica que é dentro da pasta principal do perfil), dê um Ctrl+H pra mostrar os arquivos ocultos ( o ponto indica que é um arquivo oculto).

o .profile portanto é um arquivo oculto dentro da pasta pessoal.

Offline Edusong

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Segui esses passos e tbm fiquei sem som. No icone do pulse ele não deixa abrir controle de volume, da uma mensagem de conection refused.


Alguma coisa que devo configurar alem disso?

Offline akaihen

  • Usuário Ubuntu
  • *
  • Mensagens: 194
    • Ver perfil
    • Quase-Crônicas
Re: Instalação "quase" perfeita do Pulse Audio/ possível solução para som no Flash
« Resposta #9 Online: 20 de Dezembro de 2008, 11:03 »
fiz o tutorial e o rhythmbox parou de sair som, dou play a musica começa mas não tem som
Kubuntu 10.04
Athlon 64 XP2 2.6+ Geforce 9600 GT
150 gb MAxtor +40 gb samsung +2 gb ram