Autor Tópico: Problema no Xine Totem - Cook.so !  (Lida 5291 vezes)

Offline LordAngels

  • Usuário Ubuntu
  • *
  • Mensagens: 33
  • Linux Ubuntu 7.04
    • Ver perfil
Problema no Xine Totem - Cook.so !
« Online: 12 de Novembro de 2007, 14:11 »
Pessoal, estou com um problema no Xine Totem. No meu Ubuntu antigo, o 7.04 funcionava mas nesse (7.10) não está funcionando o Xine Totem quando eu quero ver meus Animes em RMVB.

Segui vários tutoriais na Internet, mas nada. Procurei sobre o meu problema mas não achei respostas.

O problema é o seguinte, quando eu tento abrir um arquivo RMVB fala que está com problema ao carregar a biblioteca ou um decodificador com o nome de Cook.so .

Já peguei do RealPlayer as codecs e tudo o mais, mas não estou conseguindo.

Em um dos fóruns que visitei tentando achar a resposta para o meu problema, falava para eu colocar as codecs na pasta /usr/lib/win32, ao tentar fazer isso, deu permissão negada pois eu não estava como root, o que eu não sei, como eu faço isso?

Abraços
<_PcFórum User_LordAngels> WwW.PcForum.cOm.Br <_PcFórum User_LordAngels>

Offline KiodaY

  • Usuário Ubuntu
  • *
  • Mensagens: 23
    • Ver perfil
Re: Problema no Xine Totem - Cook.so !
« Resposta #1 Online: 12 de Novembro de 2007, 22:27 »
estou com esse problema também
=\

Offline Haroltz

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problema no Xine Totem - Cook.so !
« Resposta #2 Online: 23 de Fevereiro de 2008, 22:11 »
Começou esse problema aqui também.

Offline edjen

  • Usuário Ubuntu
  • *
  • Mensagens: 183
  • Toda mudança gera resistência.
    • Ver perfil
Re: Problema no Xine Totem - Cook.so !
« Resposta #3 Online: 23 de Fevereiro de 2008, 23:48 »
Oi pessoal ! Comigo aconteceu anteontem, quando fiz uma atualização com os "pacotes sem suporte" (Synaptic) foram atualizados o libxine1 e o mplayer. Se forem casos parecidos, dá pra fazer o seguinte:

1- Synaptic -> Configurações -> Repositórios -> Atualizações -> Atualizações sem suporte (deixar desmarcado)
2- Também no Synaptic remove o Totem-xine e os pacotes libxine1 maiores que versão 1.1.7
3- No terminal: "sudo nautilus" vai abrir uma janela de navegação (o Nautilus)
4- Sistema de Arquivo -> var -> cache -> apt -> archives e exclui os pacotes libxine1 maiores que 1.1.7 e fecha o Nautilus
5- Reinstala o Totem-xine que as libxine1 serão reinstaladas, provavelmente na versão 1.1.7

Lembre-se que foi o que eu fiz e resolveu o meu problema. Pode ser outra coisa, mas esse procedimento não vai causar problema.

                                                     Boa Sorte !
GNULinux = Asus P5K-E = Intel Q9450 = Quadro 400 = 3 Hd 80Gb Samsung + Hd 500Gb Seagate = 8Gb RAM DDR2 OCZ 1066 mhz

Offline dougufpa

  • Usuário Ubuntu
  • *
  • Mensagens: 36
  • "Não distribua apenas Linux. Distribua conteúdo."
    • Ver perfil
Re: Problema no Xine Totem - Cook.so !
« Resposta #4 Online: 12 de MAR?O de 2008, 14:56 »
Citação de: edjen
Oi pessoal ! Comigo aconteceu anteontem, quando fiz uma atualização com os "pacotes sem suporte" (Synaptic) foram atualizados o libxine1 e o mplayer. Se forem casos parecidos, dá pra fazer o seguinte:

1- Synaptic -> Configurações -> Repositórios -> Atualizações -> Atualizações sem suporte (deixar desmarcado)
2- Também no Synaptic remove o Totem-xine e os pacotes libxine1 maiores que versão 1.1.7
3- No terminal: "sudo nautilus" vai abrir uma janela de navegação (o Nautilus)
4- Sistema de Arquivo -> var -> cache -> apt -> archives e exclui os pacotes libxine1 maiores que 1.1.7 e fecha o Nautilus
5- Reinstala o Totem-xine que as libxine1 serão reinstaladas, provavelmente na versão 1.1.7

Lembre-se que foi o que eu fiz e resolveu o meu problema. Pode ser outra coisa, mas esse procedimento não vai causar problema.

                                                     Boa Sorte !

De fato, você estava certo. Parabéns!

Fiz exatamente como você citou acima e deu certo, apenas para arquivos .rmvb
No entanto, ainda ah problemas nos arquivos .mp3, .avi, dentre outros.
Vou fazer a reinstalação das libs para os formatos citados acima.

@br4¢0§!

Offline z3cU3c4

  • Usuário Ubuntu
  • *
  • Mensagens: 82
    • Ver perfil
Re: Problema no Xine Totem - Cook.so !
« Resposta #5 Online: 19 de MAR?O de 2008, 14:55 »
Procurando no google um cara resolveu o problema criando um link da pasta usr/lib/win32 para uma em usr/local....

"Como todos sabem o rmvb é um dos formatos mais usados hoje em dia pra reprodução de filmes, seriados, etc... Tem qualidade boa (não ótima), e com tamanhos pequenos. No 7.04 tive um problema com o som no rmvb, era um problema só com o som. Recentemente no 7.10, após atualização de alguns componentes da biblioteca xine, o totem e nem o gxine conseguiam abrir os arquivos Real Media. O totem acusa o erro de que havia um problema com o decodificador cook.so. Já o gxine aparecia um problema com o cook.so e drvc.so. Não tentei outro player, não gosto de mudar o player por um problema fácil de ser resolvido, foi o conselho de muitos posts na comunidade, "mude para o mplayer", eu gosto dois dois, e não quero ficar instalando mais. Então tentei uma solução. Na teoria, o player não estaria encontrando os arquivos de codec, e dando o erro. Foi então que eu reinstalei o paocte w32codecs, e para minha surpresa nada aconteceu, também deletei os arquivos de configuração do xine, para recomeçar por "default" e nada também. A solução foi simples, foi somente criando um link simbólico de onde tavam os codecs para outro, onde os players também poderia procurar.
Com o comando seguinte foi tudo resolvido, espero tê-los ajudado.

$ sudo ln -sf /usr/lib/win32 /usr/local/lib/



Retirado do link http://parecedificil.blogspot.com/2008_02_01_archive.html