Autor Tópico: Pixel View PlayTV mobile ( Como Instalar e configurar )  (Lida 92433 vezes)

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Pixel View PlayTV mobile ( Como Instalar e configurar )
« Online: 07 de Agosto de 2007, 01:54 »
Salve Forum,

Recebi de presente uma Placa PCMCIA PixelView PlayTV mobile.

Meu lspci foi:

Código: [Selecionar]

03:00.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev f0)
        Subsystem: Philips Semiconductors Unknown device 0000
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (3750ns min, 9500ns max)
        Interrupt: pin A routed to IRQ 9
        Region 0: Memory at 38000000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: <access denied>



dmesg:

Código: [Selecionar]

[ 1100.688000] saa7133[0]: found at 0000:03:00.0, rev: 240, irq: 9, latency: 0, mmio: 0x38000000
[ 1100.688000] PCI: Setting latency timer of device 0000:03:00.0 to 64
[ 1100.688000] saa7133[0]: subsystem: 1131:0000, board: UNKNOWN/GENERIC [card=0,autodetected]
[ 1100.688000] saa7133[0]: board init: gpio is e2c0c0
[ 1100.864000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[ 1100.864000] saa7133[0]: Huh, no eeprom present (err=-5)?
[ 1100.884000] saa7133[0]: i2c scan: found device @ 0x96  [???]
[ 1100.888000] tuner 0-004b: tuner type not set
[ 1100.888000] tuner 0-004b: tuner type not set
[ 1100.888000] saa7133[0]: registered device video0 [v4l2]
[ 1100.888000] saa7133[0]: registered device vbi0
[ 1100.888000] saa7133[0]/alsa: saa7133[0] at 0x38000000 irq 9 registered as card -2


instalado em modules

Código: [Selecionar]

#placa de video captura
saa7134 card=1
saa7134-alsa.so
tuner
# Fim da placa de video


instalado em modprobe.d / saa7134

Código: [Selecionar]

# Pixel view
options saa7134 i2c_scan=1


Instalado tvtime

-------------------------------

Mas a coisa não rola. Não vejo tv.

Alguém tem alguma sugestão ?

Procurei pela net toda e não achei nada. Apenas que o Philipps semicondutor saa7133 / 7135 funciona com o modulo saa7134. Mais nada.

Abraços a todos
« Última modificação: 10 de Dezembro de 2010, 21:50 por Tota »

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #1 Online: 07 de Agosto de 2007, 08:08 »
Baseado no que fiz aqui na minha placa posso sugerir:
Veja no lsmod se o módulo saa7134 carrega na inicialização (se não vc inclue ele no /etc/modules).
Pelo que estou vendo no dmesg nem o card nem o tuner estão configurados, por isso vc não deve estar tendo sintonia de canais.
Eu configuro a minha placa em /etc/modprobe.d/options :

# Placa de captura (PixelView Play TV Pro Ultra)
options cx88xx card=27 tuner=38

No seu caso o módulo é saa7134 e o card e o tuner vc tem que encontrar.

« Última modificação: 08 de Agosto de 2007, 14:05 por pintinho »
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #2 Online: 07 de Agosto de 2007, 15:21 »
Olá pintinho,

Já fiz uma pesquisa na Net e nos Foruns gringos do Ubuntu.

Carreguei o saa7134, o saa7134-alsa e o tuner no modules.
"levantei" o v4l e tudo o mais.

Minha placa, segundo o wiki do saa7134, é 0 (zero - unsupported) e meu tuner -2.

Já está sendo reconhecida, mas pelo tvtuner não aparece nada.Tentei também o xawTV e o MythTV sem resultados.

Por acaso: o que é o cx88xx no options?

o meu está assim:

Código: [Selecionar]

 #PixelView Play TV
options saa1734 radio=1 card=0 tuner=-2


[],s e obrigado pela ajuda.

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #3 Online: 07 de Agosto de 2007, 15:34 »
cx88xx é o modulo da minha placa...
No dmesg tem uma lista de card que vc pode tentar.
Se o tuner=2 falta o card.

option:
[   39.459328] cx88[0]:    card=0 -> UNKNOWN/GENERIC
[   39.459329] cx88[0]:    card=1 -> Hauppauge WinTV 34xxx models
[   39.459331] cx88[0]:    card=2 -> GDI Black Gold
[   39.459332] cx88[0]:    card=3 -> PixelView
[   39.459334] cx88[0]:    card=4 -> ATI TV Wonder Pro
[   39.459335] cx88[0]:    card=5 -> Leadtek Winfast 2000XP Expert
[   39.459337] cx88[0]:    card=6 -> AverTV Studio 303 (M126)
[   39.459338] cx88[0]:    card=7 -> MSI TV-@nywhere Master
[   39.459340] cx88[0]:    card=8 -> Leadtek Winfast DV2000
[   39.459341] cx88[0]:    card=9 -> Leadtek PVR 2000
[   39.459343] cx88[0]:    card=10 -> IODATA GV-VCP3/PCI
[   39.459344] cx88[0]:    card=11 -> Prolink PlayTV PVR
[   39.459346] cx88[0]:    card=12 -> ASUS PVR-416
[   39.459347] cx88[0]:    card=13 -> MSI TV-@nywhere
[   39.459349] cx88[0]:    card=14 -> KWorld/VStream XPert DVB-T
[   39.459350] cx88[0]:    card=15 -> DViCO FusionHDTV DVB-T1
[   39.459352] cx88[0]:    card=16 -> KWorld LTV883RF
[   39.459353] cx88[0]:    card=17 -> DViCO FusionHDTV 3 Gold-Q
[   39.459355] cx88[0]:    card=18 -> Hauppauge Nova-T DVB-T
[   39.459357] cx88[0]:    card=19 -> Conexant DVB-T reference design
[   39.459358] cx88[0]:    card=20 -> Provideo PV259
[   39.459360] cx88[0]:    card=21 -> DViCO FusionHDTV DVB-T Plus
[   39.459361] cx88[0]:    card=22 -> pcHDTV HD3000 HDTV
[   39.459363] cx88[0]:    card=23 -> digitalnow DNTV Live! DVB-T
[   39.459364] cx88[0]:    card=24 -> Hauppauge WinTV 28xxx (Roslyn) models
[   39.459366] cx88[0]:    card=25 -> Digital-Logic MICROSPACE Entertainment Center (MEC)
[   39.459368] cx88[0]:    card=26 -> IODATA GV/BCTV7E
[   39.459369] cx88[0]:    card=27 -> PixelView PlayTV Ultra Pro (Stereo)
[   39.459371] cx88[0]:    card=28 -> DViCO FusionHDTV 3 Gold-T
[   39.459373] cx88[0]:    card=29 -> ADS Tech Instant TV DVB-T PCI
[   39.459374] cx88[0]:    card=30 -> TerraTec Cinergy 1400 DVB-T
[   39.459376] cx88[0]:    card=31 -> DViCO FusionHDTV 5 Gold
[   39.459378] cx88[0]:    card=32 -> AverMedia UltraTV Media Center PCI 550
[   39.459379] cx88[0]:    card=33 -> Kworld V-Stream Xpert DVD
[   39.459381] cx88[0]:    card=34 -> ATI HDTV Wonder
[   39.459382] cx88[0]:    card=35 -> WinFast DTV1000-T
[   39.459384] cx88[0]:    card=36 -> AVerTV 303 (M126)
[   39.459385] cx88[0]:    card=37 -> Hauppauge Nova-S-Plus DVB-S
[   39.459387] cx88[0]:    card=38 -> Hauppauge Nova-SE2 DVB-S
[   39.459389] cx88[0]:    card=39 -> KWorld DVB-S 100
[   39.459390] cx88[0]:    card=40 -> Hauppauge WinTV-HVR1100 DVB-T/Hybrid
[   39.459392] cx88[0]:    card=41 -> Hauppauge WinTV-HVR1100 DVB-T/Hybrid (Low Profile)
[   39.459394] cx88[0]:    card=42 -> digitalnow DNTV Live! DVB-T Pro
[   39.459395] cx88[0]:    card=43 -> KWorld/VStream XPert DVB-T with cx22702
[   39.459397] cx88[0]:    card=44 -> DViCO FusionHDTV DVB-T Dual Digital
[   39.459399] cx88[0]:    card=45 -> KWorld HardwareMpegTV XPert
[   39.459400] cx88[0]:    card=46 -> DViCO FusionHDTV DVB-T Hybrid
[   39.459402] cx88[0]:    card=47 -> pcHDTV HD5500 HDTV
[   39.459404] cx88[0]:    card=48 -> Kworld MCE 200 Deluxe
39.459405] cx88[0]:    card=49 -> PixelView PlayTV P7000
[   39.459407] cx88[0]:    card=50 -> NPG Tech Real TV FM Top 10
[   39.459408] cx88[0]:    card=51 -> WinFast DTV2000 H
[   39.459410] cx88[0]:    card=52 -> Geniatech DVB-S
[   39.459411] cx88[0]:    card=53 -> Hauppauge WinTV-HVR3000 TriMode Analog/DVB-S/DVB-T
[   39.459413] cx88[0]:    card=54 -> Norwood Micro TV Tuner
[   39.459415] cx88[0]:    card=55 -> Shenzhen Tungsten Ages Tech TE-DTV-250 / Swann OEM
[   39.459417] cx88[0]:    card=56 -> Hauppauge WinTV-HVR1300 DVB-T/Hybrid MPEG
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #4 Online: 07 de Agosto de 2007, 16:03 »
Vou tentar e posto  a seguir.

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #5 Online: 07 de Agosto de 2007, 20:41 »
pintinho,

A coisa aqui melhorou editando o card=x e tuner=x

dei um

rmmod saa7134_alsa
rmmod saa7134

modprobe saa7134 card=79

dmesg

Código: [Selecionar]
[  284.344000] saa7130/34: v4l2 driver version 0.2.14 loaded
[  284.344000] saa7133[0]: found at 0000:03:00.0, rev: 240, irq: 9, latency: 64, mmio: 0x38000000
[  284.344000] saa7133[0]: subsystem: 1131:0000, board: Sedna/MuchTV PC TV Cardbus TV/Radio (ITO25 Rev:2B) [card=79,insmod option]
[  284.344000] saa7133[0]: board init: gpio is e2c0c0
[  284.344000] input: saa7134 IR (Sedna/MuchTV PC TV  as /class/input/input8
[  284.520000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[  284.568000] tuner 0-004b: setting tuner address to 60
[  284.608000] tuner 0-004b: type set to tda8290+75a
[  284.720000] tuner 0-004b: setting tuner address to 60
[  284.760000] tuner 0-004b: type set to tda8290+75a
[  284.824000] saa7133[0]: Huh, no eeprom present (err=-5)?
[  284.844000] saa7133[0]: i2c scan: found device @ 0x96  [???]
[  287.280000] saa7133[0]: registered device video0 [v4l2]
[  287.284000] saa7133[0]: registered device vbi0
[  287.284000] saa7133[0]: registered device radio0
[  287.332000] saa7134 ALSA driver for DMA sound loaded
[  287.332000] saa7133[0]/alsa: saa7133[0] at 0x38000000 irq 9 registered as card -2


Tenho video, todos os canais. mas ainda não tenho som.

Pergunta:

Como eu faria para setar o modules e o options para não ter que fazer manualmente a cada boot?
 

[],s
« Última modificação: 07 de Agosto de 2007, 21:17 por Tota »

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #6 Online: 07 de Agosto de 2007, 21:54 »
Tota,

Permita-me aproveitar esse seu tópico para dar uma geral nessa questão porque eu confesso que apanhei muito também para fazer minha placa funcionar.
Com isso podemos ajudar aqueles que estão apanhando ainda...né mesmo?

Para fazer funcionar a placa de captura  precisamos basicamente de 3 coisas:

1-Saber o driver (módulo) correto - infelizmente, o driver vem no CD da Placa só para Windons (por enquanto né?)
2-Saber o card correto.
3-Saber o tuner correto.

O driver vc consegue saber descobrindo primeiro o chip da sua placa.
No meu caso no lspci encontrei :
00:0c.0 Multimedia video controller: Conexant CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
O driver (módulo) para o Conexant CX23880 é o cx88xx (isso se descobre na internet).
No seu caso (não sei se foi no lspci) : 03:00.0 Multimedia controller: Philips Semiconductors SAA7133/SAA7135 Video Broadcast Decoder (rev f0).
O driver (módulo) para SAA7133/SAA7135 é o saa7134, como vc disse.


O card=27 no meu caso eu achei no dmesg (naquela lista que te mostrei).
No seu caso não sei se vc encontrou nessa lista (existem outras listas na internet).

O tuner é que é a carne de pescoço (pelo menos foi no meu caso).
Depois de muita luta descobri num site americano que se vc já tem o módulo e o card o tuner=? vira i2c_scan=1.
Aí vc edita o /etc/modprobe.d/options e coloca:

options xxxxxxxx card=x i2c_scan=1

Onde xxxxxxx = módulo,  x=número encontrado no dmesg e, o i2c_scan=1 é que vai te dar o tuner correto.
Quando vc faz assim ao abrir o dmesg lá estará o valor para o seu tuner.
Vc pode então fazer a configuração já com esse valor.

Aí finalmente fica:

options xxxxxxx card=x tuner=y, onde y é o que vc encontrou depois no dmesg com o i2c_scan=1

Veja como ficou o dmesg depois que configurei o /etc/modprobe.d/options dessa maneira:
options cx88xx card=27  i2c_scan=1


[   31.415874] CORE cx88[0]: subsystem: 0000:0000, board: PixelView PlayTV Ultra Pro (Stereo) [card=27,insmod option]
[   31.415877] TV tuner 38 at 0x1fe, Radio tuner -1 at 0x1fe
[   31.579762] sky2 eth0: Link is up at 100 Mbps, full duplex, flow control both
[   31.607606] cx88[0]: i2c scan: found device @ 0xc2  [tuner (analog/dvb)]
[   31.608531] cx88[0]: i2c scan: found device @ 0xc6  [???]
[   31.628802] tveeprom 1-0050: Huh, no eeprom present (err=-121)?
[   31.628919] input: cx88 IR (PixelView PlayTV Ultra as /class/input/input4
[   31.629010] cx88[0]/0: found at 0000:00:0c.0, rev: 5, irq: 25, latency: 32, mmio: 0xdd000000
[   31.648054] tuner 1-0061: chip found @ 0xc2 (cx88[0])
[   31.648076] tuner 1-0061: type set to 38 (Philips PAL/SECAM multi (FM1216ME MK3))
[   31.648079] tuner 1-0061: type set to 38 (Philips PAL/SECAM multi (FM1216ME MK3))
[   31.648944] tuner 1-0063: chip found @ 0xc6 (cx88[0])
[   31.658145] cx88[0]/0: registered device video0 [v4l2]
[   31.658233] cx88[0]/0: registered device vbi0
[   31.658317] cx88[0]/0: registered device radio0

Foi assim que descobri o valor do tuner para a minha placa e, agora a configuração é sempre essa (no etc/modprobe.d/options):

options cx88xx card=27 tuner=38 e, o tvtime o kdetv e o mythtv, todos funcionam...

[]s, e boa sorte.
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile (levando uma surra )
« Resposta #7 Online: 07 de Agosto de 2007, 23:16 »
Valeu pela ajuda, pintinho

Fui na Net pesquisar por CARDLIST.saa7134 => http://www.linuxtv.org/v4lwiki/index.php/CARDLIST.saa7134

e por

CARDLIST.tuner => http://www.mjmwired.net/kernel/Documentation/video4linux/CARDLIST.tuner

A sintonia de canais está resolvida. Tenho todos os canais com boa imagem.


O problema agora é o som, uma vez que a placa é PCMCIA e não tem saída de som para plugar na entrada da minha placa de som. ( gambiarra recomendada nos sites da net )

De todo o modo obrigado novamente pela ajuda

postarei resolvido quando meu som aparecer. ( Titulo do post já alterado )

Fui olhar nas configurações de som e tenho saa7134_alsa instalado, mas dá erro.

Vou fuçar mais por aqui.

[],s
« Última modificação: 07 de Agosto de 2007, 23:18 por Tota »

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile com video mas sem som
« Resposta #8 Online: 08 de Agosto de 2007, 01:57 »
tenho uma LTT-200 e costumo a instalar assim

crie o arquivo '/etc/modprobe.d/captura' chown root:root e chmod 644
Citar
# saa7134 modulos
# quando inicializar o modulo usa estas opções
#
options saa7134 card=78 tuner=54 oss=1

crie o arquivo '/etc/rc5.d/S90captura' chown root:root e chmod 755
Citar
#!/bin/sh
# inicializa os modulos da placa de captura no boot
#
modprobe saa7134 i2c-scan-1
modprobe saa7134-alsa
modprobe saa7134-dvb

troque o numero da card e tuner pelo da sua placa de captura
acho que deve ser card=79 e tuner =54
e reinicie

verifique em dmesg
« Última modificação: 08 de Agosto de 2007, 02:10 por mstr »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile com video mas sem som
« Resposta #9 Online: 08 de Agosto de 2007, 08:38 »
Obrigado mstr, pela ajuda

mas o som continua não rolando.

Eta plaquinha chata no linux. ;D

[],s

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile com video mas sem som
« Resposta #10 Online: 08 de Agosto de 2007, 10:34 »
vi também uma coisa errada no seu dmesg
Citar
[  284.568000] tuner 0-004b: setting tuner address to 60
[  284.608000] tuner 0-004b: type set to tda8290+75a
[  284.720000] tuner 0-004b: setting tuner address to 60
[  284.760000] tuner 0-004b: type set to tda8290+75a

onde tem 60 quando o som estiver certo aparece 61
vai ter que alterar o tuner até conseguir acertar
os modulos saa7134 nao descarregam rmmod ou modprobe -r
tem que reiniciar, tenta o depmod -a não sei se funciona

também apanhei bastante ate acertar a minha que na realidade é uma asus
os tuner mais comuns aqui no brasil são o 3 e o 43 este muito usado pela pinacle
pelo reconhecimento do seu tuner tenta os tuners philips primeiro
« Última modificação: 08 de Agosto de 2007, 10:38 por mstr »

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Pixel View PlayTV mobile com video mas sem som
« Resposta #11 Online: 08 de Agosto de 2007, 10:51 »
No início a minha placa também não tinha som no Tvtime.
Eu resolvi isso habilitando Entrada no Controle de Volume.
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Franco Almeida

  • Usuário Ubuntu
  • *
  • Mensagens: 123
    • Ver perfil
Re: Pixel View PlayTV mobile com video mas sem som
« Resposta #12 Online: 09 de Agosto de 2007, 04:24 »
pintinho, tudo bem?

A minha placa de captura de tv é uma encore ENLTV-FM-2 com chip conexant fusion 878A, que instalei conforme postei aqui: http://ubuntuforum-pt.org/index.php/topic,17391.0.html. O vídeo é uma beleza mas nada de som. Já fiz muita pesquisa e no fórum e na net e nada de som.
Por favor veja se pode me ajudar a partir das informações abaixo:
franco@franco:~$ lspci -nn
00:00.0 Memory controller [0580]: nVidia Corporation CK804 Memory Controller [10de:005e] (rev a3)
00:01.0 ISA bridge [0601]: nVidia Corporation CK804 ISA Bridge [10de:0050] (rev a3)
00:01.1 SMBus [0c05]: nVidia Corporation CK804 SMBus [10de:0052] (rev a2)
00:02.0 USB Controller [0c03]: nVidia Corporation CK804 USB Controller [10de:005a] (rev a2)
00:02.1 USB Controller [0c03]: nVidia Corporation CK804 USB Controller [10de:005b] (rev a3)
00:04.0 Multimedia audio controller [0401]: nVidia Corporation CK804 AC'97 Audio Controller [10de:0059] (rev a2)
00:06.0 IDE interface [0101]: nVidia Corporation CK804 IDE [10de:0053] (rev a2)
00:07.0 IDE interface [0101]: nVidia Corporation CK804 Serial ATA Controller [10de:0054] (rev a3)
00:08.0 IDE interface [0101]: nVidia Corporation CK804 Serial ATA Controller [10de:0055] (rev a3)
00:09.0 PCI bridge [0604]: nVidia Corporation CK804 PCI Bridge [10de:005c] (rev a2)
00:0b.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:0c.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:0d.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:0e.0 PCI bridge [0604]: nVidia Corporation CK804 PCIE Bridge [10de:005d] (rev a3)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] [10de:0161] (rev a1)
05:06.0 Multimedia video controller [0400]: Brooktree Corporation Bt878 Video Capture [109e:036e] (rev 11)
05:06.1 Multimedia controller [0480]: Brooktree Corporation Bt878 Audio Capture [109e:0878] (rev 11)
05:08.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)

Quando uso o ID da placa no comando # modprobe -c | egrep '109e.*0878' o terminal não retorna nenhuma informação. Estou cometendo algum erro? Ou isto quer dizer que não há módulo (driver) para esta placa?

Por outro lado quando utilizo o comando  # dmesg | grep '05:06.1' retorna a seguinte mensagem:
franco@franco-desktop:~$ dmesg | grep '05:06.1'
[   38.696113] ACPI: PCI Interrupt 0000:05:06.1[A] -> Link [APC1] -> GSI 16 (level, low) -> IRQ 21
[   38.696124] bt878(0): Bt878 (rev 17) at 05:06.1, irq: 21, latency: 32, memory: 0xc0101000
Li as indicações que você fez sobre como encontar o card e o tuner mas nunca consegui encontrar o card e o tuner desta placa. Você pode me ajudar?
Utilizo o Ubuntu 7.04
Antecipadamente agradecido,

[ ]s,

Franco
« Última modificação: 09 de Agosto de 2007, 04:27 por Franco Almeida »
Disposto a aprender, disposto a compartilhar

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile com video mas sem som
« Resposta #13 Online: 09 de Agosto de 2007, 11:04 »
E o chipset bt878 é o mais suportado pelo linux.

Estas plaquinhas de captura são uma chatice. ( pelo menos a minha ) ;)

No meu caso ainda estou tendo alsa=-2 ( logo não habilitada )



No seu caso => http://www.linuxtv.org/v4lwiki/index.php/TVCapture_98

Eu acredito que basta ligar um cabo da sua placa para a entrada de som.( como descrito no link ) e habilitar a entrada de som da placa no controle de volume.

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile com video mas sem som ( alsa=-2 )
« Resposta #14 Online: 09 de Agosto de 2007, 12:11 »
a primeira coisa a fazer para instalar uma placa de captura bttv depois de muitas tentativas frustadas é procurar por restos de instalação mal sucedida para fazer isso digite no termial:
grep -Rs bttv /etc/modprobe.d/
grep -Rs bttv /etc/rc?.d/

vai retornar arquivos que tenham vinculos com o modulo bttv (provavelmente inicializando o modulo, restos de tentativas de instalações mal sucedidas)
resolva isso apague ou comente as linhas

depois no termial:
modprobe -r bttv
modprobe -r tuner
descarrega os modulos vamos conferir com lsmod o modulo bttv não esta la e nem o tuner

agora vamos começar a testar
modprobe bttv i2c_scan=1

dmesg

olhamos se reconheceu a card

se reconheceu entao continuamos
modprobe -r bttv
modprobe -r tuner
modprobe bttv card=X i2c_scan=1
X = card reconhecida

dmesg

deve aparecer tudo



se não reconheceu a card ai ferrou
pode-se tentar colocar uma card aleatoria (vai ler ve que não é e direciona para certa)

outro problema é com as empresas fabricantes (pirataria)
vc compra uma placa e recebe outra
meu caso
LTT-200 da LG recebi asus mycinema é a mesma placa
a placa do topico
Pixel View PlayTV mobile recebeu Sedna/MuchTV PC TV Cardbus TV/Radio
e outras que vi pelos foruns

e agora vem a pergunta e a sua ENLTV-FM-2
é uma nova no mercado ou é uma copia de ??
quem copia apaga a marca e não é reconhecida

outra coisa que ajuda um pouco é no lspci
05:06.0 Multimedia video controller [0400]: Brooktree Corporation Bt878 Video Capture [109e:036e] (rev 11)
[109e:036e] ->  fabricante : modelo

se vc olhar na cardlist quase todas tem esse tipo de especificações
procure pelas placas do fabricante estas podem ser
e procure pelo modelo
as vezes dá sorte

tenta esse link sobre hardware http://www.guiadohardware.net/dicas/resolvendo-problemas-hardware-linux.html

espero ter ajudado

Citar
tota tenta o seguinte se vc ta usando aquela inicialização que te dei

no arquivo '/etc/rc5.d/S90captura'
Citar
#!/bin/sh
# inicializa os modulos da placa de captura no boot
#
modprobe saa7134 i2c-scan-1
modprobe saa7134-alsa index=1
modprobe saa7134-dvb
« Última modificação: 09 de Agosto de 2007, 12:27 por mstr »