Autor Tópico: Pixel View PlayTV mobile ( Como Instalar e configurar )  (Lida 93842 vezes)

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile com video mas sem som ( alsa=-2 )
« Resposta #30 Online: 12 de Agosto de 2007, 00:53 »

se vc leu la no site, deve ter lido que algumas placas tem 2 (dois) tuners
e o tuner certo é o 61
no bttv é usado essa linha nunca testei no modulo saa7134
modprobe tuner force=0,0x61 ignore=0,0x60
para forçar o 61


Sim, mstr, li, entendi, testei e não funciona com o saa7134. Retorna um erro do saa7134.

Confirmado no meu caso. O tuner é mesmo o 60. Instalei novamente o MythTV, configurei o programa e estou tendo som seguindo as instruções do site do MythTV de como instalar o mesmo.

Confirma também o lido nos foruns sobre a incompatibilidade do TvTime em lidar com uma segunda placa de som.

O XawTV também não vai funcionar pois não suporta PAL-M ( segundo os Foruns )

Agora vou me dedicar em como entrar pelo MPlayer, o que vai ser meio difícil pelo tamanho da linha de comando e dos meus conhecimentos para tal. ( Nunca utilizei o MPlayer ).

Vou pesquisar como utilizar o sox.

Depois ainda falta o radio...( que vai ficar para depois. Tenho a web para ouvir ) e a captura de videos pelo Mencoder.

até mais,

[],s
« Última modificação: 12 de Agosto de 2007, 09:30 por Tota »

Offline Franco Almeida

  • Usuário Ubuntu
  • *
  • Mensagens: 123
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #31 Online: 16 de Agosto de 2007, 10:53 »
Amigos deste fórum,

Em primeiro lugar obrigado a todos pela paciência, generosidade e disposição para ajudar

Voltando a questão da instalação de placa de captura, o racional membro deste fórum postou o seguinte:
"Como havia dito o som da placa de captura de video não eh habilitado por padrão, e no sistema ela deve ser vista como outra placa de som. Fiz umas pesquisas e consegui fazer com que a placa de captura seja vista agora também como dispositivo de som juntamente com os outros que o sistema possa ter.

Quando entrava com o comando  "cat /proc/asound/cards" eu recebia a seguinte saida:

0 [SI7018         ]: SI7018 - SiS SI7018
                      SiS SI7018 PCI Audio at 0xd000, irq 11
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x300, irq 10

Ou seja minha placa era reconecida como dois dispositivos, um pelo Alsa(SI7018) e outro pelo OSS(UART)

executei o seguinte comando : "modprobe -r snd-bt87x; modprobe snd-bt87x load_all=1"

e desta vez ao entrar com o comando:  "cat /proc/asound/cards" novamente tive outra saida :
 
0 [SI7018         ]: SI7018 - SiS SI7018
                      SiS SI7018 PCI Audio at 0xd000, irq 11
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x300, irq 10
 2 [Bt878          ]: Bt87x - Brooktree Bt878
                      Brooktree Bt878 at 0xcddfd000, irq 5

como deu pra perceber, agora além dos dois modulos padrão de som, tenho o Bt878 que eh o som da placa de captura.

Mais não para por ai, depois q vc reinicia o sistema pede tudo isso, então vi nessa pesquisa que para colocar essas configurações no boot do sistema basta fazer o seguinte :

echo "snd-bt87x" >>/etc/modules (coloca o som do bt8tx para carregar no boot)
echo "options snd-bt87x load_all=1" >>/etc/modprobe.conf  (Eh opcional caso seja requerido)

bom agora que ja coloquei tudo no boot  vou testar galera, assim q reiniciar eu digo o q deu."
Segui esta sugestão no Feisty, mas continua a aparecer só os módulos padrão de som (alsa e oss). Já no alfa do 7.10  aparece o módulo de som da placa de captura conforme abaixo logado como root:
root@franco:/home/franco# modprobe -r snd-bt87x; modprobe snd-bt87x load_all=1
root@franco:/home/franco# cat /proc/asound/cards
 0 [CK804          ]: NFORCE - NVidia CK804
                      NVidia CK804 with ALC850 at irq 16
 1 [UART           ]: MPU-401 UART - MPU-401 UART
                      MPU-401 UART at 0x330, irq 10
 2 [Bt878          ]: Bt87x - Brooktree Bt878
                      Brooktree Bt878 at 0xc0101000, irq 21
Aqui não deu certo. Alguém mais já tentou?

Postado originalmente por racional em: http://ubuntuforum-pt.org/index.php/topic,15074.0.html

Grato a todos 

[ ]s,

Franco

Disposto a aprender, disposto a compartilhar

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #32 Online: 16 de Agosto de 2007, 13:34 »
Só não entendi se funcionou para voce ou não, Franco Almeida

Se funcionou me avise para eu postar (Resolvido) e fechar a conta.

Offline jomafras

  • Usuário Ubuntu
  • *
  • Mensagens: 2.009
  • 17.04 Zesty Zapus
    • Ver perfil
Re: Pixel View PlayTV mobile com video mas sem som ( alsa=-2 )
« Resposta #33 Online: 18 de Agosto de 2007, 11:18 »
pintinho
o Xawtv para funcionar vc tem que criar o arquivo de configuração dele por isso que não funciona
se quiser te arrumo este arquivo que também me passaram

eu uso mencoder (via linha de comando) que fiz um script

o que vejo de problematico é dificil sincronizar o inicio e o final da gravação
depois vc precisa editar ai faltam bons programas eu uso o kdenlive
mas dizem que o melhor é cinerella que nunca consegui instalar

Se vc puder disponibilizar o arquivo do Xawtv e o script do mencoder eu aceito.
Quanto ao Cinelerra,  tem pacote .deb...ja instalei aqui sem problema

http://www.estudiolivre.org/tiki-index.php?page=Tutorial+video+no+ubuntu&bl

Eu usei um outro link que não tô achando aqui mas, acho que esse tbém dá...

« Última modificação: 18 de Agosto de 2007, 12:19 por pintinho »
O Ubuntu sem dúvida é a melhor Distro.
Pesquise primeiro... só depois abra um tópico.
Canal do YouTube - Blog

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #34 Online: 18 de Agosto de 2007, 11:26 »
Também quero os scripts para xawtv e mencoder.

Depois vou abrir um tópico novo sobre o radio. Este eu tou levando uma baita surra.

Brigadão antecipadamente

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #35 Online: 19 de Agosto de 2007, 01:03 »
tota no radio vc tem que prestar atenção em 3 devs
/dev/dspX -> o som
/dev/mixerX -> os volumes
/dev/radioX -> a sintonia

eu uso o kurumin e o kradio que vem com as estações pre-sintonizadas basta escolher sua cidade

nesse link tem as configurações do xawtv http://www.forumdebian.com.br/topico-3616.html&highlight=

o mencoder tenho que ver pois uso um programa que fiz em qt e não vai rodar no ubuntu depois mando o comando todo com as explicações

vcs conhecem o devede funciona no gnome em python nunca testei  http://www.rastersoft.com/programas/devede.html
« Última modificação: 19 de Agosto de 2007, 01:13 por mstr »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #36 Online: 19 de Agosto de 2007, 08:40 »
M a r a v i l h a, sua dica do xawtv mstr,

Mas o galho da minha placa ainda é o maldito tuner. Já tentei todos os tuners do cardlist tuner e ela só funciona com o 54 dando tuner = 60 e nunca 61.

Daí que só tenho som com asound + a rec como indicado no site da alsa.

No gnome radio e no kradio eu sintonizo todas as estações, stereo, etc, mas som nadinha por causa do tuner.

O negócio é esperar mais um tempo e ver se alguma alma caridosa da Net conseguiu resolver o tuner da minha placa.

Eu já até consegui o controle remoto sem problemas.

E veja que eu pesquisei na Net antes de comprar, mas Brasilzão, com tudo via xing ling, e eu só encontrei o meu modelo como placa PCMCIA dentro do meu orçamento.

Resultado: Tenho passado mais tempo tentando configurar a placa do que convertendo minhas fitas de video. ( Não, pelo windows eu não quero )

Esperei 19 anos juntado fita e tirando mofo delas e posso esperar mais um pouco, isso se meu video cassete não enferrujar. ;D

Valeu cara pelo seu empenho, Obrigado

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #37 Online: 19 de Agosto de 2007, 23:18 »
tota um pedaço do seu dmesg
Citar
[  284.344000] input: saa7134 IR (Sedna/MuchTV PC TV  as /class/input/input8
[  284.520000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[  284.568000] tuner 0-004b: setting tuner address to 60
[  284.608000] tuner 0-004b: type set to tda8290+75a
[  284.720000] tuner 0-004b: setting tuner address to 60
[  284.760000] tuner 0-004b: type set to tda8290+75a
[  284.824000] saa7133[0]: Huh, no eeprom present (err=-5)?
[  284.844000] saa7133[0]: i2c scan: found device @ 0x96  [???]

essa placa tem dois tuners, procura como usar o outro tuner que vc resolve

esse no eeprom presente não é nada, somente que quem fabricou não gravou sua marca no local certo

da uma olhada no dmesg da minha tem umas , diferentes (no som)
Citar
k70@k70:~$ dmesg |grep saa713
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7133[0]: found at 0000:00:0a.0, rev: 208, irq: 11, latency: 32, mmio: 0xee000000
saa7133[0]: subsystem: 1131:0000, board: ASUSTeK P7131 Dual [card=78,insmod option]
saa7133[0]: board init: gpio is 40
saa7133[0]: Huh, no eeprom present (err=-5)?
tuner 0-004b: chip found @ 0x96 (saa7133[0])
saa7133[0]: registered device video1 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio1
saa7134 ALSA driver for DMA sound loaded
saa7133[0]/alsa: saa7133[0] at 0xee000000 irq 11 registered as card -1
k70@k70:~$ dmesg |grep tuner
tuner 0-004b: chip found @ 0x96 (saa7133[0])
tuner 0-004b: setting tuner address to 61
tuner 0-004b: type set to tda8290+75
« Última modificação: 19 de Agosto de 2007, 23:30 por mstr »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #38 Online: 20 de Agosto de 2007, 11:11 »
Vou procurar uma maneira de dar force 61 como no BtXXX

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #39 Online: 22 de Agosto de 2007, 21:28 »
mstr, desculpa a demora na resposta.

Usar o force não rola, pois dá uma mensagem de erro.

Original:

Código: [Selecionar]
root@tota-laptop:/home/tota# dmesg |grep tuner
[   16.964000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[   17.012000] tuner 0-004b: setting tuner address to 60
[   17.052000] tuner 0-004b: type set to tda8290+75a
[   17.164000] tuner 0-004b: setting tuner address to 60
[   17.204000] tuner 0-004b: type set to tda8290+75a

Com o comando
modprobe tuner force=0,0x61 ignore=0,0x60:

Código: [Selecionar]
root@tota-laptop:/home/tota# dmesg |grep tuner
[14778.332000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[14778.356000] tuner 0-0061: could not clearly identify tuner address, defaulting to 61
[14778.380000] tuner 0-0061: TDA827x access failed!
[14778.380000] tuner 0-0061: type set to tda8290+75
[14778.428000] tuner 0-0061: could not clearly identify tuner address, defaulting to 61
[14778.452000] tuner 0-0061: TDA827x access failed!
[14778.452000] tuner 0-0061: type set to tda8290+75
[14778.548000] tuner 0-004b: chip found @ 0x96 (saa7133[0])


root@tota-laptop:/home/tota# dmesg |grep saa
[14778.332000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[14778.548000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[14940.496000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[14940.712000] tuner 0-004b: chip found @ 0x96 (saa7133[0])


Com isto estou tentando

rmmod tuner
modprobe tuner force=0,0x4a ignore=0,0x4b

E não funcionou também.

Utilizando o sox o delay de som melhorou muito.

Código: [Selecionar]
sox -c 2 -s -w -r 32000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 32000 /dev/dsp &

tvtime --mixer=/dev/mixer:pcm
wait tvtime
t=`pidof sox`;
kill $t;
amixer -c 0 sset PCM 80%,80% unmute


Daí verifiquei que minha placa e vi que ela esta identificada

Código: [Selecionar]
root@tota-laptop:/home/tota# cat /proc/asound/cards
 0 [I82801DBICH4   ]: ICH4 - Intel 82801DB-ICH4
                      Intel 82801DB-ICH4 with AD1981B at 0xe0100c00, irq 9
 1 [SAA7134        ]: SAA7134 - SAA7134
                      saa7133[0] at 0x38000000 irq 9

Conforme eu for progredindo ( ou regredindo ) eu aviso para voce ter mais informações.

[],s

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #40 Online: 22 de Agosto de 2007, 23:19 »
vc viu a identificação do tuner 0xc2 e 0x96

[14778.332000] tuner 0-0061: chip found @ 0xc2 (saa7133[0])
[14778.548000] tuner 0-004b: chip found @ 0x96 (saa7133[0])

eu ja tinha visto algo sobre isso mas não sei onde
tenta assim

modprobe tuner force= 0xc2


Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #41 Online: 23 de Agosto de 2007, 00:14 »
mstr,


modprobe tuner force= 0xc2:

Código: [Selecionar]
[   16.760000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[   16.808000] tuner 0-004b: setting tuner address to 60
[   16.848000] tuner 0-004b: type set to tda8290+75a
[   16.960000] tuner 0-004b: setting tuner address to 60
[   17.000000] tuner 0-004b: type set to tda8290+75a
[  109.684000] tuner 0-004b: chip found @ 0x96 (saa7133[0])
[  109.732000] tuner 0-004b: setting tuner address to 60
[  109.772000] tuner 0-004b: type set to tda8290+75a
[  109.884000] tuner 0-004b: setting tuner address to 60
[  109.924000] tuner 0-004b: type set to tda8290+75a

Não rola não...

Pelo que andei pesquisando, o tuner seja qual for é responsável pela sintonia.
O som é regulado pelo modulo saa7134-alsa e é este que está fazendo minha placa não ter som.

Quando eu testo o som em => sistema=> preferencias=> som

Preferencias de som

Captura de som => saa7134 alsa

Recebo um erro:
Código: [Selecionar]
gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Não foi possível obter/atribuir configurações do/ao recurso.

Procurei pela net para este erro, mas a coisa está muito dispersa.


[],s
« Última modificação: 23 de Agosto de 2007, 00:22 por Tota »

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #42 Online: 23 de Agosto de 2007, 00:57 »
não carrega saa7134 alsa na inicialiação

tenta incluir isso na linha de  inicialização do modulo saa7134

gbuffers=32 vbibufs=32 tsbufs=32

para aumentar os buffers

como vc ta chamando ela?
« Última modificação: 23 de Agosto de 2007, 10:01 por mstr »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #43 Online: 23 de Agosto de 2007, 17:30 »
Impossivel não carregar o saa7134-alsa. Basta dar modbrobe saa7134 card=79 tuner=54 ( ou só modprobe saa7134 ) que o saa7134-alsa é carregado automáticamente.

Por que o modulo i2c é carregado no kernel do 7.04.
Quando voce levanta o saa7134 o i2c faz o resto.

Já fiz isto:

Código: [Selecionar]
install saa7134 /sbin/modprobe --ignore-install saa7134; /sbin/rmmod saa7134-alsa

Que também não traz resultado algum.

A dica do buffers eu já havia tentado sem sucesso.

Qualquer novidade posto aqui.

[],s

Offline mstr

  • Usuário Ubuntu
  • *
  • Mensagens: 379
    • Ver perfil
    • instalar qualquer placas de captura PCI
Re: Pixel View PlayTV mobile ( Como Instalar e configurar )
« Resposta #44 Online: 23 de Agosto de 2007, 22:26 »
como vc ta chamando os modulos?