Autor Tópico: (Resolvido) ATI+XGL+Compiz Fusion -> xorg.conf  (Lida 3370 vezes)

Offline Shote

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
(Resolvido) ATI+XGL+Compiz Fusion -> xorg.conf
« Online: 25 de Julho de 2007, 20:57 »
Boas, sou eu de novo  :(

Correu mal.. tentei colocar o Compiz Fusion e fiquei sem aceder ao linux. Depois de vários tutoriais e sempre com o mesmo erro (qualquer coisa "pixmap", não era possível correr na minha máquina) passei para o google e vi que para as ATI era meio complicado.

Encontrei este tutorial:

http://dicasubuntubr.wordpress.com/2007/06/30/tutorial-de-instalacao-de-uma-atixglcompiz-fusion/

A coisa emperrou aqui:

Código: [Selecionar]
...
Adicionar uma sessao xgl(terminal):

sudo gedit /usr/local/bin/startxgl.sh

e adicione:

#!/bin/sh
Xgl :1 -fullscreen -ac -accel xv:pbuffer -accel glx:pbuffer &
DISPLAY=:1
cookie=”$(xauth -i nextract - :0 | cut -d ‘ ‘ -f 9)”
xauth -i add :1 . “$cookie”
exec dbus-launch –exit-with-session gnome-session

Torne o script executavel(terminal):

sudo chmod a+x /usr/local/bin/startxgl.sh

renicie o computador.

Quando reiniciei já não dava para entrar pelo modo gráfico.. O problema terá sido por editar o xorg? ou criar aquele executável?
Pelo que percebi foi criada uma cópia desse ficheiro durante o processo:

Código: [Selecionar]
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup
Como posso restaurar a cópia através da linha de comandos?

Obrigado, meto-me em cada uma  ???
« Última modificação: 26 de Julho de 2007, 10:50 por Shote »

Offline Shote

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: ATI+XGL+Compiz Fusion
« Resposta #1 Online: 26 de Julho de 2007, 10:33 »
Bem. o meu linux é caso de estudo mesmo.. tenho pesquisado e tentado resolver este problema. Entrei em modo de texto (única possibilidade actualmente) e tentei alterar o xorg.conf. Para tal usei os comandos:

 sudo nano /etc/X11/xorg.conf
 sudo vi /etc/X11/xorg.conf

A verdade é que com qualquer um deles não me aparece o xorg.conf. Aparece como se fosse um documento em branco. Isto não deveria acontecer certo?

Já estou a ser muito chato. Mas garanto que depois de meter isto de novo a funcionar não vou mexer mais.. nem devia ter inventado mais depois do grub estar a funcionar. Mas vi um vídeo do compiz fusion e fiquei cego  ;)

Offline Shote

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: ATI+XGL+Compiz Fusion
« Resposta #2 Online: 26 de Julho de 2007, 10:47 »
Já consegui.. ele é sensível  ???

tinha que aceder

 sudo nano /etc/X11/xorg.conf
 sudo vi /etc/X11/xorg.conf

em vez de

 sudo nano /etc/x11/xorg.conf
 sudo vi /etc/x11/xorg.conf

O X é maiúsculo