Autor Tópico: Tutorial de instalação do modem smartlink (hsp56) no ubuntu 7.04  (Lida 45705 vezes)

gabriel.goc

  • Visitante
    Este tutorial visa a instruir a instalação de modens com o chipset da Smartlink, alguns pctel e HSP56 também.



Observações importantes:
   1°: Se você já tentou instalar o modem outras vezes e não obteve sucesso, o ideal seria reinstalar o sistema, se for viável, como foi indicado pelo usuário alarcon.
   2°: Jamais atualize o pacote sl-modem-daemon pelo sistema de atualizações do ubuntu, preste atenção nisso, pois a sua atualização será indicada, se for atualizar o sistema. Certifique-se de ter desmarcado o item referente a atualização desse pacote



    Bom, vamos lá:
O primeiro passo é baixar todos os pacotes necessários para a instalação em um outro computador ou SO com acesso a internet:
    Lá vai a lista de pacotes(baixe-os na sua pasta "home"):
Gnome-ppp(Discador) - http://mirrors.kernel.org/ubuntu/pool/universe/g/gnome-ppp/gnome-ppp_0.3.23-1_i386.deb

Obs.: Para saber o driver que deve ser instalado, é necessário saber a versão do seu kernel, para isso, abra o terminal e digite: uname -r

Driver smartlink (PARA KERNEL 2.6.20-15-generic) - http://linmodems.technion.ac.il/packages/smartlink/Ubuntu/slamr-2.6.20-15-generic.tar.gz
 ou
Driver Smartlink(PARA KERNEL 2.6.20-16-generic) - http://linmodems.technion.ac.il/packages/smartlink/Ubuntu/slamr-2.6.20-16-generic.tar.gz




Instalação:

Abra o terminal (Aplicações->Acessórios->Terminal) e digite:
 sudo dpkg -i gnome-ppp_0.3.23-1_i386.deb
(Será pedido o "password", que é a senha que você optou na instalação.)

Depois digite este comando para descompactar o driver:

tar -vzxf slamr-`uname -r`

Agora entre na pasta:
cd slamr-`uname -r`

Após entra na pasta, edite o arquivo setup:
gedit setup

Altere a linha country:
//echo driver=$driver
COUNTRY=USA <------------------- Esta Aqui, Ao invés de USA, ponha BRAZIL (Com z e letra da maiuscula)
echo "When asked about your country, Enter:"//
Salve o arquivo, e feche-o.

Estamos chegando a etapa final.
Dê a permissão para o arquivo ser executado:
chmod +x setup

Agore é só executá-lo:
sudo ./setup



Configuração:
Abra o Gnome-ppp(Aplicações->Internet->Gnome ppp):
1°: Vá em configurações e em modem, clique em detectar.
2°: Vá à aba opções, e somente selecione estes itens:
    -Minimizar
    -Mostrar na área de notificação
    -Abortar conexão se a linha estiver ocupada
    -Verificar portadora
    -Verificar rota padrão
    -Ignorar sequências de terminaal(Modo burro)

Obs.: Deixe o resto desmarcado.

Se todos os passos fora feitos da forma correta e nenhum erro foi ocasionado, você já deve estar apto a conectar.

Agora é só preencher o nome do usuário, senha e número de acordo com o seu provedor preferido.

Espero ter ajudado.  ;D

=]



Solução de problemas:

1) Modem começa a conectar mas cai antes de completar:
Tente desativar o item "desativar portadora" e/ou "verificar rota padrão" nas opções do Gnome-PPP

2)Problemas com instabilidade

Tente modificar a "string init 2" que está nas configurações do do gnome PPP (Sequências de inicialização);
Esta string fará com que o modem não espere para discar: ATQ0 V1 E1 S0=0 X3 &C1 &D2 +FCLASS=0
Esta vai limitar a conexão a baixas frequências: ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=34
E esta usará o protocolo V90, ao invéz do V92: ATQ0 V1 E1 S0=0 X3 &C1 &D2  +MS=90

A string padrão é ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0.

Obs.: Somente coloque essas string na linha "Init 2"; uma de cada vez.

3) Conecta, mas não navega:

Abre o terminal e digite:
sudo route add default ppp0

4) Conecta, porém só navega em alguns sites:

Abra o gnome-ppp vá em Configuração na aba Rede na parte sobre DNS deixe marcado DSN Manual feche e saia do gnome-ppp. Agora via terminal digite: gedit .wvdial.conf e nesta parte:

;Nameserver =
;Nameserver2 =

Coloque os DNS do seu provedor nesses dois itens, respectivamente.
(Dica feita graças a ajuda do usuário Alarcon)
« Última modificação: 10 de Julho de 2007, 12:52 por gabriel.goc »

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #1 Online: 02 de Junho de 2007, 18:54 »
Para quem tentou todas as dicas deste tópico aqui e ainda não obteve sucesso vejam este link aqui e veja se para o seu caso funciona:

http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490


Lembrando que o melhor seria reinstalar o Ubuntu Linux 7.04 Feisty Fawn antes de testar o pacote deste link para que as tentativas anteriores não atrapalhem, isto, é claro, para quem puder reinstalar o sistema.

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #2 Online: 03 de Junho de 2007, 08:21 »
Exato!  :D
Uma reinstalação seria ideal, vou acrescentar isso ao meu tópico...
Ah, e também vale ressaltar, que o sistema de atualização do ubuntu, sempre pede a instalação do sl-modem-daemon mais novo, o que resulta uma série de erros...
Serial legal você colocar no seu tópico um aviso para que atualização desse pacote mão seja feita.
Abraços.

Offline csilva

  • Usuário Ubuntu
  • *
  • Mensagens: 125
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #3 Online: 03 de Junho de 2007, 22:39 »
Pessoal,

Uso o kubuntu desde o dapper, e o mesmo acontece com o feisty: para habilitar meu modem eu apenas instalo o sl-daemon e à partir daí é só configurar o kppp e conectar.

Meu modem é: 00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)

 O único problema é que tenho que dar o comando: /etc/init.d/sl-daemon restart, toda vez que reinicio o computador, para habilitar o modem.

Estou querendo saber como fazer isto se tornar automático a cada  boot.

Obrigado pela ajuda!

Conhecendo o Linux...

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #4 Online: 04 de Junho de 2007, 13:04 »
Não sei o que pode estar acontecendo, mas tenta fazer isto:
Abra o terminal e digite:
sudo kedit /etc/init.d/modem-start

Aparecerá um arquivo em branco, acrescente isto  à ele:
#!/bin/bash
/etc/init.d/sl-modem-daemon stop &
sleep 5
/etc/init.d/sl-modem-daemon start

Salve o arquivo; feche o kedit.
Digite no terminal:
sudo chmod +x /etc/init.d/modem-start

Reinicie o computador, e veja se esta funcionando.
Espero ter ajudado
« Última modificação: 21 de Junho de 2007, 15:58 por gabriel.goc »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #5 Online: 21 de Junho de 2007, 16:00 »
Tutorial atualizado para a nova versão do kernel, que é indicada após uma atualização do sistema.

Se você perdeu o acesso ao modem após a atualização é só seguir os passos descritos no tutorial relacionados ao kernel 2.6.20-16.

Espero ter ajudados todos..
xD

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #6 Online: 22 de Junho de 2007, 16:00 »
Olá gabriel.goc,
sou novo no ubuntu, mas não no linux, tive algumas experiencias frustantes com uma distro chamada fenix, mas isto é passado, estava usando o win xp, quando soube do lançamento do ubuntu 7.04,solicitei o cd live e instalei em dual boot, funcionou legal, mas não reconheceu o modem. Depois de muita pesquisa descobri este fórum e segui o que foi sugerido por você, mas não funcionou, depois segui  rigorosamente o tutorial :

Para quem tentou todas as dicas deste tópico aqui e ainda não obteve sucesso vejam este link aqui e veja se para o seu caso funciona:

http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490


Lembrando que o melhor seria reinstalar o Ubuntu Linux 7.04 Feisty Fawn antes de testar o pacote deste link para que as tentativas anteriores não atrapalhem, isto, é claro, para quem puder reinstalar o sistema.

o modem funcionou e o discador(gnomeppp) também, mas não estou conseguindo navegar corretamente, as páginas do ubuntu e do próprio mozilla, por exemplo, simplesmente não abrem no firefox e o sistema não está conseguindo atualizar, o sistema informa que não tem conecção com a internet. Por favor me orientem, o que fazer?

O perfil do meu pc é placa mãe p4v800-m da phitronics, memoria de 512mb, hd de 40gb e modem conexante hsp56mr(via) id modem-1106:3068.

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #7 Online: 22 de Junho de 2007, 18:15 »
Abra o terminal e digite este comando:
sudo route add default ppp0
veja se funcionou...

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #8 Online: 22 de Junho de 2007, 23:46 »
Boa Noite,
retornou a resposta:

quando estou desconectado - SIOCADDRT: Não há tal dispositivo
quando estou conectado - SIOCADDRT: O arquivo já existe

e outro detalhe, hoje quando eu tentei usar o apt-get, pela enesima vez, apareceu a mensagem, `/home/17001013/.wvdial.conf arquivo inexistente,
detalhe, o arquivo wvdial.conf existe e está na diretorio pessoal. Outra coisa o numero 17001013 é o numero do provedor itelefonica.
« Última modificação: 23 de Junho de 2007, 00:14 por jaioliver »

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #9 Online: 23 de Junho de 2007, 10:07 »
Que negócio estranho...  :o
Pow digita isso no terminal:
lspci

Posta o resultado aqui.
Mas eu acredito, que como o seu modem é conexant, o driver está incorreto.

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #10 Online: 23 de Junho de 2007, 14:04 »
Resposta do comando lspci foi:

00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge 00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge 00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)

Tenho algumas suspeitas, veja se tem fundamento:
    o kernel que uso é o 2.6.20-15 e talvez o pacote de instalação sugerido por alarcom no
http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490
talvez esteja usando outra versão do kernel.
substitui o drive que estava usando para o Driver smartlink (PARA KERNEL 2.6.20-15-generic) que vc sugeriu e teve o mesmo resultado.
   acredito que o drive esta correto, pois o modem funciona, mesmo que não totalmente integrado ao sistema. Acho que falta corrigir esta integração mas não sei como.

Pergunto: será que se fizermos a instalação do gcc, do build-essential e do linux-headers novamente resolveria? Mesmo que fosse necessário reinstalar o sistema.

De qualquer modo te agraceço a oportunidade de aprender mais sobre o Ubuntu-linux e a sua atenção. Muito obrigado.
« Última modificação: 23 de Junho de 2007, 14:07 por jaioliver »

alarcon

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #11 Online: 23 de Junho de 2007, 18:20 »
Resposta do comando lspci foi:

00:00.0 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge 00:00.2 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. PT890 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:00.7 Host bridge: VIA Technologies, Inc. CN700/VN800/P4M800CE/Pro Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge 00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
01:00.0 VGA compatible controller: VIA Technologies, Inc. UniChrome Pro IGP (rev 01)

Tenho algumas suspeitas, veja se tem fundamento:
    o kernel que uso é o 2.6.20-15 e talvez o pacote de instalação sugerido por alarcom no
http://ubuntuforum-pt.org/index.php/topic,4204.msg113490.html#msg113490
talvez esteja usando outra versão do kernel.
substitui o drive que estava usando para o Driver smartlink (PARA KERNEL 2.6.20-15-generic) que vc sugeriu e teve o mesmo resultado.
   acredito que o drive esta correto, pois o modem funciona, mesmo que não totalmente integrado ao sistema. Acho que falta corrigir esta integração mas não sei como.

Pergunto: será que se fizermos a instalação do gcc, do build-essential e do linux-headers novamente resolveria? Mesmo que fosse necessário reinstalar o sistema.

De qualquer modo te agraceço a oportunidade de aprender mais sobre o Ubuntu-linux e a sua atenção. Muito obrigado.

Bom quando fiz os meus pacotes usava um modem HSP56 MR (VIA) e o mesmo sempre funcionou com várias distribuições linux que já testei e com várias versões do driver Smartlink utilizados por mim, portanto creio eu que a possibilidade de incompatibilidade com o driver Smartlink e o sistema linux é zero.

Tente, se puder, fazer a instalação do meu pacote para o Ubuntu 7.04 Feisty do zero, ou seja, reinstale o Ubuntu e somente depois tente usar o pacote que fiz. Só um detalhe o meu pacote verifica qual é o kernel em uso ( comando uname -r ) e só instala o linux-headers correspondente a esta versão do kernel, desde que a mesma esteja no LiveCD do Ubuntu.

Pode ser algum problema de rota que ao invés de ir para o modem esteja indo para a placa de rede, mas o colega aí em cima já deu a dica de como resolver. Veja o arquivo guia_instalação por completo do meu pacote para ver se dá uma luz.

Outra coisa antes de usar o gnome-ppp abra um terminal e digite:

sudo /etc/init.d/sl-modem-daemon restart

Depois tente usar o gnome-ppp e veja se muda alguma coisa.

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #12 Online: 23 de Junho de 2007, 22:45 »
Olá Alarcon,
Fiz exatamente como voce sugeriu, reinstalei o sistema, fiz a instalação do drive do modem seguindo o manual ao "pé-da-letra", segui o que diz no manual sobre a correção de erros, dei o comando que vc sugeriu, e que também consta no manual:

sudo /etc/init.d/sl-modem-daemon restart

mas a situação é a mesma, navego em algumas páginas da internet, como o Google, Orkut, UOL e só, quando tento atualizar o sistema, utilizar o apt-get update, ou simplesmente navegar no site do Ubuntu, como este não consigo, o sistema diz que não há conecção com a internet. Não sei mas o que fazer. :'(
PS.: Consegui fazer com que o sistema fizesse a conecção de rede via modem, mas mesmo assim não funcionou. O ícone do monitor de rede pisca informando que existe uma conecção ativa, mas atualizar ou mesmo navegar corretamente, nada.

Já cogito a possibilidade de excluir definitivamente o Ubuntu e o pior é que tenho colegas de trabalho para quam eu já dei os CD Live que recebi e eles só estão esperando solucionar este problema para instalar nos PC deles também. Ubuntu deveria levar em conta que no Brasil ainda se usa muito a conecção discada via softmodem.
Infelizmente mais uma experiencia decepcionante com linux.

Por favor aguardo uma sugestão.

Muito obrigado a todos pela atenção e pela paciência.

gabriel.goc

  • Visitante
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #13 Online: 23 de Junho de 2007, 23:09 »
humnn...
Muito estranho isso, mas não desista...
Às vezes um passo errôneo por mais simplório que seja pode tah ocasionando este erro...
Mas me diga uma coisa, o que acontece quando você instala o pacote que eu sugeri??

Ahhh, e uma notícia boa, os "winmodens" virão com suporte nativo na próxima versão do ubuntu..
:)

Offline jaioliver

  • Usuário Ubuntu
  • *
  • Mensagens: 40
    • Ver perfil
Re: Tutorial de instalação do modem smartlink no ubuntu 7.04
« Resposta #14 Online: 24 de Junho de 2007, 00:07 »
Olá Gabriel.goc

A instalação ocorre sem erros, tive a curiosidade de olhar todos os passos da instalaçao que aparecem no terminal e não vi nenhum erro. Troquei de provedor, tentei Oi internet, Ig, mas deu na mesma. Com Oi Internet foi até pior. Se vc achar necessário, posso instalar tudo novamente e mandar para vc a tela do terminal de instalação.
Mas não houve, em momento algum mensagem de erro.
Podemos verificar manualmente a rota que o apt-get segue para se conectar a internet? Talvez o problema esteja na rota que ele está apontando. Talvez seja um erro durante a instalação do sistema. Será que podemos verificar este parâmetro e talvez modificá-lo?
Achamos que ele estava apontando para a placa de rede, mesmo desabilitada, e se ainda continua apontando, não podemos forçar uma mudança de rota?
Já troquei o CD Live durante a instalação e deu o mesmo, verifiquei se o CD não estava sujo ou arranhado para não comprometer a gravação.
No último caso espero o lançamento da próxima versão; quem sabe.

De qualquer modo agradeço muitíssimo a ajuda, e a paciência, de todos voces, e vamos continuar tentando, pois a coisa esta ficando cada vez mais interessante.