Autor Tópico: AMD64 Feisty 7.04 Flash  (Lida 2860 vezes)

Offline LaNCeloT_RW

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
AMD64 Feisty 7.04 Flash
« Online: 20 de Abril de 2007, 06:26 »
Pessoal,

vi que alguns tutoriais aqui falam que as dicas que estão no link (https://help.ubuntu.com/community/FirefoxAMD64FlashJava) funcionam para o Feisty (7.04) 64-Bit.
Bom, eu testei e o erro encontrado foi que o Firefox procura pelo arquivo libdl.so.1 sendo que no Ubuntu Feisty não temos esse arquivo, temos o libdl.so.2.
Portanto, vou postar aqui um tutorial que encontrei com a ajuda do fluid do #ubuntu da rede irc.freenode.com.

*** não vou traduzir o tutorial original completo, apenas as partes relevantes ***
Link para o Original:

http://ubuntuforums.org/showthread.php?t=341727

Seguem abaixo os passos para fazer funcionar, sem precisar do Firefox 32-Bits.

Primeiro passo:
Instalar as libs essenciais para o funcionamento do Flash 32-Bit.

Digite no Terminal/Shell/Console (como queira chamá-lo :-P )

Citar
sudo apt-get install ia32-libs ia32-libs-gtk linux32 lib32asound2 <enter>

Após instalado...


Segundo Passo:

Baixe o arquivo que está no link abaixo e salve-o em um local que saiba onde é:
http://gwenole.beauchesne.info/projects/nspluginwrapper/files/nspluginwrapper-0.9.91.2-1.x86_64.rpm

Como o arquivo acima é um .rpm, vamos convertê-lo para .deb (pacote utilizado pelo Ubuntu)

Código: [Selecionar]
sudo apt-get install alien
Agora, acesse o diretório onde você salvou o arquivo baixado nspluginwrapper-0.9.91.2-1.x86_64.rpm

e digite o seguinte:

Código: [Selecionar]
sudo alien nspluginwrapper-0.9.91.2-1.x86_64.rpm
o ALIEN converterá para .deb o arquivo .rpm.

Feito isso, continue no diretório e digite:

Código: [Selecionar]
sudo dpkg -i nspluginwrapper-0.9.91.2-1.x86_64.deb
Terceiro passo

Baixe o plugin do Flash:
http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz

A partir desse momento você deve fechar todas as janelas do seu browser. Dica: copie o resto do tutorial em um arquivo de texto.

Descompacte esse arquivo baixado em um lugar onde você saiba.

Após descompactada faça o seguinte:
Mova os dois arquivos: "libflashplayer.so” e “flashplayer.xpt” do diretório descompactado para dentro de /usr/lib/mozilla/plugins

após isso, dê o comando:

Código: [Selecionar]
nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so
Se tudo der certo, retornará ao prompt sem mensagens.

Você verá que foi criado um arquivo chamado: “npwrapper.libflashplayer.so” dentro da pasta .mozilla dentro da pasta do seu usuário.

Copie esse arquivo para dentro de /usr/lib/mozilla/plugins e copie também dentro de /usr/lib/mozilla-firefox/plugins

Pronto!

Agora abra o firefox e http://www.youtube.com e teste se funcionou!

Acredito que sim.. aqui eu não tive problemas.

LaNCeloT_RW

Offline ronaldo_novais

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: AMD64 Feisty 7.04 Flash
« Resposta #1 Online: 22 de Abril de 2007, 23:56 »
Boa noite....

Grata surpresa ao encontrar essa sequência de comandos que, enfim, fariam no meu amd 64, funcionar o Flash...

Segui todas as rotinas, mas não deu certo... na verdade não cheguei a concluir pois no terceiro passo, onde eu executo o comando:
nspluginwrapper -i /usr/lib/mozilla/plugins/libflashplayer.so

o resultado não é o esperado, ou seja, não foi criado o arquivo npwrapper.libflashplayer.so na pasta .mozilla.
Na verdade, quando executo o comando acima aparece a seguinte mensagem:
nspluginwrapper: /usr/lib/mozilla/plugins/libflashplayer.so is not a valid NPAPI plugin

Agradeceria se vc me mostrasse onde estou errando...

Abraço.



Offline LaNCeloT_RW

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: AMD64 Feisty 7.04 Flash
« Resposta #2 Online: 24 de Abril de 2007, 02:30 »
Amigo,

não sei onde está errando, mas de qualquer forma, para pularmos o passo de criar o arquivo com o nspluginwarapper, está aqui: http://www.esnips.com/web/fbhzsOtherStuff/ para download os arquivos que ele criou na minha máquina.

Depois baixá-los, copie esses arquivos para dentro de /usr/lib/mozilla/plugins e copie também dentro de /usr/lib/mozilla-firefox/plugins

pode ser que resolva.

 ;) :D