Autor Tópico: Problema no boot (initramfs)  (Lida 11989 vezes)

Offline Filipe Schuab

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Problema no boot (initramfs)
« Online: 20 de MAR?O de 2015, 11:46 »
Bom dia pessoal! Preciso da ajuda de vcs...não sei mais o que fazer, estou instalando o Ubuntu Server em um Dell PowerEdge R200, a instalação ocorre tudo bem, porém no boot dá erro, e para na tela (initramfs), se der Ctrl+D ele continua normal, porém, não posso deixar esse erro. Alguém sabe o que posso fazer para corrigir??

Agradeço desde já.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #1 Online: 20 de MAR?O de 2015, 13:15 »
Faltou melhores informações sobre o hardware e principalmente sobre o filesystem adotado (quantos discos? RAID? LVM? algo diferente?) e também a versão do Ubuntu Server.

Inicialmente pode-se tentar duas providências:

1) experimente subir o sistema usando na cmdline:

Código: [Selecionar]
acpi=off
2) Se isso não funcionar, experimente reparar o grub.

Código: [Selecionar]
sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list

sudo apt-get update

sudo apt-get install -y boot-repair && (boot-repair &)


Confira esse tópico:

Boot-Repair-Ubuntu para recuperação do Grub-2

http://ubuntuforum-br.org/index.php/topic,84609.0.html

E mais extensivamente esse:

Mil e uma maneiras de recuperar GRUB 2, GRUB 2 EFI e GRUB.

http://ubuntuforum-br.org/index.php/topic,14614.0.html
« Última modificação: 20 de MAR?O de 2015, 13:26 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #2 Online: 20 de MAR?O de 2015, 14:04 »
Adicionalmente, não sei se realmente se aplicaria, porém a descrição do problema parece semelhante e indica como solução editar /etc/default/grub alterando de:

GRUB_CMDLINE_LINUX=""

para:

Código: [Selecionar]
GRUB_CMDLINE_LINUX="rootdelay=90 nomodeset"
Salvar e executar:

Código: [Selecionar]
sudo update-grub
Confira aqui:

http://ubuntuforums.org/archive/index.php/t-1877789.html
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Filipe Schuab

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #3 Online: 20 de MAR?O de 2015, 16:52 »
Não possuo muito conhecimento no Linux nao, mas vamos lá...
Aqui é um Quad-Core 2.66
2Gb DDR2

Usa SCSI, já fiz instalação com LVM e sem LVM, sobre o filesystem, nao sei se é isso que vc quer saber, mas utilizei EXT4.
Já utilizei a versão 12.04 e a 14.04, ambos dão o mesmo problema.

Quanto ao que vc falou, onde coloco esse acpi=off ?
como disse não tenho conhecimento...

Instalei o Windows 7 para fazer teste, e funcionou normalmente.
O rootdelay=90 eu ja fiz e não deu certo.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #4 Online: 20 de MAR?O de 2015, 17:22 »
Citar
onde coloco esse acpi=off

Para experimentar pode colocar de forma provisória na cmdline do menu do grub, isto é, na linha que inicializa o sistema quando faz o boot.

Normalmente essa linha na tela inicial do sistema, menu inicial do grub, menu onde se escolhe qual sistema operacional quer carregar em sistemas mutiboot ou ainda qual kernel quer carregar, é algo parecido com isso:

BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic root=UUID=f4f14b99-4e2c-4229-86f9-1143d367f9c3 ro quiet splash

aí é só acrescentar editando lá mesmo para ficar assim:

BOOT_IMAGE=/boot/vmlinuz-3.13.0-32-generic root=UUID=f4f14b99-4e2c-4229-86f9-1143d367f9c3 ro quiet splash acpi=off

Evidentemente que os dados concretos de kernel e uuid serão diferentes e específicos aí para o seu sistema, portanto acima é só um exemplo.

Então para iniciar o sistema, para fazer o boot, se utiliza Ctrl X (não é [enter] )

Essa alteração é provisória e se perde no próximo boot.

Caso isso dê certo, então é só alterar para ficar definitivo lá no mesmo arquivo /etc/default/grub na linha já mencionada:

GRUB_CMDLINE_LINUX="acpi=off"

No momento não tenho certeza se precisa mesmo manter as aspas aí em cima quando se trata de um parâmetro único, só conferindo com e sem.

Editando: claro que precisa manter as aspas, sem o que ficaria dois sinais de = consecutivos, coloque entre aspas.

Depois, claro, sempre:

sudo update-grub




« Última modificação: 23 de MAR?O de 2015, 13:29 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #5 Online: 20 de MAR?O de 2015, 17:32 »
Complementando: depois que sobe o sistema, para conferir se subiu mesmo com o parâmetro correto colocado na cmdline, é só fazer numa janela do terminal:

cat /proc/cmdline

Isso irá mostrar a linha de carga do boot utilizada.
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #6 Online: 20 de MAR?O de 2015, 18:01 »
Passe aqui alguma informação sobre o(s) disco(s) do sistema para que se possa raciocinar melhor sobre o caso.
Faça num terminal, copie e cole aqui o resultado:

Código: [Selecionar]
sudo fdisk -l

(sinal de hífen mais letra ele aí no final do comando)

Código: [Selecionar]
sudo parted -l
idem sinal de hífen etc.

Código: [Selecionar]
sudo hdparm -I /dev/sdx
O parâmetro é a vogal i (com na palavra india) em maiúscula ( I )

O 'x' acima em sdx você substitui pelo caso concreto aí no sistema, conforme o fdisk aponta.
Se for disco único será sda ou então sdb, sdc, conforme sejam os discos do sistema.
« Última modificação: 23 de MAR?O de 2015, 13:30 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Filipe Schuab

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #7 Online: 23 de MAR?O de 2015, 12:07 »
So pra informar, esse é o erro que está dando.

BusyBox V1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
Enter 'help' for a lit of built-in commands.

(initramfs) [ 34.480591] sd 2:1:0:0: [sda] No Caching mode page found
[  34.481777] sd 2:1:0:0 [sda] Assuming drive cache: write through

Vou fazer aqui o que vc falou e reporto. Vlw

Offline Filipe Schuab

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #8 Online: 23 de MAR?O de 2015, 12:35 »
Coloquei o acpi=off

agora apareceu assim

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
  - check rootdelay= (did the system wait long enough?)
  - check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuuid/a408d238-deae-4453-ba67-6b7af5a6a160 does not exist.
Dropping to a shell!

BusyBox V1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
Enter 'help' for a lit of built-in commands.

(initramfs) [ 34.480591] sd 2:1:0:0: [sda] No Caching mode page found
[  34.481777] sd 2:1:0:0 [sda] Assuming drive cache: write through

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #9 Online: 23 de MAR?O de 2015, 13:37 »
Citar
ALERT! /dev/disk/by-uuuid/a408d238-deae-4453-ba67-6b7af5a6a160 does not exist.


Faz, por favor, mais dois comandos, além daqueles anteriores:

Código: [Selecionar]
cat /etc/fstab


sudo blkid
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline Filipe Schuab

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #10 Online: 23 de MAR?O de 2015, 15:15 »

Código: [Selecionar]
sudo fdisk -l


Disco /dev/sda: 72.7 GB, 72746008576 bytes
255 cabeças, 63 setores/trilhas, 8844 cilindros, total de 142082048 setores
Unidades = setores de 1 * 512 = 512 bytes
Tamanho do setor (lógico/físico): 512 bytes / 512 bytes
Tamanho da E/S (mínimo/ideal): 512 bytes / 512 bytes
Identificador do disco: 0x000a6c93

Dispositivo Boot      Início        Fim      Blocos   Id  Sistema
/dev/sda1   *        2048   137889791    68943872   83  Linux
/dev/sda2       137891838   142079999     2094081    5  Estendida
/dev/sda5       137891840   142079999     2094080   82  Linux swap / Solaris


Código: [Selecionar]
sudo parted -l


Modelo: Dell VIRTUAL DISK (scsi)
Disco /dev/sda: 72,7GB
Tamanho de setor (lógico / Físico): 512B/512B
Tabela de Partição: msdos

Número  Início  Fim     Tamanho  Tipo      Sistema de arquivos  Sinalizador
 1      1049kB  70,6GB  70,6GB   primary   ext4                 boot
 2      70,6GB  72,7GB  2144MB   extended
 5      70,6GB  72,7GB  2144MB   logical   linux-swap(v1)


Código: [Selecionar]
sudo hdparm -I /dev/sdx


/dev/sda:
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 18 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

ATA device, with non-removable media
   Model Number:       �������@���(�����(�����K
   Serial Number:      �������������
   Firmware Revision:  ���@�
Standards:
   Likely used: 1
Configuration:
   Logical      max   current
   cylinders   0   59904
   heads      0   65535
   sectors/track   510   0
   --
   CHS current addressable sectors:          0
   Logical/Physical Sector size:           512 bytes
   device size with M = 1024*1024:           0 MBytes
   device size with M = 1000*1000:           0 MBytes
   cache/buffer size  = unknown
Capabilities:
   IORDY not likely
   Buffer type: 8d00: dual port, multi-sector with read caching ability
   Buffer size: 255.5kB   bytes avail on r/w long: 59904
   Can perform double-word IO
   R/W multiple sector transfer: Max = 255   Current = ?
   DMA: not supported
   PIO: unknown



Código: [Selecionar]
cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=cef72ab1-969b-4da5-8b6e-e92a6187bc12 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=a9909056-2816-4ca9-b107-9688b69c2ba9 none            swap    sw              0       0

Código: [Selecionar]
sudo blkid

/dev/sda1: UUID="cef72ab1-969b-4da5-8b6e-e92a6187bc12" TYPE="ext4"
/dev/sda5: UUID="a9909056-2816-4ca9-b107-9688b69c2ba9" TYPE="swap"

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #11 Online: 25 de MAR?O de 2015, 04:05 »
1) Curioso, o hdparm não informou o estado do checksum do disco no final do comando?

2) De onde apareceu aquele uuid (ALERT! /dev/disk/by-uuuid/a408d238-deae-4453-ba67-6b7af5a6a160 does not exist.) já que não existe na unidade e tampouco está relacionado no fstab?
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.552
    • Ver perfil
Re: Problema no boot (initramfs)
« Resposta #12 Online: 25 de MAR?O de 2015, 04:10 »
Verifique a 'saúde' desse hd, instale o smartmontools:

Código: [Selecionar]
sudo apt-get install smartmontools
depois faça:

Código: [Selecionar]
sudo smartctl -a /dev/sda
Talvez seja necessário especificar o tipo de dispositivo:

Código: [Selecionar]
sudo smartctl -a -d scsi /dev/sda
Não sei se essa unidade tem suporte SMART.

De toda forma, se tiver, faça também o teste longo (extended self-test):

Código: [Selecionar]
sudo smartctl -a -d scsi --test=long /dev/sda
Pode demorar bastante para ser executado.
O teste é executado em segundo plano e na verdade não há nenhum indicativo na tela de que está sendo executado após uma mensagem do tipo abaixo, onde há um simples indicativo de que foi iniciado (begun), duração (83 minutes) e horário de termino (17:27 etc)0.
Como está lá anotado, usar smartctl -X no prompt aborta o teste.

-----------------------

=== START OF OFFLINE IMMEDIATE AND SELF-TEST SECTION ===
Sending command: "Execute SMART Extended self-test routine immediately in off-line mode".
Drive command "Execute SMART Extended self-test routine immediately in off-line mode" successful.
Testing has begun.
Please wait 83 minutes for test to complete.
Test will complete after Tue Mar 24 17:27:23 2015

Use smartctl -X to abort test.

-----------------------

Ao final um:

Código: [Selecionar]
sudo smartctl -l selftest /dev/sda
mostrará um sumário dos testes.

Repita:

Código: [Selecionar]
sudo smartctl -a -d scsi /dev/sda
para ter a posição atualizada após o extend offline.


Talvez ao invés disso seja preferível montar um live-pendrive desktop do 14.04 , instalar e executar o GSmartControl, que é o front-end,  pela Central de Programas do Ubuntu, questão de gosto.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.