Autor Tópico: /etc/sudoers é possuído por uid 33, deveria ser 0  (Lida 1749 vezes)

Offline AndreyDuarte

  • Usuário Ubuntu
  • *
  • Mensagens: 1
    • Ver perfil
/etc/sudoers é possuído por uid 33, deveria ser 0
« Online: 02 de Outubro de 2012, 17:10 »
Boa tarde galera,

Ontem estava instalando asterisk 1.8.17 e não havia instalado uma biblioteca chamada libssl-dev, mas até descobrir isso mexemos em muita coisa... e talvez, TALVEZ tenha feito alguma besteira. Pois bem, hoje meu sistema nao deixa mais eu logar no root, dando a seguinte mensagem:

#sudo su
sudo: /etc/sudoers é possuído por uid 33, deveria ser 0
sudo: nenhuma fonte válida sudoers encontrada, saindo
sudo: incapaz de inicializar plug-in de politica

pois bem, para eu ter aberto um topico é porque eu estou sem recursos, ja procurei muito e o que encontrei foi isso:
http://www.vivaolinux.com.br/topico/Ubuntu-e-Kubuntu/Comando-sudo-nao-funciona/?pagina=1&num_por_pagina=12
Um cara com o mesmo problema e resolvido por meio de FAILSAFE. só que fui tentar acessar esse modo failsafe mas não consigo, segui esse link:
http://www.ehow.com/how_8622704_boot-ubuntu-failsafe-graphics-mode.html

Eu entrei na tela de instalação mas quando aperto f4 nao acontece nada...


Alguem pode me ajudar?
Grato.

Offline selvaking

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.142
  • Parque Anchieta - Rio de Janeiro - RJ
    • Ver perfil
Re: /etc/sudoers é possuído por uid 33, deveria ser 0
« Resposta #1 Online: 03 de Outubro de 2012, 01:05 »
Se vc criou senha pro usuario root, tente somente o "su" e use a senha do root.
Dê-me um computador com o Tux que movo o mundo!

Linux User #323049

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.524
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: /etc/sudoers é possuído por uid 33, deveria ser 0
« Resposta #2 Online: 04 de Outubro de 2012, 11:47 »
Dê boot com o LiveCD de instalação, carregue o Ubuntu sem instalar.
Monte sua partição raiz, vá para o diretório "etc" dentro do ponto de montagem e execute o comando abaixo:

sudo chown root:root sudoers

depois saia do diretório, desmonte sua partição, e reboote o sistema. Supondo que o problema seja só esse, deve resolver.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D