Autor Tópico: É impossivel corrigir problemas,voce manteve (hold) pacotes quebrados.  (Lida 13979 vezes)

Offline RodoNext

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Pessoal estou com o seguinte problema: estava a usar o libreoffice 3.6.0 e fui atualizar para a nova versão 3.6.1 pelo terminal. Aconteceu erro na instalação, por teimosia desinstalei a versão 3.6.0 pelo synaptic, e tornei a instalar pelo terminal. O problema é que aconteceu alguma coisa que não permite instalar a versão nova e nem instalar a versão antiga.
Já tentei alguns comandos basicos como, apt-get install -f (não consta nada), apt-get update (atualiza normalmente), mas quando tento instalar o libreoffice tanto pelo terminal quanto pelo synaptic tenho a seguinte mensagem:

Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
Alguns pacotes não puderam ser instalados. Isto pode significar que
você solicitou uma situação impossível ou, se você está usando a
distribuição instável, que alguns pacotes requeridos não foram
criados ainda ou foram retirados da "Incoming".
A informação a seguir pode ajudar a resolver a situação:

Os pacotes a seguir têm dependências desencontradas:
 libreoffice : Depende: libreoffice-core (= 1:3.6.0~rc4-0ubuntu3~ppa1~precise1) mas não será instalado
               Depende: libreoffice-writer mas não será instalado
               Depende: libreoffice-calc mas não será instalado
               Depende: libreoffice-impress mas não será instalado
               Depende: libreoffice-draw mas não será instalado
               Depende: libreoffice-math mas não será instalado
               Depende: libreoffice-base mas não será instalado
               Recomenda: libreoffice-gnome mas não será instalado ou
                          libreoffice-kde mas não será instalado
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.

Estou usando ubuntu 12.04.
Se alguem puder me ajudar agradeço.
« Última modificação: 03 de Setembro de 2012, 09:13 por RodoNext »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: É impossivel corrigir problemas, voce manteve (hold) pacotes quebrados.
« Resposta #1 Online: 02 de Setembro de 2012, 23:26 »
ola

Instale o gerenciador de pacotes synaptic

nele procure por => corrigir pacotes quebrados

[]'s

Offline RodoNext

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: É impossivel corrigir problemas,voce manteve (hold) pacotes quebrados.
« Resposta #2 Online: 03 de Setembro de 2012, 09:18 »
Ola Tota, como dito acima, eu já havia tentado instalar via Synaptic, e tambem tentei a opção "corrigir pacotes quebrados", porem nada acontecia.
Consegui resolver da seguinte maneira: fiz a instalação manual baixando o Libreoffice diretamente do site, e o sistema aceitou e os erros sumiram.
Obrigado! E fica a dica, vai que alguem precise.
« Última modificação: 03 de Setembro de 2012, 09:25 por RodoNext »

Offline bertoni

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: É impossivel corrigir problemas, voce manteve (hold) pacotes quebrados.
« Resposta #3 Online: 03 de Setembro de 2012, 12:08 »
ola

Instale o gerenciador de pacotes synaptic

nele procure por => corrigir pacotes quebrados

[]'s

Tenho o synaptic instalado e neste caso ele não mostra os pacotes quebrados, como deveria fazer.

Tem alguma coisa quebrada nos repositórios. Aqui este erro ocorreu depois de fazer uma atualização de uma lib sugerida pelo Muon...

Fiz váriso testes via linha de comando e quando pedi um apt-get purge libreoffice o cara me diz que o libreoffice não está instalado.

Zoneou tudo.

Tentei baixar o pacote direto no site do LibreOffice e deu erro. Fui em outras versões e lá tinha a disposição a 3.5.6 e a 3.6.1 Pedi para baixar a segunda e o cara baixou. Porém está com erro de dependência. Baixei a versão 3.5.6 e instalei. O sistema diz que o cara não está instalado.

Erro no repositório do LibreOffice???

Resultado. Estou sem o LibreOffice.

« Última modificação: 03 de Setembro de 2012, 13:28 por bertoni »

Offline e-kim

  • Usuário Ubuntu
  • *
  • Mensagens: 13
    • Ver perfil
Re: É impossivel corrigir problemas,voce manteve (hold) pacotes quebrados.
« Resposta #4 Online: 04 de Setembro de 2012, 14:26 »
Estava na mesma situação que o bertoni.

Desinstalei tudo do LibreOffice. Desabilitei o repositório

http://ppa.launchpad.net/libreoffice/ppa/ubuntu precise main

dei um sudo apt-get update para atualizar a lista de pacotes disponíveis

instalei o LibreOffice 3.5 dos repositórios Ubuntu.

testei o cara e voltei a habilitar o repositório ppa do libreoffice

outro apt-get update

aí sim consegui reinstalar o LibreOffice em sua versão 3.6.0.2

Tá funfando beleza.

Offline bertoni

  • Usuário Ubuntu
  • *
  • Mensagens: 86
    • Ver perfil
Re: É impossivel corrigir problemas,voce manteve (hold) pacotes quebrados.
« Resposta #5 Online: 04 de Setembro de 2012, 19:15 »
Interessante! Temos 6 máquinas com Kubuntu 12.04 instalado. Todas tem extamente os mesmos softwares e configuração.

Por que só uma deu o problema, é a grande questão...