Autor Tópico: Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04  (Lida 18350 vezes)

Offline animorealista

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #15 Online: 12 de Julho de 2016, 18:54 »
1) Qual a sua versão do Ubuntu?

cat /etc/lsb-release

Código: [Selecionar]
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.5 LTS"

2) Arquitetura?

arch

i686

3) kernel?

uname -srvm

Código: [Selecionar]
Linux 3.13.0-91-generic #138~precise1-Ubuntu SMP Fri Jun 24 18:50:28 UTC 2016 i686

4) Está atualizado?

sudo apt-get update
Código: [Selecionar]
Hit http://pt.archive.ubuntu.com precise Release.gpg
Hit http://pt.archive.ubuntu.com precise-updates Release.gpg                   
Hit http://pt.archive.ubuntu.com precise-backports Release.gpg                 
Hit http://pt.archive.ubuntu.com precise Release                               
Hit http://pt.archive.ubuntu.com precise-updates Release                       
Hit http://ppa.launchpad.net precise Release.gpg                               
Hit http://ppa.launchpad.net precise Release.gpg                               
Hit http://ppa.launchpad.net precise Release.gpg                               
Hit http://extras.ubuntu.com precise Release.gpg                               
Hit http://pt.archive.ubuntu.com precise-backports Release                     
Hit http://ppa.launchpad.net precise Release                                   
Hit http://ppa.launchpad.net precise Release                                   
Hit http://extras.ubuntu.com precise Release                                   
Hit http://ppa.launchpad.net precise Release                                   
Hit http://pt.archive.ubuntu.com precise/main Sources                         
Obter:1 http://security.ubuntu.com precise-security Release.gpg [198 B]
Hit http://pt.archive.ubuntu.com precise/restricted Sources                   
Hit http://pt.archive.ubuntu.com precise/universe Sources                     
Hit http://pt.archive.ubuntu.com precise/multiverse Sources             
Hit http://pt.archive.ubuntu.com precise/main i386 Packages             
Hit http://pt.archive.ubuntu.com precise/restricted i386 Packages       
Hit http://pt.archive.ubuntu.com precise/universe i386 Packages         
Hit http://pt.archive.ubuntu.com precise/multiverse i386 Packages       
Hit http://pt.archive.ubuntu.com precise/main TranslationIndex           
Hit http://pt.archive.ubuntu.com precise/multiverse TranslationIndex           
Hit http://pt.archive.ubuntu.com precise/restricted TranslationIndex           
Hit http://pt.archive.ubuntu.com precise/universe TranslationIndex             
Hit http://pt.archive.ubuntu.com precise-updates/main Sources                 
Hit http://pt.archive.ubuntu.com precise-updates/restricted Sources           
Hit http://pt.archive.ubuntu.com precise-updates/universe Sources             
Hit http://pt.archive.ubuntu.com precise-updates/multiverse Sources           
Hit http://pt.archive.ubuntu.com precise-updates/main i386 Packages           
Hit http://pt.archive.ubuntu.com precise-updates/restricted i386 Packages     
Hit http://pt.archive.ubuntu.com precise-updates/universe i386 Packages       
Hit http://pt.archive.ubuntu.com precise-updates/multiverse i386 Packages     
Hit http://pt.archive.ubuntu.com precise-updates/main TranslationIndex         
Hit http://pt.archive.ubuntu.com precise-updates/multiverse TranslationIndex
Hit http://pt.archive.ubuntu.com precise-updates/restricted TranslationIndex
Hit http://pt.archive.ubuntu.com precise-updates/universe TranslationIndex
Hit http://pt.archive.ubuntu.com precise/main Translation-pt             
Hit http://pt.archive.ubuntu.com precise/main Translation-pt_BR         
Hit http://pt.archive.ubuntu.com precise/main Translation-en             
Hit http://pt.archive.ubuntu.com precise/multiverse Translation-pt       
Hit http://pt.archive.ubuntu.com precise/multiverse Translation-pt_BR   
Obter:2 http://security.ubuntu.com precise-security Release [55,5 kB]         
Hit http://pt.archive.ubuntu.com precise/multiverse Translation-en             
Hit http://pt.archive.ubuntu.com precise/restricted Translation-pt             
Hit http://pt.archive.ubuntu.com precise/restricted Translation-pt_BR         
Hit http://pt.archive.ubuntu.com precise/restricted Translation-en             
Hit http://pt.archive.ubuntu.com precise/universe Translation-pt               
Hit http://pt.archive.ubuntu.com precise/universe Translation-pt_BR           
Hit http://pt.archive.ubuntu.com precise/universe Translation-en               
Hit http://pt.archive.ubuntu.com precise-backports/main Sources               
Hit http://pt.archive.ubuntu.com precise-backports/restricted Sources         
Hit http://pt.archive.ubuntu.com precise-backports/universe Sources           
Hit http://pt.archive.ubuntu.com precise-backports/multiverse Sources         
Hit http://pt.archive.ubuntu.com precise-backports/main i386 Packages         
Hit http://pt.archive.ubuntu.com precise-backports/restricted i386 Packages   
Hit http://pt.archive.ubuntu.com precise-backports/universe i386 Packages     
Hit http://pt.archive.ubuntu.com precise-backports/multiverse i386 Packages   
Hit http://pt.archive.ubuntu.com precise-backports/main TranslationIndex       
Hit http://ppa.launchpad.net precise/main Sources                             
Hit http://pt.archive.ubuntu.com precise-backports/multiverse TranslationIndex
Hit http://pt.archive.ubuntu.com precise-backports/restricted TranslationIndex
Hit http://pt.archive.ubuntu.com precise-backports/universe TranslationIndex   
Hit http://pt.archive.ubuntu.com precise-updates/main Translation-en           
Hit http://pt.archive.ubuntu.com precise-updates/multiverse Translation-en     
Hit http://pt.archive.ubuntu.com precise-updates/restricted Translation-en     
Hit http://pt.archive.ubuntu.com precise-updates/universe Translation-en       
Hit http://pt.archive.ubuntu.com precise-backports/main Translation-en         
Hit http://pt.archive.ubuntu.com precise-backports/multiverse Translation-en   
Hit http://pt.archive.ubuntu.com precise-backports/restricted Translation-en   
Hit http://pt.archive.ubuntu.com precise-backports/universe Translation-en     
Hit http://ppa.launchpad.net precise/main i386 Packages                       
Hit http://ppa.launchpad.net precise/main TranslationIndex                     
Hit http://extras.ubuntu.com precise/main Sources                             
Hit http://ppa.launchpad.net precise/main Sources                             
Hit http://ppa.launchpad.net precise/main i386 Packages                       
Hit http://ppa.launchpad.net precise/main TranslationIndex                     
Hit http://ppa.launchpad.net precise/main Sources                             
Hit http://ppa.launchpad.net precise/main i386 Packages                       
Hit http://ppa.launchpad.net precise/main TranslationIndex                     
Hit http://extras.ubuntu.com precise/main i386 Packages                       
Ign http://extras.ubuntu.com precise/main TranslationIndex                     
Hit http://ppa.launchpad.net precise/main Translation-en                       
Hit http://ppa.launchpad.net precise/main Translation-en                       
Hit http://ppa.launchpad.net precise/main Translation-en                       
Obter:3 http://security.ubuntu.com precise-security/main Sources [142 kB]     
Obter:4 http://security.ubuntu.com precise-security/restricted Sources [4476 B]
Obter:5 http://security.ubuntu.com precise-security/universe Sources [48,9 kB]
Obter:6 http://security.ubuntu.com precise-security/multiverse Sources [2731 B]
Obter:7 http://security.ubuntu.com precise-security/main i386 Packages [677 kB]
Ign http://extras.ubuntu.com precise/main Translation-pt_PT                   
Ign http://extras.ubuntu.com precise/main Translation-pt                       
Ign http://extras.ubuntu.com precise/main Translation-pt_BR                   
Ign http://extras.ubuntu.com precise/main Translation-en                       
Obter:8 http://security.ubuntu.com precise-security/restricted i386 Packages [11,6 kB]
Obter:9 http://security.ubuntu.com precise-security/universe i386 Packages [141 kB]
Obter:10 http://security.ubuntu.com precise-security/multiverse i386 Packages [3335 B]
Obter:11 http://security.ubuntu.com precise-security/main TranslationIndex [208 B]
Obter:12 http://security.ubuntu.com precise-security/multiverse TranslationIndex [199 B]
Obter:13 http://security.ubuntu.com precise-security/restricted TranslationIndex [202 B]
Obter:14 http://security.ubuntu.com precise-security/universe TranslationIndex [205 B]
Obter:15 http://security.ubuntu.com precise-security/main Translation-en [256 kB]
Obter:16 http://security.ubuntu.com precise-security/multiverse Translation-en [1698 B]
Obter:17 http://security.ubuntu.com precise-security/restricted Translation-en [2976 B]
Obter:18 http://security.ubuntu.com precise-security/universe Translation-en [85,0 kB]
Obtidos 1435 kB em 8s (176 kB/s)                                               
A ler as listas de pacotes... Pronto

sudo apt-get upgrade
Código: [Selecionar]
A ler as listas de pacotes... Pronto
A construir árvore de dependências       
A ler a informação de estado... Pronto
0 pacotes actualizados, 0 pacotes novos instalados, 0 a remover e 0 não actualizados.

Pelo que vê, acho que sim.

5) Qual o nome do arquivo da VMware que você baixou?

VMware-Workstation-Full-8.0.2-591240.i386.bundle

6) Qual versão da VMware?

Como viu na resposta anterior, é 8.0.2-591240.

7) Como instalou (ou está tentando instalar)?

Por terminal, usando os comandos:
Código: [Selecionar]
# chmod  +x VMware-Workstation-Full-8.0.2-591240.i386
# ./VMware-Workstation-Full-8.0.2-591240.i386

8 ) Indique exatamente o link de onde baixou

https://my.vmware.com/group/vmware/details?downloadGroup=WKST-802-LX&productId=241&download=true&fileId=0f41ba61117704201cfe99892405e179&secureParam=9dd254458226c9c4d549f2ab73b330ed&uuId=bbf86f74-baa2-4523-8264-2c5c6a4b57b9&downloadType=
Lembre-se de se registar no my vmare, ou, se não tiver uma conta disso, crie uma para poder fazer download disso.

Espero que isto lhe tenha ajudado a responder às suas perguntas.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #16 Online: 12 de Julho de 2016, 19:28 »
Precisamos decifrar isso, o arquivo que baixei, instalei e tudo funcionou de primeira, mesmo em cima de um simples live-iso, foi outro arquivo. :-(

Baixei e instalei o arquivo para arquitetura 64-bit:

VMware-Player-12.1.1-3770994.x86_64.bundle

Baixei dessa página:

https://my.vmware.com/en/web/vmware/downloads

No link quase lá no final da página:

VMware Workstation Player - Download Product

Então abrem-se opções para baixar para Windows e para Linux

https://my.vmware.com/en/web/vmware/free#desktop_end_user_computing/vmware_workstation_player/12_0

Só que nessa página não há opção para 32-bit, só mesmo 64-bit

Não estou achando no site o arquivo .bundle que você referiu.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #17 Online: 12 de Julho de 2016, 19:43 »
Agora achei:

https://my.vmware.com/web/vmware/details?dlg=wkst_802_lx&baseCode=dCVkYnRAQGVidHQldw==

Mas esse arquivo parece ser um release antigo, um arquivo antigo, obsoleto, veja que está assinalado:

Release Date    2012-01-24

Em outras palavras, está me parecendo que a VMware simplesmente não dá mais suporte para arquitetura 32-bit, foi para escanteio, acabou.

Não sei não se o Ubuntu 12.04.5, que é atual, que vem tendo todas as atualizações, ainda conseguirá trabalhar com esse release antigo.

Vou baixar aqui e tentar reproduzir num live-iso para ver o que acontece.
« Última modificação: 12 de Julho de 2016, 19:50 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #18 Online: 12 de Julho de 2016, 19:49 »
Que coisa, enroscou de novo, quando clica no link do arquivo ao invés de baixar ele envia para aquela página que você havia mencionado e parece que pede um cadastro para fazer um log-in.

Coisa mais "sacal" essa, pô, não quer fazer cadastro nenhum, fornecer endereço de e-mail nenhum, por enquanto só queria baixar um simples arquivo e fazer um teste.  >:(

Engraçado que para a versão corrente, que é a 12 que havia baixado, não pede isso, consegui baixar e instalar sem nada disso.  :o




« Última modificação: 12 de Julho de 2016, 19:54 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline animorealista

  • Usuário Ubuntu
  • *
  • Mensagens: 11
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #19 Online: 12 de Julho de 2016, 21:15 »
Que coisa, enroscou de novo, quando clica no link do arquivo ao invés de baixar ele envia para aquela página que você havia mencionado e parece que pede um cadastro para fazer um log-in.

Coisa mais "sacal" essa, pô, não quer fazer cadastro nenhum, fornecer endereço de e-mail nenhum, por enquanto só queria baixar um simples arquivo e fazer um teste.  >:(

Engraçado que para a versão corrente, que é a 12 que havia baixado, não pede isso, consegui baixar e instalar sem nada disso.  :o
Foi como te disse. Tens que criar uma conta para fazer download desse VMWare.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #20 Online: 12 de Julho de 2016, 22:16 »
Citar
Tens que criar uma conta para fazer download desse VMWare.

Bem, depois de fazer o registro, informar o nome do pai, da mãe, dos avós, bisavós, todos antepassados, país, estado, cidade, bairro, rua, se usa chapéu ou prefere boné, levantar, agachar, direita, esquerda, volver, validar, finalmente se consegue baixar um arquivo obsoleto. Ufa, consegui !  >:(

Vamos ao que interessa realmente:

Instalei o tal arquivo numa live-iso 12.04.5 - 32-bit

Para ultrapassar aquela tela o que funcionou foi criar um symlink (=link simbólico) da seguinte forma:

Entre no diretório:

cd /lib/modules/$(uname -r)/build/include/linux

Agora crie os seguintes symlinks:

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/utsrelease.h

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/autoconf.h

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h

Depois disso para a path pedida para a caixa de diálogo é informar:

/usr/src/linux-headers-$(uname -r)/include

Aqui foi direto, como já estava tentando antes algumas hipóteses, não cheguei a voltar para o quadro da caixa de diálogo, já começou a instalar, então, experimente da forma acima ou então substituindo o a variável $(uname -r) pela versão específica do kernel que tem aí, vez que aqui, como partiu de um live-iso evidentemente a versão do kernel era outra.

Assim sendo, depois de ter criado os symlinks conforme acima, na caixa de diálogo ou vai a forma acima mencionada ou se for para literalmente especificar o kernel então deve ficar:

/usr/src/linux-headers-3.13.0-91-generic /include

Como disse, aqui foi adiante, porém começa a compilar e no final aparece um novo erro:

Inicia com um quadro assim:

"Before you can run VMware, several modules must be compiled and loaded into the running kernel"

clica no botão Install

Começa Compiling....

e no final, mais uma mensagem de erro:

Error

Unable to start services

See log file /tmp/vmware-root/modconfig-17312.log for details

a referência numérica do log (17312) é variável conforme as tentativas, mas não vai adiante.

Indo olhar o log ele diz:

etc e tal ... Failed to compile vários e vários  modules, por exemplo vmci, etc

Ou seja, resolveu um problema e bateu em outro.

Experimente aí, como aqui é um live-iso, portanto sem as atualizações do sistema, eventualmente o resultado será diferente (duvido muito, mas tente).









« Última modificação: 12 de Julho de 2016, 22:33 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #21 Online: 12 de Julho de 2016, 22:22 »
Para registo, o tal do log de erro tem o seguinte conteúdo:

Código: [Selecionar]
2016-07-12T21:56:07.851-03:00| vthread-3| I120: Log for VMware Workstation pid=17312 version=8.0.2 build=build-591240 option=Release
2016-07-12T21:56:07.851-03:00| vthread-3| I120: The process is 32-bit.
2016-07-12T21:56:07.851-03:00| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8
2016-07-12T21:56:07.851-03:00| vthread-3| I120: Host is Linux 3.13.0-32-generic Ubuntu 12.04.5 LTS
2016-07-12T21:56:07.851-03:00| vthread-3| I120: Msg_Reset:
2016-07-12T21:56:07.851-03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory.
2016-07-12T21:56:07.851-03:00| vthread-3| I120: ----------------------------------------
2016-07-12T21:56:07.851-03:00| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values.
2016-07-12T21:56:07.851-03:00| vthread-3| I120: Msg_Reset:
2016-07-12T21:56:07.851-03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory.
2016-07-12T21:56:07.851-03:00| vthread-3| I120: ----------------------------------------
2016-07-12T21:56:07.851-03:00| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values.
2016-07-12T21:56:07.851-03:00| vthread-3| I120: Msg_Reset:
2016-07-12T21:56:07.851-03:00| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory.
2016-07-12T21:56:07.851-03:00| vthread-3| I120: ----------------------------------------
2016-07-12T21:56:07.851-03:00| vthread-3| I120: PREF Failed to load user preferences.
2016-07-12T21:56:07.852-03:00| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-17312.log
2016-07-12T21:56:08.021-03:00| vthread-3| I120: modconf query interface initialized
2016-07-12T21:56:08.022-03:00| vthread-3| I120: modconf library initialized
2016-07-12T21:56:08.054-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.060-03:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.060-03:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
2016-07-12T21:56:08.060-03:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
2016-07-12T21:56:08.060-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.063-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.073-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.084-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:08.084-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.087-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.097-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.108-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:08.123-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.126-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.129-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.131-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.134-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.147-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.150-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.152-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.155-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.157-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.160-03:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.161-03:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
2016-07-12T21:56:08.161-03:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
2016-07-12T21:56:08.161-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.164-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.173-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.184-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:08.201-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.203-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.206-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.208-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.211-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.214-03:00| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.214-03:00| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h
2016-07-12T21:56:08.214-03:00| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found.
2016-07-12T21:56:08.214-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.218-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.231-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.245-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:08.278-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.281-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.284-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.288-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.291-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.493-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:08.493-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:08.504-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.517-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:08.532-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:08.532-03:00| vthread-3| I120: Building module vmmon.
2016-07-12T21:56:08.532-03:00| vthread-3| I120: Extracting the sources of the vmmon module.
2016-07-12T21:56:08.550-03:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.13.0-32-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2016-07-12T21:56:11.025-03:00| vthread-3| I120: Installing module vmmon from /tmp/vmware-root/modules/vmmon.o to /lib/modules/3.13.0-32-generic/misc.
2016-07-12T21:56:11.026-03:00| vthread-3| I120: Registering file: /usr/lib/vmware-installer/2.0/vmware-installer --register-file vmware-vmx regular /lib/modules/3.13.0-32-generic/misc/vmmon.ko
2016-07-12T21:56:12.023-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:12.023-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:12.027-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:12.037-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:12.048-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:12.048-03:00| vthread-3| I120: Building module vmnet.
2016-07-12T21:56:12.048-03:00| vthread-3| I120: Extracting the sources of the vmnet module.
2016-07-12T21:56:12.056-03:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmnet-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.13.0-32-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2016-07-12T21:56:14.695-03:00| vthread-3| I120: Failed to compile module vmnet!
2016-07-12T21:56:14.701-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:14.701-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:14.705-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:14.715-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:14.726-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:14.726-03:00| vthread-3| I120: Building module vmblock.
2016-07-12T21:56:14.726-03:00| vthread-3| I120: Extracting the sources of the vmblock module.
2016-07-12T21:56:14.734-03:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmblock-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.13.0-32-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2016-07-12T21:56:16.566-03:00| vthread-3| I120: Failed to compile module vmblock!
2016-07-12T21:56:16.572-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:16.572-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:16.576-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:16.586-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:16.597-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:16.597-03:00| vthread-3| I120: Building module vmci.
2016-07-12T21:56:16.597-03:00| vthread-3| I120: Extracting the sources of the vmci module.
2016-07-12T21:56:16.606-03:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.13.0-32-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2016-07-12T21:56:19.591-03:00| vthread-3| I120: Failed to compile module vmci!
2016-07-12T21:56:19.597-03:00| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.13.0-32-generic.
2016-07-12T21:56:19.597-03:00| vthread-3| I120: Validating path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic
2016-07-12T21:56:19.601-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:19.611-03:00| vthread-3| I120: Your GCC version: 4.6
2016-07-12T21:56:19.622-03:00| vthread-3| I120: Header path /lib/modules/3.13.0-32-generic/build/include for kernel release 3.13.0-32-generic is valid.
2016-07-12T21:56:19.622-03:00| vthread-3| I120: Building module vmci.
2016-07-12T21:56:19.622-03:00| vthread-3| I120: Extracting the sources of the vmci module.
2016-07-12T21:56:19.631-03:00| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmci-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.13.0-32-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6
2016-07-12T21:56:20.426-03:00| vthread-3| I120: Failed to compile module vmci!


Novo teste:

sudo ln -s /usr/src/linux-headers-$(uname -r)/include/generated/uapi/linux/version.h /usr/src/linux-headers-$(uname -r)/include/linux/version.h

outro:

cat ~/update_version.sh
#!/bin/bash

cd /lib/modules/$(uname -r)/build/include/linux
sudo ln -s ../generated/utsrelease.h
sudo ln -s ../generated/autoconf.h
sudo ln -s ../generated/uapi/linux/version.h

Mesmos resultados.
« Última modificação: 13 de Julho de 2016, 02:38 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #22 Online: 14 de Julho de 2016, 00:53 »
Então, /animorealista/,

Vamos de novo começar do começo, para ver se é possível melhorar o entendimento da questão.  :)

Por qual razão você precisa instalar exatamente essa versão 8 do VMware Player 32-bit obsoleta (release de 2012)?
Não pode ser outra, tem que ser de fato exatamente essa?

Pelo pouco que consegui olhar realmente o suporte para hosts 32-bit (=hospedeiro, aquele que hospeda, a máquina física) por parte da VMware já era, ficou no passado, e não apenas no Linux, mas para o Windows também.

Encontrei uma outra versão 32-bit do arquivo, a versão 10, cujo release também é antigo, porém um pouco mais novo e vai um passo adiante e com ele até consegui subir uma versão do Lubuntu dentro da VM instalada, mas também está visivelmente defasado.

Se quiser testar, o tal versão 10 - 32-bit é esse:

VMware-Workstation-Full-10.0.6-2700073.i386.bundle


This bundle includes the full product and VMware Tools for 32-bit operating systems.

Release Date: 2015-05-05
Build Number: 2700073

https://my.vmware.com/group/vmware/details?downloadGroup=WKST-1006-LX&productId=362&download=true&fileId=21e06d7c36bdb78f877c33f803283785&secureParam=09232aaddab8c2dd62fc9cb09c2d222c&uuId=9826d445-fff2-42b3-bc22-137ef4a02a29&downloadType=

É último 32-bit que consegui encontrar lá no site deles.

Nesse caso da versão 10 não ocorreu nenhum problema de localizar os headers, não precisou criar symlinks, instalei apenas o build-essential, instalou e criou a VM direto, sem maiores dificuldades, mas está visivelmente obsoleta.

Note que ficar perdendo tempo com software antigo e obsoleto geralmente é pura perda de tempo, no mais das vezes não compensa e não leva a nada, então precisa ter um motivo muito bom para insistir nisso.

É algo um pouco ilógico, se até o fabricante abandonou, por que então o usuário deve insistir naquilo que o "pai da criança" deixou de lado?

Como seu sistema operacional real é 32-bit, avalie a possibilidade de migrar para um 64-bit, o que certamente seria a melhor solução, ou ainda avalie se precisa e só pode usar mesmo VMware para as suas necessidades, se não pode de fato ser outra máquina virtual.

A VMware é software proprietário, código fechado, tem dono, e eles certamente não têm mais interesse comercial em gastar recursos e manter versões 32-bit, até porque estão escasseando equipamentos que ainda fazem uso disso, notadamente em ambiente corporativo, que é o grande e quase único usuário real e cliente de remuneração de Virtual Machine.

De toda forma, considere que a alternativa é a VirtualBox Oracle que continua dando suporte nativo para 32-bit, e é opensource, dependendo de suas necessidades operacionais talvez seja a melhor solução.

https://www.virtualbox.org/

« Última modificação: 14 de Julho de 2016, 01:15 por druidaobelix »
www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.

Offline arthurgerhardt

  • Usuário Ubuntu
  • *
  • Mensagens: 31
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #23 Online: 15 de Julho de 2016, 04:24 »
Eu estou com o mesmo problema no VMware Workstation Player 12. Ele dá um erro e não deixa eu executar a máquina virtual. Aguardo solução.

Offline druidaobelix

  • Usuário Ubuntu
  • *
  • Mensagens: 5.554
    • Ver perfil
Re:Instalando VMware-Workstation-Full-8.0.2 ubuntu 12.04
« Resposta #24 Online: 15 de Julho de 2016, 18:55 »
Citar
Eu estou com o mesmo problema no VMware Workstation Player 12. Ele dá um erro e não deixa eu executar a máquina virtual.

Então, /arthurgerhardt/,

Creio seja melhor você abrir um tópico específico sobre isso, pois o título do presente tópico induz a uma outra questão, vez que da VMware versão 8.

Nesse novo tópico não basta dizer que dá um erro, pois isso é dizer nada, transcreva **exatamente** qual é a mensagem de erro retornada pelo sistema, dizendo ainda em qual versão/ambiente do Ubuntu está tentando instalar, enfim, enriqueça o seu post com elementos que tornem possível identificar mais claramente qual possa ser o problema, ou seja, ajude a te ajudar.

www.arredondar.org.br
Vencedor Desafio de Impacto Social Google 2016!
Você também pode participar e fazer a diferença.