Autor Tópico: Problema com msn-proxy nao inicia(Resolvildo)  (Lida 1941 vezes)

Offline joaotime

  • Usuário Ubuntu
  • *
  • Mensagens: 210
    • Ver perfil
Problema com msn-proxy nao inicia(Resolvildo)
« Online: 18 de Janeiro de 2012, 09:30 »
Ola pessoal estou com problema com meu msn-proxy eu instalei ele normalmente deu certo porem quando renicio o servico(reboot) ele para e nao inicia
estou usando o camando
e quando ligo ele denovo tenho que rodar o camando abaixo
msn-proxy -d -i &

como posso resolver isto?


Obrigado

Joao
« Última modificação: 21 de Janeiro de 2012, 17:00 por joaotime »

Offline irtigor

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.344
  • Delete, delete, delete!
    • Ver perfil
Re: Problema com msn-proxy nao inicia
« Resposta #1 Online: 19 de Janeiro de 2012, 11:26 »
Verifique se não existe um script de inicialização. Se não existir, você pode criar um, ou usar uma das várias formas de rodar um programa na inicialização do sistema (numa pesquisa aqui pelo fórum mesmo você acha).

Offline joaotime

  • Usuário Ubuntu
  • *
  • Mensagens: 210
    • Ver perfil
Re: Problema com msn-proxy nao inicia
« Resposta #2 Online: 21 de Janeiro de 2012, 17:00 »
Obrigado Resolvilso soluccao abaixo

#!/bin/bash

start() {
echo "Iniciando o MSN Proxy..."
        /usr/local/bin/msn-proxy -b &
}
stop() {
echo "Finalizando o MSN Proxy..."
        pkill -9 msn-proxy >> /dev/null

}

case "$1" in
start) start
;;
stop) stop
;;
*) echo "Uso correto: msn-proxy (start|stop)"
;;
esac