Autor Tópico: [Resolvido] Saída fones de ouvido Ubuntu 11.10 não funcionam...  (Lida 6752 vezes)

Offline Robertogc

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
[Resolvido] Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Online: 13 de Dezembro de 2011, 16:11 »
Olá a todos.
Sou iniciante (3 dias de experiência) no Linux e escolhi o Ubuntu e estou gostando muito.
Só que estou com um problema com os fones de ouvido. Estão mudos. Já li muito, muitos foruns, existem problemas parecidos mas as resoluções não se encaixam no meu problema.
Já desistalei e instalei o Alsamixer, o Pulse e nada.

Quando eu digito "alsamixer" no Terminal aparecem as informações:
AlsaMixer v1.0.24.2
│      Placa: HDA Intel                                      
│      Chipe: SigmaTel STAC9205                    
                          
Aparecem também os ganhos dos volumes das speakers e headphones, sendo que estão tudo no máximo.

Eu encontrei esse Tutorial (http://tirloni-rs.blogspot.com/2009/07/hda-intel-no-ubuntu-904.html) só que o comando
sudo aptitude install build-essential libncurses-dev gettext xmlto xmltoman linux-headers-`uname -r` não é aceito pelo terminal dando a mensagem "command not found"
então não tem como prosseguir com o tutorial.

OBS:
1 - Estou usando Ubuntu 64bits. Já testei o 32bits e o problema persiste.
2 - Eu tenho dual boot com W7 e os fones estão funcionando perfeitamente.
3 - Nas "configurações de som", na aba "hardware" aparecem 2 dispositivos:
- RV 630/M7 Audio Device [Radeon HD 2600 Séries]  >>>>quando eu seleciono essa opção de hardware, o som fica totalmente mudo, até as speakers.
- Audio interno (duplex audio analógico) >>>>>>quando eu seleciono essa opção, o som sai muito bem somente nas speakers, os fones de ouvido ficam mudos.

Só falta isso pro meu Ubuntu ficar perfeito....me ajudem galera!!!

vlw

« Última modificação: 17 de Dezembro de 2011, 21:02 por Robertogc »

Offline Dionnatan

  • Usuário Ubuntu
  • *
  • Mensagens: 240
  • Liberdade de Conhecimento.
    • Ver perfil
    • diolinux
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #1 Online: 13 de Dezembro de 2011, 16:15 »
Olá, bom não parei para analisar a fundo o seu problema, mas vou viabilizar o seu tutorial
o comando not found acima, é porque o aptitude não vem mais instalado no ubuntu por padrão
entao primeiro instale-o

sudo apt-get install aptitude

então continue, abraç

Offline Robertogc

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #2 Online: 13 de Dezembro de 2011, 19:39 »
De fato, após aplicar o "aptitude" consegui inserir o comando sudo aptitude install build-essential libncurses-dev gettext xmlto xmltoman linux-headers-`uname -r`. Porém, já travei de novo no próximo passo, no descompactar os arquivos baixados. Como o "Linux" vai achar o arquivo para descompactar se nesses comandos não tem endereço deles e nem o nome completo do arquivo que baixei?

Ajuda aí gente...

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #3 Online: 13 de Dezembro de 2011, 20:01 »
Ola

Amigo, se usou o comando install, o GNU/Linux foi lá nos repositórios, baixou e instalou os pacotes, simples assim.

Esqueça o modo "windows de pensar"

Aqui quase tudo é muito mais intuitivo e portanto mais fácil.

Como os pacotes do alsa estão nos repositórios digite

Código: [Selecionar]
sudo aptitude install alsa-base Alsa-base-udeb alsa-firmware-loaders alsa-oss alsa-source  alsa-tools alsa-tools-gui alsa-utils alsamixer-gui
Veja os pacotes de sua versão do Ubuntu aqui => http://packages.ubuntu.com/

Depois de instalados, continue de: Configurando driver, lá do tutorial.

E não se desespere se o "sudo make install" demorar pra caramba. Tenha paciência e espere até o fim.

Poste os erros se houverem, copiando a mensagem direto do terminal com <shift>+<ctrl>+<c>

[]'s


Offline Robertogc

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #4 Online: 14 de Dezembro de 2011, 13:55 »
Tota....


depois de dar esse comando extenso, aparece o seguinte resultado:

root@roberto-M-153X:/home/roberto# sudo aptitude install alsa-base Alsa-base-udeb alsa-firmware-loaders alsa-oss alsa-source  alsa-tools alsa-tools-gui alsa-utils alsamixer-gui
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "Alsa-base-udeb"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "alsamixer-gui"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "Alsa-base-udeb"
Não foi possível encontrar nenhum pacote cujo nome ou descrição combinasse com "alsamixer-gui"
Nenhum pacote será instalado, atualizado ou removido.
0 pacotes atualizados, 0 novos instalados, 0 a serem removidos e 33 não atualizados.
É preciso obter 0 B de arquivos. Depois do desempacotamento, 0 B serão usados.

E agora? tem muita coisa q nao foi possível instalar...

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #5 Online: 14 de Dezembro de 2011, 15:10 »
veja aqui o nome dos pacotes => http://packages.ubuntu.com/search?keywords=alsa&searchon=names&suite=oneiric&section=all

estou assumindo que voce usa o oneiric 11.10 como o titulo do topico informa.

senão, veja no packages a sua versão.

[]'s

Offline Robertogc

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #6 Online: 14 de Dezembro de 2011, 16:09 »
Tota, não tinha visto seu último post. Antes disso, fiz uma cagada.

Sabe esse tutorial q eu apontei aí atrás? Então, aprendi que devemos abrir um terminal no local onde se encontra o pacote, senão não dá certo. De posse dessa informação eu fui dando os comando, o sistema foi aceitando uns e ignorando outros, e eu fui até o fim, reiniciei a máquina.
Pra minha surpresa, aqui na "configuração de som" não há mais nenhum dispositivo para eu configurar/escolher. Antes tinham os dois que eu mencionei no início do tópico, agora tem nenhum...agora estou 100% sem som.
Fui na "central de programas do Ubuntu" e pesquisei tudo q tinha com palavra ALSA e estão todos instalados (pelo menos teoricamente),  ou seja, não foi desinstalado nada, mas os dispositivos de som sumiram.

Obs: uso Ubuntu 11.10 64bits

Tem conserto?

vlw

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #7 Online: 14 de Dezembro de 2011, 17:59 »
sim tem conserto.

Remova os alsa, reinstale tudo sobre pulse

Gerenciador de pacotes synaptic => pesquisa => pulse

instale tuso do pulse e pulseaudio, inclusive o pacote pavucontrol

Depois de instalado, reinicie a maquina, entre em terminal e configure pelo terminal digitando
Código: [Selecionar]
pavucontol
Hoje em dia o pulse esta muito bom, então acredito que não precisa do alsa.

Se não funcionar, ao ligar a maquina pressione os dois <shift>  de seu teclado

escolha uma versão anterior do kernel e boote por ela. remova o kernel que estragou com a compilação e depois instale ele de novo.

com isto deverá resolver.

[]'s

Offline Robertogc

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #8 Online: 15 de Dezembro de 2011, 20:29 »
Tota...

Depois das altereções que fiz ontem, meu Ubuntu não iniciou mais, ficava piscando uma mensagem q não me lembro mais na hora do boot. Então, formatei e instalei o Ubuntu 11.10 64bits outra vez. Pesquisando mais sobre a assunto, encontrei uma pessoa com problema parecido com o meu, só que não estou conseguindo finalizar o processo e gostaria que me ajudasse a interpretar o que realmente o cara fez conforme ele põe lá no final do seu relato.
Vou por o link aqui e vc já pode ir lá pro final onde fala ( http://blog.wessendorf.org/2009/05/headphones-with-ubuntu-904-and-gateway-t-6345u/)

Compared to the previous version that shipped with Ubuntu, there are two new entries, eapd and auto now. The eapd (external amplifier power down) option looks quite promising, so back to…

sudo nano /etc/modprobe.d/alsa-base.conf
and added the following line:

options snd-hda-intel model=eapd probe_mask=1 position_fix=1
Restart and success! The headphones finally work properly. If you were having similar problems and found this blog in the attempt to find a solution, I hope these steps could help you a bit further in your quest. I can imagine that other headphone issues could perhaps be solved as well, with an alsa-upgrade and adjustments to alsa-base.conf.


Tota, preciso saber como eu modifico esse arquivo "alsa-base.conf". Eu abro ele pelo terminal, aí aparece tipo um controle de um programa, só que não consigo inserir a tal linha citada acima. Se eu abro com o comando "sudo gedit nano / etc / modprobe.d / alsa-base.conf" aí aparece um texto, tipo bloco de notas, eu copio e colo a linha, mas nao ceita salvar por falta de permissão.

Enfim, interpreta essa informaçao pra mim.

vlw cara..

Offline Robertogc

  • Usuário Ubuntu
  • *
  • Mensagens: 7
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #9 Online: 16 de Dezembro de 2011, 09:48 »
Moderação

Consegui resolver o problema dos fones de ouvido após instalação do Ubuntu 11.10, cujos notebooks (normalmente Dell, Gateway, Toshiba etc) possuem placa de som discriminada como HDA Intel e chip SigmaTel STAC9205. Como descrito no início do tópico, os fones ficam mudos. Como tem muita gente com esse problema e não sabem como resolver, vou postar aqui a solução, que aliás é muito simples, e a moderação pode dar o tópico como resolvido, se quiser.

Então, basta fazer o seguinte:

Abra o terminal e de o comando
sudo gedit /etc/modprobe.d/alsa-base.conf

Adicione a linha a baixo no final do arquivo,salve,saia e reinicie o pc. Só isso e funcionou comigo.
options snd-hda-intel model=eapd probe_mask=1 position_fix=1

É bom lembrar que o Alsa deve estar atualizado (driver, biblioteca e utilits).

O texto completo com todos os detalhes de quem descobriu a solução do problema está aqui:
http://blog.wessendorf.org/2009/05/headphones-with-ubuntu-904-and-gateway-t-6345u/

Obrigado a todos.
« Última modificação: 16 de Dezembro de 2011, 10:31 por platao »

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: Saída fones de ouvido Ubuntu 11.10 não funcionam...
« Resposta #10 Online: 16 de Dezembro de 2011, 10:33 »
Ola Roberto, por gentileza, marque o seu topico com o icone "solucionado" editando a sua primeira mensagem nesse topico e escolhendo o icone verde, assim outras pessoas que tem o mesmo problema podem usar o seu topico como referencia na solução.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997