Autor Tópico: Não consigo instalar o omnibot no Enemy Territory  (Lida 4905 vezes)

Offline lipeodonto

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
Não consigo instalar o omnibot no Enemy Territory
« Online: 16 de Janeiro de 2010, 15:53 »
Boas equipe do Ubuntu fórum,

Instalei o ET no meu notebook e ele está rodando corretamente, inclusive com o som.
Porém tentei instalar o omnibot e não obtive sucesso. Copiei o arquivo do site oficial (versão 0.71) e tentei rodá-lo como manda o arquivo .txt que vem junto.
No terminal apareceu o seguinte erro:

Setting MOTD...
Omni-bot: ^1LoadLibrary Failed with Error: /omnibot_et.so: cannot open shared object file: No such file or directory
Omni-bot: ^2Looking for /omnibot_et.so,
Omni-bot: ^1LoadLibrary Failed with Error: ./omnibot_et.so: cannot open shared object file: No such file or directory
Omni-bot: ^2Looking for ./omnibot_et.so,
Omni-bot: ^1LoadLibrary Failed with Error: /home/chacal/omni-bot/omnibot_et.so: cannot open shared object file: No such file or directory
Omni-bot: ^2Looking for /home/chacal/omni-bot/omnibot_et.so,
Omni-bot: ^1LoadLibrary Failed with Error: omnibot_et.so: cannot open shared object file: No such file or directory
Omni-bot: ^2Looking for omnibot_et.so,
^1Unable to Initialize Omni-Bot.
Setting Allied autospawn to Old City
Setting Axis autospawn to Old City
^1Warning: setstate called and no entities found
[skipnotify]ChacalRN^7 entered the game
[skipnotify]^1FIGHT!


Alguém poderia me dar uma ajuda?

Grato.

Offline brunionline

  • Usuário Ubuntu
  • *
  • Mensagens: 19
    • Ver perfil
    • Twitter
Re: Não consigo instalar o omnibot no Enemy Territory
« Resposta #1 Online: 16 de Janeiro de 2010, 19:13 »
Cara, também me bati MUITO pra rodar o omnibot no Enemy Territory. A solução que eu encontrei foi baixar o .deb disponibilizado pelo pessoal do Ubuntu Games. Ele já vem configurado com o omnibot.

Offline lipeodonto

  • Usuário Ubuntu
  • *
  • Mensagens: 28
    • Ver perfil
[Resolvido] Não consigo instalar o omnibot no Enemy Territory
« Resposta #2 Online: 16 de Janeiro de 2010, 21:13 »
Consegui pessoal...

Baixei o bobot do site http://www.wmaker.net/bobots/downloads/ (Linux-Bobot-04.05.tar.bz2) e deu certo.

Logo após, descompactei o mesmo em /usr/local/games/enemy-territory/ e também em /home/(usuário)/.etwolf.
Dentro da pasta bobot executei o example-bobot-local.sh e... bingo!!! É só ir em host game, e na hora que abrir o mapa acessar o menu bobot e mandar ver.


Qualquer dúvida estou na área.

Offline fabio2paolini

  • Usuário Ubuntu
  • *
  • Mensagens: 125
    • Ver perfil
Re: Não consigo instalar o omnibot no Enemy Territory
« Resposta #3 Online: 18 de Janeiro de 2010, 18:53 »
Pelo log de erro que você postou deve estar faltando o arquivo omnibot_et.so. No arquivo que você baixou do etserver deve haver este arquivo. Copie ele para um dos diretórios que o jogo procura, como por exemplo "/home/chacal/omni-bot/"

Offline disaster

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Não consigo instalar o omnibot no Enemy Territory
« Resposta #4 Online: 08 de Janeiro de 2011, 20:13 »
É importante lembrar também que o as pastas omnibot e omni-bot em /usr/local/games/enemy-territory/,  e todos os seus arquivos, devem estar ao menos com a permissão 755. Para isso execute o comando:

$ sudo chmod 755 -R omni*

Offline felipeludo2011

  • Usuário Ubuntu
  • *
  • Mensagens: 2
    • Ver perfil
Re: Não consigo instalar o omnibot no Enemy Territory
« Resposta #5 Online: 14 de Novembro de 2011, 19:48 »
Olá !
Eu baixei o omni-bot e tive problemas para adicionar e renomear bots, tive problemas com o som tambem e etc...
Então eu resolvi criar um programa que faz tudo automaticamente, escrito em shell script, com ele pode se renomear os bots facilmente, controlar o numero de bots, ativar o som e carregar o omni-bot automaticamente, etc...
Basta desempacotar o omni-bot, copiar as pastas omnibot e omni-bot para a pasta do jogo (/usr/local/games/enemy-territory, por exemplo), instalar e usar o script que fiz.
Links :
    http://kiwi6.com/file/2fv29745x9

    http://k003.kiwi6.com/hotlink/2fv297...osetup_2011.7z
Espero que ajude quem estiver com o mesmo problema que eu tinha.
Adios !   :D