Autor Tópico: Problemas com Transmission  (Lida 7633 vezes)

Offline Cauê Fabiano

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Problemas com Transmission
« Online: 18 de Dezembro de 2010, 16:23 »
Boa tarde a todos  :)

Esse é meu primeiro post por aqui.

Uso o Ubuntu 10.04 tanto no meu notebook quanto no meu desktop e sempre usei o Transmission para fazer download de torrents.

Nunca tive grandes problemas, somente o fato do aplicativo derrubar a conexão wireless após certo tempo de download - o que foi resolvido ao atualizar o firmware do modem (um D-Link DI-524).

Estava baixando torrents normalmente a uma velocidade boa (tenho conexão 10MB), porém, faz pouco tempo, a velocidade caiu muito e, além disso, o Transmission se conecta a poucos peers (algo como 2 de 60). Testei minha conexão e, fora do Torrent, tenho boas taxas de download (geralmente 850kbps).

Já reiniciei o modem, reconfigurei, atualizei o Transmission pelo Terminal, tentei usar o Vuze (e obtive o mesmo problema),  fiz de tudo, mas tanto no notebook quanto no desktop, as taxas de transferência ficam baixas só no Torrent.

Alguém pode me ajudar? Desde já agradeço!
« Última modificação: 18 de Dezembro de 2010, 17:57 por Cauê Fabiano »
Twitter: @Cauefabiano

Offline ElMago

  • Usuário Ubuntu
  • *
  • Mensagens: 204
    • Ver perfil
Re: Problemas com Transmission
« Resposta #1 Online: 18 de Dezembro de 2010, 16:43 »
Olá, muitas vezes programas p2p, aMSN, eMesene, CAM, torrent, etc, são impossibilitados de trabalhar corretamente, ou até ficam impossibilitados de se conectar por causa da configuração do Firewall, que se chama Ufw.
Vá no terminal e digite o comando: sudo ufw status
Se a resposta for; Estado: inativo, aí pode descartar a possibilidade de ser problema de configuração do Firewall.
Se estiver ; Estado : ativo e com as configurações de porta abaixo, aí vc terá que configurar as portas abrindo-as.
Cada programa mostra uma porta, e o Ufw já mostra, aí é só adicionar.
Pra ficar bem mais fácil configurar, instale a interface do Ufw, chamada GUfw.
No terminal digite: sudo apt-get install gufw.

Offline ElMago

  • Usuário Ubuntu
  • *
  • Mensagens: 204
    • Ver perfil
Re: Problemas com Transmission
« Resposta #2 Online: 18 de Dezembro de 2010, 16:45 »
Se depois de abrir as portas do (s) programa (s) de compartilhamento e ver que ainda não deu certo, aí agente parte p/ outra solução.
« Última modificação: 18 de Dezembro de 2010, 16:53 por ElMago »

Offline Cauê Fabiano

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problemas com Transmission
« Resposta #3 Online: 18 de Dezembro de 2010, 17:08 »
ElMago, muito obrigado pela atenção! :)

Instalei a interface e adicionei as regras para o Transmission (creio que tenha feito tudo certo) e, aparentemente, a taxa de transferência aumentou!

Estou com pico de 350kbps e média de 280kbps, o que é não é o máximo, porém é muito mais do que eu estava obtendo :).

Vou continuar monitorando aqui. Será preciso abrir toda vez o a interface do Firewall para fazer download de Torrents?

Obrigado!

Twitter: @Cauefabiano

Offline Cauê Fabiano

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problemas com Transmission
« Resposta #4 Online: 18 de Dezembro de 2010, 17:11 »
Notei uma coisa: mesmo assim, estou baixando de um número muito reduzido de pares.

Tirei alguns printscreens, caso ajude:

http://img94.imageshack.us/img94/8177/transmission01.png
http://img441.imageshack.us/img441/5799/transmission02.png

Obrigado novamente!

Twitter: @Cauefabiano

Offline ElMago

  • Usuário Ubuntu
  • *
  • Mensagens: 204
    • Ver perfil
Re: Problemas com Transmission
« Resposta #5 Online: 18 de Dezembro de 2010, 17:31 »
Opa, que bom que melhorou muito.
Não precisa ir toda vez no Firewall não. Basta apenas esta vez, que a porta fica lá aberta no Firewall. Quando vc quiser fechar, é só remover.
Pelo que vi nas imagens, vc fez correto, e a porta é essa mesmo, 51413.
Creio que foi em Adicionar> Simples, e no campo digitou o n° da porta.
Pra CAM é a mesma coisa, onde tive um problema similar, porem fechava logo que começava a exibição. Abri pelo Simples (que é p/ todos) e pronto.
Por exemplo, quando vc for empreferencias do Transmiossion, clique na guia Rede, e teste a porta. Ela agora vai mostrar que está aberta.
Falow!
« Última modificação: 18 de Dezembro de 2010, 17:33 por ElMago »

Offline ElMago

  • Usuário Ubuntu
  • *
  • Mensagens: 204
    • Ver perfil
Re: Problemas com Transmission
« Resposta #6 Online: 18 de Dezembro de 2010, 17:37 »
Em Preferências de Transmission, voce pode controlar melhor o limite de velocidade. No canto inferior esquerdo, clique num ícone de uma ferramenta, chamada opções, e lá vc controla o limite de dowload e upload.
Do lado tem o limite temporario de velocidade...Nao entendo muito esta opção, mas depois eu vejo.
Falow!

Offline ElMago

  • Usuário Ubuntu
  • *
  • Mensagens: 204
    • Ver perfil
Re: Problemas com Transmission
« Resposta #7 Online: 18 de Dezembro de 2010, 17:43 »
Se caso realmente resolveu, depois coloque no sua primeira postagem na caixa ''Assunto'', e escreva na frente da frase, [Resolvido].
Nos avise.
Abraço!
« Última modificação: 18 de Dezembro de 2010, 17:47 por ElMago »

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: Problemas com Transmission
« Resposta #8 Online: 18 de Dezembro de 2010, 17:50 »
Ola Elmago e Caue, agora temos um icone resolvido para ser usado nessas circunstancias, e so alterar o icone para " solucionado " se for esse o caso, para servir de referencia e ajudar na organização do forum. (bem vindo Caue ao forum)
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline Cauê Fabiano

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problemas com Transmission
« Resposta #9 Online: 18 de Dezembro de 2010, 17:52 »
Beleza!

Vou tentar baixar um Torrent e monitorar os resultados.

O número de pares ainda está muito baixo do que costumava ser (entre 7 e 12) de 60, mas vou esperar baixar. Existe alguma razão para o número de pares ficar tão baixo?

Se a velocidade não despencar novamente, marco como resolvido! :)

Em todo caso, muito obrigado! :)
Twitter: @Cauefabiano

Offline Cauê Fabiano

  • Usuário Ubuntu
  • *
  • Mensagens: 6
    • Ver perfil
Re: Problemas com Transmission
« Resposta #10 Online: 18 de Dezembro de 2010, 17:57 »
Pelo que parece, a velocidade aumentou bastante, e oscila agora entre 600 e 300.

Muito obrigado pela solução e pelas boas-vindas!  ;D
Twitter: @Cauefabiano

Offline ElMago

  • Usuário Ubuntu
  • *
  • Mensagens: 204
    • Ver perfil
Re: Problemas com Transmission
« Resposta #11 Online: 18 de Dezembro de 2010, 18:15 »
É mesmo rsrs, bem vindo ao Ubuntu Fórum.
Quanto ao n° de pares não sei como se resolve, mas deve ter solução sim.
Abraço!

Offline lpr

  • Usuário Ubuntu
  • *
  • Mensagens: 22
    • Ver perfil
Re: Problemas com Transmission
« Resposta #12 Online: 08 de Setembro de 2011, 23:14 »
Já fiz tudo o que foi sugerido nesse tópico e mais um monte de outras coisas... nada funciona... e não estou falando só do Transmission.... nenhum cliente torrent que eu baixei e instalei funciona. É irritante. Parece aquele burro teimoso que empaca e não sai do lugar de jeito nenhum....