Autor Tópico: (ERROR) Gerenciador de atualizações  (Lida 3082 vezes)

Offline lsoares

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
(ERROR) Gerenciador de atualizações
« Online: 30 de Maio de 2011, 23:18 »
Amigos,
Fiz uma busca no fórum e não encontrei um tópico com um problema
parecido com o meu. Encontrei um outro sobre problemas na atualização,
mas bem diferente do meu. Sou um pouco noob com o linux ainda, me desculpem se já tem outro tópico.

Estou com o seguinte erro:

Não foi possível inicializar as informações do pacote

Um problema impossível de se resolver ocorreu enquanto inicializava as informações do pacote.

Por favor relate este erro do pacote 'update-manager' e inclua a seguinte mensagem de erro:

'E:Problem parsing dependency Depends, E:Ocorreu um erro ao processar apturl-common (NewVersion2), E:Problem with MergeList /var/lib/dpkg/status, E:As listas de pacotes ou os arquivos de estado não puderam ser analisados ou abertos.'

__________________

Ja fui no terminal e coloquei a seguinte linha de comando: sudo apt-get update
Chegar numa parte em que ele dar erro no terminal, apresentando os erros da mensagem acima.

Fui na central de programas do Ubuntu, é o mesmo não está abrindo mais a janela, não sei se tem alguma coisa haver com esse problema no gerenciador de atualizações.

Como posso prosseguir para corrigir o problema?

Se alguem puder ajudar eu agradeço.
« Última modificação: 31 de Maio de 2011, 00:37 por lsoares »

Offline Andreson Goveia

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 1.985
  • Kubuntu 14.10
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #1 Online: 30 de Maio de 2011, 23:29 »
Vá la no terminal, hehe
e digite

$sudo gedit /etc/apt/sources.list

copia o conteudo aqui
(Não altere nada ainda ok?)

Offline lsoares

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #2 Online: 30 de Maio de 2011, 23:34 »
Andry, abriu este arquivo com o seginte conteudo:


#deb cdrom:[Ubuntu 10.10 _Maverick Meerkat_ - Release i386 (20101007)]/ maverick main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://br.archive.ubuntu.com/ubuntu/ maverick main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ maverick main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://br.archive.ubuntu.com/ubuntu/ maverick-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ maverick-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://br.archive.ubuntu.com/ubuntu/ maverick universe
deb-src http://br.archive.ubuntu.com/ubuntu/ maverick universe
deb http://br.archive.ubuntu.com/ubuntu/ maverick-updates universe
deb-src http://br.archive.ubuntu.com/ubuntu/ maverick-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://br.archive.ubuntu.com/ubuntu/ maverick multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ maverick multiverse
deb http://br.archive.ubuntu.com/ubuntu/ maverick-updates multiverse
deb-src http://br.archive.ubuntu.com/ubuntu/ maverick-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://br.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse
# deb-src http://br.archive.ubuntu.com/ubuntu/ maverick-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu maverick partner
# deb-src http://archive.canonical.com/ubuntu maverick partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu maverick main
deb-src http://extras.ubuntu.com/ubuntu maverick main

deb http://security.ubuntu.com/ubuntu maverick-security main restricted
deb-src http://security.ubuntu.com/ubuntu maverick-security main restricted
deb http://security.ubuntu.com/ubuntu maverick-security universe
deb-src http://security.ubuntu.com/ubuntu maverick-security universe
deb http://security.ubuntu.com/ubuntu maverick-security multiverse
deb-src http://security.ubuntu.com/ubuntu maverick-security multiverse

_____________________

Isso msmo? Agradeço pela ajuda desde já.

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #3 Online: 30 de Maio de 2011, 23:42 »
Ola veja se ajuda e um comando so;

sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.bkup ; sudo rm /var/lib/dpkg/status ; sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status ; sudo rm /var/lib/apt/lists/* ; sudo rm /var/lib/apt/lists/partial/* ; sudo apt-get clean ; sudo apt-get -f install ; sudo apt-get update
« Última modificação: 30 de Maio de 2011, 23:45 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline lsoares

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #4 Online: 31 de Maio de 2011, 00:04 »
Platão, verifique se fiz certo:


leandro-I38II:~$ sudo cp /var/lib/dpkg/status /var/lib/dpkg/status.bkup
leandro-I38II:~$ sudo rm /var/lib/dpkg/status
leandro-I38II:~$ sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status
leandro-I38II:~$ sudo rm /var/lib/apt/lists/*
rm: não foi possível remover `/var/lib/apt/lists/partial': É um diretório
leandro-I38II:~$ sudo rm /var/lib/apt/lists/*
rm: não foi possível remover `/var/lib/apt/lists/partial': É um diretório
leandro-I38II:~$ sudo rm /var/lib/apt/lists/partial/*
rm: não foi possível remover `/var/lib/apt/lists/partial/*': Arquivo ou diretório não encontrado
leandro-I38II:~$ sudo apt-get clean
leandro-I38II:~$ sudo apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  linux-headers-2.6.35-22 linux-headers-2.6.35-22-generic
Use 'apt-get autoremove' para removê-los.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.


____________________

Verificando aqui o Gerenciador de pacotes Synaptic voltou a abrir a janela. A mensagem de erro também desapareceu.

Vou fazer uns testes aqui para ver se stá tudo ok.

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #5 Online: 31 de Maio de 2011, 00:10 »
Ola e um comando so, simples, que deve ser copiado inteiro no seu terminal, mas como vc fez esta certo tbm.
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline lsoares

  • Usuário Ubuntu
  • *
  • Mensagens: 20
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #6 Online: 31 de Maio de 2011, 00:17 »
O meu sistema está tudo ok agora, obrigado pela ajudar de vocês. Realmente, fiz o comando pelo modo mais dificil. Ficar como experiência..rs
A Central de Programs Ubuntu também abriu; :)

O sistema Ubuntu é muito soda, estou adorando. Espero domina-ló assim como eu fiz com o XP.
O Windows Seven é muito ruim, sistema bug toda hora, mandei logo pra valar.

Só uma ultima dúvida, algum comando para instalar o Java? Estou precisando para abrir a plataforma Apligraf.

Obrigado pela ajudar Platão e Adryan.

Offline platao

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 5.052
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #7 Online: 31 de Maio de 2011, 00:30 »
Se a duvida foi sanada por gentileza edite a primeira pergunta desse topico e acrescentar o icone solucionado;

http://www.youtube.com/watch?v=cW8isbYhR_M

Filminho cortezia do Tota.

Apostilas na assinatura abaixo.
« Última modificação: 31 de Maio de 2011, 00:33 por platao »
\\\\\\\\Apostilas Dicas e Guias do Ubuntu\\\\\\\\\> http://ubuntuforum-br.org/index.php/topic,79368.msg440997.html#msg440997

Offline manasses745

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: (ERROR) Gerenciador de atualizações
« Resposta #8 Online: 29 de Junho de 2011, 19:16 »
 ;D cara valeu eu estava com o mesmo def.no meu ubuntu 11.04 muito obrigado.