Autor Tópico: Ubuntu 11.04 conecta, mas não acessa alguns sites com internet rádio [Resolvido]  (Lida 42586 vezes)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Boa noite pessoal,

Criei este tópico na seção de iniciantes (que sou), mas não obtive sucesso para resolver o problema.
Trata-se do seguinte: recentemente, tanto com a versão 10.10 e, agora, com a 11.04, encontro o seguinte problema: o firefox não acessa algumas páginas como youtube. Fica apenas carregando, aparece o nome na barra de títulos mas, nada de exibir o conteúdo. Uso internet via rádio, de 600 kbps. O problema acontece tanto conectando o notebook diretamente no cabo de rede, ou pela wireless. No windows 7 navega normalmente, e acessa qualquer página. O IP da rede é dinâmico. Não fiz nenhuma configuração manual, o ubuntu auto-configurou a conexão. O Firestarter não está instalado.
Já me recomendaram alterar a configuração do roteador wireless, mas não vejo porque, já que o problema persiste se conecto o notebook diretamente ao cabo da rede (que está ligado a um roteador, e este diretamente conectado à antena da internet).

Desde já agradeço a atenção.

Obrigado.
« Última modificação: 26 de Julho de 2011, 14:48 por luizjunior »
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #1 Online: 15 de Maio de 2011, 16:17 »
Você está usando o plugin Flash proprietário, ou o Gnash?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #2 Online: 16 de Maio de 2011, 21:25 »
Boa noite,
desculpe a demora.

Como faço para verificar isso? através do firefox?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline ale.leleco

  • Usuário Ubuntu
  • *
  • Mensagens: 24
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #3 Online: 16 de Maio de 2011, 21:34 »
Amigo alem do plugin do flash da uma olhada no plugin do java....
neste tópico aqui eu tive problema com a instalação mas resolvi:
http://ubuntuforum-br.org/index.php/topic,80814.0.html
neste aqui estou tentando instalar no ubuntu 11.04
http://ubuntuforum-br.org/index.php/topic,82949.0.html
Alessandro
Ale.leleco@gmail.com
@_aleleleco

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #4 Online: 16 de Maio de 2011, 22:00 »
Boa noite,
desculpe a demora.

Como faço para verificar isso? através do firefox?

Sim, vc pode verificar pelo próprio firefox.

Abra a página "about:plugins" e veja se aparece na lista de plugins o Shockwave Flash.
Aproveite e veja também e veja o plugin java, já que o leleco lembrou.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #5 Online: 16 de Maio de 2011, 22:00 »
Valeu,

vou dar uma olhada e posto aqui o resultado.
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #6 Online: 16 de Maio de 2011, 23:47 »
Fiz conforme dizia o tutorial de configuração e instalação do Java. Não sei se instalou completamente, veja no final da instalação o que aparece:

luizjunior@luizjunior-Vostro1310:~$ sudo apt-get -y install sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin
[sudo] password for luizjunior:
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Os pacotes extra a seguir serão instalados:
  gsfonts-x11 unixodbc
Pacotes sugeridos:
  ttf-kochi-gothic ttf-sazanami-gothic ttf-kochi-mincho ttf-sazanami-mincho
  ttf-arphic-uming libmyodbc odbc-postgresql tdsodbc unixodbc-bin
Os NOVOS pacotes a seguir serão instalados:
  gsfonts-x11 sun-java6-bin sun-java6-fonts sun-java6-jre sun-java6-plugin
  unixodbc
0 pacotes atualizados, 6 pacotes novos instalados, 0 a serem removidos e 89 não atualizados.
É preciso baixar 36,6 MB de arquivos.
Depois desta operação, 105 MB adicionais de espaço em disco serão usados.
Obter:1 http://br.archive.ubuntu.com/ubuntu/ natty/main unixodbc i386 2.2.14p2-2ubuntu1 [227 kB]
Obter:2 http://archive.canonical.com/ubuntu/ natty/partner sun-java6-jre all 6.24-1build0.10.10.1 [6.386 kB]
Obter:3 http://br.archive.ubuntu.com/ubuntu/ natty/main gsfonts-x11 all 0.21 [10,5 kB]
Obter:4 http://archive.canonical.com/ubuntu/ natty/partner sun-java6-bin i386 6.24-1build0.10.10.1 [30,0 MB]
Obter:5 http://archive.canonical.com/ubuntu/ natty/partner sun-java6-fonts all 6.24-1build0.10.10.1 [1.882 B]
Obter:6 http://archive.canonical.com/ubuntu/ natty/partner sun-java6-plugin i386 6.24-1build0.10.10.1 [1.854 B]
Baixados 36,6 MB em 9min 22s (65,0 kB/s)                                       
Pré-configurando pacotes ...
Selecionando pacote previamente não selecionado sun-java6-jre.
(Lendo banco de dados ... 147032 ficheiros e directórios actualmente instalados.)
Desempacotando sun-java6-jre (de .../sun-java6-jre_6.24-1build0.10.10.1_all.deb) ...
Selecionando pacote previamente não selecionado unixodbc.
Desempacotando unixodbc (de .../unixodbc_2.2.14p2-2ubuntu1_i386.deb) ...
Selecionando pacote previamente não selecionado sun-java6-bin.
Desempacotando sun-java6-bin (de .../sun-java6-bin_6.24-1build0.10.10.1_i386.deb) ...
sun-dlj-v1-1 license has already been accepted
Selecionando pacote previamente não selecionado gsfonts-x11.
Desempacotando gsfonts-x11 (de .../gsfonts-x11_0.21_all.deb) ...
Selecionando pacote previamente não selecionado sun-java6-fonts.
Desempacotando sun-java6-fonts (de .../sun-java6-fonts_6.24-1build0.10.10.1_all.deb) ...
Selecionando pacote previamente não selecionado sun-java6-plugin.
Desempacotando sun-java6-plugin (de .../sun-java6-plugin_6.24-1build0.10.10.1_i386.deb) ...
Processando gatilhos para shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Processando gatilhos para man-db ...
Processando gatilhos para bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processando gatilhos para desktop-file-utils ...
Processando gatilhos para python-gmenu ...
Rebuilding /usr/share/applications/desktop.pt_BR.utf8.cache...
Processando gatilhos para fontconfig ...
Processando gatilhos para python-support ...
Configurando unixodbc (2.2.14p2-2ubuntu1) ...
Configurando gsfonts-x11 (0.21) ...
Configurando sun-java6-bin (6.24-1build0.10.10.1) ...
update-alternatives: a usar /usr/lib/jvm/java-6-sun/jre/bin/ControlPanel para disponibilizar /usr/bin/ControlPanel (ControlPanel) em modo automático.
update-alternatives: a usar /usr/lib/jvm/java-6-sun/jre/bin/java_vm para disponibilizar /usr/bin/java_vm (java_vm) em modo automático.
update-alternatives: a usar /usr/lib/jvm/java-6-sun/jre/bin/jcontrol para disponibilizar /usr/bin/jcontrol (jcontrol) em modo automático.
Configurando sun-java6-jre (6.24-1build0.10.10.1) ...
Configurando sun-java6-fonts (6.24-1build0.10.10.1) ...
Updating fontconfig cache for /usr/share/fonts/truetype/ttf-lucida
Configurando sun-java6-plugin (6.24-1build0.10.10.1) ...
Processando gatilhos para libc-bin ...
ldconfig deferred processing now taking place
N: Ignorando 'apt-build' no diretório '/etc/apt/sources.list.d/' pois não tem extensão de arquivo

luizjunior@luizjunior-Vostro1310:~$ java -version
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.1) (6b22-1.10.1-0ubuntu1)
OpenJDK Server VM (build 20.0-b11, mixed mode)

Verifiquei e na lista do firefox em "about-plugins" tanto o java quanto o Shockwave Flash aparecem.

Ainda não abre a página do youtube.
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #7 Online: 16 de Maio de 2011, 23:50 »
Desculpe por não ter postado como código. Não me liguei.
Ah, e tive que acessar pelo windows para postar aqui. Pelo Ubuntu pedia para fazer download ou abrir o index do site, acabava abrindo um documento de texto em branco...
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline cesargcomp

  • Usuário Ubuntu
  • *
  • Mensagens: 545
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #8 Online: 17 de Maio de 2011, 00:40 »
No caso do java, acrescente esses comandos (são 4 comandos digitados um de cada vez no terminal):

Código: [Selecionar]
sudo update-java-alternatives -s java-6-sun
cd /usr/lib/mozilla/plugins
sudo ln -s /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so
sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

Teste o java assim: java -version
E assim: http://javatester.org/version.html

O caso de não acessar alguns sites acontece comigo no 10.04, aconteceu no 10.10 e no 11.04. Hoje uso o 10.04.  Só volta funcionar ao reiniciar o sistema (muito estranho e ainda não achei solução).

« Última modificação: 17 de Maio de 2011, 00:43 por cesargcomp »
Use Ubuntu. Segurança, facilidade e gratuidade em suas mãos.

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #9 Online: 17 de Maio de 2011, 09:37 »
No caso do java, acrescente esses comandos (são 4 comandos digitados um de cada vez no terminal):

Código: [Selecionar]
sudo update-java-alternatives -s java-6-sun
cd /usr/lib/mozilla/plugins
sudo ln -s /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so
sudo ln -s /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so

Teste o java assim: java -version
E assim: http://javatester.org/version.html

O caso de não acessar alguns sites acontece comigo no 10.04, aconteceu no 10.10 e no 11.04. Hoje uso o 10.04.  Só volta funcionar ao reiniciar o sistema (muito estranho e ainda não achei solução).

Cesar, isso só é necessário quando se instala o pacote Java direto do site da Sun, sem ser pelo repositório.

Citar
Pelo Ubuntu pedia para fazer download ou abrir o index do site, acabava abrindo um documento de texto em branco...
Hmm. Isso não é problema com o Java (que aliás, não é necessário pra Youtube) nem com Flash. Fosse com o Flash, a página abriria, mas o vídeo em si não apareceria, ou travaria, ou sei lá, mas a página base apareceria.

Luiz, vc tem algum outro navegador instalado que possa fazer o teste de acessar? Por exemplo, o Opera?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #10 Online: 17 de Maio de 2011, 22:39 »
Citar
Luiz, vc tem algum outro navegador instalado que possa fazer o teste de acessar? Por exemplo, o Opera?
Hoje o sistema pediu para fazer uma atualização, onde foi acabou sendo instalado o Chromium. Nele o mesmo problema acontece, porém após ficar carregando a página por um tempo, aparece a mensagem como se não estivesse conectado à internet (mesmo acontece ao tentar postar aqui no fórum); diferente do Firefox que fica só carregando.
Zekkerj, você acha que devo fazer um teste com este Opera? não sei o que está havendo.
Estou utilizando windows em uma partição, e ubuntu na outra. Mas a vontade é ir resolvendo estes problemas para no futuro passar a usar apenas o Ubuntu.

Fico no aguardo!
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #11 Online: 18 de Maio de 2011, 08:42 »
Acho necessário sim, pq três navegadores diferentes não podem estar com o mesmo problema. Descarta a possibilidade do problema estar na aplicação, e resta do problema ser de rede...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #12 Online: 18 de Maio de 2011, 11:03 »
Ok. Hoje meio dia vou instalar o Opera e fazer o teste. Mas Zekkerj, se o windows navega bem, não é possível que seja uma questão de re-configuração da rede no Ubuntu?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #13 Online: 18 de Maio de 2011, 11:05 »
Explicando um pouco melhor...

Inicialmente estavámos pensando ser um problema na aplicação: verificamos plugin flash, plugin java.

Quando fizemos o teste com navegadores diferentes, vimos que a resposta não bate com problema de aplicação. Por isso estou pedindo pra você instalar e testar com o Opera, para descartar de vez essa possibilidade.

A hipótese seguinte é justamente testar a configuração de rede do Ubuntu. Veja que há um ponto em que a rede do Ubuntu é significativamente diferente da rede do windows, principalmente windows vista e 7, que é o suporte a ipv6.

Ocorre que essas duas versões do windows criam automaticamente uma conexão de túnel [teredo] ipv6, que dá alguma conectividade ipv6 à máquina. Ou seja, se o navegador resolver um nome em IPv6, vai conseguir acessar.

Já no Ubuntu, apesar do navegador já resolver nomes em IPv6, e o sistema estar plenamente preparado para funcionar em IPv6, não há criação desse túnel automático (pra variar, o custo da praticidade é a segurança: o tal túnel passa pela rede da Microsoft, o que significa que ela tem acesso a tudo que vc faz trafegar por esse túnel). Sem o túnel, a única forma de navegar em IPv6 é se o seu provedor der suporte. No momento, acredito que nenhum provedor comercial ofereça o serviço de conexão com IPv6 (apesar de ser de pleno conhecimento que o IPv4 está com os dias contados).

Depois que a gente descartar definitivamente a possibilidade do problema na aplicaçãok, vamos começar a verificar problemas de rede, e uma das coisas que vamos tentar é desativar o suporte do navegador pra IPv6.
« Última modificação: 18 de Maio de 2011, 11:13 por zekkerj »
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Ubuntu 11.04 conecta, mas não acessa alguns sites
« Resposta #14 Online: 18 de Maio de 2011, 23:37 »
Boa noite,
Zekkerj, instalei o Opera versão 11.11 para Ubuntu e o problema ocorre também através dele. No caso do youtube a página chega em +- 70% e para de carregar. Outro site que dava problema é o do terra mail (mail.terra.com.br). Neste segundo, abria a página inicial, porém quando colocava login e senha, não acessava a conta. Com o Opera, quando vou digitar um dos campos, some o conteúdo da página. Enfim, não quero ficar escrevendo coisa que não precisa ser levada em conta. É só por questão de informação.
Um fator que lembrei hoje foi que, quando fui instalar a versão 11.04, instalei-a do zero. Formatei a  partição antiga, e criei uma swap de 1 gb, e a outra que não lembro o nome agora para o Ubuntu. Instalei o sistema e, ao final da instalação, o notebook não reiniciou. Tive que fazê-lo pelo botão de liga/desliga forçando o desligamento. Quando o sistema reiniciou, ocorreu tudo normalmente.
Como sou iniciante, ocorrem algumas coisas que não sei se é normal, fico pensando se não é por erro de instalação do sistema. Por exemplo quando vou desligar o Ubuntu, depois de encerrar o sistema (a parte gráfica bonitinha), aparecem umas mensagens em uma tela preta (se não me engano em uma das linhas diz no final: killed). Como disse sou iniciante. Só me lembrei disso porque pode ter ocorrido algum problema no final da instalação, ou não.
Realmente não quero estar me apegando a detalhes demais. Isso foi só por questão de informação.
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)