Autor Tópico: Libreoffice não abre corretamente no KDE 4.6  (Lida 2645 vezes)

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Libreoffice não abre corretamente no KDE 4.6
« Online: 17 de Maio de 2011, 18:20 »
Olá.

O KDE 4.6 está impressionante. Mas estou com problemas. Removi o libreoffice que vêm por padrão no Kubuntu e instalei os pacotes baixados diretamente do site do libreoffice (testei inclusive a versão beta 5) e o mesmo problema acontece:

O libreoffice abre e funciona corretamente, mas o tema oxygen-gtk não funciona, e o programa abre com aquele tema padrão do gtk, ficando com uma aparência muito ruim (ou seja, não há tema nenhum).

Já pesquisei no google, mas as soluções apresentadas não surtem efeito.

Grato.
« Última modificação: 17 de Maio de 2011, 19:15 por promurilo »

Offline promurilo

  • Usuário Ubuntu
  • *
  • Mensagens: 185
    • Ver perfil
Re: Libreoffice não abre corretamente no KDE 4.6
« Resposta #1 Online: 17 de Maio de 2011, 19:11 »
Descobri uma solução muito prática. Talvez seja útil para quem vier a ter o mesmo problema. Estou usando o Kubuntu 11.04.

Tive que mesclar algumas informações encontradas em vários sites.

O problema que eu tive parece estar relacionado ao fato de o meu kubuntu ser 64 bits, mas não tenho certeza.

Quando instalamos o libreoffice diretamente do site, sem usar os repositórios, a pasta do programa fica localizada em:

Código: [Selecionar]
/opt/libreoffice
Dentro dessa pasta existem os seguintes arquivos, responsáveis pelo problema:


Código: [Selecionar]
libstdc++.so.6 e libcairo.so.2
O endereço completo dos dois arquivos são os seguintes:

Código: [Selecionar]
/opt/libreoffice/basis3.3/program/libcairo.so.2
/opt/libreoffice/ure/lib/libstdc++.so.6

Em alguns sites, a correção do problema consistia em apenas apagar ou renomear estes arquivos. Preferi somente renomear os dois para o seguinte (como root):

libstdc++.so.6 renomeado para libstdc++.so.6orig
libcairo.so.2 renomeado para libcairo.so.2orig

O problema é que aqui no meu computador a solução não funciona, pois o libreoffice abria, mas ao focar qualquer controle com o mouse ele fechava imediatamente.

Em outro site descobri que faltava criar um link simbólico para a biblioteca libcairo do sistema, localizada em /usr/lib.

Cuidado: esse é um arquivo de sistema e não deve ser apagado.

A dois arquivos importantes: o arquivo chamado libcairo.so.2 na verdade é um link simbólico. Simplesmente copiei esse arquivo (como root) para a pasta

Código: [Selecionar]
/opt/libreoffice/basis3.3/program/.

Devemos agora modificar o link para que ele aponte para o verdadeiro aruivo libcairo.so.2. Para isso, clique no arquivo copiado com o botão direito e escolha 'propriedades'.

Você verá uma caixa de texto indicando que o link aponta para libcairo.so.2.11000.2. Mas esse é um link relativo, assim, como copiamos o arquivo, ele vai procurar o arquivo na pasta atual, e não na pasta /usr/lib. Assim, modifique o link para que fique assim:

Código: [Selecionar]
/usr/lib/libcairo.so.2.11000.2
Pronto. Aqui eu abri o libreoffice e o tema oxygen-gtk funcionou normalmente, integrado com o restando do sistema.

Testei o processo na versão beta 5 do libreoffice e funcionou normalmente.

Obrigado a todos.
« Última modificação: 17 de Maio de 2011, 19:13 por promurilo »