Autor Tópico: Internet 3G nao conecta  (Lida 13589 vezes)

Offline HerrSchafer

  • Usuário Ubuntu
  • *
  • Mensagens: 135
  • Sempre aprendendo... isso evita o Alzhimmer!
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #30 Online: 13 de Maio de 2011, 12:56 »
Progressos zekkerj!

anselmo@chaosdevice:~$ dmesg | tail -20
[  304.457894] sr: Add. Sense: No additional sense information
[  304.628071] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  304.936050] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  305.192066] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  305.508071] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  305.840055] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  306.204052] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  306.456099] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  306.712073] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  306.968081] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  307.224064] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  307.532105] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  307.896079] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  308.071059] sr2: CDROM (ioctl) error, command: Xpwrite, Read disk info 51 00 00 00 00 00 00 00 02 00
[  308.071095] sr: Sense Key : Hardware Error [current]
[  308.071107] sr: Add. Sense: No additional sense information
[  308.184073] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  308.500070] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  308.808079] usb 2-2: reset full speed USB device using uhci_hcd and address 3
[  309.172067] usb 2-2: reset full speed USB device using uhci_hcd and address 3
anselmo@chaosdevice:~$ eject sr2
anselmo@chaosdevice:~$ lsusb
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 05c6:6000 Qualcomm, Inc.
Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
anselmo@chaosdevice:~$ wvdial -C /etc/wvdial.conf
--> WvDial: Internet dialer version 1.61
--> Cannot set information for serial port.
--> Initializing modem.
--> Sending: ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
ATDT*99***1#
CONNECT
--> Carrier detected.  Starting PPP immediately.
--> Unable to run /usr/sbin/pppd.
--> Check permissions, or specify a "PPPD Path" option in wvdial.conf.
--> Timed out while dialing.  Trying again.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
--> Timed out while dialing.  Trying again.
--> Sending: ATDT*99***1#
--> Waiting for carrier.
--> Timed out while dialing.  Trying again.
--> Sending: ATDT*99***1#
--> Waiting for carrier.


Ao que parece, o problema com o hardware foi resolvido; é comum esses modens se apresentarem como um dispositivo composto, onde no "cd-rom" vem os drives pra instalação no sistema do Tio Bíu. Agora pelo que entendi, ele não conseguiu "completar" a ligação.

Tentarei mudar o número de conexão, como dito anteriormente, ou alterar algum parâmetro nowvdial.conf.
O usb-modeswitch é quem faz essa troca do "cd-rom" pelo "modem"?

E muito obrigado pela ajuda
Notebook HP Pavilion g4 Ubuntu 13.04
Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz
3GB ram 500 GB hd (ext4 tunado... tks galactus!)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet 3G nao conecta
« Resposta #31 Online: 13 de Maio de 2011, 14:31 »
Bom saber que estamos evoluindo. Vc chegou a instalar o pacote "usb-modeswitch"? Se não instalou, instale.

Baixar os pacotes para o Ubuntu:
http://packages.ubuntu.com/natty/i386/usb-modeswitch/download (32bits)
http://packages.ubuntu.com/natty/amd64/usb-modeswitch/download (64 bits)

Baixar o usb-modeswitch-data:
http://packages.ubuntu.com/natty/all/usb-modeswitch-data/download (32/64 bits)
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #32 Online: 19 de Julho de 2011, 21:50 »
Boa noite,
como faço para executar o arquivo install.sh?
estou tentando: sudo apt-get install luizjunior/documentos/linux/install.sh

e o terminal retorna com: Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
E: Impossível encontrar o pacote luizjunior/documentos/linux


copiei a pasta com o conteúdo do linux para esta pasta linux de documentos, e descompactei a Vivo_3g para lá junto...
estou executando errado certo?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Internet 3G nao conecta
« Resposta #33 Online: 19 de Julho de 2011, 22:46 »
Citar
como faço para executar o arquivo install.sh?
Supondo que é um arquivo executável, vc vai fazer algo como

cd /diretorio
./install.sh

ou então

/diretorio/install.sh
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #34 Online: 19 de Julho de 2011, 22:52 »
Cara, o usb-modeswitch é a versão mais atual que está instalada, mas conecto o modem, e o pc meio que "tranca", não reconhece. Fiz o processo de instalação do modem pelo terminal, e deu como se tivesse instalado corretamente. Clico no aplicativo do modem, não abre nada. Tentei localizar "Procure por Applications isso já fora do Terminal...Dentro do Applications você vai achar(CONECTIONS NETWORKS) entre La , depois procure por (MOBILE BROADBAND) clique em (ADD) e depois siga os passos sem se esquecer de colocar os (DNS) e (*99#) ", seguindo um tópico aqui do fórum, mas não encontrei nada disso... o que está faltando será?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #35 Online: 19 de Julho de 2011, 22:55 »
Quando instalei o modem, o terminal mostrou uma mensagem de instalação completa, mas apareceu algum erro em seguida. Como faço para verificar esta instalação pelo terminal?
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #36 Online: 19 de Julho de 2011, 23:05 »
Ok. Tudo certo. Após a instalação, conectei o modem, aguarde uns instantes e ele foi reconhecido, segui o assistente, e tudo jóia.  :D
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #37 Online: 19 de Julho de 2011, 23:58 »
ok, conectou uma vez, e as outras, ele reconhece o modem, tenta conectar e dá a mensagem que foi desconectado da rede... Percebi que desmarca sozinha a opção "Habilitar Banda Larga Móvel". Vou fazer o teste do usb que o Zekkerj sugeriu acima, mas instalei corretamente o moderswitch...
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)

Offline luizjunior

  • Usuário Ubuntu
  • *
  • Mensagens: 100
    • Ver perfil
Re: Internet 3G nao conecta
« Resposta #38 Online: 20 de Julho de 2011, 00:03 »
Código: [Selecionar]
luizjunior@luizjunior-Vostro1310:~$ dmesg | tail -20
[  947.973645] option 2-3:1.5: GSM modem (1-port) converter detected
[  947.973822] usb 2-3: GSM modem (1-port) converter now attached to ttyUSB4
[  953.041936] scsi 10:0:0:0: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
[  953.043668] sd 10:0:0:0: Attached scsi generic sg2 type 0
[  953.052129] sd 10:0:0:0: [sdb] Attached SCSI removable disk
[ 1068.607299] usb 2-3: USB disconnect, address 7
[ 1068.613202] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[ 1068.613234] option 2-3:1.0: device disconnected
[ 1068.613522] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[ 1068.613566] option 2-3:1.1: device disconnected
[ 1068.628558] option: option_instat_callback: error -108
[ 1068.628670] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[ 1068.628692] option 2-3:1.3: device disconnected
[ 1068.628821] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[ 1068.628841] option 2-3:1.4: device disconnected
[ 1068.628964] option1 ttyUSB4: GSM modem (1-port) converter now disconnected from ttyUSB4
[ 1068.628982] option 2-3:1.5: device disconnected
[ 1071.970476] keyboard: can't emulate rawmode for keycode 240
[ 1071.970504] keyboard: can't emulate rawmode for keycode 240
[ 1072.412162] usb 3-2: new full speed USB device using uhci_hcd and address 4
luizjunior@luizjunior-Vostro1310:~$ wvdial -C /etc/wvdial.conf
--> WvDial: Internet dialer version 1.61
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
--> Cannot open /dev/modem: No such file or directory
"Amar e mudar as coisas me interessa mais..." (Engenheiros do Hawaii)