Autor Tópico: Madwifi/kismet no ubuntu v10.10 usando Ath9k (resolvido)  (Lida 2527 vezes)

atamico

  • Visitante
Madwifi/kismet no ubuntu v10.10 usando Ath9k (resolvido)
« Online: 06 de Abril de 2011, 20:50 »
Estou com um grande problema, não consigo instalar o madwifi pelo apt-get ....
instalando a ultima versão do madwifi e instalando aparentemente não acontece nada... pois o drive verificado pelo comando "$ iwconfig" mostra a placa como wlan0 e o que quero é colocar esse wlan0 para ath0. (Modelo = Atheros AR5B97)

O problema é que... apos instalar o madwifi (ou pelomenos tentar) colocar ath_pci na no arquivo "/etc/modules utilizando "nano" e detre tantas outras tentativas... o "kismet" não reconhece a placa com interface ath0.

Obs.:
1º - Kernel reconhece placa como ath9k
2º - com "$ iwconfig" tenho como retorno "wlan0" (queria ath0)
3º - kismet não reconhece, como se madwifi nao estivesse instalado e aparentemente não instalou de verdade.
4º - placa "wlan0" não aceita ser colocada em modo monitor
5º - pacote apt-get/aptitude install não encontra pacotes madwifi-tools
6º - Todas as operações de tentativa foram feitas com user "root" no teminal.

Espero que tenha dado para entender e que me ajudem... Aguardo!!!!

(EDITADO EM 09/08/2011)
Resolvi o problema sozinho alterando o arquivo "kismet.conf" com "nano" nas linhas "source e user"

user: seu nome de usuario
source: ath5k,wlan0,atheros

Isso mesmo! ath5k!
Não sei explicar... só sei que funcionou como ath5k e que esta versão do ubuntu não depende do madwifi.

Até +
« Última modificação: 09 de Agosto de 2011, 02:09 por atamico »