Autor Tópico: modem 3g da huawei E173 s da tim não é reconhecido como modem  (Lida 18443 vezes)

Offline jo7ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
modem 3g da huawei E173 s da tim não é reconhecido como modem
« Online: 23 de Fevereiro de 2011, 10:27 »
por favor, alguém me ajude!!
tenho um modem da huawei modelo E173s que não é reconhecido de jeito nenhum como modem, e sim como unidade de cd.
como resolvo isso?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.335
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #1 Online: 23 de Fevereiro de 2011, 10:56 »
Instalou o pacote "usb-modeswitch"?
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #2 Online: 23 de Fevereiro de 2011, 10:57 »
como resolvo isso?

Ola

A maneira mais rápida para resolver isto, seria utilizar a pesquisa do forum.

Como voce não fez, vou dar uma dica. Leia este tópico => http://ubuntuforum-br.org/index.php/topic,77066.0.html

Abraços

Offline jo7ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #3 Online: 23 de Fevereiro de 2011, 11:43 »
vou tentar fazer oq o tópico manda

Offline jo7ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #4 Online: 23 de Fevereiro de 2011, 12:18 »
eu ja tenho a versão mais nova do usb-modeswitch, e já pesquisei também em todo o forum e também na internet e nada,
vale lembrar que o modelo do meu modem é E173s, e não E173.
meu S O é o Ubuntu 10.10

por favor preciso muito saber como faze-lo funcionar.

obrigado!!
« Última modificação: 23 de Fevereiro de 2011, 12:26 por jo7ribeiro »

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #5 Online: 23 de Fevereiro de 2011, 13:48 »
ola

se abrir seu modem como pendrive, existe uma pasta /Linux dentro?

se tiver, quais arquivos possui?

[]'s

Offline jo7ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #6 Online: 23 de Fevereiro de 2011, 22:54 »
dentro da unidade de armazenamento (pen drive) não tem nada sobre linux, somente windows e mac

Offline Tota

  • Usuário Ubuntu
  • *
  • Mensagens: 14.982
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #7 Online: 24 de Fevereiro de 2011, 08:12 »
Ola

Verifique no gerenciador synaptic se o usb-modemswitch-data também está instalado.

Se não, instale. Reinicie a maquina.

[]'s

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.335
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #8 Online: 24 de Fevereiro de 2011, 11:01 »
O pacote "usb-modemswitch-data" é dependência do "usb-modeswitch", um não instalaria sem o outro.

Mas se ele instalou a partir do site do desenvolvedor (http://www.draisberghof.de/usb_modeswitch/#download), pode ser que realmente tenha esquecido de instalar o "usb-modeswitch-data".
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline jo7ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #9 Online: 24 de Fevereiro de 2011, 18:54 »
eu instalei pelo repositorio do linux, e tenhu certeza q estah instalado o usb-modemswitch-data...

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.335
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
    • Blog do Zekke
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #10 Online: 24 de Fevereiro de 2011, 19:50 »
Então já fica a sugestão de tentar instalar os pacotes do desenvolvedor, que são um pouco mais novos.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline giovaniforum

  • Usuário Ubuntu
  • *
  • Mensagens: 3
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #11 Online: 24 de Fevereiro de 2011, 20:39 »
Olá a todos!! Essa será minha primeira participação aqui com vocês. Espero que aproveitem!

Antes de responder saibam que, a melhor parte, de tudo, foi ouvir o vendedor da operadora falar (como fala para todos os clientes):

          "XIIiiiiiiii, não funciona no Linux! Vai ter que instalar o Windows!!!"

          Peraê né!!! Tá de brincadeira!!! Heheheh!! Quem aqui tomou essa decisão por causa de um modenzinhoinho desse!!! HahahHAHahah!!

Caro jo7ribeiro, o meu S.O. é um Ubuntu 10. Caso seja o mesmo (pois só testei nesta versão), apenas faça o seguinte:

"Os crédito vão para o anônimo deste link". => http://www.taginfo.com.br/s1/index.php?option=com_content&view=article&id=95:instalar-o-modem-huawei-e173-no-ubuntu-10&catid=6:ti&Itemid=8

O modem Huawei E173 vendido pela operadora da Vivo na realidade é o modelo E173S, que não é reconhecido automaticamente pelo Ubuntu 10.

Segue abaixo os passos para configurar este dispositivo no Ubuntu 10:

Vai um OB, importante > Leia tudo antes!! Depois execute os comandos! Pra não ter dúvidas. Mas se tiver pergunte que nós respondemos!

1 - Digite na linha de comando

         ubuntu@ubuntu:$ lsusb  >para obter ou confirmar o ID, do vabricante e do produto

     Você vai ter algo como

         Bus 002 Device 005: ID 12d1:1c0b Huawei Technologies Co., Ltd.

     Neste ""exemplo"" os caracteres após o "ID" são na ordem > "ID do Fabricante":"ID do produto"

   
     Agora você continua com o how to...

         Crie o arquivo /etc/usb_modeswitch.d/12d1:1c0b <> Não esqueca este é exemplo. Coloque no lugar do "12d1:1c0b" o ID do seu modem.

     sudo gedit /etc/usb_modeswitch.d/12d1:1c0b


2 - Coloque o conteúdo abaixo e salve o arquivo:

########################################################
# ""Escreva aqui o nome do seu modem""

DefaultVendor= 0x12d1 #não esqueça de trocar caso o ID do vendor (fabricante) e produto, seja diferente!!
DefaultProduct= 0x1c0b

TargetVendor= 0x12d1
TargetProduct= 0x1c05

CheckSuccess=20

MessageEndpoint= 0x0f
MessageContent= "55534243123456780000000000000011062000000100000000000000000000"


3 - Adicione no final do arquivo /lib/udev/rules.d/40-usb_modeswitch.rules

             sudo gedit /lib/udev/rules.d/40-usb_modeswitch.rules

     Estas linhas
     
     Não esqueça de trocar as ID neste arquivo também, sem retirar as aspas.

# ""Coloque aqui o nome do seu modem""
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1c0b", RUN+="usb_modeswitch '%b/%k'"


Agora você só deverá escolher se vai utilizar o Gerenciador de redes que está em "Sistema>Preferências>Conexões de rede"
ou o "wvdial" ou o "pppconfig" e ainda o "gnome-ppp"!!!

É tudo facimmm!! Nese link =>  http://www.vivaolinux.com.br/artigo/Passos-essenciais-para-configurar-seu-modem-3G-no-Linux?pagina=4
 do amigo "acvsilva", e explica com detalhes  a configuração para se conectar ou... dê uma googada.

Já testei com 03 modelos de modem no meu not com Ubuntu 10, e não tive problemas!

"Os crédito vão para o anônimo deste link". => http://www.taginfo.com.br/s1/index.php?option=com_content&view=article&id=95:instalar-o-modem-huawei-e173-no-ubuntu-10&catid=6:ti&Itemid=8

Offline jo7ribeiro

  • Usuário Ubuntu
  • *
  • Mensagens: 8
    • Ver perfil
Re: modem 3g da huawei E173 s da tim não é reconhecido como modem
« Resposta #12 Online: 25 de Fevereiro de 2011, 10:44 »
jah havia feito este procedimento e ainda assim ele naum funcionou