Autor Tópico: Problema para conectar à internet  (Lida 9936 vezes)

Offline Mauricio_E

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #15 Online: 02 de Fevereiro de 2011, 23:41 »
Olá .carol.

Execute os comandos abaixo e cole o resultado aqui, pra gente poder analisar seu problema.

sudo lshw -C network

ifconfig -a

nm-tool

ping www.google.com




Olás.
Será que alguém poderia me ajudar.
Instalei o ubuntu 10.10 há 15 dias.
Tudo ia muito bem até que hoje o sistema não reconhece mais as redes wireless.
Creio que o problema aconteceu após uma atualização, mas não tenho certeza.

O resultado das perguntas acima está aqui:

root@mauricio-Inspiron-N4010:~# sudo lshw -C network
  *-network DISABLED      
       description: Wireless interface
       product: Centrino Advanced-N 6200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 35
       serial: 00:27:10:92:16:90
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=2.6.35-25-generic-pae firmware=9.221.4.1 build 25532 latency=0 link=yes multicast=yes wireless=IEEE 802.11abg
       resources: irq:46 memory:f0500000-f0501fff
  *-network
       description: Ethernet interface
       product: AR8152 v1.1 Fast Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: c1
       serial: b8:ac:6f:ec:8b:ae
       size: 100MB/s
       capacity: 100MB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.0.2-NAPI duplex=full firmware=N/A ip=192.168.2.104 latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
       resources: irq:47 memory:f0400000-f043ffff ioport:2000(size=128)
root@mauricio-Inspiron-N4010:~# iwconfig wlan0
wlan0     IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
root@mauricio-Inspiron-N4010:~# ifconfig -a
eth0      Link encap:Ethernet  Endereço de HW b8:ac:6f:ec:8b:ae  
          inet end.: 192.168.2.104  Bcast:192.168.2.255  Masc:255.255.255.0
          endereço inet6: fe80::baac:6fff:feec:8bae/64 Escopo:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Métrica:1
          pacotes RX:17551 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:18489 erros:0 descartados:0 excesso:0 portadora:3
          colisões:0 txqueuelen:1000
          RX bytes:13883642 (13.8 MB) TX bytes:3543929 (3.5 MB)
          IRQ:47

lo        Link encap:Loopback Local  
          inet end.: 127.0.0.1  Masc:255.0.0.0
          endereço inet6: ::1/128 Escopo:Máquina
          UP LOOPBACK RUNNING  MTU:16436  Métrica:1
          pacotes RX:50 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:50 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:0
          RX bytes:5366 (5.3 KB) TX bytes:5366 (5.3 KB)

wlan0     Link encap:Ethernet  Endereço de HW 00:27:10:92:16:90  
          BROADCAST MULTICAST  MTU:1500  Métrica:1
          pacotes RX:0 erros:0 descartados:0 excesso:0 quadro:0
          Pacotes TX:0 erros:0 descartados:0 excesso:0 portadora:0
          colisões:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@mauricio-Inspiron-N4010:~# mm-tool
Comando 'mm-tool' não encontrado, você quis dizer:
 Comando 'nm-tool' do pacote 'network-manager' (main)
 Comando 'mmc-tool' do pacote 'libcdio-utils' (universe)
 Comando 'mc-tool' do pacote 'telepathy-mission-control-5' (main)
mm-tool: comando não encontrado
root@mauricio-Inspiron-N4010:~# A^C
root@mauricio-Inspiron-N4010:~# ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill
root@mauricio-Inspiron-N4010:~# nm-tool

NetworkManager Tool

State: connected

- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlagn
  State:             unavailable
  Default:           no
  HW Address:        00:27:10:92:16:90

  Capabilities:

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points


- Device: eth0  [Auto eth0] ----------------------------------------------------
  Type:              Wired
  Driver:            atl1c
  State:             connected
  Default:           yes
  HW Address:        B8:AC:6F:EC:8B:AE

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         192.168.2.104
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.2.1

    DNS:             201.6.0.106
    DNS:             201.6.0.104






Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.126
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #16 Online: 03 de Fevereiro de 2011, 01:51 »
Citar
Será que alguém poderia me ajudar.
Aguarda só resolver o problema da (do?) .Carol....
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline Mauricio_E

  • Usuário Ubuntu
  • *
  • Mensagens: 33
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #17 Online: 03 de Fevereiro de 2011, 10:07 »
Obrigado pela disponibilidade, Zzerkerj.
Eu aguardo.
Mauricio

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #18 Online: 03 de Fevereiro de 2011, 10:29 »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.126
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #19 Online: 03 de Fevereiro de 2011, 16:45 »
Nos campos "DNS1" e "DNS2", informe, respectivamente, "8.8.8.8" e "208.67.220.220".

Salve a configuração, depois vá nas estações e mande renovar a cessão do IP. (Essa dica serve tanto pro Linux quanto pro Windows).

Pra renovar a cessão no Linux, execute o comando

sudo dhclient -r eth0

Pra renovar a cessão no Windows, execute o comando

ipconfig /renew

Depois de renovar a cessão, confirme que o servidor DNS da estação passou a apontar pros servidores do Google (8.8.8.8) e do OpenDNS (208.67.220.220). Teste novamente as conexões, diga se melhorou.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #20 Online: 03 de Fevereiro de 2011, 17:23 »
Tive que mudar o DNS de Dinâmico para estático para poder alterá-lo
A Internet até agora está funcionando normalmente

Imagens:
http://img707.imageshack.us/i/capturadetelaqwestfirmwy.png/
http://img691.imageshack.us/i/capturadetelacarolineca.png/
http://img203.imageshack.us/i/capturadetela2h.png/



Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #21 Online: 03 de Fevereiro de 2011, 17:29 »
tentei fazer a mesma coisa no desktop, mas não obtive o mesmo resultado  :-[

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #22 Online: 04 de Fevereiro de 2011, 13:09 »
Depois de reiniciar o modem a internet não funcionou mais

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.126
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #23 Online: 04 de Fevereiro de 2011, 14:22 »
Confirme que:

1. Vc recebeu as informações corretas da conexão (IP, gateway e servidores DNS) pelo DHCP;

2. Vc tem conectividade para o IP do roteador.

3. Vc tem  conectividade para o IP dos servidores DNS.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #24 Online: 04 de Fevereiro de 2011, 15:35 »
Como fasso para confirmar isso?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.126
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #25 Online: 04 de Fevereiro de 2011, 15:43 »
No linux, vc pode usar o comando "nm-tool" pra confirmar os parâmetros recebidos por DHCP.
Pra testar conectividade, vc usa o comando "ping", seguido pelo IP a ser testado.
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #26 Online: 04 de Fevereiro de 2011, 17:30 »
Depois de executar o comando dhclient -r eth0
a internet voltou a funcionar, mas vou colar o resultado do comando nm-tool aqui


NetworkManager Tool

State: connected

- Device: eth0 -----------------------------------------------------------------
  Type:              Wired
  Driver:            forcedeth
  State:             unavailable
  Default:           no
  HW Address:        00:1E:68:B1:0D:D5

  Capabilities:
    Carrier Detect:  yes

  Wired Properties
    Carrier:         off


- Device: wlan0  [Auto Molina] -------------------------------------------------
  Type:              802.11 WiFi
  Driver:            ath5k
  State:             connected
  Default:           yes
  HW Address:        00:22:69:01:33:64

  Capabilities:
    Speed:           54 Mb/s

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points (* = current AP)
    DnBRpt2:         Infra, 00:4F:62:21:E6:0C, Freq 2412 MHz, Rate 54 Mb/s, Strength 15
    *Molina:         Infra, 00:15:05:33:91:53, Freq 2437 MHz, Rate 54 Mb/s, Strength 64 WEP
    dlink:           Infra, 00:26:5A:5F:84:88, Freq 2437 MHz, Rate 54 Mb/s, Strength 24 WPA WPA2

  IPv4 Settings:
    Address:         192.168.0.139
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.254.254
    DNS:             192.168.0.1


Apesar de aparecer esses numeros de DNS ai, quando vou no modem estão aqueles numeros que vc me passou antes

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #27 Online: 18 de Fevereiro de 2011, 15:35 »
Novamente estou tendo problemas com a minha internet

quando tento executar o comando dhclient -r eth0 aparece isso

caroline@caroline:~$ dhclient -r eth0
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

can't create /var/lib/dhcp3/dhclient.leases: Permission denied
Open a socket for LPF: Operation not permitted
 
e eu não consigo usar a internet, mas quando a minha irmã começa a usar o computador dela e se conecta à internet, volta a ter internet no meu computador

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.126
  • Gratidão gera gratidão, lamúria gera lamúria...
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #28 Online: 18 de Fevereiro de 2011, 15:38 »
Citar
Open a socket for LPF: Operation not permitted
Só o root pode mexer nas interfaces. Execute o comando com "sudo".

sudo dhclient -r eth0
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline .Carol.

  • Usuário Ubuntu
  • *
  • Mensagens: 18
    • Ver perfil
Re: Problema para conectar à internet
« Resposta #29 Online: 27 de Fevereiro de 2011, 11:23 »
Isso não está funcionando mais

caroline@caroline:~$ sudo dhclient -r eth0
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/00:1e:68:b1:0d:d5
Sending on   LPF/eth0/00:1e:68:b1:0d:d5
Sending on   Socket/fallback
caroline@caroline:~$ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.