Autor Tópico: [Resolvido] Erro ao iniciar Apache 2 após intalação do ISPConfig  (Lida 3020 vezes)

Offline recbr9

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
[Resolvido] Erro ao iniciar Apache 2 após intalação do ISPConfig
« Online: 28 de Novembro de 2010, 23:26 »
Olá, estou preparando um servidor Ubuntu Lenny 10.04 desktop para servidor Web, Firewall, Squid, eMail ...etc, eu tinha o Apache 2 rodando normalmente até instalar o ISPConfig.

Agora tento iniciar ou reiniciar o Apache 2 e da o seguinte erro


root@acsrv001:/# /etc/init.d/apache2 start
 * Starting web server apache2                                                  Syntax error on line 16 of /etc/apache2/sites-enabled/000-apps.vhost:
Invalid command 'SuexecUserGroup', perhaps misspelled or defined by a module not included in the server configuration
                                                                        [fail]
root@acsrv001:/#


editando o arquivo /etc/apache2/sites-enabled/000-apps.vhost temos

Código: [Selecionar]

######################################################
# This virtual host contains the configuration
# for the ISPConfig apps vhost
######################################################

 Listen 8081
# NameVirtualHost *:8081

<VirtualHost _default_:8081>
  ServerAdmin webmaster@localhost


  <IfModule mod_fcgid.c>
    DocumentRoot /var/www/apps
    SuexecUserGroup ispapps ispapps
    <Directory /var/www/apps>
      Options Indexes FollowSymLinks MultiViews +ExecCGI
      AllowOverride AuthConfig Indexes Limit Options FileInfo
      AddHandler fcgid-script .php
      FCGIWrapper /var/www/php-fcgi-scripts/apps/.php-fcgi-starter .php
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  <IfModule mod_php5.c>
    DocumentRoot /var/www/apps
    AddType application/x-httpd-php .php
    <Directory /var/www/apps>
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
    </Directory>
  </IfModule>

  ServerSignature Off

</VirtualHost>

Já procurei na net mas não acho nada...

Alguém pode me ajudar...

Fico no aguardo....

Obrigado...
« Última modificação: 29 de Novembro de 2010, 17:23 por recbr9 »

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Erro ao iniciar Apache 2 após intalação do ISPConfig
« Resposta #1 Online: 29 de Novembro de 2010, 09:22 »
O módulo "fcgid" não deve ter sido carregado corretamente.

PS: "Ubuntu Lenny"? Ubuntu é uma coisa, Debian Lenny é outra...
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline recbr9

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Erro ao iniciar Apache 2 após intalação do ISPConfig
« Resposta #2 Online: 29 de Novembro de 2010, 14:28 »
Grato pela resposta zekkerj, já desinstalei e instalei o libapache2-mod-fcgid, e mesmo assim continua o mesmo erro.
O que mais posso fazer?

Offline zekkerj

  • Usuário Ubuntu
  • *
  • Mensagens: 19.735
  • Gratidão gera gratidão, lamúria atrai lamúria...
    • Ver perfil
    • Blog do Zekke
Re: Erro ao iniciar Apache 2 após intalação do ISPConfig
« Resposta #3 Online: 29 de Novembro de 2010, 14:41 »
Acabei de consultar o Oráculo, e ele me disse que vc tem que instalar e ativar o módulo "suexec".
http://httpd.apache.org/docs/2.0/mod/mod_suexec.html
Pesquise antes de perguntar, sua dúvida pode já ter sido respondida.
Não respondo dúvidas por MP, coloque sua dúvida no fórum onde ela pode ser pesquisada pelos seus colegas!
Não venha ao fórum apenas para perguntar. Se você sabe a resposta de um problema, porque não ajudar seu colega? ;D

Offline recbr9

  • Usuário Ubuntu
  • *
  • Mensagens: 4
    • Ver perfil
Re: Erro ao iniciar Apache 2 após intalação do ISPConfig
« Resposta #4 Online: 29 de Novembro de 2010, 17:23 »
valeu velho, deu certo, executei o comando e deu certim...

Código: [Selecionar]
# a2enmod suexec rewrite ssl actions include deflate
grande abraço!