Autor Tópico: Permissão negada como root  (Lida 8328 vezes)

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Permissão negada como root
« Online: 17 de Outubro de 2010, 12:21 »
Olá pessoal,

Estou com problemas para executar arquivos que compilei com gcc, toda vez que tento: "./nome_do_arquivo" aparece "permissão negada" mesmo eu tentando como root.
Tento mudar a permissão do arquivo com "sudo chmod +x nome_do_arquivo" e nada acontece...

Nunca aconteceu isso antes... eu preciso continuar meu laboratório de programação, mas assim não dá.

Alguém tem alguma sugestão?
Desde já agradeço.

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Re: Permissão negada como root
« Resposta #1 Online: 17 de Outubro de 2010, 12:41 »
Completando..., dentro da minha home/ eu consigo alterar a permissão do arquivo e executar, mas dentro do pendrive não.

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Permissão negada como root
« Resposta #2 Online: 17 de Outubro de 2010, 13:14 »
Qual o formato do pendrive?
Se for fat32, não sei porque está acontecendo, mas se for ntfs, ai, já é outra história...
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Re: Permissão negada como root
« Resposta #3 Online: 17 de Outubro de 2010, 13:20 »
Pois então..., é FAT32.

Offline irtigor

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.344
  • Delete, delete, delete!
    • Ver perfil
Re: Permissão negada como root
« Resposta #4 Online: 17 de Outubro de 2010, 13:51 »
O fat32 não é um sistema de arquivo nativo do gnu/linux, por isso existem limitações.

---
A partição está montada como executável, talvez funcione.
« Última modificação: 17 de Outubro de 2010, 13:55 por irtigor »

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Permissão negada como root
« Resposta #5 Online: 17 de Outubro de 2010, 13:57 »
O linux dá total ou quase total suporte a fat32, ntfs que é o problema...
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Re: Permissão negada como root
« Resposta #6 Online: 17 de Outubro de 2010, 14:27 »
Consegui... (ufa)

Estava tentando editar as permissões no fstab para deixar exec sempre que montasse automaticamente. Mas não deu muito certo.

Fiz assim:

Criei uma pasta em /media
$ sudo mkdir media/PEN

e remontei o pendrive com exec
$ sudo mount -o remount,exec media/PEN

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Re: Permissão negada como root
« Resposta #7 Online: 17 de Outubro de 2010, 14:50 »
Só queria saber porque ele mudou o padrão de uma hora para outra...
Ter que ficar fazendo isso toda hora enche os pacovas.

Como deixo exec, automático para esse meu pendrive?

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Permissão negada como root
« Resposta #8 Online: 17 de Outubro de 2010, 15:18 »
Pode disponibiliar o conteudo do seu fstab?
Já pra ajudar:
http://www.vivaolinux.com.br/topico/Ubuntu-e-Kubuntu/Problemas-ao-montar-pendrives-no-Ubuntu-7.10
http://www.vivaolinux.com.br/artigo/Montando-um-pendrive-no-Linux

Acredito que a segunda página seja a solução para o problema.
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Re: Permissão negada como root
« Resposta #9 Online: 17 de Outubro de 2010, 16:09 »
Não há nada relacionado ao meu pendrive no meu fstab..., eu já tentei colocar, mas ele verifica as coisas ali ao iniciar o sistema, então para um disco removível ele dá erro ao inciar

Eis o conteúdo:
Código: [Selecionar]
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc        proc  nodev,noexec,nosuid         0  0 
# / was on /dev/sda8 during installation
UUID=792574ba-981d-401c-af84-e9911d58715d  /            ext4  errors=remount-ro           0  1 
# swap was on /dev/sda6 during installation
UUID=37045959-3247-44d1-a587-46eb6e8a083c  none         swap  sw                          0  0 

/dev/sda5                                  /media/128GiB-W  ntfs  defaults,brenno.rw,exec,auto  0  0

Vou verificar os links que vc passou. Volto já.

Offline Brenno Machado

  • Usuário Ubuntu
  • *
  • Mensagens: 44
    • Ver perfil
    • C'est la Vie
Re: Permissão negada como root
« Resposta #10 Online: 17 de Outubro de 2010, 16:34 »
bred81, o segundo link "resolveu" o meu problema

Adicinei isso ao meu fstab:
Código: [Selecionar]
/dev/sdb1  /media/PEN  vfat  noauto,user,exec,umask=000  0  0
Agora ele executa programas (por exemplo os que eu compilo com o gcc) no meu pendrive.

Mas a questão é, ele só vai executar quando o dispotivo usb for reconhecido no sdb1, seu inserir mais algum outro dispositivo, ou se por alguma outra razão este venha a ser reconhecido como sdXY não irá executar, pois o default para isso  é "noexec" (obs: Ficou assim depois que atualizei pro Maverick)

Queria que todos os pendrives inseridos eu pudesse executar. Se isso for "inseguro" poderia ser só para root, pois do jeito que está nem root executa.

Offline irtigor

  • Equipe Ubuntu
  • Usuário Ubuntu
  • *****
  • Mensagens: 4.344
  • Delete, delete, delete!
    • Ver perfil
Re: Permissão negada como root
« Resposta #11 Online: 17 de Outubro de 2010, 18:20 »
Eu não sei nenhuma forma "fácil", só me ocorre fixar com o udev.

Offline bred81

  • Usuário Ubuntu
  • *
  • Mensagens: 971
  • HAN?!
    • Ver perfil
Re: Permissão negada como root
« Resposta #12 Online: 18 de Outubro de 2010, 00:24 »
Que bom que deu pra resolver.
Infelizmente não consigo te ajudar mais que isso.

[]'s
O que o Mario foi fazer no pscicólogo?
- Ele estava passando por uma fase difícil...