Autor Tópico: problema com programinha para código morse cw não encontra som  (Lida 1429 vezes)

Offline ucastrobr

  • Usuário Ubuntu
  • *
  • Mensagens: 693
  • Usa Ubuntu 11.10 (Oneiric Ocelot)
    • Ver perfil
problema com programinha para código morse cw não encontra som
« Online: 31 de Agosto de 2010, 18:58 »
ucastrobr@ucastrobr-desktop:~$ cw
cw: cannot set up soundcard sound
/dev/audio: Arquivo ou diretório não encontrado
ucastrobr@ucastrobr-desktop:~$

Já tentei:

ucastrobr@ucastrobr-desktop:~$ cw --help
Usage: cw [options...]
  -s, --sound=SOURCE     generate sound on SOURCE [default 'soundcard']
                         one of 's[oundcard]', 'c[onsole]', or 'b[oth]'
  -x, --sdevice=SDEVICE  use SDEVICE for soundcard [default /dev/audio]
  -y, --mdevice=MDEVICE  use MDEVICE for sound mixer [default /dev/mixer]
  -d, --cdevice=CDEVICE  use CDEVICE for sound ioctl [default /dev/console]


                  Mas quando tento cw -x /dev/váriasopções aqui já coloquei
                                                cw -y /dev/váriasopções aqui já coloquei
                                                cw -d /dev/váriasopções aqui já coloquei

E sempre retorna erros.

Estou usando o Ubuntu 10.10 funcionando tudo 100%, só este programinha que não.
Veja que existem pasta de versões anteriores que não existe mais:

ucastrobr@ucastrobr-desktop:~$ sudo fuser -v /dev/dsp* /dev/snd/* /dev/audio* /dev/mixer* /dev/seq*
[sudo] password for ucastrobr:
O nome de arquivo especificado /dev/dsp* não existe.
O nome de arquivo especificado /dev/audio* não existe.
O nome de arquivo especificado /dev/mixer* não existe.
O nome de arquivo especificado /dev/seq* não existe.
                     COMANDO DE ACESSO DO USUÁRIO PID
/dev/snd/controlC0:  ucastrobr   1240 F.... pulseaudio
/dev/snd/controlC1:  ucastrobr   1240 F.... pulseaudio


Alguma solução?
« Última modificação: 31 de Agosto de 2010, 19:00 por ucastrobr »
Spock – "After a time, you may find that having is not so pleasing a thing, after all, as wanting. It is not logical, but it is often true."
("Depois um de tempo você vai perceber que ter algo pode não ser tão prazeroso quanto deseja-lo. Isto não é lógico, mas frequentemente é verdade.")

Offline RonaldoRG

  • Usuário Ubuntu
  • *
  • Mensagens: 659
    • Ver perfil
    • Twitter: @rafas_andrade
Re: problema com programinha para código morse cw não encontra som
« Resposta #1 Online: 10 de Outubro de 2010, 20:26 »
Acabei de instalar esse programa e apresenta o mesmo erro que o seu.
Mas quando eu digito no terminal e dou enter:
Código: [Selecionar]
cw -w 10É só digitar a frase e dar enter que funciona. O -w é pra escolher a velocidade que no caso botei 10 palavras por minuto.
Testa ai pra ver se dá certo. Abraço.
Ubuntu 12.04