Autor Tópico: [Resolvido] Ubuntu não está captando o som do Microfone  (Lida 14062 vezes)

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #30 Online: 11 de Setembro de 2010, 21:57 »
Amigo. Sugiro atualizar seu sistema para acertar algum deslize que possa ter ocorrido e seguir com a seguinte reinstalação:
No terminal
apt-get update
apt-get upgrade

apt-get install linux-headers-2.6.32-24-generic (supondo que seja este). Com o comando uname -r você descobre.

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #31 Online: 11 de Setembro de 2010, 22:10 »
mundus@mundus-desktop:~$ sudo apt-get update
Atingido http://br.archive.ubuntu.com lucid Release.gpg
Atingido http://br.archive.ubuntu.com/ubuntu/ lucid/main Translation-pt_BR    
Atingido http://br.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-pt_BR
Atingido http://br.archive.ubuntu.com/ubuntu/ lucid/universe Translation-pt_BR
Atingido http://br.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-pt_BR
Atingido http://br.archive.ubuntu.com lucid-updates Release.gpg                
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-pt_BR  
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-pt_BR
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-pt_BR
Ign http://br.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-pt_BR
Atingido http://br.archive.ubuntu.com lucid Release                            
Atingido http://br.archive.ubuntu.com lucid-updates Release                    
Atingido http://br.archive.ubuntu.com lucid/main Packages                      
Atingido http://br.archive.ubuntu.com lucid/restricted Packages                
Atingido http://br.archive.ubuntu.com lucid/main Sources                      
Atingido http://br.archive.ubuntu.com lucid/restricted Sources                
Atingido http://br.archive.ubuntu.com lucid/universe Packages                  
Atingido http://br.archive.ubuntu.com lucid/universe Sources                  
Atingido http://br.archive.ubuntu.com lucid/multiverse Packages                
Atingido http://br.archive.ubuntu.com lucid/multiverse Sources                
Atingido http://br.archive.ubuntu.com lucid-updates/main Packages              
Atingido http://br.archive.ubuntu.com lucid-updates/restricted Packages        
Atingido http://br.archive.ubuntu.com lucid-updates/main Sources              
Atingido http://br.archive.ubuntu.com lucid-updates/restricted Sources        
Atingido http://br.archive.ubuntu.com lucid-updates/universe Packages          
Atingido http://br.archive.ubuntu.com lucid-updates/universe Sources          
Atingido http://br.archive.ubuntu.com lucid-updates/multiverse Packages        
Atingido http://br.archive.ubuntu.com lucid-updates/multiverse Sources        
Obter:1 http://dl.google.com stable Release.gpg [191B]                        
Atingido http://ppa.launchpad.net lucid Release.gpg                            
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-pt_BR      
Ign http://ppa.launchpad.net/cdemu/ppa/ubuntu/ lucid/main Translation-pt_BR    
Atingido http://ppa.launchpad.net lucid Release.gpg                            
Atingido http://archive.canonical.com lucid Release.gpg                        
Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-pt_BR      
Obter:2 http://dl.google.com stable Release [1310B]                            
Ign http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ lucid/main Translation-pt_BR
Atingido http://ppa.launchpad.net lucid Release                                
Atingido http://archive.canonical.com lucid Release                            
Obter:3 http://dl.google.com stable/main Packages [945B]                      
Atingido http://ppa.launchpad.net lucid Release                                
Atingido http://archive.canonical.com lucid/partner Packages                  
Atingido http://ppa.launchpad.net lucid/main Packages                          
Atingido http://ppa.launchpad.net lucid/main Sources                          
Atingido http://ppa.launchpad.net lucid/main Packages                          
Atingido http://security.ubuntu.com lucid-security Release.gpg                
Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-pt_BR
Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-pt_BR
Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-pt_BR
Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-pt_BR
Atingido http://security.ubuntu.com lucid-security Release
Atingido http://security.ubuntu.com lucid-security/main Packages
Atingido http://security.ubuntu.com lucid-security/restricted Packages
Atingido http://security.ubuntu.com lucid-security/main Sources
Atingido http://security.ubuntu.com lucid-security/restricted Sources
Atingido http://security.ubuntu.com lucid-security/universe Packages
Atingido http://security.ubuntu.com lucid-security/universe Sources
Atingido http://security.ubuntu.com lucid-security/multiverse Packages        
Atingido http://security.ubuntu.com lucid-security/multiverse Sources          
Baixados 2446B em 7s (340B/s)                                                  
Lendo listas de pacotes... Pronto

mundus@mundus-desktop:~$ sudo apt-get upgrade
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

mundus@mundus-desktop:~$ sudo apt-get install linux-headers-2.6.32-24-generic
Lendo listas de pacotes... Pronto
Construindo árvore de dependências      
Lendo informação de estado... Pronto
linux-headers-2.6.32-24-generic já é a versão mais nova.
0 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.

e o som continua na mesma (sem som)=P

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #32 Online: 11 de Setembro de 2010, 22:14 »
Você reiniciou?

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #33 Online: 11 de Setembro de 2010, 22:17 »
acabei de tentar entrar no Ubuntu pelo kerrnel anterior, o linux-headers-2.6.32-21-generic, e ele esta sem som tambem (tanto não sai som pela caixa de som, quant o gravador de som não detecta nada.)

sim, tentei reiniciar pelo kernel -24

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #34 Online: 11 de Setembro de 2010, 22:24 »
Vai em preferencias de som, aquelas configurações, e aumenta. Reinicia atenta para o som.

Você não está conseguindo reiniciar pelo linux-headers-2.6.32-24-generic?
« Última modificação: 11 de Setembro de 2010, 22:26 por libonati »

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #35 Online: 11 de Setembro de 2010, 22:35 »
consegui reiniciar pelo linux-headers-2.6.32-24-generic
mas só pra fazer um teste, eu resolvi depois de reiniciar o linux-headers-2.6.32-24-generic e constatar que ele ainda estava sem som, ir no linux-headers-2.6.32-21-generic e ver se ele tinha o mesmo problema, e tem, o que eu acho q mostra que o problema não está no kernel.

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #36 Online: 11 de Setembro de 2010, 22:40 »
Concordo, com ressalvas...
Seu computador é notebook,netbook ou desktop?
Você atualizou para o 10.4 a partir do 9.8, 9.4 ou fez uma instalação limpa?

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #37 Online: 11 de Setembro de 2010, 22:57 »
Desktop, Fiz uma instalação limpa e acabei de gravar este video ainda no kernel linux-headers-2.6.32-21-generic, usando o comando:
ffmpeg -f x11grab -s 1024x768 -r 25 -b 1000 -g 300 -i :0.0 -qmin 2 -qmax 5 outout.mpg
a questão é que eu vi o gravador de som acusando algo que parecia som de dentro do PC, mas não sai nada na minha caixa de som, e nem no meu headset (tentei alternar entre os dois pra ver se não era ero de algum deles, e aparentemente não é, pois ambos funcionavam bem ontem).

http://www.youtube.com/watch?v=hpi2aWeYrBE

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #38 Online: 11 de Setembro de 2010, 23:08 »
Observa que no vídeo você capta som do microfone, só que não gravou. É preciso testar com calma e paciência.

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #39 Online: 11 de Setembro de 2010, 23:10 »
na verdade eu não tenho ideia de que som captou, pois não sai nada da minha caixa de som =P
dai eu te pergunto, que som q captou? foi o do microfone mesmo? =D

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #40 Online: 12 de Setembro de 2010, 09:19 »
Mundus. Um fato interessante agora: Suspendi o módulo snd-hda-intel e mesmo assim quando fui escutar uma música o som fluiu normalmente amparado por outro módulo. Levantei o módulo novamente para voltar as configurações anteriores. Só para você ver que um sistema bem instalado sempre tem recursos que amenizam o prejuízo.
No vídeo você está alterando rapidamente (se a velocidade não foi alterada). Você tem de testar um por um e inclusive fazendo a gravação com o microfone.
De qualquer maneira é um problema muito estranho. O módulo carregado, também penso que não é o kernel. Começo a desconfiar da bios da sua placa mãe.
Gostaria que a reinstalação fosse o último recurso mas se a bios estiver desatualizada deverá ocorrer o mesmo problema.
Não ver a placa e saber se é moderna ou não, ver se existe algum problema com entradas e outros fatores é a dificuldade em ajudar a distância. A maioria de minhas pesquisas são nos meus próprios computadores mas vou continuar tentando reproduzir sua situação  em busca de uma solução. Talvez alguém que esteja acompanhando tenha uma idéia para o que fazer.
Vamos para uma última cartada:
Lembra aqueles módulos que não estavam carregados no seu sistema?
snd_hda_codec_via
snd_usb_audio
snd_usb_lib


Tente carrega-los como root. Por nossas placas diferentes não sei se irá ajudar

modprobe snd_hda_codec_via
modprobe snd_usb_audio
modprobe snd_usb_lib



Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #41 Online: 12 de Setembro de 2010, 12:03 »
tentei carregar os três modprobes, um pro vez e reiniciando o pc a cada tentativa, e ainda esta sem som.
O que me intriga é que eu tinha um Windows XP instalado antes neste PC, e nele tanto o som como o microfone funcionavam normalmente, dai nos três Ubuntus que eu usei (oito ponto algo, nove ponto algo e 10.04) o microfone passou a não funcionar mais. e era a mesma placa mãe.

Offline Mundus

  • Usuário Ubuntu
  • *
  • Mensagens: 36
    • Ver perfil
Re: Ubuntu não está captando o som do Microfone
« Resposta #42 Online: 12 de Setembro de 2010, 12:36 »
não sei se ajuda, mas de uma olhada no meu alsa-base.conf

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #43 Online: 12 de Setembro de 2010, 13:20 »
 diff -u seuarquivo meuarquivo

[/b]--- teste1   2010-09-12 13:01:00.375934809 -0300
+++ teste2   2010-09-12 13:05:10.095934965 -0300
@@ -38,4 +38,3 @@
 options snd-cmipci mpu_port=0x330 fm_port=0x388
 # Keep snd-pcsp from being loaded as first soundcard
 options snd-pcsp index=-2
-
Existe diferença. faça uma cópia do seu arquivo com o nome alsa-base.conf.original
Apague o seu arquivo alsa-base.conf
Cole o meu arquivo com o nome alsa-base.conf
Não sei se vai funcionar. Para retornar as configuraçõews originais
Apague meu arquivo
modifique o nome alsa-base.conf.original para alsa-base.conf

Citar
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-usb-caiaq index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
 

libonati

  • Visitante
Re: Ubuntu não está captando o som do Microfone
« Resposta #44 Online: 12 de Setembro de 2010, 13:30 »
Não consegui detectar a diferença que o diff acusou. Acho que foi diferença de linha/tab. Mesmo assim tente.